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HOW-TO

LibreOffice Pt27: Intro To Draw

Written by Elmer Perry

T

he LibreOffice Draw module is
a vector graphics application
included in the LibreOffice suite.
Draw lets you create graphics you
can use in your documents. While
there are more advanced vector
graphics programs – such as
Inkscape – Draw provides you with
more tools than most drawing
packages included in other office
suites.
Vector graphics create images
by defining geometric shapes such
as circles, rectangles and polygons,
rather than by pixel points on the
screen. Because of this, vector
graphics scale without distortion.

you need to create a graphic
image. The center of the screen is
the area where you will create your
graphic. To the right, you have the
page pane, showing the different
pages of the graphic. Multi-page
graphics are used mostly for
presentations, and I will cover
them at a later time.
By default, you have three
toolbars. The standard toolbar is
the topmost toolbar. This is the
toolbar you see in most of the
LibreOffice modules. It controls
the new, open, save, copy, cut,
paste, and other functions that
pertain to most modules. The line

and fill toolbar sits below it. This
toolbar controls how the lines and
fill of an object will look. At the
bottom of the window sits the
drawing toolbar. From this toolbar,
you can create most of the objects
for your graphic. You can move the
toolbars by grabbing the handle at
the beginning of the toolbar and
dragging it to the location where
you want it.
The status bar at the bottom of
the window gives you a lot of
useful information about the
object you are editing. An object’s
type, dimensions, angle, and other
useful information will show up

here. I will refer to the status bar
often during the How-tos on Draw.
At the top and along the left
edge sit the rulers. The rulers are
guides to where you are in the
image. If you want to change the
unit of measure in the rulers, you
can right-click the ruler and select
a different unit of measure. When
you have an object selected, the
ruler shows double lines to
indicate the object’s position on
the drawing.

As with the other modules in
LibreOffice, Draw integrates well
with the others, making it the tool
of choice when creating graphics
for your documents.

THE DEFAULT LAYOUT
The default layout for Draw is
rather sparse. You will probably
want to modify it to include the
toolbars you use most often. The
layout includes the basic elements

THE COLOR BAR
The color bar displays the
current color palette under the
full circle magazine #74
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drawing area. You can use it to
select colors for your objects
rather than having to use the
dropdown list in the line and fill
toolbar. The first box – the white
box with an X in it – is the no color
(or invisible) selection. To display
the color bar, go to View >
Toolbars > Color Bar. To use the
color bar, left-click the color you
want for the fill color of the object,
and right-click to select the line
color.

can detach these items from the
toolbar, creating a floating toolbar.
When you expand the item, you
will see a grab bar at the bottom.
Click and drag the grab bar to
create a floating toolbar of the
items. This is helpful when you
need to use the items repeatedly,
and is quicker than having to
expand the items each time. When
you are finished, just close the
floating toolbar by clicking on the
close button in the title bar.

TEAR-OFF TOOLBARS

GRID, SNAP LINES, AND
SNAP POINTS

Many of the icons on the
toolbars have a triangle or arrow
to the right. This indicates the item
is expandable. Clicking on the
arrow gives you more choices. You

When creating an image, I find
it useful to have guides to work
from. The grid, snap lines, and snap
points are useful for such guides.
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You can set the program to snap to
these guides, which help you
precisely place your objects in the
drawing.
To set up the grid, go to Tools >
Options > LibreOffice Draw > Grid.
If you want objects to snap to the
grid by default, check the Snap-togrid checkbox under grid. You also
have the option to make the grid
visible by default. Resolution sets
the vertical and horizontal settings
for the grid. Subdivision sets the
number of markers between the
horizontal and vertical grid points.
The more subdivisions the more
precise the changes when snap-togrid is on. But like most things, a
happy medium is usually better
12

than too much. You can set certain
snap options on by default under
the snap section, but I recommend
leaving these all off by default,
and using the options toolbar
when you need to turn them on.
Use the snap range to control how
close to a snap point you are
before your object snaps to the
point.
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Unlike the grid, snap points and
snap lines are inserted when you
need a more exact location. Snap
lines are great for aligning objects
vertically or horizontally. To create
a snap line or point, Insert > Insert
Snap Point/Line from the menu
bar. The X position controls the
distance from the left of the
image. The Y position controls the
distance from the top. The type
controls whether you are inserting
a snap point, vertical snap line, or
horizontal snap line. You can also
create snap lines by clicking and
dragging from either the
horizontal or vertical rulers. To
delete a snap line, click and drag it
back to the ruler. To delete a snap
point, right-click the snap point
and select Delete Snap Point.

OPTIONS TOOLBAR
The options toolbar contains all
your snap options. If it is not
showing, select View > Toolbars >
Options. On the toolbar, you can

toggle whether your guides are
displayed, and toggle on and off
the snap options. You might want
to dock this toolbar to the bottom
or side of your window as I suspect
you will use it often to toggle
these options.
There is one more guide on the
toolbar we have not discussed yet.
It is the helplines. When you select
the helplines on the options
toolbar, then, when you move an
object, dashed lines appear from
the corners of your object to the
rulers. The helplines are just one
more tool to help you accurately
place your objects.

to combine text and geometric
objects to create your graphics.
Guides, and the ability to snap to
the guides, help you to precisely
place your objects.
In the next LibreOffice How-To,
we will look at creating basic
objects in Draw.

CONCLUSION
LibreOffice Draw is the graphics
application of the LibreOffice
suite. Draw saves graphics in a
vector graphic format for use in
your documents created with
other applications in the suite.
Draw provides you with the tools

The show is presented by
members of the UK’s Ubuntu
Linux community. Because it is
covered by the Ubuntu Code of
Conduct it is suitable for all.

Elmer Perry's history of working,
and programming, computers
involves an Apple IIE, adding some
Amiga, a generous helping of DOS
and Windows, a dash of Unix, and
blend well with Linux and Ubuntu.
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The Ubuntu Podcast covers all
the latest news and issues facing
Ubuntu Linux users and Free
Software fans in general. The
show appeals to the newest user
and the oldest coder. Our
discussions cover the
development of Ubuntu but
aren’t overly technical. We are
lucky enough to have some
great guests on the show, telling
us first hand about the latest
exciting developments they are
working on, in a way that we can
all understand! We also talk
about the Ubuntu community
and what it gets up to.
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The show is broadcast live every
fortnight on a Tuesday evening
(British time) and is available for
download the following day.
podcast.ubuntu-uk.org
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Written by Elmer Perry

W

hen I was a child, I enjoyed
playing with building blocks.
I didn't have the finely finished and
polished blocks like you can buy
for children these days. Instead, I
had wood scraps from my father's
woodworking. I ended up with a
collection of various geometric
shapes and sizes. These blocks
became forts for my toy soldiers,
roadways for my cars, and even a
cityscape complete with airport.
The only limit was my imagination.
While my artistic skills never
advanced much beyond 9th grade
art class, I still enjoy putting things
together and have always enjoyed
geometry. My blocks taught me
that most things can break down
to basic geometric shapes like
circles, rectangles, and other 2D
geometric shapes. With these
objects you can create, even if only
rudimentary, anything.
At the heart of LibreOffice
Draw are these basic geometric
shapes. They allow you to draw
almost anything, and the only
limitation is your imagination. You
will find all the basic objects on the
Drawing toolbar. Starting with the

LibreOffice Pt28: Draw Basic Objects
most basic of all drawing elements,
the line, let's take a look at how to
use the basic objects available to
us in LibreOffice Draw.

LINES AND ARROWS
The line is the second tool on
the default Drawing toolbar, the
first being the selection tool. To
draw a line, click in the drawing
area where you want to start your
line and drag to the end point. If
you look at the status bar while
you draw your line, you will notice
it tells you the size and angle of
your line. To restrict the angle of
your line to increments of 45
degrees (0, 45, 90, 135, 180, -135,
-90, -45), hold down the Shift key
while drawing your line.

Sometimes, you need to draw
your line from a center point
rather than an end point. Hold
down the Alt key while drawing
your line, and the line will grow
outward from the center point.
You can hold down Alt and Shift
together to draw a line from the
center point and restrict the angle
to increments of 45 degrees.
There is also an extended
toolbar for lines on the Drawing
toolbar. It allows you to draw lines
with different arrows and start
points. There is also a line for
showing dimensions. You can use
all the same methods for drawing a
line with arrows that you use to
draw an ordinary line.
Use the line and filling toolbar
to change the line style and
thickness, and to color your line.
Make sure your line is selected
when you make these changes. You
can also select different arrow
styles for your line using the
arrows tool on the Line and Filling
toolbar.
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RECTANGLES AND SQUARES
If you wanted, you could use
the snap to grid function and the
Shift key to draw four lines to
create a rectangle or square, but
Draw does provide you with an
easier way to create them. The
rectangle is the fourth tool on the
default Drawing toolbar. With it
you can create rectangles and
squares.

To draw a rectangle, select the
rectangle tool from the toolbar.
Click where you want to place one
corner, and drag to the location of
the opposite corner. You make a
square by holding down the Shift
key while dragging. The shift key
ensures the width and height are
always the same.
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Just like the line, you will
sometimes need to create a
rectangle or square starting from
the center point rather than a
corner. Again, the Alt key causes
the rectangle to expand from the
center. Use the Shift-Alt
combination to draw a square from
the center out.
Rectangles and squares by
default are drawn with the
currently selected line and fill
colors. You can change these using
the Line and Fill toolbar. You can
also use the color bar. Right-click
for line color and left-click for the
fill color. You can also control the
thickness and style of the border
line using the Line and Fill toolbar.

ELLIPSES AND CIRCLES
The ellipse tool is the fifth tool
on the default Drawing toolbar.
Ellipses are drawn much in the
same manner as for rectangles and
squares. Basically, you are drawing
a rectangle which will contain your
ellipse or circle. Just like with the
square, the Shift key lets you draw
a circle. The Alt key is used to draw
your ellipse from the center, and
the Shift-Alt combination lets you
draw a circle from the center.

As with the rectangle and
square, ellipses and circles are
drawn with the currently selected
line and fill colors. You can change
them with the Line and Fill toolbar
or the color bar. The Line and Fill
toolbar also lets you change the
border line style and thickness.

SHAPES AND SYMBOLS
EXTENDED TOOLBARS
Besides the lines extended
toolbar, you have several other
extended toolbars to choose from,
including basic shapes (2D
geometric objects), symbols
(smiley face, moon, heart, etc),
block arrows, flowchart symbols,
callouts, and stars. These extended
toolbars give you a broader set of
objects for building your graphic.
They are drawn in much the
full circle magazine #75

same manner as rectangles,
squares, ellipses, and circles. You
draw a containing rectangle for the
object. The Shift and Alt keys also
work on most objects in the same
way as with rectangles. You can
use the Line and Fill toolbar to
change the line thickness, line
style, line color, and fill color of the
object.

SAMPLE DRAWING – A
SIMPLE ROCKET
As I said in the beginning, I'm
not much of an artist, but I do have
a sense for putting shapes
together to create an object, so
let's walk through creating a very
simple rocket image. Along the
way I will introduce a few new
tools and concepts for working
with basic shapes.
12

First, we will set up a grid for
our drawing, Tools > Options >
LibreOffice Draw > Grid. Set the
vertical and horizontal resolution
to 1 inch. Set both subdivisions to
10. This will create a nice 1-inch
box grid on our drawing surface.
Check the snap-to-grid. This will
help us get our objects to the right
size.
Let's start with the nose cone.
Select the isosceles triangle tool
from the basic shapes extended
toolbar. Draw the triangle, 2 grid
squares by 2 grid squares, at the
contents ^
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top of the image. Make the line
color black and the fill color gray
30%. For the body of the rocket,
use a rectangle, 2 grid squares
wide and 6 grid squares tall, line
color black, and fill color gray 30%.
Let's add some stabilizing fins
to our rocket. Select the right
triangle from the basic shapes
extended toolbar. Draw the right
triangle at the bottom right of the
rocket body, 2 grid squares tall and
1 grid square wide. Set the line
color to black and the fill color to
gray 40%. With the newly created
fin selected, Edit > Copy, then Edit
> Paste. The copy will appear over
the top of the first fin. Drag and
drop the copy to the left side of
the rocket body. Right-click the
copy and Flip > Horizontally. Move
it to the lower left of the rocket
body. With the copy still selected,
down-arrow three times to move it
just below the rocket body. Do the
same with the right fin.
We will finish off our drawing
with the engine nozzle. Create an
isosceles triangle at the bottom
center of the rocket body. Use
your best judgment on the size.
The top point of the triangle
should overlap the bottom part of
the rocket body. Make the line

color black and the fill color gray
60%. Make sure the nozzle is
centered at the bottom of the
body. Right-click the triangle and
Arrange > Send to Back. This
pushes the triangle behind the
other objects so we can see only
the bottom part.
There! You have a very simple
drawing.

CONCLUSION
The basic shapes are the
building blocks for images in Draw.
From them, you can create as
simple or as complicated a drawing
as you need for your documents.
You can arrange your objects on
the image to overlap each other
and flip to change the horizontal
or vertical orientation.
In my next How-To, I will show
you how to create arcs, curves, and
polygons in your images.

Elmer Perry's history of working,
and programming, computers
involves an Apple ][E, adding some
Amiga, a generous helping of DOS
and Windows, a dash of Unix, and
blend well with Linux and Ubuntu.
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ANNOUNCEMENT FROM CANONICAL
UBUNTU TOUCH SDK BETA

T

oday we [Canonical] are announcing the Ubuntu SDK Beta.
The SDK provides a set of APIs that includes the UI toolkit,
enabling developers to create responsive and interactive
applications with a native Ubuntu mobile UI. Qt Creator is an IDE
with a visual interface for writing, testing and deploy applications;
its API documentation and a developer site full of resources and
tutorials make it easy to produce quality applications.
Together with a vibrant and ever-growing community of app
developers, Ubuntu and the SDK provide the best ecosystem for
your apps to thrive.

GET STARTED - GUIDE TO INSTALLING THE SDK
To get started with the Ubuntu SDK, including easy installation
instructions, tutorials and detailed API documentation, visit
developer.ubuntu.com/get-started
To help you design and build beautiful apps, the App Design
Guides include everything you need to know about UX and visual
design best practices. Find them at design.ubuntu.com/apps
You can keep your development phone up-to-date with the
latest build by following the instructions at
wiki.ubuntu.com/TouchInstallProcess
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Written by Elmer Perry

A

s I mentioned last time, the
building blocks I owned as a
child were the result of my father's
woodworking. Not every block was
perfectly proportioned into neat
geometric shapes. Sometimes,
they were oddly shaped, or, as
wood often is, shaped by splitting
along the grain line rather than
being cut by the saw. Some had
curved patterns where their
opposites were used to trim a chair
or cabinet. I didn't discard these
irregular shapes but embraced
them. Not everything in our world
is created from straight lines,
ellipses, and circles.
With this in mind, we continue
our look into LibreOffice Draw by
learning how to create polygons,
arcs, and curves. A polygon is a
plane object with at least three
straight lines and angles. In
geometric terms squares,
rectangles, and triangles are types
of polygons. For our purposes, we
will discuss polygons with more
than four sides. An arc, in Draw, is a
partial circle or oval. You can make
them filled or empty. A curve is a
bent line. We will look at two

LibreOffice Pt29: Polygons, Arcs & Curves
methods for creating curves, the
curve tool itself and the Bezier
method.

DRAWING POLYGONS
As I said, a polygon is an object
with multiple sides. In Draw, you
have four polygon tools. Two
enclosed and filled polygon tools,
and two open and unfilled polygon
tools. The unfilled polygon tools
are good for making a series of
lines. For both types, you have a
free-form version and a version
restricted to angles that are
multiples of 45 degrees.

To create a polygon, select one
of the polygon tools from the Lines
extended toolbar. Click and drag to
create the start point of the first
line. When you release the mouse
button, the end point of the first
full circle magazine #76

line is created. Move the mouse to
the position where you want the
end point for the next line and
click. Continue until you have
created all the lines for your
polygon. Double-click on the last
point to end the polygon. If you are
using one of the filled polygon
tools, the end point of the last line
will automatically connect to the
start point of the first line,
enclosing the polygon.
If you use one of the filled
polygon tools, Draw fills the

polygon with the currently
selected fill color and sets the lines
to the currently selected line color.
You can change these using the
Line and Fill toolbar or the color
bar.

TOOLBAR
For quick access to the arcs and
segments tools, we need to add
the Circles and Ovals toolbar to
the Drawing toolbar. Right-click
the Drawing toolbar and select
Customize Toolbar. This opens the
Customize dialog. Click the Add
button. Select Drawing under the
Category list. In the Commands
list, find the Ellipse tools – there
are two. You want the one with the
description “Using Customize
toolbar, you can add the Ellipse
icon which opens the Circles and
Ovals toolbar.” Click the Add
button. Click Close to close the
selection dialog.
Using the up and down arrows,
move the new icon to where you
want it on the toolbar. I placed
mine below the Ellipse tool. We
don't really need the Ellipse tool
any longer as it is included in the
Circles and Ovals toolbar. Uncheck
the Ellipse tool. Click the OK
button, and you should see the
toolbar is now on your Drawing
toolbar.

ADD CIRCLES AND OVALS
11
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second time to create the end
point for the arc or segment. The
status bar will show you the angle
from center of the points as you
move around the circle or oval.
This can help you create accurate
and precise arcs and segments.

DRAWING CURVES

DRAWING ARCS OR
SEGMENTS
To draw an arc
or segment,
select one of the
tools from the
Circles and Ovals
toolbar you just
added. Click and drag to create a
containing circle or oval. Release
the mouse button. Click in the
circle or oval where you want the
arc or segment to begin. Move the
mouse around the circle or oval to
create the arc or segment. Click a

A curve is a bent line rather
than a segment of a circle or oval.
To draw a curve, select the curve
tool from the line toolbar. Click on
the start point and drag to draw a
line. Release the mouse button at
the peak point for your curve.
Move the mouse to bend the line
to the point where you want the
curve to end. Double-click to
complete the curve.

point, and two control points. The
mathematics behind the Bezier
curve is beyond the scope of this
article, but you don't need to
understand the math in order to
draw one.
To draw a Bezier curve, select
the curve tool from the lines
toolbar. Click at the start point,
drag to the end point and doubleclick. Click on the Points tool on
the Drawing toolbar (F8 on the
keyboard), and the Edit Points
toolbar is displayed. Select either
the start or end point (the start
point is the larger square). Select
the Smooth or Symmetric
Transition tool from the Edit Points
toolbar. A dashed line and circle
will appear indicating the control
point for that point. Move the
control point to create the curve
for that point. Repeat these steps
for the other point.

BEZIER CURVES

CONCLUSION

A Bezier curve is a smooth
curve with a start point, an end

Since not all things are created
from straight lines, ellipses, and
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circles, the creators of Draw gave
us more tools for creating objects.
A polygon can create an object
with more than four sides. Arcs
and segments gives us parts and
segments of a circle or ellipse.
Curves give us the ability to bend a
line into different shapes. With
these extra tools in hand, Draw
lets you create more advanced
images for your documents.

Elmer Perry's history of working,
and programming, computers
involves an Apple ][E, adding some
Amiga, a generous helping of DOS
and Windows, a dash of Unix, and
blend well with Linux and Ubuntu.
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LibreOffice Pt30: Draw/Edit Objects

W

hen working with physical
blocks, you sometimes need
to change the shape of a block,
customizing it for a special
purpose. You may use a plane or
sandpaper to make a side slant or
to round an edge. You might use a
saw to whack off a corner. All to
create a special custom block
unlike any other block in your
collection.
Sometimes, we need to do the
same with our digital blocks. The
editing tools built into LibreOffice
Draw become our digital plane,
sandpaper, and saw. In fact, you
can do things I never dreamed of
doing to my blocks as a child.

THE LINE DIALOG
The Line dialog lets you edit the
look of the lines in your object. To
access the Line dialog, right-click
your object and select Line. From
here, you can change the style of
the line (solid, dashed, dash-dot,
etc.), the color, width, and
transparency. You can also add
arrow styles to the start and end of
your line. Keep in mind that for

enclosed objects (triangles,
squares, circles, etc.), arrows are
not drawn on the lines.
Underneath the arrow styles, you
can adjust the width of the arrow.
Center places the center of the
arrowhead(s) on the endpoint(s) of
the selected line. Synchronize ends
automatically updates both arrow
heads when you change the style,
width, or center of one of the ends.
Corner style controls how the
corner of your object is drawn. Cap
style controls how the endpoints
of lines without arrows will look.
If you are working with an open
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object, you get a shadow tab. This
allows you to create a shadow for
the line by defining the position,
distance, color, and transparency
of the shadow.
The Line Styles and Arrow
Styles tabs allow you to add,
modify, delete, and save different
line and arrow styles. You can play
around with these, but usually you
can find what you need in the
predefined styles. If not, feel free
to create your own.

AREA DIALOG
10

The Area dialog applies to
objects that are enclosed, and
deals with the space inside the
object. You can change the color of
the fill as well as the manner in
which the object is filled. To access
the Area dialog, right-click the
object and select Area.
The Area tab controls what fills
the object. You can choose from
color, gradient, hatching, and
bitmap in the Fill drop-down list.
Once you have selected the type of
fill, you can select a fill from the
list. The preview box shows you
the result of your selections.
The Shadow tab allows you to
add a shadow under your object.
Check Use shadow to create a
shadow. The position determines
the location of the shadow, and
contents ^
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the distance how far from the
object. Color determines the color
of the shadow, and transparency
sets the opacity of the shadow.
On the Transparency tab, we
determine the opacity of the fill of
the object. We have three options
for the transparency of the fill. No
transparency means the fill is
completely opaque. With
transparency, you can set a
percentage for the whole area.
Gradient is the option with the
most settings and the chance to
create the most interesting
effects. You have six choices for
the gradient types, linear, axial,
radial, ellipsoid, quadratic, and
square. For all except the linear
and axial, you can control the XY
center of the gradient. The XY
center is the point where the
object is the clearest, or most
transparent. Except for the radial,
you can also define an angle for
the gradient area. The border

setting reduces the size of the
transparent area. The bigger the
percentage, the smaller the
transparent area. Use the start and
the end values to change the
beginning and ending opacity
levels. For example, if you don't
want any totally clear places on
your object, you can start with a
value of 10 or 15%.
The colors, gradients, hatching,
and bitmaps tabs allow you to
create new fill styles by defining
new colors, gradients, hatchings,
and bitmaps.

Besides controlling the position
and size of an object, the position
and size dialog also allows you to
control the rotation, slant, and
corner radius of an object. To
access the Position and Size dialog,
right-click your object and select
Position and Size.
The Position and Size tab does
what you would expect. You can
control the XY position on the
canvas of the object, and its width
and height. The base point for
each of the options gives nine
points on the object from which

position or size is calculated. There
is a Keep ratio checkbox under size
to help maintain the aspect ratio
of the object (any change in height
will create a change in width and
vice versa). You also have options
to protect the position or size to
prevent accidentally changing
them. The adapt option only
relates to text frames and allows
you to fit the width and/or height
to match the text.
On the Rotation tab, you can
control the rotation of the object.
This is usually much more accurate
than using the rotation tool. You
can select the pivot point through
the input boxes, or by selecting a
pivot point on the Default settings
box. Select your angle through the
input box or by selecting a point on
the angle Default settings
compass.

POSITION AND SIZE DIALOG
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stack in the order in which they
were created, the last on top.
Using the arrange options, you can
push objects forward or backward
in the stack until you get the
results you want.

radius is blocked for some objects.

Finally, the Slant & Corner
Radius tab allows you to control
the roundness of the corners and
the slant (think italics text). Think
of the corner radius as using
sandpaper to round off a corner.
The more you sand, the rounder
the corner. The bigger the number,
the rounder the corner. If you set
the corner radius high enough on a
rectangle, it will become an oval.
The slant, given as an angle, skews
the object to the right for a
positive angle and to the left for a
negative angle. Using the corner
radius and slant, you can get some
interesting shapes. The corner

ARRANGE, ALIGN, FLIP,
CONVERT
Sometimes, it just becomes
necessary to stack objects, make
them line up, mirror them, or just
convert them into something that
you can edit in a different way. All
the following commands are found
by right-clicking the object. They
are also available in the Modify
menu.
The arrange options allow you
to control the stack position of
objects. When you have multiple
objects which overlap, you may
need to change the order in which
they are stacked. By default, they
full circle magazine #77

Align allows you to align objects
in reference to each other or to
the page. If you have only one
object selected, the object will
align to the current page. If more
than one object is selected, they
will align according to each other.
The larger of the objects usually
controls the final location, and the
other objects are moved to align to
the selected position of that
object. The alignment options are
left, right, horizontal center,
vertical center, top, and bottom.
Draw has an align toolbar in
addition to the right-click menu
and Modify menu.

within that object, allowing you to
achieve completely original
shapes. Once an object is a curve,
you can add points, remove points,
and use the point transition tools
on the points of the object. Turn a
rectangle into a curve, then start
adding, moving, and manipulating
the points, and see what you can
create.

CONCLUSION
The options in Draw for editing
an object are numerous. By
applying the right tools to an
object, you can create almost any
shape you can imagine (maybe a
few you never imagined). I
encourage you to play with these
tools and see what you can come
up with. You never know, you
might discover that little piece of
artist or designer in you.

The flip options are
straightforward. You can flip an
object vertically (top to bottom) or
horizontally (left to right).
There are many options under
the right-click > Convert option,
but one in particular that I want to
draw your attention to, Convert >
To Curve. By converting any object
to a curve, you can edit the points
12
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LibreOffice Pt31: Templates

Written by Elmer Perry

I

f you work in LibreOffice much,
you will find yourself using the
same formating over and over.
Whether you use it to write letters
or to create the next best-seller,
you spend a lot of time setting up
the same styles over and over
again. Templates are the answer to
this problem. A template is a
document model used to create
other documents. All the
LibreOffice applications can use
templates. In fact, every time you
create a new document,
LibreOffice is using a default
template.
Styles are the key to creating
templates. Styles are a preset way
of displaying information. I first
discussed the importance of using
styles all the way back in part 3 of
this series, discussing how styles
help create a uniform look in your
document as well as saving you
time. In the spirit of saving you
time, we can add one more use for
styles, creating templates.

SETTING UP A TEMPLATE
Everything from a business

letter to a scientific research paper
has a required layout and format.
Let us say we are writing a
document that requires a
numbered outline format with
sublevels. Another requirement is
that the title and author appear at
the top of each page, and the page
number at the bottom in the
format of “Page # of #”.

the Footer tab and check Footer
On. Click OK to save the changes.
Click into the header area of the
first page, Insert > Fields > Title.
Type a space and “by”, then Insert
> Fields > Author. Move your cursor
down to the footer at the bottom
of the page. Type “Page”, a space,
then Insert > Field > Page Number.
Type space “of” space, then Insert
> Fields > Page Count.

We will tackle the numbering
style first. In a new Writer
document, open the Styles and
Formatting window. Click on the
list styles icon (the last one on the
Styles toolbar). Select Numbering
1. Right-click Numbering 1 and
choose Modify. On the Outline tab,
pick the style that is labeled
“Numeric with all sublevels” when
you hover the mouse over it. Click
the Apply and OK buttons.

SAVING THE TEMPLATE
We are now ready to save our
template. File > Save as Template
will open the Template Manager.
Select the template folder where
you want to store your template.
Click Save. A dialog will prompt
you to name the template. Enter
the name you want to show for the
template and click Accept. Close
the Template Manager.

Now, to take care of the header
and footer. Open the Styles and
Formatting window and click on
the Page styles icon (next to last
on the Styles toolbar). Right-click
the Default Style page style and
select Modify. On the Header tab,
check Header On, then switch to
full circle magazine #78
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to the folder where you have your
template and select it. Click on the
“Set As Default” button. Now,
anytime you start a new document
of that type, LibreOffice will use
your template instead of the
default template that comes with
LibreOffice.

DIFFERENT SOURCES FOR
TEMPLATES
USING THE TEMPLATE
Let's use our newly created
template. File > New > Templates.
Open the folder where you saved
your template and double-click
your template. The title shows as
the title you gave the template.
Let's change it. File > Properties.
Select the Description tab and
change the title to something else.
Click OK. The title in the header
will change to whatever you typed
in.

Let's try out that outline
numbering system. Open the
Styles and Formatting, click on the
List styles icon, and double-click
Numbering 1. Your input will
change to the list style we defined
for the Numbering 1 when creating
the template. Add some text and
be sure to add several levels to
make sure it is all working. Now,
you can save your document like
you normally would. This does not
save it as the template, but as a
new file on your computer.

full circle magazine #78

SETTING A NEW DEFAULT
TEMPLATE
If you need to use your new
template most of the time, why
not make it your default template?
This is easily done in LibreOffice.
File > New > Templates. Navigate
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Creating your own templates is
great, but you will not always need
to put in all that work. The official
template repository at
http://templates.libreoffice.org
has hundreds of templates for you
to try and use. To use individual
templates, import them into the
template manager.
Some templates are collections.
They have a extension of .OXT. To
import these templates, you use
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the Extension Manager, Tools >
Extension Manager. Click Add, and
browse to your downloaded OXT
file. Select the file and click Open.
The Extension Manager will
process the file and add the
collection to your Template
Manager.

PYTHON SPECIAL EDITIONS:

CONCLUSION
Templates are a way to repeat
the formatting of a document
from one document to the next.
Creating and saving templates
relies mostly on the use of styles.
Though I demonstrated creating a
Writer template, you can create
templates in the other modules of
LibreOffice, too. You can even set
your template as the default for
that type of document. Templates
are just one more time-saving tool
within the LibreOffice suite.

Elmer Perry's history of working,
and programming, computers
involves an Apple ][E, adding some
Amiga, a generous helping of DOS
and Windows, a dash of Unix, and
blend well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com
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LibreOffice Pt32: Impress Remote

Written by Elmer Perry

I

f you have ever given a
presentation, you know that
moving back to the computer to
advance your slides is a pain,
especially if, like me, you move
around a lot and actively engage
your audience. I recently presented
for a training session at work and
constantly wished I had a remote.
The Document Foundation has
provided a solution in the Android
application Impress Remote.
Impress Remote allows you to
control your Impress presentation
from your Android phone or tablet.
Impress Remote requires
LibreOffice version 4.0.1 or
greater, and a phone or tablet
running Android 2.3 or greater. If
you own a recent phone or tablet
and your Linux distribution is up to
date, you shouldn't have any
problem using the program.

SETUP
We will need to make changes
to our LibreOffice Impress setup to
run the remote program. Start by
opening a new or existing
presentation. Then Tools > Options

> LibreOffice Impress > General.
Check “Enable Remote Control”.
Click OK. Tools > Options >
LibreOffice > Advanced. Check
“Enable experimental features”.
Click OK. Restart LibreOffice and
open your presentation.
When we set up the remote
control app, we will need the IP
address of the computer running
LibreOffice. From a Linux terminal
prompt, the following command
should work for most users:
ifconfig eth0

The information you need is on
the line that starts with “inet
addr:xxx.xxx.xxx.xxx”, where
xxx.xxx.xxx.xxx is the IP address
for your computer. Write this
address down and keep it for later.
You will need it when you set up
the remote app.
Now, we install the Impress
Remote app. From the Google Play
store, search for Impress Remote,
and install the app on your phone
or tablet. The first time you open
the app, you see a mostly empty
screen. Select “Add WI-FI Computer
full circle magazine #79

Manually”. Enter a name for the
computer and the IP of the
computer. Select Add. Select the
computer from the list and let it
connect. Back in Impress, Slide
Show > Impress Remote. Select
your remote device. Enter the code
given you by the app. Click Select.
In the remote app, click “Start
Presentation” to start the
presentation.

USING IMPRESS REMOTE
APP

If your computer has Bluetooth,
you can also connect by pairing
your phone with your computer.
Once you open the app, it will scan
for your device using Bluetooth,
and you can just select your device
from the list. You still need to
enable the remote and

The remote app is pretty basic,
but let's face it, the less
complicated the better when
you're giving a presentation. The
tool bar across the top has the
current time, which is handy when
your presentation needs to start or
end at certain times. To the left of

10

experimental options in
LibreOffice.
NOTE: If you are running a firewall
on your computer, you will need to
open TCP port 1599 for
communications through WiFi.
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the time is the view switcher, and
to the right of the time is the app
menu.

or designed, way to move through
your presentation is with the
volume up and down buttons. The
up button moves forward in the
presentation, and the down button
moves backward in the
presentation.

Sometimes, you need to pause
a presentation and move your
audiences' attention from the
screen to something else. Impress
Remote gives you the ability to
blank the screen. In the app menu,
select “Blank Screen”. Your
presentation screen will go blank.
When you are ready to return to
the presentation, just click “Return
to Slide”. The presentation will
pick up where you left off.

is practical only for fixed slides.
Any slides with animations will
require the use of the volume up
and down buttons.

If you select the clock, you have
the option of leaving it as the
current time or starting a
stopwatch. Select the stopwatch to
use it. You will get a Start and
Reset option. Press Start to start
the timer. The timer will begin to
count, and the options will change
to Pause and Restart. Select Pause
to pause the timer, and Restart to
start over from 0.00. This is handy
for timing an activity or working on
your timing for your presentation.

Once you start a presentation,
you get the slide scroll view of
your presentation. This view is the
most useful, because while you are
in scroll mode, you can also see any
notes you made for the slide.
While you can use your finger to
move between slides, this is not
the best method unless you are
just needing to skip forward or
move back in your presentation
several slides at a time. The best,

You can display your slides in
two different ways. One we have
seen already, the scroll mode. The
other is the list mode. You can
switch between the two mode by
selecting the view switcher button.
In the scroll mode, you move
quickly to a slide by swiping with
your finger. To select a slide in list
view, you just select the slide. This
full circle magazine #79
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In the app menu, there is an
item for Options. The first option
is for using the volume up and
down buttons to control the
presentation. I can't think of a
good reason to uncheck this, but
I'm guessing it is there because
someone had a reason. The second
option is for enabling a wireless
connection between the phone
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and the computer. This allows the
app to automatically search for
devices on the wireless network
that are running LibreOffice
Impress with the remote feature
turned on. Finally, the switch
computer option allows you to
switch to a different computer.

PYTHON SPECIAL EDITIONS:

CONCLUSION
When giving a presentation, it is
nice to have mobility. The Android
app Impress Remote gives you
mobility by allowing you to control
your Impress presentation from
your Android phone or tablet. The
app is easy to set up through
Bluetooth or WiFi. The interface is
not cluttered, making it easy to
use and control. Since the app was
developed by the same people
who develop LibreOffice, future
compatibility is almost assured.

Elmer Perry's history of working,
and programming, computers
involves an Apple ][E, adding some
Amiga, a generous helping of DOS
and Windows, a dash of Unix, and
blend well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com
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Written by Elmer Perry

Li breO ffi ce Pt3 3 : Con n ect Ba se to M ySQ L

sing the default HSQLDB
database management system
(DMS) in LibreOffice Base is great
for creating new databases, but
sometimes you need to connect to
an existing database on another
DMS like MySQL, dBase, JDBC,
Oracle, PostgreSQL, and others. I
showed you how to connect to a
simple spreadsheet database back
in Issue 52. Today, I will show you
how to connect to a database
created in MySQL.

If you are installing MySQL on
your current machine, you will need
to install the MySQL server
package as well: “mysql-server”.
When you install the server
package, it prompts you for a
“root” password and asks for
confirmation. This is your master
password for MySQL. Jot it down
somewhere. You will need it later.
If you are connecting to a database
on a different machine, you don't
need this package.

MySQL is a DMS used on many
websites. Wordpress and other
content management systems use
MySQL for their databases. You
might have many reasons to access
a database created in MySQL.
MySQL is open source, and you can
install it from your software
manager.

The last package we need to
install is “libreoffice-mysqlconnector”. This package will allow
us to connect to MySQL without
using an OBDC or JDBC wrapper.

I NSTALL M YSQL
Installing MySQL from your
software manager requires the
installation of two packages. The
first package is “mysql-client” – the
client program for MySQL. It allows
you to interact with MySQL.

CREATE A TEST M YSQL
D ATABASE
If this is the first time you are
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connecting to an external database
using LibreOffice Base, I
recommend you create a test
database in MySQL where you can
make mistakes and learn. You can
install a program like PHP
MyAdmin or EMMA, but I think it is
easier just to use the MySQL
command-line client.
To connect to MySQL on your
local machine, use the command:
mysql -h localhost -u root -p

details on setting up MySQL to
accept remote connections, read
this tutorial:
http://www.cyberciti.biz/tips/howdo-i-enable-remote-access-tomysql-database-server.html
To create a database use the
following command at the MySQL
prompt:
CREATE DATABASE <dbname>;

where <dbname> is the name you
want to give the database. To
create a databases name
“myTestDB” enter:

MySQL will prompt you for the
“root” password. Enter it and you
are greeted with a welcome
message and the “mysql>” prompt. CREATE DATABASE myTestDB;
To connect to a MySQL server on
MySQL responds with a
another computer, replace
“localhost” with the server name or message that the query was
executed. Enter
IP address. Keep in mind that you
will need to set up MySQL to
SHOW DATABASES;
accept remote connections. For
to generate a list of all the
databases. You should see your
new database among those listed.
An empty database is all we need
to connect to MySQL from Base,
but you can also connect to a fully
functional database as well; but,

10
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like I said, it is better to practice on
Step 2: Since we installed the
a test database first. Type “quit”
“libreoffice-mysql-connector”, we
and press Enter to exit your MySQL have no use for the ODBC or JDBC
session.
connections. Select “Connect
directly”. Click Next.

CONNECT B ASE TO M YSQL
D ATABASE

Now for the part we have been
working for – actually connecting
Base to the MySQL database. Start
by creating a new database
document in LibreOffice, File >
New > Database. We will use this
document to connect to the
database we created before. Using
the database wizard
(recommended), it is a five step
process.

Step 1 : We want to connect to
an existing database. Don't
confuse this with connecting to an
existing database file. You want
the last selection. From the drop
down list select MySQL. Click Next.

Step 3: The database is the
name of the database we just
created in MySQL. Our example
database was “myTestDB”. The
server is “localhost” for the local
computer, or the server name or IP
address of another computer.
Leave the Port as the default
unless you changed it in your
MySQL settings or have been told
to do so by your IT department.
Click Next.

computer. Use “root” if you are
connecting to MySQL on your local
computer. Check “Password
required”. Click “Test Connection”.
You are prompted for your
password. Enter your password
and click OK. If you set everything
correctly, you will get a message
back saying Base successfully
connected to the database. OK on
the message and click Next.

Step 5: Select Register or Don't

Register according to your needs
for the database. A registered
database is available in other
LibreOffice modules. Check “Open
database for editing”. Click Finish.
Base will prompt you for a file
name. Enter a name and click Save.

You can now interact with the
MySQL database in the same way
you would an HSQLDB database.
You can create tables, queries,
reports, and forms just like you
would with the default DMS. You
will need to pay attention to the
data types as they are slightly
different in MySQL. For an
overview of the HSQLDB data
types see my article at
http://wp.me/pvwht-8Q. For a list
of MySQL data types see
http://dev.mysql.com/doc/refman/
5.0/en/data-type-overview.html.
While using the default DMS for
Base is good for new databases,
sometimes it becomes necessary to
connect to existing databases. In
this article, we showed how this is
done by connecting to an external
database we created in MySQL. We
installed MySQL and created a
blank database. Using the database
wizard in Base, we connected to
that database where we can create
tables, forms, queries, and reports
to interact with the database. Base
can also connect to other database
types like dBase, JDBC, Oracle,
PostgreSQL, and others.

Step 4: The user name you need

to connect to MySQL from your
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Li b re O ffi ce Pt3 4: Exp e ri m e n ta l S i d e b a r

Written by Elmer Perry

ith the release of
LibreOfffice 4 came some
new features and improvements.
Among the most interesting is the
Experimental Sidebar. The new
sidebar puts a lot of the operations
and tools in one easy location. The
sidebar eliminates the need for the
formatting toolbar for many
objects.
Today, we will look at the
sidebar and how it adapts in
accordance with the document you
are currently working with. Just
remember that the sidebar is an
experimental feature, which means
it can crash the program without
warning. So, when using the
sidebar, I recommend saving often.

O VERVIEW
The sidebar for LibreOffice is
similar to the sidebar in Calligra or
the ribbon in Microsoft Office.
While it can't replace everything,
you will find yourself using it
instead of the formatting toolbars
and dialogs. The sidebar actually
has more features than the
formatting toolbar by default.

The sidebar is a collection of
panels. The available panels
depend on the program you are
using. You can access each of the
panels by selecting their icon from
the right side of the sidebar or
from the sidebar menu. Each of the
panels serves as a shortcut to
different tools in the program. Of
these, I personally use Properties,
and Styles and Formatting most
often. Let's take a closer look at
each one.

S ETUP
Since the sidebar is
experimental, we need to activate
it. From any LibreOffice screen,
Tools > Options > LibreOffice >
Advanced. Check “Enable
experimental sidebar (on restart)”
and click OK. You will need to
restart LibreOffice in order for this
change to take affect.

By default the sidebar is docked
to the right side of the main
window. You can show or hide the
sidebar using the show/hide button
on the inside border, or through
the menus View > Sidebar. From
the sidebar menu you can
undock/dock the sidebar. You can
also customize the sidebar by
removing the panels you will not
use.

the different properties using the
icons in the panel. Changing
properties using these icons is the
same as making manual changes
through the dialogs and formatting
toolbar, meaning it has no effect
on the underlying style assigned to
the item – only the current item. If
you cannot find a property, you can
click on the ”More Options” button
in the corner of each property type
to get a complete properties dialog
with tabs. You can collapse and

P ROPERTIES
The Properties panel shows you
the properties for the current item
in the document. You can adjust
full circle magazine #81
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expand any of the blocks using the
expand / collapse button next to
the block title.

As an example, when typing in a
Writer document, you will see
three property blocks in the
Properties panel: Text, Paragraph,
and Page. The Text block allows
you to control different settings
related to text – font, bold, italics,
color, etc. The Paragraph block
allows you to control the
paragraph's alignment, spacing,
margins, etc. The Page block lets
you change the page's size,
orientation, margins, and columns.

STYLES AND FORMATTING

Formatting window and docks it in
the sidebar. This allows you quick
access to your different styles.
Though you could still just use the
button on the Formatting toolbar,
the new sidebar does provide a
central location for this tool and
others like it. The window still
provides styles broken down by
type (characters, paragraphs,
frames, pages, and lists), as well as
the subcategory drop-down list.
You still create and modify styles in
the same manner as with the Styles
and Formatting window.

categories, called themes, at the
top, and a list of images
underneath. You can use this
library of images to insert clip-art
and backgrounds into your
documents, as well as sounds into
your presentations. You can add to
and create new themes in your
Gallery. A complete how-to on the
Gallery library is for a future article.

N AVIGATOR

G ALLERY

The Gallery is a collection of
images for use in your documents.
The sidebar takes the Styles and The Gallery panel presents a list of
full circle magazine #81

good argument for giving
meaningful names to your OLE
objects and images.

M ASTER PAGES (I MPRESS
O NLY)
The Master Pages panel is used
for selecting and creating master
pages in Impress. I discussed
Master Pages in part 1 6 of this
series, FCM#63:
http://fullcirclemagazine.org/issue63/. This panel is just a translation
of the old Master Pages section of
the Impress Tasks pane.

CUSTOM ANIMATIONS
(I MPRESS O NLY)

The Navigator is a catalog of
your document headings, tables,
sections, images, etc. The
Navigator allows you to quickly
move from one point in your
document to another by reference
to an object. This becomes quite
handy in large documents, and is a
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The Custom Animations panel is
used to animate objects on an
Impress slide. I discussed
animations in part 1 8 of this series,
FCM#65:
http://fullcirclemagazine.org/issue65/. This is also a translation from
the old Impress Tasks pane into the
new format.

SLIDE TRANSITIONS
(I MPRESS O NLY)
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Slide Transitions control how a
presentation moves from one slide
to another. For more details see
part 1 8 of this series, FCM#65:
http://fullcirclemagazine.org/issue65/. This panel is another copy
from the old Impress Tasks pane.

FUNCTIONS (CALC O NLY)

The Function panel gives you
access to all the Calc functions. A
drop-down list divides the
functions into categories, including
“Recent Used” and “All” categories.
Below is a list of all the functions in
the selected category. You can
insert the function into the current
cell by double-clicking the function

name or selecting the fx button
next to the drop-down list of
categories. This gives you quick
access to the functions and is much
easier (in my opinion) to use than
the function wizard.
The experimental sidebar is a
tool that makes access to common
tools quicker and easier.
LibreOffice has accomplished this
by making the panel’s expansions
and combinations of common
toolbars, and translating older
panels and wizards to the new
format. You can compare it to the
sidebar in Calligra or the Microsoft
Office ribbon bar. I have found it
handy to use, but keep in mind that
it is experimental and might crash
LibreOffice occasionally.

PYTHON SPECIAL EDITIONS:
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Li breO ffi ce Pt3 5 : Th e G a llery

Written by Elmer Perry

ollecting clip art for use in your
newsletter, spreadsheet,
presentation, or other document
can become a timely task.
Especially when it comes to
organizing – and later finding – the
image you want to use. LibreOffice
provides a built-in Gallery for
collecting and organizing images,
sounds, and videos. The Gallery
collects files into categories called
themes. You can add files from the
Gallery directly into your
document. Creating new themes
allows you to add your own files
into the collection.

THE G ALLERY
You can access the Gallery in
three different ways, through the
menus (Tools > Gallery); by a

button on the standard toolbar;
and through a panel on the
experimental sidebar. By default,
the Gallery is docked under the
formatting toolbar. You can undock
and dock the Gallery with the
combination of CTRL + double-click
on the border of the Gallery. Use
the hide/show button on the lower
border to display and hide the
Gallery while it is docked. If you
hover over the lower border, your
mouse cursor will turn to a double
arrow, and you can resize the
docked Gallery's height.
On the left side of the Gallery is
the themes list. Selecting a theme
changes the files which display in
the main panel. The main panel
shows the files available in the
currently selected theme. Above
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the main area are two buttons for file and Insert > Copy.
displaying the files – in tile or detail
To link a file from your Gallery
view. Beside the buttons, it shows
into a document, select the theme
the theme name, file name, and
and file. Hold down SHIFT + CTRL
path for the selected file.
while dragging and dropping the
file into the document, or rightU SING THE G ALLERY
click then Insert > Link.
The Gallery allows you to insert
Sometimes, you will want to use
a file as a copy, a link, or a
an
image
as the background for a
background. When you insert the
file as a copy, the file is embedded page or a paragraph. To set an
image as the background for a
into the current document and is
page, select the theme and image.
not reliant on another file. If you
insert the file as a link, a reference Right-click the image and Insert >
Background > page. To set the
to the file is created in the
image as the background for the
document. If you opened a
current paragraph, right-click the
document with linked files, the
image and Insert > Background >
files will show only if they are in
Paragraph.
the location referenced in the
document. If the file needs to
travel among multiple computers, M ANAGING THE G ALLERY
insert a copy. If the document will
A nice feature of the Gallery is
reside on only one computer, you
the ability to add your own files to
can safely insert a link.
the collection. You cannot,
however, add to, remove from, or
To insert a copy of a file from
delete the default themes. In order
your Gallery into the document,
to add your own files to the
select the theme containing the
Gallery, you will have to create
file and select the file. You can
your own themes. You add your
then drag and drop the file into
own theme by clicking on the “New
your document, or right-click the
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Theme” button, which opens the
“New Theme” dialog. In the
“General” tab, enter the name for
your new theme. You can now add
files to your theme in the “Files”
tab or just click “OK” to save the
theme.
Adding files to the theme you
just created is easy. You can add
files one at a time by dragging and
dropping them into the main panel
with your theme selected. To
selectively add files or to add an
entire folder, right-click on the
theme title and click “Properties.”
A theme “Properties” dialog will
display. This is the same dialog you
get when adding a theme, so you
can use this method to add files
when you create a new theme.
Select the “Files” tab, then click
“Find Files.” Use the file dialog to
navigate to the folder containing

the file(s) you want, and click
“Select.” A list of files in the folder
will display in the list box. Use the
drop-down box above the list to
filter the files if needed. Take time
to scroll through the filter list to
get an idea of the many file
formats the Gallery accepts. For
image files, you can get a preview
by checking the “Preview” check
box. Once you find the file you
want, you can select it and click
“Add” to add it to the theme, or
click “Add All” to add all the files in
the list box.
You won't always add files to
the Gallery with the intention of
keeping them there indefinitely.
You may want to just add them
while working on a certain project.
Once the project is done and you
no longer need them, you will want
to delete the files and themes
full circle magazine #82

created for the project. To delete a
file from a theme, right-click the
file and select “Delete.” You can
also delete a theme with all its files
by right-clicking the theme title
and selecting “Delete.” Keep in
mind that there is no undo for
these actions, and that deleting a
file from the Gallery does not
delete it from the computer, just
from the Gallery’s theme list.
LibreOffice provides a media
library called the Gallery. The
Gallery is divided in collections
called themes. You can add your
own themes and files to the
Gallery. If a file or theme is added
15

only for a certain project, you can
delete them when the project is
finished. The Gallery is available in
all modules of the suite, and helps
you to maintain consistency for
newsletters, spreadsheets,
presentations, databases, and
reports.

Elmer Perry's history of working, and
programming, computers involves an
Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com
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H O W-TO

f you work with Base long
enough, you will run into a
situation where you need a table
structured a little differently, or
you’ll need the results of a query as
a table you can use. The answer to
these problems is ‘Views’. A view is
a query which acts like a table you
can use in other queries, forms, or
controls. Today, I will show you an
example of how this is useful when
creating forms.

O UR TABLES

Li breO ffi ce Pt3 6: Ba se Vi ews

Written by Elmer Perry

Increment
FirstName|Varchar(25)|Not
Null
LastName|Varchar(25)|Not Null

Shown right is the SQL to create
the tables. Create a new database
document, then go to Tools > SQL,
and type the commands in by hand
or copy and paste.
You can also get the above SQL
commands on pastebin.com at
http://pastebin.com/Wyb3R5Fz.

The key to our task is the
We are going to create a simple foreign key “MemberID” in the
“Project” table, which connects to
database with two tables. The
the “TeamMember” table's “ID”
database will track projects for a
field. When we create our form we
company and allow us to assign a
will create a drop-down list for
team member to each project.
Below is the structure of the tables selecting the team member who is
responsible for the project. Notice
we will create.
that the “TeamMember” table
provides first and last name fields.
Project Table
Field|Type|Properties
The list control allows us to use
ID|Integer|Primary Key, Auto
only one field in the list. We could
Increment
display just the last name in the
Title|varchar(50)|Not Null
Description|varchar(250)
drop-down list, but what if two
Due|Date
team members have the same last
MemberID|Integer|foreign key
name. We will solve this problem
TeamMember Table
by creating a view that will
Field|Type|Properties
combine the first and last name
ID|Integer|Primary Key, Auto
full circle magazine #83

drop table "Project" if exists;
drop table "TeamMember" if exists;
create table "TeamMember" (
"ID" integer generated by default as identity
(start with 1) not null primary key,
"FirstName" varchar(25) not null,
"LastName" varchar(25) not null
);
create table "Project" (
"ID" integer generated by default as identity
(start with 1) not null primary key,
"Title" varchar(50) not null,
"Description" varchar(250),
"Due" date,
"Member" integer,
constraint FK_MEM foreign key ("Member")
references "TeamMember" ("ID")
);

into one field called “Name”. We
will use our view to populate the
drop-down list box.

the first and last name fields to
create one field. We will also get
the “ID” field, as we will need it to
connect back to the “Project” table.

If the tables do not show in your
To create the query, we select
table list after running the
commands, Review > Refresh Table the “Queries” option in the
“Database” pane. In the “Actions”
will populate the list.
pane, select “Create Query in SQL
View.” The follow SQL command
CREATE Q UERY / VIEW
will create our query:
To create our view, we will use a
SELECT "FirstName" || ' ' ||
two-step process. First, we create a
query, then convert the query into "LastName" AS "Name",
"ID" FROM "TeamMember";
a view. In our query, we combine
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If you are familiar with SQL, this
looks like a standard query except
for the double pipe symbols “||”.
They are used to concatenate
strings together. In the command,
we select each “FirstName” and
join it to a space, then take the
result and join it to “LastName.”
Finally, we name this string
“Name.” We also get the “ID” as it
identifies each record. You can test
the query to make sure it works,
but at this point your results are
blank, but the query should run
without error. Save the query as
“QueryTeam”.

wizard will display.

On the first screen, select
“Table: TeamMember” from the
drop-down box. Move the
“FirstName” and “LastName” fields
into the list box labeled “Fields in
the form.” Click the “Next >”
button. There is no subform so just
click “Next >” again. On step 5, use
any of the options for arranging
the controls except tabular. On
step 6, just accept the defaults.
With Step 7 pick a style that you
like. When you get to step 8, name
the form “TeamMemberForm” and
leave it on “Work with the form.”
Turning the query into a view is When you click the “Finish” button,
as simple as right-clicking the query the form will open for input. Add a
few names for testing the project
name and selecting “Create as
View.” Name the view “TeamView.” form when we finish it.
If you select “Tables” under the
For the project form, we need
“Database” pane, you will see
about the same thing, except use
“TeamView” listed under the
“Table: Project” from the droptables.
down in step 1 , and select all the
fields except for “ID” for inclusion
CREATE THE FORMS
in the form. Name the form
“ProjectForm” and select “Modify
We will create a team member
the form” on step 8. This time,
form and a project form for data
instead of the form opening for
input. The team member form is
input, it opens for editing.
the easiest, so let's make it first.
Click on the “Forms” icon in the
When you create forms using
“Database” pane and select “Use
the
form wizard, the wizard groups
Wizard to Create Form.” The form
a text box for most data types with
full circle magazine #83

a label for each field. In order to
change the control for the data
field, you have to ungroup the text
box from the label. In our case, we
want to change the “Member”
field, so right-click the “Member”
label and text box and select Group
> Ungroup. Click on the form
background to unselect both.
Right-click on the text box and
select “Delete.” From the forms
toolbar, select the list box. If the
form toolbar is not showing then
View > Toolbars > Form Controls to
display it. Once you select the list
box, your cursor will become a
crosshair, +. Click and drag to
create the list drop-down box.
When you release the mouse
button the list box wizard will pop
up.
Select “TeamView” as your table
and click “Next >”. The field we
want to fill the list box is “Name”,
so select “Name” and click “Next
>”. Finally, we need to match the
fields from the two tables. For the
“Value Table” select “Member”.
“ID” is the field to select for “List
Table” as it is the primary key that
matches up with the “Member”
foreign key field in the “Project”
table.
Save your changes and close the

20

design window.
Now, if you entered names in
“TeamMemberForm”, you can open
the “ProjectForm” and those
names will appear in the dropdown list box we created. You will
want to test creating several
projects and assigning members to
them to test the workability of
your forms.
In this article, we discussed the
use of a LibreOffice Base view to
create a new table from an existing
table. We used this view in the
construction of a form that
automated the retrieval and
selection of records from that
view.

Elmer Perry's history of working, and
programming, computers involves an
Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com
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