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HOW-TO

Written by Elmer Perry

Libre Office - Part 8

alcis the spreadsheet

module of LibreOffice,

which is compatible with

Microsoft's Excel. We
already saw one use for Calc when
we created our poor man's
database in my last article, but
Calc is capable of more than just
data collection. As the name
implies, Calc can do calculations
using a rich number of

the bottom of the window. Each
spreadsheet consists of individual
cells. You identify the cells by their
column letter and row number. For
example, the First cell in the upper
left hand corner is A1, the First
column, first row. Each
spreadsheet is capable of having
1,024 columns and 1,048,576 rows.

o Untitled 2 - LibreOffice Calc
»

The leftmost box is the current cell
name box. It tells you the currently
selected cell or range of cells. The
three buttons are the function
wizard, the sum button, and
function button. The text box is
the input line. Use it to edit the
contents of a cell.

At the top of your spreadsheet,
you have the column headers
(A, B, C...), and along the left
hand side, you have the row
headers (1, 2, 3...). The

columns and rows are

marked on the sheet by light

gray lines. You will find this

functions bu.ilt into the B - B /5 & & e .
program. This means we don't | Formula Bar =
have to manually calculate Default gy Anat }
the Fotal of some column; we [ ) fe E = | |
caninsert a formula to add it T T o | =
up for us. Calc also allows you ™ :
to do a “what if..” scenario to 2
: : 3 Column Headers
play with the numbers in your 2
spreadsheet. g
= Current Cell
Before we get into 8
9 Row Headers
building our budget 10 Sheet Tabs
spreadsheet, you need to n 2 v \Sheetl Ohee AOTec AL/ 1« ‘
(_Sheet 1/3 | Default | |stD | | Isum=0 |©@ ——o——

grid handy when you are
laying out your spreadsheet.

You have several choices
in the way you enter data
into the cells. You can click
'L | on the cell and just start

know a few things about how
a file, sometimes referred to as a
workbook in Calc, works. Each file
can contain several different
spreadsheets. In a new workbook,
you get three spreadsheets by
default named sheet1, sheet2, and
sheet3. They are listed on tabs at

The layout of the Calc window
is a little different than the Writer
window. You still have a menu bar
and formatting bar, but below the
formatting bar, you have the
formula bar. The formula bar is
your friend when you work in Calc.

typing. When you have
finished, press enter and you will
move to the cell below. You can
also click on a cell and enter your
datain the input line of the
formula bar. This method has a
drawback, which | will explainin a
minute, but sometimes, it is the
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best method for editing the
content of a cell. You can edit
directly in the cell by double-
clicking the cell. This puts you in
cell edit mode. This mode is similar
to editing in the formula bar.

To navigate within your
spreadsheet, you can always grab
the mouse and click on the cell you
want. However, since often your
hands are already at the keyboard,
keyboard shortcuts work better.
Tab moves you one cell to the
right. Shift-Tab moves you one cell
to the left. Enter moves you one
cell down, and Shift-Enter moves
you one cell up. While not in edit
mode or not using the input line,
the arrow keys move you in the
direction of the arrow. The arrow
keys are disabled for navigation
while in the input line and in edit
mode to allow you to move within
your content.

Now, with these tools on your
belt, let's build the First section of
our budget spreadsheet. Open a
new Calc file. Click on the blank
gray spot to the left of the column
header and above the first row
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header. This will select the entire
sheet. In the formatting bar, set
the font to a nice sans-serif font
like Arial, and set the font size to
12pt. By doing this, we have set
the default font and size for our
entire sheet.

In cell A1, enter the text
“Income for This Period,” and press
Enter. For now, don't worry if the
text overruns the cell. We will fix
that in a minute. On the second
row of column A, type in “Sources”.
Down column A starting with row
3, type in the different types of
income you have, e.g. Work,
Freelancing, Bonus. | usually add a
“Misc” for those things that don't
fit into other categories, like
winning the lottery and quiting
your day job.

At this point, some of your
income sources may overflow their

Vs

Category

All £
User-defined

Number

Percent

Date
Time
Scientific —

A7 v f®
B
1 [Income this Period
2 |Sources
3 |Work
4 |Freelancing
| 5 |Bonus )

\.

Numbers Font FontEffects Alignment Borders Background

Format

'USD $ English (USA) -
-$1,234

-$1,234.00

-$1,234

-$1,234.—

-1,234.00 USD

-1,234.00 USD

cells. We can adjust the width of
the column by clicking between
the cell headers for A and B and
dragging. We are still not
concerned with the cell A1. At this
point, A1's overflow is okay, just
make sure all your income sources
fit in the column.

Move to cell B2. Type in
“Amount”. Press Enter. Down
column B, enter an amount for
each of the income sources. You
will notice the default for numbers

is just some unformatted numbers.

Let's make them look like currency
amounts. We will change them all
at once. You can select all the
numbered cells by click with the
left mouse button and dragging
until you have all the numbers
highlighted. You can also click on

the first cell, hold down the Shift
ke,y and click on the last one. With
the keyboard, use Shift in
combination with the arrow keys.

Format > Cells > Numbers. Select
the Currency category. Above the
format box, select the correct
currency type for your country.
Select a currency format from the
format box. This is entirely up to
you. Since you should never have a
negative figure in your income
cells, you don't need to worry too
much about Formats that deal with
negative numbers.

Now, we will take care of A1
overflowing into B1. Since this text
is a heading for the section, we
want it to span across the width of
the section. Cell Merge is the
answer. Highlight cells A1 and B1,

Line arrangement
Default

User-defined

¥ ¥ ¥
> «

.

Numbers Font FontEffects Alignment Borders Background

Line

Style

-none- =
0.50pt |

------------ 0.50 pt

———————— 0.50 pt
1.00 pt
2.50 pt
A DN nF =

Color

B Gray ~
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and Format > Merge Cells > Merge
and Center Cells. We will use
merge cells a lot, and it should
become one of your favorite
formatting features.
Unfortunately, there is no
keyboard shortcut. You can create
one in Tools > Customize >
Keyboard, but take care that you
don't assign the keyboard shortcut
to a common or predefined
functionality.

Now, let's make it look like a
header. Let's make the font bold,
Format > Cells > Font tab. Select
bold under Typeface. Let's put a
border around it to make it stand
out just a little more. Click on the
Borders tab. Under Default, click
the second box, Set All Four
Borders. Leave the style at the
default, but change the color to
gray. Click OK.

With our Source and Amount
headings, we want them to stand
out as well, but they need to look a
little different to distinguish them
from the section header. Select
the two cells with Source and
Amount in them. Format > Cells >
Font tab. Select bold again. Click
on the Borders tab. This time we
just want a border between the
two cells. Click in the User-defined

box between the two gray boxes
with a white X in them. You will
see a line between the two.
Change the color to gray. On the
Alignment tab, change the
alignment for horizontal to center
and vertical to middle. On the
Background tab, select a light blue
(Blue 8) for the background color.
Click OK.

For our income items, we could
put a border around them, but
that can be hard to read
sometimes. Instead, let's highlight
the even numbered rows. Start
with the second item, highlight
both the name and its amount.
Format > Cells > Background tab.
Select a light gray for the
background. | used Gray 10%. Click
OK. Repeat for all the even rows.

It would be nice to have a
divider between the name and the
amount and a border around the
whole list. Click on the first name,
hold the Shift key, and click on the
last amount. This should highlight
all the items and their amounts.
Format > Cells > Border tab. Under
Default select the second box, Set
Outer Border Only. You will notice
the User-defined box is different
this time. There are four gray
boxes with white X's in them. Click

between the top two boxes. This
will give you a vertical line
between the cells. If you click in
the middle, it will create a vertical
and horizontal line, which is not
what we want. Change the color to
gray and click OK.

A B

Income this Period

2 Sources | Amount

3 |Work $1,079.00

4 |Freelancing| $200.00

5 |Bonus $50.00

6 |Misc $5,000.00
_7 y,

This completes the Income
section of our spreadsheet. In the
next article, we will continue with
our budget spreadsheet by adding
the Assets section. And we will
begin looking at making our
spreadsheet do some math for us
using the Sum function.

Elmer Perry is a children's minister in
Asheville, North Carolina whose
hobbies include web design,
programming, and writing. His
website is eeperry.wordpress.com
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LibreOFfFice - Part 9

n Part 8, we looked into

formatting our spreadsheet

cells to look a certain way, but

the true power of Calc comes
from its ability to calculate
formulas using basic math and its
built-in Functions. Calc formulas are
just what you think, mathematical
expressions that use data to create
a result. Calc functions give us
predefined calculations and
decision making. With just a little
knowledge of formulas and
functions, Calc becomes a powerful
data analysis tool. When entering a
formula or Function into a cell, your
formula or function must begin
with the = (equals), - (minus), or +
(positive) signs.

Arithmetic Operators

Calc has five basic arithmetic
operators:
+ (Plus) — add two numbers
together, or as a sign for a number.
Ex.=2+5or +5
- (Minus) — subtract one number
from another, or negate a number.
Ex.=5-2 or-5
* (Asterisk) — multiplication. Ex.
=2*3

/ (Slash) — division. Ex. =21/7
A (Caret) — exponentiation. Ex.
=572

Just like in real math, you can
use parentheses to group
expressions together to create
more complicated formulas. For
example, if you enter the equation
=5-2*3in a cell, when you press the
Enter key, you get -1 for the result.
However, if you enter the equation
=(5-2)*3 in a cell, you get 9 for the
result when you press the Enter
key. This happens because Calc
obeys the rules of precedence. In
the first equation, the
multiplication is done Ffirst, as per
the rules, which gives us 5-6, which
equals -1. In the second equation,
we change the order of operation
by using parentheses. In this case,
5-2 is calculated first because of
the parentheses, giving us 3, and 3
x3is9.

Cell References

Hard coding our numbers
doesn't make much sense. We
could just use a calculator for that.
To unleash the power of Calc's

calculating abilities, a reference to
the data in our spreadsheet is
needed. Cell references allows us
to use the data within our
spreadsheet in our calculations.
Cells are referenced by the column
letter and row number. The First
cell of the first column is A1, the
second cell of the first column is
A2, the first cell of the second
column is B1, the second cell of the
second column is B2, etc. If we
enter 5in cell A1 and 6in cell B1,
we can enter the equation =A1+B1
in any other cell in the
spreadsheet, and the result will
show as 11.

In some functions, you will need
to reference a range of cells rather
than just individual cells. To
reference a range of cells, start
with the first cell in the range,
followed by a colon (), and the last
cellin the range. To access the First
9 items in the B column, use B1:B9.
To access the First 5 items in row 1
use A1:E1.

What if you need to reference
multiple rows and columns? You
just start with the First cell in the

full circle magazine #55 @ 14

block and end with the last cell in
the block. For example, to
reference all the cells in the first 5
columns and rows, you would use
A1:ES.

Mathematical
Functions

If you need to sum a column of
numbers, using basic mathematical
operators could become laborious
very quickly. Calc provides many
functions for mathematic
calculations, from finding the sum
of given cells to trigonometry
functions. These functions speed
up your entry of formulas.

SUM() is the bread and butter of
mathematical functions. This
function is used so often, it has its
own button on the function
toolbar. SUM() can take up to 30
numbers or cell references
between parentheses. You can also
use range references with SUM(),
which allows you to quickly total a
column, row, or range of rows and
columns. Multiple numbers, cell
references, or range of cells are
separated by a semicolon (;).
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SUM() Examples

=SUM(A1;C2;D5) — sum of the three
cells

=SUM(2;A1;C5) — sum the number 2
with A1 and C5

=SUM(A1:A5) — sum the First five
cells in column A

=SUM(A1:B5) — sum the first five
cells in columns A and B

=SUM(A1:A5;C1:C5) — sum the first
five cells in columns A and C

Calc provides many other
mathematical functions. See the
LibreOffice Calc documentation for
a complete list, including the
trigonometry functions.

Conditional
Calculations

Sometimes, you only want to
perform a calculation when certain
conditions are met. A good
example of this is avoiding division
by zero. If you try to divide-by-zero,
you get an error. The conditional
Function IF() helps us accomplish
this. The basic syntax of the IF()
Function is:

IF( Test; ThenValue; ElseValue)

So, if we want to divide A1 by
B2, but we want to avoid the
operation if B2 is zero, we could
use the IF() function:

=IF(B2>0;A1/B2;"Can't div by
zero”)

This translates as “If B2 is
greater than 0, divide A1 by B2;
else, output the text 'Can't div by

"n

Zero.

Conditional calculations can
help you avoid errors in your
spreadsheets. Use them any time
you think problems might pop up,
like division-by-zero, or a number
not being entered.

Comparative Operators

Calc provides six comparative
operators we can use in our test.
= (equal to)
> (greater than)
< (less than)
>= (greater than or equal to)
<= (less than or equal to)
<> (not equal to)

In addition to the comparative
operators, we can use the NOT()
and AND() Functions in our test.

The AND() function allows us to
test more than one condition and
NOT negates the condition. This
time, let's make sure neither of the
numbers equal 0:

=IF (AND (NOT (A1=0) ; NOT (B2=0));
Al/B2; “Can't div by zero”)

In this formula, we make sure
than A1is NOT zero AND B2 is NOT
zero before we do our calculation.
While this formula shows both the
AND() and NOT() Functions being
used, a more practical formula
would be:

=IF (AND(A1>0;B2>0);A1/B2;"Can
't div by zero.”)

We have only begun to scratch
the surface of the possibilities
using Calc's formulas and
functions. Next time, we will take a
look at some practical uses for
some of these functions.

Elmer Perry's history of working, and
programming, computers involves an
Apple lIE, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
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ubuntu

uk podcast

(@)

The Ubuntu Podcast covers all the
latest news and issues facing
Ubuntu Linux users and Free
Software fans in general. The
show appeals to the newest user
and the oldest coder. Our
discussions cover the
development of Ubuntu but aren’t
overly technical. We are lucky
enough to have some great guests
on the show, telling us first hand
about the latest exciting
developments they are working
on, in a way that we can all
understand! We also talk about
the Ubuntu community and what it
gets up to.

The show is presented by
members of the UK's Ubuntu Linux
community. Because it is covered
by the Ubuntu Code of Conduct it
is suitable for all.

The show is broadcast live every
fortnight on a Tuesday evening
(British time) and is available for
download the following day.

podcast.ubuntu-uk.org
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LibreOFFice - Part 10

n part 8 of this series, we
began our work in Calc, and
created and formatted an
income section for a budget
worksheet. Last month we began
our discussion of functions and
formulas. In this part, we will
continue working on our budget
worksheet, and use formulas and
functions to do calculations in it.

Setting Up the Assets
Section

| o [ E

Assets

Type Beginning Ending
Period Income Total ﬂl

Checking Balance
Savings Transfer
Total Expendable
Savings Balance
Retirement Balance
Gross Assets

If you recall, we had set up a
section that contained all of our
income items in columns A and B.
We will begin our Assets section in
cell D1. Move to that cell and enter
“Assets” in it. Select cells D1-G1,
and merge and center the cells
(Format > Merge Cells > Merge and

hd G

Center Cells). In cell D2, enter
“Type”. Merge and center this cell
with E2. Enter “Beginning” and
“Ending” in cells F2 and G2
respectively. In cell D3, enter
“Period Income Total,” and merge it
with cell E3 (Format > Merge Cells
> Merge Cells). In rows D4-D9,
enter the following text in order:
Checking Balance, Savings Transfer,
Total Expendable, Savings Balance,
Retirement Balance, Gross Assets.
After entering the text in the cells,
go back and merge these cells with
their adjacent cell in column E (i.e.
merge D4 with E4, D5 with E5...).

Initial Calculations for
Asset Section

In cell F1, we will place our first
calculation using the SUM()
function. For this cell we need to
total the numbers of column B in
our Income section. Enter this
formulain cell F3:

=SUM(B3:B6)

This formula uses the SUM()
function to total the numbers
entered in cells B3, B4, B5, and B6.

If your Income section contains
more or less income items, adjust
the cell reference given to the
SUM() fFunction. If you pull out a
calculator and add up the numbers,
you will find you get the same
number as the total calculated by
LibreOffice Calc.

In cells F4 and F5, enter
amounts for the Checking Balance
and Savings Transfer. In cell F6, we
will need to sum the three amounts
above for the Total Expendable
item, but this time, we will use a
different method. Select cell F6

and click on the sum button

(shown left) in the formula

toolbar. You will notice that
LibreOffice automatically finds the
three amounts above and creates a
SUM() function Formula with the
range inside. Press Enter to accept
the range.

Enter amounts for the Savings
Balance and Retirement Balance in
cells F7 and F8. Select cell F9, and
click the sum button in the formula
toolbar. Notice that, once again,
Calc has selected the two numbers
above it, but for an accurate total
of the Gross Assets, we need to
include the Total Expendable
amount. Left click and drag to
select the three cells. You should
now see the corrected range in the
SUM() function. Press Enter to
accept.

| D | E e G |
Assets
Type Beginning  Ending
Period Income Total $6,329.00
Checking Balance 100

Savings Transfer 50
Total Expendable $6.479.00

Savings Balance 1000
Retirement Balance 264 ,
Gross Assets =SUM(
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| o | €& [ ¢ | G |
Assets
Type Beginning  |[Ending
Period Income Total $6,329.00
Checking Balance 100
Savings Transfer 50
Total Expendable $6,479.00
Savings Balance 1000
Retirement Balance 5264
Gross Assets $12,743.00

Setting Up the
Expenses Section

We will come back to the Assets
section to do some more
calculations once we get the
Expenses section set up. In cell
A11, enter “Expenses”. Merge and
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center the cells A11-G11. In cell
A12-E12, enter the following text
in the cells: Type, Due, Amt Due,
Amt Pay, and Notes. Merge and
center the cells E12-G12. This
becomes our header row for this
section.

In cell A13, enter “Savings”, and
in cell A14 enter “Retirement”.
These two expenses will represent
deposits into these two accounts,
and we will use them in our final
calculations in the Assets section.
Beginning with cell A15, and going
down the A column, enter other
expenses like Food, Fuel,
Mortgage, Phone, etc. In columns B
and C, enter due dates and due
amounts for all the items you
entered in the Expenses section.
Select a few of the items and put
payment amounts in the D column.
Merge the E, F, and G rows for each
of the items.

Formulas in the
Expenses Section

In the cell below the last item
(column A), enter “Total
Expenses:”, and merge it with
column B on that row. Select the
cellin column C fFor that row. Click
the sum button in the formula

toolbar. Calc should select all the
amounts in the Amt Due column.
Press Enter. In the D column of the
same row, type “Total Payments”
and merge it with column E on the
same row. Select column F of the
same row and click the sum button
on the formula toolbar. This time
Calc jumps all the way up to the
last amount in our Assets section,
but this is not what we want. This
happens because this is the First
number Calc found in the column.
Select the numbers in the Amt Pay
column of the section to change
the range. Press Enter.

Final Calculations for
the Asset Section

Going back to the Assets
section, we will use some of the
numbers in the Expenses section to
do a few more calculations. Select
cell G6. This is the total for our
expendable income after all
payments have been made. Enter
the formula:

=F6-F##

where ## is the row number where
the total payments is calculated.

For the ending balance on our

savings account, we need to take
the beginning total, add the
deposit, and subtract the transfer.
If you put the Savings as your first
item in the Expenses section, the
formula will look like this:

=F7+D13-F5

For the Retirement ending
balance, we just need to add the
deposit. If you added Retirement
as the second item in the Expenses
section, the formula will be:

=F8+D14

Finally, we will make the final
adjustment to the Gross Assets by

we need. Press Enter.

Our budget spreadsheet is now
complete, but it doesn't look very
pretty. Next time, we will format
our spreadsheet using styles.

3=

Elmer Perry's history of working, and
programming, computers involves an
Apple IIE, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.

summing A 1 = c [ o T © [ * ECEE
the three | 1 | Income this Period Assets

2 | Sources | Amount Type Beginning  Ending
numbers [ —5—oq $1,079.00 Period Income Total $6,329.00
inthe G 4 _|Freelancing| $200.00 Checking Balance 100
column 5 |Bonus $50.00 Savings Transfer 50

: 6 [Misc $5,000.00 Total Expendable $6,479.00 $6,069.00

Select G9, [ 7 Savings Balance 1000 965
and click 8 Retirement Balance 5264 5279

o | Gross Assets $12,743.00
the sum | 10
buttonin [ Expenses

12 [Type Due AmtDue AmtPay Notes
the 13_[Savings 01/05/12 15 15
formula 14 |Retirement | 01/05/12 15 15

15 [Fuel 01/05/12 50 50
toolbar. 16_|Food 01/10/12 130 130
Calc 17 _|Mortgage 01/15/12 500
should 18 |Phone 01/20/12 100

19 |Utilities 01/25112 350
select the | 20 |CreditCard  01/01/12 75 75

21 [Insurance 01/15112 350
three 22 |Cable 01/15/12 125 125
numbers 23 |Total Expenses: 1710 Total Payments: 410

24
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n the last part of this series,
we added the data and
formulas For our budget
worksheet. The end result,
while functional, is not very pretty :
or easy to read. Now, we willadd
some styles to our spreadsheet to
help make the worksheet not only
more pleasant to look at, but easier :
to read and find specific data. We
will accomplish this using cell
styles.

Written by Elmer Perry

: our column titles based on the

: Section style. Basing one style on
: another style makes it quick and

. easy to just add and change the

. differences between the styles. In
: the Styles and Formatting

- windows, right-click on the Section :
© style and select New. Give the style :
. notice that the style is linked to the | Editable, Total, and
© Section style. IF you browse :
: through the tabs, you will see all

Back in part 3 of this series, we
used paragraph styles to format
the paragraphs in our documents.
Cell styles are Calc's equivalent to
paragraph styles. Cell styles allow
us to specify the border, font,
background color, font effects,
number format, alignment and cell :
protection. Styles help to create
consistency throughout the
spreadsheet.

HOW-TO

|| Name

rBectuon
| Linked with Default
:| Catagory Custom Styles

Line arrangement
Default

() () i D

Now, we will create a style for

—

the name “Column Title.” You will

: the settings we made for the

Section and Column _ﬁg
Title Styles

We'll start by creating styles for
our section titles and column titles. :
Click on the styles icon (above).

. distinguish column titles from
: sections, we will give them a

- different background color. Onthe : 1 der the column titles except

: those that contain formulas - which ' style. Right-click on the Editable

" style in the Style and Formatting

: Background tab, select a suitable

Section style are already set. To

: light color for the background, such:

as Blue 8.

LibreOFFice - Part 11

. Applying the Section
. and Column Title Styles
: : window, right-click on the default

. style and select New. Give the new

. style the name “Editable”. On the
Number tab, select currency and

Now, we can apply our two new

. styles to cells in our spreadsheet.
: The sections are “Income This

: Period”, :
© Select the cells for these items and :
. double-click on the Section style in :
© the Styles and Formatting window. :
© You can select more than one cell :
. and apply the style all at once. For
. example, highlight all the column

: titles under Income (Source and

. Amount) and double-click on the

: Column Title style. Do the same for :
. the column titles under the other

n ua

‘Assets”, and “Expenses”.

two sections.

. Date Styles

Editable items are the items in

our budget spreadsheet that we
. will need to change from use to
: use. These are most of the cells

are our total cells. We will first
create the Editable style and use it

full circle magazine #57 @ 10

as the link for our Total and Date
styles.

In the Styles and Formatting

Category ERT—
Percent USD $ Eng
-$1,234

Date -$1,234.00
Time
Scientific -$1,234

i -$1,234.00
Fraction

-$1,234.--

your currency type. Set your font
. and font size on the font tab. |

: suggest a font size of at least 12

: points. Make sure the font style is
: regular (not bold or italic). On the
: border tab, create light gray

. borders on the left and right. You
: can accomplish this by clicking on
© the third box under defaults. Make
© sure that the Protected box is

. unchecked on the Cell Protection
: tab.

Now, we will create the Total

styles by linking it with the Editable

ﬁ contents ©
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window, and select New. Once
again, we are starting with an exact
copy of the style we right-clicked. :
Name the style “Total”. We will
make changes to distinguish our
totals from ordinary items. On the
Font tab, change the style to bold.
On the background tab, select a
darker gray color than the light
gray we used for the borders - like
gray or gray 40%. Finally, check
Protected on the Cell Protection
tab.

Category Format :
Percent 12/31/99) :
Currency Friday, D| :

12/31/19 :
Scientific Dec 31, § :

Apply the styles much in the
same manner as we did previously. :
You will notice that if you apply the :
Editable style to the date column
under expenses, you get a strange
result For your dates (probably
###1t). That's because it was
converted into currency. Right-click :
the Editable style and create a new
style named “Dates”. All we need
to do here is change the number
type to Date and select asimple
numeric date style on the Numbers
tab. :

Conditional Formatting |

We need a way to break up the

: big block of data under the

. Expenses section. We could just
. put borders around them, but large:
. groups of bordered boxes look

- dull. Instead, we will highlight all
. the even rows with light gray. We
- also want to do this quickly. For

. this we will use conditional

. formatting.

ISEVEN (ROW())

With this formula, whatever

: style we choose will only apply to
: the even rows. For the cell style,

- click on the New Style button. Give :
. the style the name “Editable :
: Highlight” and link it to the

: Editable style. On the Borders tab, : :
. change theyborder color from light sec.tion, youcan add th'e.highlights :
. to it as well using conditional

. formatting and the Highlight

. Editable style. Also, you can right
. justify the “Total Expenses” and

. “Total Payments” labels at the

bottom.

: gray to gray. Move to the

- Background tab and change the

. background color to light gray.

. Click OK to save the changes. You
- will notice the Cell style is now

. Editable Highlight. Click OK and :
. you will see the even number rows :
. are highlighted in light gray. :

. Formatting. Once again use the

: Formula ISEVEN(ROW()). Click on
. the New Style button and name the:
. new style “Dates Highlight”. Link
the style with Dates style. Change
: the border color to gray and the
background to light gray. OK to

. save the style, and OK to apply the :
. conditional formatting. :

Finishing Touches

effect of changing our dates again,

~ but that is easily fixed by doing the
: same thing with the Date style.
. Select all the dates in the Expenses :
- will get a message window saying

. the cell is protected. However, the
. unprotected cells are easily edited

section. Format > Conditional

Just a few simple things to

make all things even. If you have
. more than two items in the Income :

Now, to test run your

spreadsheet. Remember, we

Unfortunately, this has the side protected the cells we didn't want

Condition 1

to change. Tools >
' Protect Document >

Formulais |2 | [EEENGE0I

Cell Style  Editable Highlight [4 |

New Style... |

Sheet. You can enter a:
password to '
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password-protect the document,
or just click OK to protect it

: without a password. If you try to

edit one of the protected cells you

as before. Using cell protectionis a

. good way to keep your formulas
. from getting changed once you

. have the spreadsheet set up and
. working the way you want it.

In the next part of this series,

. we will prepare our spreadsheet

. for printing by adding a header and
. footer to the page, and looking

. into our printing options.

A - Y — o |
1 Income this Period
7 | Sources Amount Type
3 |Work §2 150.00 Period Income Totg
4 |Freelencing | $300.00| Check ng Balance
: 5 |Bonus $5C.00 Saangs Transfer
o | Misc | 85 000 00| Total Expendable
: 7 Savings Balance
8 Rebremert Balarce
9 Gross Assets
10
11 | Expenses
12 Type Due AmtDue AmtPay
13 [Savings 00512 315.00 $1500
Y
(3=

Elmer Perry's history of working, and
programming, computers involves an
Apple lIE, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
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n my last article, | discussed
setting up styles in LibreOffice :

Headers and Footers

Calc. This month, | will show
you how to prepare, examine,

and print your spreadsheet. We will

add headers and footers to our
sheet, use the Page Preview to
examine how our sheet will look
when we print it, and review the
print dialog and how it affects the
final printed pages.

Renaming Sheets

When you first create a new
spreadsheet file, the default

workbook starts with three sheets
named Sheet1, Sheet?2, and Sheet3. :

You can use these names in other
places in your sheet, and we will
use them when we create the
header and footer for our budget

spreadsheet. However, the default :
names are not very informative, so :
. margins, width, and height of the
. header area. | would recommend
. checking the Autofit Height

. checkbox, otherwise your header

we will rename them. The names
are located on tabs at the bottom
program window. To rename a
sheet, right-click on the tab and

select Rename Sheet from the pop-
up menu. The Rename Sheet dialog :
. format dialog. You will notice the

will display. Type in a meaningful
name for the sheet, i.e. “February

1 Written by Elmer Perry

24,2012" and click OK.

: Headers and footers allow us to :
. create consistency between pages. :
. Doing this on the sheet would

- mean shuffling cells as the sheet
- changes and grows. Using the page :
. settings, we can create the same
. look For multiple pages.

Organizer | Page | Borders | Background Header I Footer | Sheet |
Header

V| Same content left/right

Left margin 0.00* e
Right margin 0.00* e
Spacing 0.10* &
Height 0.20° v

V| AutoFit height

More... Edit..

Open the page settings dialog,

Format > Page. Click on the Header
: the name you gave the sheet. For

. theright area, we will insert the
: current date. Click in the right area :
and delete any content that

. already exists. The next-to-last
button on the toolbar inserts the
. current date. To change the font,

button to bring up the header area :
. size, color, etc, of the text,

tab. Here you can adjust the

may get cut off. Click on the Edit

header is divided into three areas,

LibreOFFice - Part 12

PR (T HeRer Page S Derauki T R

Left area

Lerter area Rught area

2012 Budget

Heagder Customized v

Custom header * (=4 P, 5 o) K

Note

Use the buttons to change the font or insert field commands such as date, tin

. our header from the rest of the

. sheet with a border or background
. color. We can do this by clicking on

: the More button on the Header tab
© in the Page dialog. For mine, I just

: put a0.50pt line at the bottom.

. left, center, and right. Along the
bottom, you will notice a toolbar.
7 . The toolbar lets you insert

X i Page Style: Default placehOlderS into the header and
: format the text. For our budget
spreadsheet, we will place

: something in each of the areas. In
the left area type “2012 Budget”.
. For the center area, we will place
our sheet name. To get the sheet
: name, click in the center area and
delete any content that already

. exists, then click on the third

button on the toolbar. This inserts

highlight the text in any of the
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areas and click on the first button

February 24, 20 ozloslzo12§ on the. toolbar. This brings up a
. font dialog, where you can change
. the attributes of the text. Click the
: OK button when you are finished

. editing your header.

We also might want to separate

The Footer tab is the same as

: the Header tab, but let’s put some
. different information in the three

: areas. On the Footer tab, click the

© Edit button. In the left area, place

: the sheet name using the third

: button on the toolbar like we did

: with the header's center area. In

© the center area, delete the content
© that is already there and type the

word Page and a space. Click on

: the fourth button in the toolbar.

© This creates a placeholder for the

© page number. This placeholder will
: increment for each page of the

. sheet. In the right area, click on the
" last button on the toolbar to insert
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a current time placeholder. This
will print the time when you print
the sheet. Having the current date :
and time on the sheet can come in :
handy when you have to do
revisions and need to know which
one is the most current. As with
the header, we can edit the
attributes of the text by
highlighting the text we want to
change and clicking on the First
button in the toolbar. Click OK
when you are done editing.

: @

2012 Budget February 24, 2012 02/06/2012
| Income this Period Assets
Sources  Amount Type Beginning Ending
Work $2,150.00 Period Income Total $7,500.00
[Freelancing $300.00 Checking Balance $100.00
Bonus $50.00 Sawvings Transfer $50.00

. sheet before printing. With the
. preview, we can make sure _
. everything fits on the page the way:
we want it, and the data shows as

: we intended.

To separate the footer from the :
rest of the document, we can use :
the More button to create a border :
or background color. | used a :
0.50pt border on the top.

File > Page Preview. The current

. window is replaced by the page
. preview window. You can make

. several adjustments while in page

In our setup, we used all the
buttons in the header/footer edit
dialog except for two. The second
button inserts the filename of the
workbook, and the fifth inserts the :
total number of pages.

. preview mode.

The slider in the toolbar is the

scaling factor. This allows you to

. want. You can increase the size by

We are finished editing the
page setup. Click OK to close the
page-setup dialog.

Page Preview

The page preview allows us to
make final adjustments to our

. clicking on the plus (+) or reduce it :
© by clicking on the minus (-). You can
. also click and drag the adjustment
. handle.

The Format Page button

displays the Page Style dialog. Hereé

you can change your overall page

margins and background color, and
- make corrections and adjustments :

to your header and footer. Two

. things we haven't mentioned yet
. are the table alignment and the

. print order. Table alignment is
To open the page preview, go to :

found on the Page tab. It allows

: you to center the table
. horizontally, vertically, or both. On :
. the Sheet tab, the page order

. controls how the cells are printed
. on the page. This allows you to

. make your data layout in the order :
. and way you intended. If you have
- more columns than can fit on a

. make the cells bigger or smaller so
. they fit on the page the way you

page, you can change it from the

something other than 1. You can

. also specify what prints and what
. does not. Finally, you can manually :
. adjust the scaling here as well. :

The page preview gives you

~ buttons to page forward and
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: mode.

backward, and jump to the first

~ page or the last page. There are
. also zoom in/out buttons for closer
. examination of the page.

Organzer Page |Qovde's | Background | Header | Footer | Sheet |

Paper format

Eormat

Paper tray

Width

Height 11.00°

Crien tation o Portrait
Landscape (From printer satti|
Margins

Left

Layout settings

Page layout Right and left

Right Format 1.2 3

<> <> O

Top Table alignment v Horgontal

©o o o o
R '

Vertical

<>

Bottom

The Margins button gives you

. the ability to adjust the page,

. header, footer, and column

- margins. Click the Margins button

. to activate margins mode. The

. dotted lines let you manually

. adjust the page, header, and footer
: margins. The black markers at the

. top allow you to adjust the widths

. of the columns. Click the Margins

. button again to exit margins mode.

default to left-to-right, then down.
: You can also set the beginning :
. page number should you need

Close Preview exits the preview

Printing

Finally, we have completed all

our preparation and it is time to
. print our sheet. File > Print brings
" up the print dialog. On the General
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tab, you can select your printer.
Click on the Properties button for
settings specific to your printer.
You can choose to print just the
selected sheets, all sheets, or just

whether to print all the pages or
just selected pages. If you don't
feel like ordering your pages after
you print, you can also choose to
print them in reverse order. You
have an option to print multiple
copies, and whether or not to
collate them.

Printer

Phe

> Detar

Range and copms

11.0Gin

&l sheets
o Selected shests
Selected cells
From which print

o Algages

Pages |

On the LibreOffice Calc tab, you

can choose to print or not print
blank pages. The Page Layout tab

gives you options for printing more
than one page on a sheet of paper, :

what order to print them, and
whether to put a border around
the page. On the Options tab, you
can choose to print to a postscript
file, and, if you are printing

HP Photosmart 0110-senes i
yemart-4610-senes

multiple copies, whether to do it as

~ one print job or multiple.

Once you have everything set,

click Print.
selected cells. You can also specify

This may seem overkill for a

. single document, but you needto :
. always consider how often you will :
. use and change the document. If
. you use the sheet often, as in a

. budget, once the header and :
. footer is set, you will never have to :
. change them again. By considering :
. the reusability, you decrease the
. setup time the next time you use it.

General | UbreCfMce Cale | | :

Next month, we will look at

some quick tips and tricks for
. working with spreadsheets in
. Calc.

/ /ﬂ

3=

Elmer Perry's history of working, and
programming, computers involves an
Apple IIE, adding some Amiga, a
generous helping of DOS and

Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
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Quick Opinion

Tune out, Drop Out, Get things Done
by Allan J Smithie

turned off the Internet today. |
don’t mean the whole thing. | mean
my access to it. | unplugged the
router from the wall.

| also killed my music player and left
the mobile phone in another room.

Something mystical then happened.
Concentration.

| love the Internet. I'm probably addicted. It's a huge
resource for information and an unparalleled research,
educational and entertainment resource, but every so often |
have to shut it all out just to Get Things Done.

Turn off the TV, radio, iPod, Xbox, PSP and Wii. Close the
browsers (both of them), kill the chatroom, the IRC, AIM,
Facepunch, Twiddle and anything else that’s running. The fact
checking can wait. Contrary to contemporary systems of belief,
your status doesn’t have to be updated in real time. It will all
still be there. After you get something DONE.
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Written by Elmer Perry

o far, we have covered
many topics for using

that are worth knowing. In this
article, I will give you my top-10
quick tips for using Calc. Most of

the current sheet. You can use

these tips in most any sheet you
are working with.

1. Naming Sheets

Position

) Before current sheet

o) New sheet
No. of sheets 1 b

A
Name New Sheet Name

) Erom file

The default name for sheets is
SheetX, where X is a number. You
have 3 ways to name a sheet. The
first is when you create a new
sheet, using Insert > Sheet. In the
dialog, you have a choice of how
you want to name the sheet. You
can also choose to insert multiple

sheets. When inserting multiple
: sheets, you have no control over
LibreOffice's Calc, but Calc :

has many minor operations :
: convention.

the sheets' names. They will get
the default SheetX naming

However, you may need to

them have to do with manipulating : rename a sheet after it has been
: created. This is where the second
. and third methods apply. The
. second way to name a sheet is by
: right-clicking the sheet's tab and
. selecting Rename Sheet from the
: menu. The Rename Sheet dialog

% : will come up, and you can change

: the name of the sheet. The third

. method is simply to double-click

: the sheets tab. This brings up the

. rename Sheet dialog, where you

: can change the sheet's name.

: NOTE: The sheet name must start
. with a letter or digit. Then, sheet

: names can include spaces, letters,
. digits, underscore, and some

. special characters, i.e. -, & When

. saving in the Microsoft Excel

. format, sheet names cannot

. containthe:,\,/,?2, % [,and]

: characters. If you have an invalid

. character in the name, Calc will

give you an error message.
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2. Deleting Sheets

Sometimes, you will want to

. delete a sheet, or multiple sheets,
: from the workbook. To delete a

: sheet, right-click on the sheet's tab :
: and select Delete from the menu,
© or select Edit > Sheet > Delete

: from the menu bar. Calc will verify
© that you do want to delete the

. sheet. To delete multiple sheets

: hold down the Ctrl key while

: clicking on the tabs for the sheets
© you want to delete. Use either the
: right-click or the menu method to
. delete the sheets. Once again, Calc :
© will verify that you want to delete
: the sheets.

3. Move/Copy Sheets

Move/Copy Sheet

Action
__ Copy
Location

To document

Poorman_db (current document) v

Insert before

Poorman Freeze Row-Column
Fill Cells
- move to end position -
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Sometimes, you need to

: rearrange or copy sheets. For

. example, you might want to order

. amultiple sheet workbook in order
. of predominate use, or by date.

: Copying a sheet comes in handy

: when you need to create an exact

. duplicate of the current sheet,

: thereby creating a history. When

: you copy a sheet, you get an exact
. duplicate of the sheet you copied:;

. however when you make changes

© to the new sheet, those changes

© are not translated to the old sheet.
: For example, you can create a copy
. of a budget spreadsheet for each

: pay period of the year and keep

. them all in one workbook.

Moving sheets is accomplished

© in one of two ways. The first

: method is to drag the tab of the

: sheet to the position you want it.

: Double arrows will show the

. location the sheet will occupy

: when you release it. The other

. method is through the Move/Copy
: Sheet dialog. You can access the

: Move/Copy dialog by right-clicking
: the tab you want to copy or move

. and selecting Move/Copy Sheet, or
" through the menu bar, Edit > Sheet
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> Move/Copy Sheet. Under the
Action section, you can select to
copy or move the current sheet.

NOTE: If you have only one sheet in :

the workbook, move and copy are

grayed out, and copy is selected. In :
the Location section, you can select
. of the current sheet is always

to move/copy the sheet to the

current document, to another open : :
. color for when it is not selected. To :
. set the tab color of a sheet, right-
click the tab and select Tab Color

document, or to a new document.
The Insert Before section controls
the placement of the move/copy.
The sheet will move/copy to a

position before the selected sheet.
A special choice here is the “- move

to end position -". Selecting this
last choice will move/copy the
sheet to the end of the sheet list.
The Name section allows you to
give the sheet a new name.

Renaming your sheet is a good idea

when copying. If you do not give it
a new name, it will keep the
existing name and append an
underscore and a number, i.e.
MySheet_2.

Visual aids can often help get
things done quickly while working

. with a large workbook with :
. multiple sheets. Coloris an easy to
. deploy visual aid. Giving each sheet :

tab a different color can help you
find it and go to it quickly. The tab

white, but you can still give it a

from the menu. A color dialog will

pop up. Simple select the color you

want for the tab and click OK.

. 5.Freeze

Row(s)/Column(s)

Long and wide sheets often
require scrolling to view some of
the content in the sheet. However,

: in many cases the first columns or :
: rows contain information you need :
. in order to make sense of the :
- information. Luckily, Calc provides
. you with a way to freeze rows and

4. Color Tabs - columns in place.
43 [Ms. Violly Holly ZZ Harvard Rd  [Wally SD
44 |Mr.  Tom Jones 123 Some St.  Someplace NC
45 |Dr. Harry McMahon 321 No Road Noplace NY :
14400 Poorman DB Poorman Freeze Row-Column Fill Cells & Selection List[
v D
Sheet 1/ 3 | Default

A | B E | F
1 | Title First Name City State
56 [Mr.  Tom Someplace NC
57 |Dr. Harry MNoplace NY
58 |Rev. Mike Gospel CT
59 |Ms.  Amber Thatplace |CA
60 [Mr.  Charlie Lunix NJ
61 |Ms. Molly Wally SD
62 [Mr.  Tom Someplace NC
63 |Dr. Harry MNoplace NY
64 |Rev. Mike Gospel CT
65 |Ms.  Amber Thatplace  |CA
66 |Mr.  Charlie Lunix NJ

To freeze a row or rows, select

the row below the row(s) you want scrollbars that appear.

frozen by clicking on the row
number, then Window > Freeze. To
unfreeze the rows, select Window
> Freeze again. The same is done

with the columns by selecting the

column letter to the right of the
columns you want frozen, then

. Window > Freeze.

To freeze both rows and
columns, select the cell below the
rows you want frozen and to the
right of the columns you want
frozen, then select Window >
Freeze.

6. Split Screen

Another way to view large
sheets is using the split screen. To

. split the screen horizontally, grab
. the thick bar just above the vertical :

* scrollbar. The mouse cursor will - cancel all spits, use Window > Split.
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: TV Tom Jones

become a double arrow. Drag the
thick bar down to the position

where you want it. To split the
. screen vertically, do the same with

the thick bar to the right of the
horizontal scrollbar. To get a quick
horizontal and vertical split, just

select Window > Split. The spits are
: shown by a thick heavy line. Each
. area of the split screen is

manipulated by the various new

< X

: G | D D | E | F
: tName  Street Address | Street Address  City Stat
: i Tom ones 123 Some St. [123 Some St. Someplace  NC

McMahon 321NoRoad  |321 NoRoad  Noplage  NY
547 Trinity Way [547 Trinity Way Gospel cT
54This Way |54 This Way  Thatplace  CA
101 Binary Way [101 Binary Way Lunix NJ
22 Hanard Rd |22 Havard R Wally SD

123 Some St 123 Some St Someplace  NC

Rev.  Mike Mickey
Ms.  Amber Sams

Mr.  (Charlie Hacker
Ms.  Molly Holly

M. Tom Sawyer
McMahon 321 NoRoad  |321 NoRoad  Noplace  NY
Mickey 547 Trinity Way [547 Trinity Way Gospel cT
Sams 54This Way |54 This Way  Thatplace  CA
Hacker 101 Binary Way [101 Binary Way Lunix NJ
Holly 22 HanardRd |22 Havard Rd Wally sD
Jones 123 Some St. [123 Some St.Someplace NC
McMahon 321 NoRoad  |321 NoRoad  |Noplags  NY
MRev.  Mike Mickey 547 Trinity Way [547 Trinity Way Gospel cT
Sams 54 This Way |54 This Way
Hacker 101 Binary Way [101 Binary Way Lunix NJ
Holly 22 Hanard Rd |22 Havard Rd  Wally SD
Jones 123 Some St.  [123 Some St. Someplace NC
McMahon 321 NoRoad  [321 NoRoad  Noplace  NY
Mickey 547 Trinity Way_|547 Trinity Way Gospel cT
123 Some St [123 Some St._|Someplace |NC
McMahon 321NoRoad  |321 NoRoad  Noplace  NY
Mickey 547 Trinity Way [547 Trinity Way Gospel cT
e Sams 54This Way |54 This Way  Thatplace  CA
Mr. (Charlie Hacker 101 Binary Way [101 Binary Way Lunix NJ
22 Hanard Rd |22 Havard Rd  Wally sD
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To undo a split screen, grab the
thick heavy line and drag it up to
the top for a horizontal split or to
the right fFor a vertical split. To
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7. Print Rows or
Columns on Every Page

right, up, or down).

Print range -

-hone - v

Rows to repeat

- user defined - v| $1:$2
Columns to repeat
- user defined - v| 34

Printing a sheet which will span

multiple pages may require key
information in certain rows or
columns in order to help make
sense of the data. To control how
the pages print, you can define
whether certain rows or columns
repeat on each page.

Open format > Print Ranges >
Edit. Under Rows to repeat, you
can define the rows that need to
repeat on each page, i.e. to repeat
the Ffirst two rows enter $1:$2.
Under Columns to repeat, you can

do the same for the columns, i.e. to . .
. 9. Selection List

repeat the first column type $A.

8. Fill Selected Cells

At its most basic use, the Fill
tool is a way to repeat information

in a cell. To repeat the information

in a cell, select the cells you want
to repeat, then Edit > Fill > (the
direction you want to Fill: left,

Direction Series type
«, Down | Linear
2 ) Growth
) Up (o) Date
& ) AutoFill

Start value 4/1/2012]

End value

Increment 1

the list, select an empty cell and
press Alt + Down Arrow on your

. keyboard.

10. Remove Data from
. Cells

- [April A

However, the real power of the

. fill tool come through using the Fill :
. Series. Edit > Fill > Series. The Fill  :
. Series tool allows you to create

: many different types of serial

. information, from numbers to

. dates. There is also AutoFill, which
. uses a series of text predefined in
. the program. Examples of the

. AutoFill are Days of the week and
: months. You can define your own

. AutoFill ranges in Tools > Options > :
. LibreOffice Calc > Short Lists. :

: The selection list is :
: g‘;g‘e‘fgber a text function. The
. |February selection list works
: |January only for text, and will :
: jﬂ'ﬁ]’e contain only text :
March from the current
May ~ | column your selected
November™ | cq||is in. To activate
4 -

Selection

=
@
@
-t
@
™

AN

Numbers

Date & time

AN

Eormulas

AR AR LS

Comments
Formats

Objects

Sometime, you need to not just

change the datain a cell but

. completely remove it. Removing
. data can be done in one Ffell swoop, :
- and you can select the type of :
. information that is removed. For
- example, you can select a group of

cells and choose to remove only

the formating, or only the text.
: There is also a remove all to

remove all the information from

the cell(s). You activate the
. Remove Content dialog by

selecting a cell or cells and
pressing the Backspace key on the

full circle magazine #59 @ 14

Text nE

keyboard. You can also do this
through the menus: Edit > Delete

Content.

So, there you have it; my top-10

quick tips for LibreOffice Calc.

In my next article, we will

: continue our journey in Calc by

learning how to create charts and
graphs.

o
Elmer Perry's history of working, and
programming, computers involves an
Apple lIE, adding some Amiga, a
generous helping of DOS and

Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
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hile data collection is :
useful and helpfulin :
determining results, :
or whether goals
were met, charts and graphs
simplify data so others can quickly :
digest and interpret results. The
art of charts and graphs is well
beyond the scope of this article,
but I will show you how to create a :
chart in Calc, which you could use
in Writer or Impress. There are :
many predefined charts and graphs :
available in Calc. :

We will use a simple collection
of data to create our chart. The
data represents the boat rentals

For a six month period. We will use

a bar chart to show the relationship
between the different types of
boat rentals for each month.

The Chart Wizard

Before starting the wizard, you

need to highlight the data used for

the chart. You will want to make

: sure you just highlight the data and
. their labels. Although you can :

modify the ranges for the data

. series later, getting it as close as
: possible helps Calc to better
. render the final results.

®

e 1 [ T = === T 5
1
2
3 Equipment Re :
o Boats Canoes |:
5 WA 12
Feh 14
Mar 13
Apr 20
May 18
Jun 15

you select the type of chart you

: want to create. For some chart
types, you have the option of 3D

. effects, and for others you do not.

You have two ways to
start the chart wizard.

. wizard icon (shown right) on the

The chart wizard allows us to
get the basics of our chart
completed quickly and easily. In
fact, sometimes the chart wizard is :
all you will need to complete your
chart. The wizard is your jumping
off point For all chart creation.

: butit is possible to click the Finish
. button at any time to end the

wizard process.

. For our chart, we will select the

: basic bar chart. Since we have the
. option of 3D effects for a bar chart,:
. we will also check the 3D Look
You can click on the chart checkbox. In the 3D Look
. dropdown box, you have the

: main toolbar, or through the menu options of Realistic or Simple. This

with Insert > Chart. The chart
: wizard consist of four steps. We

: will walk through each of the steps, different shapes for your data

. series. We will use cylinder. Click
. the Next button to move to the

LibreOFfFfice - Part 14

The chart type (above) is where

. helps determine the look and
. shading of the 3D effect. We will

next step.

full circle magazine #60 @ 8

B als
Steps Choose a chart type
L Chart Type : z > =
p— B> Bar h ' ‘ | I p l
2 Data Range ® re W[} a0 [wi) |0
3.Data Series k& Area
2, Chart Flemerts K Line i Hormal
[ Xv (Scatter) : '
1*s Bubb'a ¥ 3Dlaok |Realistc |+
Hy Net Shape
i Stock (Box
Kil Column and Lne
Cane
Pyramid
. 1. Chart Type

2. Data Range

In step two we define the data

. range and how Calc will use the

. data range to create the chart. If

: we need to change the range from
. what we selected, we can type in

. the range or select the range from
. the spreadsheet. The small button

. atthe end of the data range

. textbox will shrink the wizard

. dialog so more of your spreadsheet
¢ isvisible.

We need to tell Calc whether

. . our data series are defined by row
. use Realistic. Finally, you can select : y

. or column. For our example, we
. used columns. Also, since we

. selected the labels as well as the

data, we need to check both First
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% =
Steps Choose a data range
1. Chart Type 2‘-5':; rl:ng::P PTOTATTTE G
ar Charl 2. sA%4: 1 3
2. Data Range L8 SR e
3. Data Serjes J3%a 5eres In [ows

£, Chart Flemarts

o Data series In golumns

% First row as ‘abel

| First column as label

x

Choose titles, legend, and grid settings

Steps
1. Chart Type Title Sample Bar Chart
2.Data Range Subtit'e
3.Data Series
2 Chart Flemarts X axls

Y axis Num aof rentals

Z axis

Display grids

X 3495 X Y ans

Laft

Z 3ns

row as label and First column as
label.

Click the Next button to move
to the next step.

3. Data Series

The third step (below) lets us
redefine, add, change the order,
and remove data from our data
series. You will see the data series

For the chart defined by their label

in a listbox. You can change the

. range of the series much as you

. could in the data range step;

. however, keep in mind, this is only
. for one set of data and not the

. entire chart. You can add another
. series by clicking on the Add ;
. button. You can remove a series by :
. selecting it and clicking the

. Remove button. Change the order
. of the series by selecting the series :
. you want to move and use the up
. and down arrow buttons.

We don't need to change

anything here, so click the Next

button to move to the last step of
. the wizard.

4. Chart Elements

. revisit any of the steps, you can use
. the Back button or select the step

. from the list on the left. Click the

. Finish button to complete the
wizard and display the chart in your

. spreadsheet.

The fourth step (above right) of :
. the wizard allows us to define :
. names for the different parts of

. our chart, including title, subtitle,

. and x and y axis. We can also set

. the location of our legend and the
. grid for the chart area. For our

. chart sample, give it the title

: “Sample Bar Chart”. We also want

Y}~ to label our Y-Axis as “Num of
Steps Customize data ranges for individual data serles Rentals”. Since our X-Axis is the
i ‘::-.:..t:»ms %:::unges S — months of the year, we dgn't really :
2.Dats Range l EET— ek w e |- need a label for the X-Axis. It is
[ . self-explanatory. Set the legend to
e ST appear at the bottom, giving our
‘ $3D Bar Chart 2'.$C$5:42510 1| |: data more room to spread out.
A add | A | Categories :
R * 20 Bor Chart 2. 4445: 44810 Gl We are now finished with the
‘ Chart Wizard. If you ever need to

full circle magazine #60 @ 9

. Formatting Chart
. Elements

After creating the chart with

. the Chart Wizard, it is possible to

. change the elements of the chart.
. After clicking on finish, you will

. notice that the newly created chart
. is selected and your toolbar has

. changed. You have the chart

. Formatting toolbar instead of the

. standard edit toolbar. The new

. toolbar has a dropdown box which
. allows you to select the different

. elements you can change. After

. selecting an element from the

" dropdown, click on the Format

/h\ contents ©
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Selection button to display the
dialog for that element.

Chart Area

; @
v |Format Selection il

EE &

. of the chart. On the Area tab,

There are also buttons for
changing the chart type, and
displaying the chart grid and :
legend. The button with the double :
arrow beside the capitol A is used
to scale the text with the chart
when you resize it. | highly
recommend this, as it keeps things
proportional. In addition to the
changes in the toolbar, you will find :
changes in the Insert and Format
menus as well. These changes allow :
you to insert and format elements
of your chart.

You can move the chart by
clicking and dragging the borders.
Resize the chart by clicking and :
dragging one of the eight handles. :
If you selected the text scale :
button, the size of the text will
scale with the chart as you change
it.

Now, let's make some changes
to our chart. In the dropdown list in :
the toolbar, select Chart Title and
click on the Format Selection
button. On the Font tab, change :
the size to 18 and the style to bold. :
Click OK. Next, select Chart Area
and click Format Selection. The
chart area is the entire background

. chart.

- select a background color of light : his changes the perspective of the
. gray. You will notice this changes
- the color of our data area as well,
. but we want the data area to stand :
. out. Select Chart from the

. dropdown list and click Format

. Selection. On the Area tab, select
. to fill with color and pick white. :
. Since we are using a 3D chart, let's :
change the perspective a little: :
- Format > 3D, check the Perspective :
. checkbox and change the :
. percentage to 50%. You will see

There are other things to do on
: your own. Try changing the color of :
. one of the data series or adjusting
. the placement of some of the
. elements. All can be done through
the dropdown list, and the Format
: and Insert menus. When you

deselect the chart, you are taken
. back to normal toolbars and

: menus. To edit the chart later, just

Mum ofrertals

60

50

10

30

Sample Bar Chart

Jan Feb Mar Apr

mBozats mCanoes Motor

IMay

Jun
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double-click the chart, and you get
the specialized toolbar and menus

. back.

We have only touched the

surface of the chart and graphs in
: Calc, but I encourage you to play

around with the different types

. and elements. The type of chart
. you use is dependant upon the

. type of data you have and the

. information you want to convey.

. Next time, we will begin our work
. in Impress, LibreOffice’s
. presentation program.

Elmer Perry's history of working, and
programming, computers involves an
Apple lIE, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
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HOW-TO LibreOFfice Pt15: Impress

cis

mpress is LibreOffice's document. D Presentation Wizard (Recommendation of a Strategy)
presentation program andis

equivalent to Microsoft . The first screen of the wizard y 2

Office's Powerpoint. With - (right) lets you pick from an empty :

Impress, you can create . presentation, a template, or open | Twe
professional visual presentations : an existing presentation. If you : R o o i
that include graphics, pictures, select “From template”, there are @ Erom template
videos, audio, spreadsheets, and two default templates in Impress. Open existing presentation
charts. Impress has a presentation Both come with predefined slides. | Prasentations - |
wizard that is very useful for : recommend you have Preview ; [P
setting up a new presentation and : checked asitallowsyoutoseea
getting you started on the right - visual of your presentation as you
track, and a main window that : createitin the wizard. & Preview
helps break the process down into : Do not show this wizard again
tasks.  TIP: At any point in the wizard, you ©
. can click the Create button to Help Sancel |

: i create a new presentation. This :
Th.e Presentation . allows you to use only the partsof | Click Next >> to move to the
Wizard - the wizard you need. - second screen of the wizard. On | esesieetmmsion

. this screen you can pick from many s M:;:mm = e
You can create a new blank TN different backgrounds for your j : .
presentation by going to File > . presentation. You can change the Sels:g:;"uﬂgsmtat")n“pe
New > Presentation. However, to _ background for individual slides | automatc
start the presentation wizard, click :| ciecssidedesion - later, but this will become the basic : Durstionofpage  [RoETD
on File > Wizards > Presentation. If :|  ereseatation Backarounds . background for your presentation. Duntionofpeue  (ENET B Previes
you want to start with the wizard T T © You will also want to select the Shawlogo
every time you create a new b onbin output medium for the 1| mel gncel || <pack [
presentation, you can turnitonin i - © presentation - normally screen-
the settings. While in Impress, click i = osmemedom © but other options are available . third wizard screen. You can pick a
on Tools > Options > LibreOffice I 'Sﬁf,: i = should you need them. - slide transition for changing from
Impress > General, and check iR ) & preview: - one slide to the next. There are
“Start with wizard” under New ' : Click Next >> to move to the : many different transitions to
Kisia O | | reback . choose from. When you select a
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transition, you get a preview on
the effect in the preview window.
You can also adjust the speed of
the transition. You can change the
transition fFor individual slides

the background, is one of the
things that create consistency in
your presentation. On this screen
you can also pick the presentation
type. “Default” advances the
elements and slides through
mouse clicks or the keyboard.

“Automatic” allows you to set each

slide to advance after a certain
amount of time. The choice will

depend on the presentation and is

beyond the scope of this article.

™ Presentation Wizard (Recommendation of a Strategy)

Describe your basic ideas
wWhat is your name or the name of your company?

Elmer Perry

What is Lhe subject of your presentation?

LibreOffice

Further ideas to be presented?

The keyto an open scource office

Help Cancel \

your name if your presentation is
not for a company), and the ideas

. behind your presentation. The

. information you use here will plug
© into your opening slide.

later, but the transition, along with :

™ Presentation Wizard (Recommendation of a Strategy)

Choose your pages
@i

F [ Overview
» ¥ Longterm goal
» @ The Present Situation F
> [ Development up Lo present
* & Potential Alternatives
» @ Recommendation

& Preview

Help Cancel <« Back

<< Back |_

Click Next >> to move to the

give a topic, company name (or

Click Next >> to move to the

: Fifth wizard screen. If you selected
: atemplate on the first screen of

© the wizard, you can use this screen
© to preview each of the slides after
: your changes. You can select

. whether a slide will be included in
© the presentation or not. Check

: “Create summary” to create a

. summary of your slide.

SIDEBAR: You can always use

the << Back button to move back
: and change elements of your
fourth wizard screen. Here you can -

presentation.
Click on the Create button, and

= | Moemal Oxtilae Notes Handout SHde Sorter

Workspace Pane

LibreOffice

Elmer Pesty

Tasks

The key to an open sowce office

Impress will create the slides for
© your new presentation.

The Main Window

The main window for Impress

: (above) is divided into three

: sections, the Slide pane, the

: Workspace pane, and the Tasks
: pane. You can hide the Slide and
© Tasks panes by clicking the X in the :
. upper corner of each pane. To :
: show the panes again use View >
. Slide Pane or View > Tasks Pane.

: Alternatively, you can use the

. Hide/Show markers (circled in red
© in the image) to hide and show the :
© panes. '

The Slide Pane

Full circle magazine #62 @ 12

The Slide pane shows

thumbnails of all the slides in your
. presentation in the order in which
. they will appear in the

. presentation. In the Slide pane,

: you can add, delete, copy, paste,

: move, duplicate, rename, or hide

- slides. Clicking on a slide in the

. Slide pane placesitin the

. Workspace pane where you can

: change and modify it.

The Workspace Pane

The Workspace pane is the main

work area for editing slides. You

have five tabs in the Workspace

: pane.

Normal View

ﬁ contents ©
.
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Normal View is where you make
changes to individual slides. Here
you can add images, modify and
add text, animation effects, and
more.

Outline View

The outline view displays an
outline of all the text in the
default text boxes on each slide.
Each slide is numbered. You can
use the outline view to proof and
change the text on your slides, as
well as add text to the slides. The

outline.

Notes View

You can use the Notes View to
add notes to individual slides. You
can change the size of the note
box under the slide by clicking on
the border and dragging the

handles. The notes will not show in :

the presentation, but you can print : Master Pages

them and use them during your
presentation or as handouts.

Handout View

how your handout of the
presentation will print. If you

select Layout in the Tasks pane,
you can set the number of slides

. that show on each page of the

- handout (up to 9 slides per page).
© You can also use this view to

. determine what information will

. print on the handouts.

Slide Sorter View

The Slide Sorter view works

. much like the Slide pane but gives
: you more space to work. You can

. add, delete, move, copy, paste,

- duplicate, rename, and hide slides.
: You can also work with groups of

- slides by selecting more than one

slide names are not included in the : >
slide.

The Tasks Pane

The Tasks pane has five

: sections. You expand a section by
. clicking on the section name. You
- can only expand one section at a

. time.

Here you define the page style

for your presentation. Impress

. contains many predefined master
. pages you can use. You can modify :
: the look of a master page using

In Handout View, you can setup ) i
. styles. A single presentation can

contain more than one master

page, allowing you to use more
than one visual style in the

: presentation.

Layouts

The prepackaged layouts are

. shown here. You can select a :
- layout - and use it as it is or modify
. it. Unfortunately, you cannot save
: custom layouts to the layout lists.

Table Design

Standard table layouts are

. shown here. You always have the
. option of changing the layout, and
. the table will behave much like a
- tablein Calc.

Custom Animation

With custom animations, you

. can control when and how
elements appear on the slides. You :
: have many different options that
help create the visual effects you
: need as you give your

presentation. Don't go overboard
: here unless you have a good ;
. reason. While animations can make :
: your presentation visually pleasing :
and interesting, they can also make :
* your presentation look :

unprofessional and overwhelming.
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On the other hand, if you need to
make an emphasis on a certain

. point, custom animations can help
. you accomplish such emphasis.

Slide Transition

The Slide Transition section
gives you access to changing how

: one slide replaces the next. You

. have the choice of many different

© transitions as well as the speed of

: the transition. If you use automatic
© transition, you can also control

. how long the slide will display.

This has been a quick overview

: to get you started working in

. Impress. | encourage you to begin

: to play with the different views,

. sections, and layouts to get a feel

: for how they work and what you

: can do with them. Next time we

. will begin work on editing slides,

: adding text, and adding graphics to
- our slides.

Elmer Perry's history of working,
and programming, computers
involves an Apple IIE, adding some
Amiga, a generous helping of DOS

and Windows, a dash of Unix, and
blend well with Linux and Ubuntu.
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“great presentation

begins with a pleasing

and well thought out

slide design. You also
need consistency between your
slides, elements that fit them
together. In LibreOffice, you can
use the Master Pages to create the
base design for your presentation.
Master Pages become the
framework for the entire
presentation, binding the
elements of our presentation
together. Much of this is
accomplished through styles, and
Master Pages are the main style.
You can think of Master Pages
being equivalent to Page Styles in
Writer.

Editing Master Pages

To edit master pages, you must
switch to the Master View. Start
Master View through View >
Masters > Slide Master.
Alternatively, you can right-click
the master page you want to edit
in the Master Page section of the
Tasks pane, and select Edit Master.

When you enter Master View,

Master View v

'E'_] & @ Close Master View

the master toolbar appears. The
: master toolbar gives you options
. specific to editing master pages.

© Use add to add a new master page.

. Delete allows you to delete the
: selected master page. Delete is

LibreOFfice Pt16: Impress

. have at least one. Rename lets you
: rename the currently selected

master page, and Close Master
. View exits master page editing.

You have five predefined

: grayed out when you have only one editable areas in a master page:

: master page, because you must

» Object Area

* Third Outline Level

- Fourth Outline Level
* Fifth Outline L evel

Date/Time Area

<dateime>

Title Area

- Second Outline Level

« Sixth Outline L evel
» Seventh Qutline Level

Footer Area

<footer>

Slide Number Area

<number>
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Title Area — The title area

: contains the title of the slide.
: Think of it as the subject of the
- slide.

Object Area — The object area

© contains the data of the slide,

© whether it is text, an image, a

© chart, or a table. As you will learn,

© the data of the slide is not

: confined to the object area. You

© can add elements outside the

© object area, but it's a good idea to
. keep data generally in this area for
consistency in your presentation.

Date, Footer, and Slide Number

. Area - By default, these areas do

: not show up on the actual slide. To
. change, go to View > Header and

. Footer, and you can change

: whether or not these objects will

. appear on the slides.

Modifying the Master
. Page

/‘ﬁ\ contents ©
|
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We will start with the default
style For your master page. First,
let's change the background.

tab, use the dropdown box and

select gradient. In the gradient list,

select Radial red/yellow. Click OK.
This gives you a bright, sunny
background to work on.

NOTE: You can download the icon
graphic used in this tutorial at

http://eeperry.co.cc/resources/mo :
. title. Select the line tool from the
. drawing toolbar at the bottom of

: the window, and draw a line under
. the title area. You can change the
- line style using the line toolbar.

. Change the style of the line, the
graphic containing the icons for all :
. end arrow styles.
want it to sit just below the object

dules.png.

Next, we will add a graphic to
your master page. The graphic will
show up on all slides that use this
master page. | created a ribbon

the LibreOffice applications. We

area. Insert > Picture > From File.
Select your picture and Open.

: Move the image to the position
Format > Page. On the background :
© area. You want the image centered :
at the bottom. Rick-click the image
. and select Alignment > Centered.
© You also want the image to appear :
. behind any objects which might go :
. over it. Right-click the image again, :
. and select Arrange > Send to back. :

you want it, just below the object

Now, let's add a line under the

thickness, color, and the start and

Slide  Notes and Handouts

Include on slide

| | Date and time;

7] Eooter

slide number

M Do not show on first slide

ar ¥e

Apply to All

App Y

Cancel

He'p

Finally, let's edit the date,
footer, and slide number areas

. (below). While in Master View, you :
© can change the size and placement
. of these objects, but actually filling :
. the slide number will show up in
. the slide number area.

them with content can be done at

© any time. View > Header and

Footer. On the slide tab, thereis a
checkbox for each of the three
areas: date, footer, and slide
number.

Under date and time, you can

. choose a fixed date or a variable

: date. You can use fixed date when
: you have a presentation that is

. presented one time, or you want

. the date to appear in a non- :
- standard way. Place your date text :
© in the textbox beside the variable
. selection. What you place in the

. textbox is what will show in the

. date textbox on the slide. Use

: variable date when a presentation
. date is unknown, or you will give

: the presentation more than once.
© Variable will place the current date :
© in the date textbox. With variable,
: you need to select a format in the
. dropdown. You can also change

. the language.

For the footer area, you type

the text you want in the footer
- area in the textbox. Whatever you

type in the textbox appears in the

Full circle magazine #63 @ 12

footer area.
There's not much to the slide

number. You either check it to
show or not show. When checked,

NOTE: The date, footer, and

slide number areas are disabled on
. the first slide, the title page.

Click the Apply to All button to

. apply the settings to all the slides

. except the title page. Click the

. Apply button to apply it to only the
. current slide.

. Impress Styles

Just like in Writer and Calc,

: Impress can use styles to keep

. everything uniform. Styles are also
. atime saver. However, styles are a
. little different in Impress. Impress
. only has two different style types,
. Presentation and Graphic.

An easy way to think about

. presentation styles is as the styles
. related to the master pages. You

. have styles for backgrounds,

. background objects, outline text,

© notes, titles, and subtitles. You can
" modify these styles any way you

ﬁ contents ©
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want. However, you cannot create
new presentation styles.

Graphics styles are styles for
objects and text not directly
related to the master pages. You
can modify these styles in any way
you want, and you can create new
ones.

Editing of styles is done from
the Styles and Formatting dialog.
You can open the Styles and
Formatting dialog by clicking on
the button in the line and filling

toolbar, pressing the F11 key on
the keyboard, or by going to

: Format > Styles and Formatting.

Let's do a couple of

. modifications to the presentation
: styles to show how they work.

© First, enter master view mode,

: View > Master > Slide Master, and
: open the Styles and Formatting

: dialog, Format > Styles and

: Formatting. Right-click Title in the
: dialog and select Modify. On the

: font tab, select a suitable serif or
. slab font. Maybe make it bold.

lllllllllll

Switch to the area tab and change
the fill to gradient. Select the first

: gradient in the list (black to white). :
© On the transparency tab, switch :
: the mode to transparency and the
: percentage to 50%. Click OK, and
: you will see the font for the title

: has changed and it has a

: semitransparent gradient

: background.

Now, select Outline 1in the

© Styles and formatting dialog. :
: Right-click and modify. All we want :
: to do here is change the font. Click :
: OK. Switch to Master View and you
- will notice that the font is changed :
: for all the outline levels. This is :
: because each of the outline levels :
: links to the previous one. You can't
: change the linking, but you can :
: change each of the levels to be

. different. This cascade effect can
: be useful, especially with the font
© in helping to create uniformity.

In this how-to, we learned

. about creating and modifying

: master pages in Impress. Master
: pages are key to helping create

: consistency in your presentation.
: We also looked at presentation

: styles and how they help create

© the style for your slides. | :
* encourage you to play around with :

the master page settings and
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presentation styles. The
presentation styles have 14
different tabs, making them very

. flexible. You can create a very
. professional and visually appealing
. presentation with these tools.

Next time, we will begin work

with individual slides.

@

Elmer Perry's history of working,
and programming, computers
involves an Apple IIE, adding some
Amiga, a generous helping of DOS
and Windows, a dash of Unix, and
blend well with Linux and Ubuntu.
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