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  Welcome to another 'single-topic special'


  In response to reader requests, we are assembling the content of some of our serialised articles into dedicated editions.


  For now, this is a straight reprint of the Inkscape series, Parts 1-7 from issues #60 through #67; nothing fancy,just the facts.


  Please bear in mind the original publication date; current versions of hardware and software may differ from those illustrated, so check your hardware and software versions before attempting to emulate the tutorials in these special editions. You may have later versions of software installed or available in your distributions' repositories.


  Enjoy!


  
    Please note: this Special Edition is provided with absolutely no warranty whatsoever; neither the contributors nor Full Circle Magazine accept any responsibility or liability for loss or damage resulting from readers choosing to apply this content to theirs or others computers and equipment.
  


  SVG Where Art Meets Code


  By Mark Crutch


  Imagine giving instructions to someone in order for them to draw a picture of a house. The chances are that you would describe geometric shapes and their relative positions. “Draw a big red rectangle about half the width of the page, roughly in the middle and a little wider than it is tall. Now put a grey triangle on top of it that’s a little wider so it overhangs at the edges...” The same instructions would work for any size of canvas from a postage stamp to a billboard.


  You’ve just imagined the world of vector graphics.


  When you take a photo or create an image in GIMP, you’re working with raster graphics – sometimes called bitmaps (not the same as the .bmp file format – although that is an example of a bitmap graphic). A raster graphic (or bitmap)is essentially a list of pixel colors, which tells the computer to draw a red pixel, then a blue one, then a green one... and so on, pixel-by-pixel, line-by-line, until the last pixel is reached.


  Vector graphics, on the other hand, consist of a series of instructions. “Draw a red circle with a radius of 10 units, centered at coordinates X,Y. Now draw a blue line from the top left corner of the page to the bottom right.” That red circle could have a radius of 10 inches, or it could be 10 miles, meaning that, unlike raster images, vector graphics can be scaled with no loss of quality.


  
    [image: ]

    A small circle scaled up as a bitmap image (left), and as a vector image
  


  Just as there are many raster formats – JPEG, GIF, PNG, BMP to name just a few – so there are also many vector formats. Most of them have grown from proprietary applications, such as AutoCAD’s DWG, or Adobe Illustrator’s AI, but one in particular is an open format, defined by the W3C – the same standards body that’s responsible for the HTML format that drives the web. Vector graphics are, by their very nature, scalable – but that didn’t stop them trying to make absolutely sure you know what you’re getting with their format: they called it “Scalable Vector Graphics”, or SVG.


  SVG files are plain text containing nested collections of “tags” in a similar manner to HTML files. There's a <circle> tag, a <line> tag, and so on. They can be modified using any text editor, though as an image becomes more and more complex it's usually easier to use a drawing program to edit them. Probably the best known software for this is Inkscape (www.inkscape.org) which can be found in the repositories of most Linux distributions, Ubuntu included, and is available also for Windows and MacOS. Inkscape uses SVG as its primary file format, which makes it a great tool for creating or editing SVG files, but which also places a limitation on the program's capabilities. With serious work now underway on defining version 2.0 of the SVG format, Inkscape should, hopefully, be able to make some ground on its proprietary competition over the coming years.
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    Inkscape, editing an icon from the Tango desktop project
  


  The HTML-like structure of SVG files, together with their origins at the W3C, have made them the official standard for vector graphics in the web world. It has taken a long time, but most web browsers now natively support SVG files, and it's possible to mix them directly into HTML files – ideal for inline graphs or maps. The hierarchical structure of tags is also open to being modified by Javascript in the same way as HTML content, allowing for anyone with some web development skills to create interactive graphics. As is often the case, however, specific support varies between browsers, and some more advanced features of the SVG format may not display in the same way in all of them.


  So SVG is great for diagrams, interactive charts, and even artistic works, but it's got one other trick up its sleeve which elevates it beyond the inherent smoothness and simplicity of pure vector graphics: it also has some support for raster images. At the simplest level, it's possible to include a raster image in an SVG file, then draw lines and circles over it, or clip it into an odd shape using an SVG path. But raster images can also be used as fill patterns in SVG files: Inkscape ships with a few of them by default, and I've personally used the sand texture (which looks like the noise or snow on an un-tuned television) to help simulate stone, ash, bricks, and even a cornfield!


  Going further still, SVG has a concept of filters – mathematical operations that can be combined and applied to the rasterised pixels in your final image. The image is still made up of vectors, but once those vectors have been drawn, filters can create all sorts of grungy raster effects which would usually require a program like GIMP or Photoshop. Just look at how a little filtering can turn some semi-random vector blobs into an explosive fireball:
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    Some simple vector blobs...
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    ...brought to life with some SVG filters
  


  Whether you want to draw icons for an application using Inkscape, graphs for a website using Javascript, or abstract art using a text editor, SVG is a powerful and flexible format that promises even more in the years to come. So grab a copy of Inkscape using your package manager and get drawing.


  Useful Links:


  Inkscape: http://www.inkscape.org

  Inkscape User Forum: http://www.inkscapeforum.com

  Tango SVG Icons: http://tango.freedesktop.org/

  W3C SVG Working Group: http://www.w3.org/Graphics/SVG/


  Mark has been using Linux since 1994, and uses Inkscape to create two webcomics, 'The Greys' and 'Monsters, Inked' which can both be found at: http://www.peppertop.com/


  Drawing with Inkscape – Part 1


  By Mark Crutch


  Before you skip on past this tutorial thinking it's not for you, I'm going to let you in on a little secret: I can't draw. If you give me a pencil and paper, or sit me in front of The GIMP with an expensive graphics tablet, then I'll easily be bested by a four-year-old. Yet, somehow, I'm one of the artists for a regular webcomic. So, how does a fat-fingered cave painter like me manage to produce artistic works? I use Inkscape.


  Inkscape is no replacement for an artistic eye, or three years at art school, but, if your problem is largely one of hand-eye coordination, then it offers you something that pencils and The GIMP don't. It gives you the opportunity to tweak and modify every line and shape that you draw - until you're happy with the result. If your hand-drawn lines are close, but not quite what you'd imagined, Inkscape gives you the time and tools to alter them, rather than having to throw them away and try again. So, before you dismiss this tutorial because you're not a natural artist, why not have a try anyway – you might surprise yourself. If art comes naturally to you, then you've already got a head start, but, hopefully, you'll be able to pick up some Inkscape-specific tricks and tips along the way.


  Let's begin by getting a copy of Inkscape. It's in the repositories of most desktop Linux distributions, so just use your normal package installer. These tutorials will be based on the 0.48 series, which has been the stable version for some time now.


  On first launching Inkscape, you'll be presented with a blank working area, surrounded by a variety of toolbars, and a menu bar at the top of the window (or at the top of the screen if you're using Unity on a recent Ubuntu release). The exact arrangement of the toolbars can be modified to a limited degree: you can show and hide them using the View > Show/Hide menu, and you can switch between three predefined layouts using the Default, Custom, and Wide options at the bottom of the View menu. For these tutorials, I'll be using the Custom layout (which is badly named, as it doesn't let you customise it at all), with all the toolbars visible, and resulting in a main window that looks something like this:
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  Now, let's draw something. From the Toolbox (which runs down the left regardless of your screen layout), click on the Circles and Ellipses tool . Move your cursor back into the working area and you should notice that the pointer has changed to indicate that you're using the Circle tool [image: ]. In the working area is an outline that represents your page – although Inkscape will happily let you draw outside its boundaries - which provides you with a large area for rough work, reference images or anything else that you don't want to appear on your printed page or exported image. Click within the page, and drag to the right and downwards to create an ellipse, releasing the mouse button when you're happy with its size and shape. Yours will probably be a different color, but we'll sort that out shortly.
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  Your ellipse should have a dotted line around it, indicating that it's currently selected. Many operations in Inkscape only work on the objects that are currently selected. The quickest way to de-select everything is to click on a blank section of the working area, away from any of the objects you've drawn. To re-select your ellipse just click on it with the Circles and Ellipsis tool still active.


  As well as the dotted line, you should see two small squares and a small circle on the edge of your ellipse. These are referred to as “handles”, and are a graphical way for you to modify some of the properties of your objects. Try moving one of the square handles by dragging it with the mouse: it changes the radius of the ellipse in one direction. The second square handle changes on the other radius.


  The circle is a little different – it's actually a pair of circles on top of each other. They allow you to turn your circle into a segment or an arc. Try dragging one round the outline of the ellipse. Now drag the other. Inkscape tries to guess whether you want a segment or an arc, so will flip between the two modes as you move the handles. You can switch between them manually using the buttons on the Tool Control Bar, just above the drawing area. Clicking on the third button will put the handles on top of each other once more, returning you to a full ellipse.


  [image: ][image: ]


  Let's give your ellipse a little color. Select it and look down to the bottom-left of the Inkscape window. There you will find a pair of colored swatches labelled Fill and Stroke. Fill shows the color that is used to draw the inside of your ellipse, while Stroke shows the color that is used to draw its outline. You can right-click on the number next to the Stroke swatch to pick from a few standard sizes if your stroke is too thick or thin.
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  Above those two swatches, you'll find a whole load more swatches stretching the width of the window. This is referred to as the color palette. Click on a swatch in the palette to set the fill color of the currently selected object, and SHIFT-click to set the stroke color. At the far left of the palette is a swatch with a cross through it which can be used to set the fill or stroke to transparent. Try setting the fill to transparent and giving the stroke a color. Now play with the circular handles and the Segment and Arc buttons – it should be a bit clearer why the latter is so named.


  Finally let's move the ellipse around on the page. For this you'll need to click on the Select tool, which is the first button in the toolbox and looks like an arrow [image: ] . With this tool enabled, you can move an object simply by clicking and dragging it. When an object is selected using the Select tool, you'll see a dotted line around it, but rather than the small square and circular handles we saw when the Circle tool was active, you'll see some arrow-shaped handles arranged around the outside of the dotted line.
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  Dragging these arrows will let you change the width and height of the ellipse. Although they may seem to have the same effect as the small square handles you used earlier, they're subtly different. Try clicking on the ellipse a second time, as though you're trying to select it again. The handles change to a different collection of arrows, and a small cross appears in the center of the object.
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  By dragging the arrows at the corners you can rotate your object. The handles at the sides let you skew it. Try playing with them to get a feel for how they work. You can drag the little cross around to change the center of rotation; SHIFT-click on it to return it to the middle of the object. A single click on the ellipse will switch back and forth between the resize and rotate modes.


  A double-click will switch you to the Circle tool, letting you gain access to the small square and circular handles once more. Try rotating an ellipse using the Select tool, then double-click to access the square handles and change the ellipse using them. Back to the Select tool and change the width and height using the arrow handles. See, I told you they were different!


  If you draw a few more circles and ellipses and move them around, you'll soon find that they can overlap or obscure each other as though they're stacked on top of one another. When you select an object with the Select tool, you'll find a group of four icons which let you move your objects up and down so that they appear in front of or behind other objects. The first and last buttons will make your object jump to the back or front of the stack, whereas the second and third let you nudge the object down and up by one position at a time.
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  Sometimes you might need to get a closer view of the objects you create – or zoom out for an overview. We'll cover that in detail in a later article, but for now you can simply use the plus (+) and minus (-) keys on your keyboard to zoom in and out, and use the scrollbars to move your view around.


  Now you know how to create ellipses, segments, and arcs, change their colors, and adjust the thickness of the stroke. You can move them around on the page and nudge them up and down in the stack of objects you've created. You can zoom in and out and move around the canvas. Next time we'll introduce some other shapes, but even with just ellipses, segments, and arcs, you can start to make some simple images: although it's not really the right season for it, how about drawing a snowman.
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  Finally, you should save your work using the File > Save (or Save As...) menu. There's a pop-up menu in the save dialogue that lets you choose between various formats. For now just choose Inkscape SVG, the first item on the list – I'll cover some of the other options in a future instalment.



  
    Mark has been using Linux since 1994, and uses Inkscape to create two webcomics, 'The Greys' and 'Monsters, Inked' which can both be found at: http://www.peppertop.com/
  


  Drawing with Inkscape – Part 2


  by Mark Crutch


  Last month, we learnedhow to draw ellipses using the Circle tool. But you may have noticed that we didn't actually draw any circles, despite the tool's name. You may have got close by adjusting an ellipse by eye, but that's not quite the same as drawing a perfect circle. The secret to drawing a perfect circle is actually the secret to making the best use of Inkscape in general: you need to use the keyboard.


  Inkscape has a huge number of keyboard shortcuts and modifiers. Last month, I mentioned using the Plus and Minus keys to zoom in and out, but there are hundreds more listed on the Inkscape Keys and Mouse Reference – the URL is at the end of this article, but you can also get to it directly via the Help menu in Inkscape. Such a large number of shortcuts can be overwhelming, so I'm just going to introduce them a few at a time, starting with the CTRL and SHIFT keys.


  These keys serve different purposes depending on what you're doing in Inkscape at the time that you press them, but, very broadly speaking, they usually have the following effects:


  
    	CTRL: Lock or snap some aspect of the operation


    	SHIFT: Affect the center or starting point for an operation

  


  An “operation” in this case refers to drawing, rotating, skewing, or otherwise manipulating an object. Let’s look at each of these keyboard modifiers when used with our Circles and Ellipses tool.


  Select the Circle tool by clicking its icon, or by pressing the “e” key (for ellipse) or the F5 key. Now hold down CTRL while you drag an ellipse out onto the canvas. You'll find that you can no longer smoothly adjust the width and height of the ellipse, but rather that it snaps to fixed ratios of 1:1, 1:2, 3:1, and so on. So the answer to the question of how to draw a circle is simply to hold down CTRL whilst drawing an ellipse.
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  As well as locking the ratio when you first draw an object, the CTRL key can also be used to snap your subsequent edits to defined values. Try selecting your ellipse with the Circle tool active, then move the small circular control handles (to turn your ellipse into a segment or arc) while holding the CTRL key. You'll find that the handles snap to particular angles, defaulting to 15°. You can change that value via the File > Inkscape Preferences > Steps dialog, where you can choose from a selection of other angles via a drop down list, although the default is a good choice for most uses.
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  [image: ]Now try selecting an ellipse using the Select tool (left), then clicking a second time to enable the rotation and skewing handles. Hold down CTRL as you rotate your object, and you'll find that the same snapping action occurs. It also happens for skewing, but that's a little less obvious with an ellipse, so we'll come back to that one a little later.


  Click on the ellipse again to switch back to the move and scale handles. If you try dragging your ellipse around, you'll find that the CTRL key locks you to only horizontal or vertical movements. Now, try resizing with the arrow handles, and you'll discover that the CTRL key locks the aspect ratio of your ellipse – you can make it bigger and smaller, but it will keep the same ratio of width to height.


  If you use a mouse with a wheel, then the CTRL key has another feature: hold it down as you scroll the mouse wheel in order to quickly zoom in and out of your document. While you're playing with the mouse wheel, try using it to click and drag the canvas around – a much faster way to pan around your drawing than using the scroll bars.


  Now let's consider the SHIFT key. Try holding it down while drawing a new ellipse. Notice that it's being drawn relative to the center of the ellipse, rather than the corner. One of the most common uses for the SHIFT key in Inkscape is to change the starting or reference point for an operation.


  Select an ellipse using the Select tool, then hold SHIFT as you resize it with the arrow handles. Notice how the reference point for your actions has switched to the center of the ellipse. Try pressing and releasing SHIFT while you're in the middle of resizing the ellipse to make it more obvious. You don't have to press these modifiers right at the start of an operation, you can press and release them at any point. The only thing that matters is whether they're pressed when you release the mouse button.


  Click the ellipse to switch to rotation mode, and hold SHIFT while you rotate or skew using the handles. You should see the small cross that indicates the rotation centerjump to the opposite corner or side from the handle you're moving, and your ellipse will rotate or skew around that reference point.


  You can also combine the CTRL and SHIFT keys. Press both as you draw with the Circle tool in order to create a perfect circle drawn out from its center point, or while you rotate your ellipse to rotate it in 15° steps around the opposite corner from the rotation handle.


  Let's finish this month with a new shape: there's only so much you can draw with circles and ellipses so we'll create some rectangles and squares instead.


  [image: ]For this, we'll use the Rectangle tool (shown left. Press F4 or “r”). Start by clicking on the button in the toolbox, then drag your shape out on the drawing canvas, just as you've been doing with ellipses. You should now have a nice rectangle:
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  Notice how your rectangle has small square and circular handles, like those on the ellipses. The two square handles are used to adjust the width and height. Hold SHIFT as you move them to constrain your changes to just one direction or the other. The circle handle, like that on an ellipse, is actually a pair of handles on top of one another. Move just one of them (or hold CTRL whilst moving either of them), and you'll get nice symmetrically rounded corners to your rectangle – like a quarter of a circle. Move both of them and you'll get an elliptically rounded corner instead. If you want to go back to perfect 90° corners, simply SHIFT-click one of the circular handles, or use the [image: ]button at the end of the Tool Control bar (just above the canvas).


  [image: ][image: ]


  The CTRL and SHIFT keys work in a very similar way with the Rectangle tool as they do with the Circle tool: hold down CTRL while you draw your rectangle to constrain it to fixed ratios if you want to create a perfect square, or hold down SHIFT if you want to draw from the center outwards rather than corner to corner.


  Of course you can change the color of the fill and stroke for your rectangles –just as we did with ellipses last month. You can also use the Select tool to move, resize, rotate, and skew them – and if you hold down CTRL while skewing a rectangle, it's a lot more obvious what's happening than it is with an ellipse.


  Now that you can create rectangles and squares, why not enhance that snowman you drew last month by adding a hat and pipe?


  [image: ]


  Useful Links:


  Keys and Mouse Reference: http://inkscape.org/doc/keys048.html

  


  
    Mark has been using Linux since 1994, and uses Inkscape to create two webcomics, 'The Greys' and 'Monsters, Inked' which can both be found at: http://www.peppertop.com
  


  Drawing with Inkscape – Part 3


  By Mark Crutch


  Here's a riddle for you: when is a circle not a circle? More specifically, which of these two circles is a circle, and which one isn't?
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  They may look the same, but they're not. If you double-click on each of them to make their edit handles visible, you can start to see a difference.


  The one on the left is the true circle, created by holding down CTRL while drawing an ellipse. The other is a square, created by holding CTRL while drawing a rectangle, which has had its corners rounded using the small circle handles.
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  Often it's quite obvious what type of object you're working with in Inkscape, but as your drawings become more complex, and as you begin to use more and more tools, it's easy to lose track. Some features only work with particular types of objects, so it's handy to be able to tell at a glance exactly what you've got selected. Inkscape reveals that information – and a whole lot more – in the status bar at the bottom of the window. Here's the relevant part of the status bar when each of these “circles” is selected with the Select tool:
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  From that information it's quite obvious that the two circles are different. But that image has been edited a little; the text actually reads “Ellipse in layer Layer 1. Click selection to toggle scale/rotation handles.” The status line is telling you that clicking your selected object will toggle between the scale handles and the rotation & skew handles.


  In fact much of what has been verbosely described in the previous two articles can be found written far more succinctly in Inkscape's status line. With the Circle tool selected you're told to “Drag to create an ellipse. Drag controls to make an arc or segment. Click to select.” In this case “drag controls” is Inkscape's terminology for moving the small square and circle handles. A similar line when the Rectangle tool is selected suggests you can “Drag controls to round corners and resize.”


  Hovering the mouse pointer over the various handles also provides valuable information in the status line, including this gem when you use the circle handles on an ellipse: “...drag inside the ellipse for arc, outside for segment.” So if you were wondering about Inkscape's seemingly random switching between segments and arcs, it turns out not to be random after all. Keep the pointer inside the boundary of the ellipse if you want to create an arc, and outside if you want to create a segment – although you can always switch using the toolbar buttons if you end up with the wrong type of object.


  As well as these handy tips, the status bar also houses a few other things that you should become familiar with if you want to make the most of your time with Inkscape. At the far left are the fill and stroke swatches that were introduced back in the first part of this series. In theory you can click and drag on them in order to change their colors, but I've always found that to be an imprecise and awkward approach. Next month we'll look at the Fill and Stroke dialog which is a much better way to pick colors that aren't present in your color palette.
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  The stroke thickness offers an equally useless facility to click and drag in order to change its value. For most quick changes a right-click on the number to bring up the context menu is a much better option.


  The spin-box labelled with a cryptic “O:” lets you set the opacity of your selected objects. It's shown as a percentage, so 100 is the norm for a completely opaque color whilst 0 will render your objects completely transparent. Inkscape has lots of ways to make your objects transparent, which can be a real problem for new users. You can set a value in this box by typing directly, by using the up and down buttons at the side, or by right-clicking to bring up a rather coarse five-step context menu. I usually use the context menu, at least as a starting point, and, if nothing else, it provides a fast way to get back to 100% opacity when you're in danger of losing your transparent objects.


  The eye and lock icons, and the pop-up menu that follows them, are all related to layers. I'll be covering layers in a later article, but there are three things worth knowing about them at this stage:


  
    	If you're familiar with layers in GIMP or another graphics program, layers in Inkscape work in a similar way.


    	Clicking the eye button is another of the many ways to make your objects disappear from the screen – in this case by hiding the layer they're drawn on. The icon changes to a closed eye in this case and you can simply click it again to display the layer once more.


    	If the lock icon looks like a closed padlock, then your layer is locked and you won't be able to draw anything new onto it. Click the icon again to unlock it.
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  To the right of the status text is a pair of fields which show the X and Y coordinates of your mouse pointer, relative to the bottom-left corner of the page boundary. You can't modify these in any way, other than by moving your mouse, as they're just there for information. Be warned, however, that Inkscape's choice of the bottom-left of the page as the origin point is different to the SVG specification's use of the top-left corner – it's not a distinction that will affect most people, but it does mean that if you're a programmer type who wants to edit the SVG file directly, these values are almost useless to you.


  The last Inkscape-specific widget in the status bar is a zoom spin-box which shows you the current zoom level, lets you set a specific value by typing or using the up and down buttons or pick from a few standards via a context menu. There are so many other zoom tools, including the CTRL plus scroll wheel and the +/- keys which I've described previously, that I doubt you'll ever use this widget. Finally there's a handle to resize the window.


  Let's finish this month by introducing another drawing tool to your arsenal: the Stars and Polygons tool. It's got an icon in the tool box[image: ]and can also be activated using the asterisk key (easy to remember because it looks a little like a star) or SHIFT-F9. Dragging out a shape on the canvas will produce either a convex polygon or a concave, star-like, polygon. You can switch between the two modes using the first two buttons on the tool control bar.
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  Depending on which mode you're using, you'll see either one or two small diamond-shaped handles. These let you adjust the size, rotation and, for concave polygons, the spoke ratio. By holding various modifier keys as you move them, you can also adjust several other parameters (have a look at the status bar for the details) – although I usually prefer to change them using the spin-boxes in the tool control bar.


  [image: ]


  The only parameter that can't be changed via the diamond handles is the number of corners on your polygon, but the other advantage to using the spin-boxes is that, like the spin-boxes on the status bar, they each have a context menu that you can access with a right-click. These context menus are tailored to each spin-box separately, with descriptive titles to provide you with a little insight into the effect they'll have.


  The best way to get a feel for the Star tool is simply to play with it. Try different combinations of values in the spin-boxes. If your objects start to get a little out of control just click the button at the right of the tool control bar – the one that looks like a small broom – in order to 'clean up' the parameters back to sensible defaults. To give you some idea of what you can achieve simply by tweaking the parameters for the Star tool, this image contains six identical polygons which differ only in the settings in their spin-boxes:
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  To go back to the question that started this article, you now have a third way to create a 'circle' – draw a convex polygon with a large number of corners. It's not a particularly good way to draw a circle, and it's certainly not efficient, but it does reinforce the fact that objects in Inkscape aren't always what they seem. Keep an eye on the status text.


  Why not use this new tool to add some stars to the background of your snowman image from the previous articles. The same tool will also let you replace those circles that we used for the eyes and mouth with slightly randomised convex polygons – far more authentic as lumps of coal.


  [image: ]

  


  
    Mark has been using Linux since 1994 and uses Inkscape to create two webcomics, 'The Greys' and 'Monsters, Inked' which can both be found athttp://www.peppertop.com/
  


  Drawing with Inkscape – Part 4


  By Mark Crutch


  This month, we're going to look at setting colors for our objects. So far we've applied colors to the fill and stroke of our objects by clicking and SHIFT-clicking on the palette at the bottom of the screen. You can also set either to transparent by using the leftmost palette entry – the one with a cross through it. You've probably already discovered the scroll bar that usually lives between the palette and the status bar, and which lets you scroll through the full collection of colors in the palette, but have you noticed the tiny little button to the right of the palette area – the one that looks like a small “<” character? Clicking on that presents you with a pop-up menu of palette options:
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  Most of this menu is taken up by a list of palettes you can use. Try switching between a few of them to see how they look. Then play with the Size and Width sub-menus to find a swatch size that you're comfortable with. Finally, try the Wrap checkbox to see whether you prefer to see all of your palette at once (even if it takes up more vertical space), or are happy to use the scrollbar when you need to access the more distant colors.


  If you want to use your own palette – perhaps to fit in with a corporate color scheme or to integrate with other icons in an application – you can drop a GIMP palette file (.gpl) into your .inkscape/palettes directory, or into /usr/share/inkscape/palettes if you want it to be available to all users on your computer.
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  The palette is great for quickly selecting a color for your fill or stroke, but what if you want a color that's not present in the palette? That's where the Fill & Stroke dialog comes in. There are various ways to open the dialog, including the button on the Commands toolbar, selecting an object then picking 'Fill and Stroke' from the right-click context menu, pressing CTRL-SHIFT-F, or simply clicking on the current fill and stroke swatches at the bottom-left of the window. You may dock the dialog to the right-hand side of the Inkscape window, or move it into a window of its own, by dragging it using the grey title bar at the top.
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  At the top of the dialog are three tabs for setting the Fill, the Stroke Paint, and the Stroke Style. The first two offer almost identical options, so we'll just discuss the Fill tab and you can extrapolate from there.


  Immediately below the tab is a row of buttons which are used to determine what type of paint is used for the fill or stroke. At the left is a button for 'No Paint' which looks like a cross and has the same effect as using the crossed swatch at the left of the palette in the main drawing window. If both the fill and stroke are set to No Paint, then your object will be completely invisible.


  The second button lets you choose a single color for your fill or stroke. In that respect, it's the same as selecting from the palette, except that you have much finer control over the color. Choosing this button presents you with yet more tabs offering a few different methods for picking your color. Don't be fooled though: Inkscape uses RGB (Red, Green, Blue) values in its files even if you select a color via the HSL or CMYK tabs. This is one example of Inkscape being restricted by the capabilities of the SVG format. The CMS tab is only of use if you set up a color management system on your computer, and is outside the scope of this series.


  Whichever color picker you choose, you'll find a slider at the bottom labelled with an 'A'. This is the 'alpha channel', which is just another term for opacity. If this slider is moved to the far left, then your fill or stroke will be completely transparent. To the far right, it's completely opaque. Anywhere in between will make it partially transparent. This image demonstrates the same two objects with the stroke fully opaque, but the top object's fill alpha being set at the 0, 128 and 255 levels:
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  As with the No Paint option, setting the alpha channel for both the fill and stroke to zero will render your object completely invisible. If the fill or stroke is partially transparent, the color swatches in the bottom-left corner of the status bar in the main window will show a two-part arrangement: the left half shows the color with the alpha applied over a checkerboard effect, while the right half shows an opaque version of the same color. You can easily make a translucent fill or stroke completely opaque via the context menu on the swatch.


  The third and fourth buttons let you use a gradient for your fill or stroke. Gradients will be the subject of next month's article, so remember that these buttons exist, but we'll skip over them for now.


  The next button lets you paint your fill or stroke using a pattern. Inkscape ships with a variety of stripes and polka dots which are available via a pop-up menu when you select this option. Most patterns are black or white, with just one color pattern (Camouflage) and three grayscale bitmap images that can be used as patterns, right at the bottom of the list. It is possible to create your own patterns and to adjust the size and scale of the built-in patterns, but those are subjects for another day.


  Also being put off for later articles are the Unset Paint button that looks like a question mark and the two splodges on the right of the Fill tab.


  The third main tab on the Fill and Stroke dialog is labelled as Stroke Style. While the Stroke Paint tab is used to set the color, gradient or pattern that is used for the stroke, this tab lets you manage all the other parameters. Most of these settings can be adjusted only by using this dialog, so it's worth becoming familiar with it.
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  At the top is a spin-box for setting the width of the stroke, and an associated pop-up menu for picking the units that the width is measured in. These duplicate the functionality available from the right-click menu on the status bar, but offers a greater choice of units and finer control over the width. SVG currently allows the stroke to only straddle the outline of the object, half inside and half outside it. You can see this clearly by reducing the alpha channel on a thick stroke – notice that the fill shows through the inner half of the stroke. It's worth remembering, as Inkscape novices often wonder why increasing the stroke also reduces the area inside their shapes.


  Next are three radio buttons labelled as Join. These determine how the corners of your objects are drawn – either as sharp (mitred), rounded or bevelled corners. The difference between them can easily be seen by drawing a star:
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  When a mitred corner is particularly sharp, the point of the join may extend quite some way. In this case Inkscape will switch to drawing a bevelled corner instead. The length that the point is allowed to grow to, before this switch occurs, is set by the Mitre Limit spin-box.


  The Cap buttons affect the ends of your lines. Most of the objects we've drawn so far are continuous loops, so the ends aren't really clear, but if you use the circle handles to turn an ellipse into an arc then you'll have an object with obvious ends. The middle option, Round Cap, finishes your lines with a semicircular smooth extension to the end. The other two options, Butt Cap and Square Cap, both give a squared-off end to your line, and differ only in whether the square extends beyond the nominal end of the line (Square Cap), or stops precisely at that point (Butt Cap).


  The stroke doesn't have to be a single continuous line, it can consist of a repeating pattern of dashes. Anyone who has spent time with technical drawings will be familiar with the dash-dot-dash of a center line, and a series of dashes can be used to give a stitched effect for artistic purposes. The Dashes pop-up lets you choose from a variety of dash patterns built into Inkscape, with the adjacent spinbox letting you adjust the relative start position of your pattern. The Cap buttons also play a big part when it comes to dash patterns – this image shows our star with a thick dashed stroke using each of the three cap settings:
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  The three pop-up menus for Start, Mid and End Markers allow you to select arrowheads, circles, squares and other shapes which will be positioned on your stroke. Once again, the Start and End options make most sense on an unclosed line, such as an arc. On a closed line, you'll probably want to use only one or the other. The Mid Markers appear wherever there is a corner or a transition to a different line segment – which includes the transition from straight to curved segments on a rounded rectangle. This image shows just three examples of markers and dash patterns in use:


  [image: ]


  On big caveat with markers is that they will appear in black, regardless of the color of your stroke. Fortunately Inkscape does ship with an extension that tweaks the necessary SVG internals for you, so making the colors match is as simple as selecting your marker-laden object, and then heading up to the menu bar to choose Extensions > Modify Path > Color Markers to Match Stroke. Even using this extension, however, markers are always opaque, regardless of the alpha setting of your stroke.


  The last part of the Fill and Stroke dialog to explain is the pair of sliders at the bottom– to adjust the Blur and Opacity. The former is a convenient shortcut for adding the Gaussian Blur filter to an object. SVG filters are a major topic of their own that we'll look at in a later article, but, for now, it's enough to know that increasing this slider will cause your object to become blurred. The more you increase it, the more blurred your object will be. Don't go too overboard: usually a small value will give you a good effect, whilst larger values just dissipate your object into mist. Be aware that using filters will slow the speed at which Inkscape redraws the screen, especially if you're zoomed in closely.


  The opacity slider has the same effect as the 'O' spin-box and context menu on the status bar, but with more fine-grained control. Changing this value affects the opacity of the entire object – both the fill and the stroke. Effectively, the object is drawn in memory using the fill and stroke alpha values, then that whole image is drawn to the screen using the object opacity. This cumulative effectmakes it possible to combine transparency values in complex ways that wouldn't be possible with just alpha or just opacity. In this rather garish example the squares have 100% opacity and alpha throughout, but the circles have the fill, stroke and opacity values indicated:
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  The opacity slider is one way to make some use out of those colorless fill patterns. By duplicating an object (Edit > Duplicate), and then filling the copy with a pattern and reducing its opacity, you can let the original object's color show through.


  Why not use that trick on your snowman image to give a little graininess to the covering of snow on the ground with the addition of the Sand texture at a low opacity. Add in some color tweaks, a bit of blurring, and some translucency on the shadows, and you should find that, with your new found mastery of the Fill and Stroke dialog, your image is starting to look a little less flat.
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    BIO: Mark has been using Linux since 1994, and uses Inkscape to create two webcomics, 'The Greys' and 'Monsters, Inked' which can both be found at: http://www.peppertop.com/
  


  Drawing with Inkscape - Part 5


  By Mark Crutch


  Last month, I introduced the Fill and Stroke dialog as a method for setting flat colors or patterns on your objects The SVG specification also allows for gradients to be used, but, unfortunately, describes only two types: linear and radial. If you've used gradients in other graphics programs, you may be used to far more variety, but Inkscape is bound by the limitations of the SVG specification so, for now at least, two gradient types are all you have. Inkscape has separate buttons for these in the Fill and Stroke Paint tabs of the dialog: as you might expect, one looks like a linear gradient [image: ] and the other looks like a radial gradient [image: ].


  Whichever one you choose, you'll be faced with the same user interface within the dialog:
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  The first item is a pop-up list of the gradients that already exist within your document. The currently selected gradient, at the top of the list, will be the new one that you're in the process of creating. If you prefer to use an existing gradient, then you can simply select another one from the list. Each gradient gets given a user-unfriendly name, such as the «linearGradient3791» in the screenshot. Unfortunately, Inkscape doesn't provide a practical user interface for modifying this name, so, once you have more than a handful of gradients in a document, it can quickly become an unwieldy list which gives little indication of where each one is used in your image.


  Your new gradient will always take the same basic form: it has a start color which is set to a fully opaque version of your current fill color (or to black if there is no fill color set), and it has an end color which is the same as the start color - but with its alpha value set to zero. The result is a gradient running from an opaque color to a transparent color which runs from left to right for a linear gradient, and from the center outwards for a radial gradient:
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  If you double-click on your object - so that you enter editing mode and can see the small handles we've explored in previous articles - you'll also find that two or three new handles have appeared, joined by lines and indicating the start and end points of your gradients as square and circular handles respectively. You can drag these handles around - even outside the boundary of your object - in order to change the position and angle of your gradient. For radial gradients, the two end points can be moved independently, allowing you to have circular or elliptical gradients.
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  When you click on one of the gradient handles, you'll notice that the Fill and Stroke dialog switches back to the Flat Color mode, with the selected color also reflected in the swatches in the bottom-left corner of the main Inskcape window. The color you can see is that of the selected end point of your gradient, and you can change it in any of the ways we've discussed previously. Try selecting the transparent end, clicking on another color swatch, and then playing with the opacity slider or the «O» spin-box. This approach lets you create gradients that change smoothly between any two colors.
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  A gradient with two colors is all well and good, but what happens if you want three, four, or a whole rainbow? You could create multiple objects, each with a part of the overall gradient, but that quickly gets complex and unwieldy. In practice the answer is simpler than you might think - we just create more handles on our gradients. Instead of a start and end handle, we'll have one or more in the middle as well. These handles each define a particular color in the gradient, and are usually referred to as «stops».


  To add a new stop to a gradient we need to make it clear to Inkscape that we want to edit the gradient rather than the object itself, by selecting the Gradient tool [image: ] from the toolbox (or by pressing «g» or CTRL-F1). Now it's possible to double-click on the line that joins your existing stops in order to add a new stop. It will default to the color and opacity at that point on the line, so the visual appearance of your object won't change - but now that the new stop exists, you can select it and change its color. You can also drag stops along the line, crowding them together for a sharp transition between colors, or spreading them out for something more gradual. Very quickly, it's easy to create garish multi-colored gradients, although more subtle color changes between stops will often give a better artistic effect.
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  While the Gradient tool is active, you can still move the end stops to modify the size and angle of the gradient. When you're done, just select your object using the Select tool [image: ] in order to return to the familiar view of the Fill and Stroke dialog with the gradient in place. A useful shortcut for this step is to just hit the space - bar. In most cases, this will toggle between the current tool and the Select tool, switching back and forth with each press.


  Let's go back to a simpler gradient with only two stops. The quick way to do that is to switch your fill to Flat Color, and then back to a gradient again, returning you to the default arrangement of a fade from opaque to transparent - centered on your object. The Fill and Stroke dialog should look like the first image in this article once more, giving us a chance to explore the remaining options on the screen.


  The Duplicate button is almost self explanatory. It duplicates whichever gradient is currently selected in the pop up menu, and applies the duplicate to the currently selected object. That last point is important - it means that you can happily change the stop colors and positions in the duplicated gradient without affecting any objects that use the original version. As such, it can be a convenient starting point if you already have a gradient that's close to the one you need, but not quite perfect.


  The Edit… button we'll come back to shortly.


  The Repeat pop-up is used to define what happens beyond the start and end stops of your gradient. The default setting is «none», in which case the area before the start handle will take on the same color as the start handle itself, and the area beyond the end handle will likewise take on the color of the end stop. Both the other settings repeat the gradient: «reflected» causes the gradient to reverse for each repeat, giving a smooth transition that cycles as Start End, End-Start, Start-End, End-Start…; «direct» uses the gradient as it stands, giving a more abrupt cycle of Start-End, Start-End, Start-End, Start-End… As is often the case, a picture demonstrating this makes far more sense than a textual description, so here are three pairs of gradients demonstrating «none,» «reflected» and « direct» modes using the gradients shown in the top pair:
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  Now we'll return to that Edit… button. If you click it, you'll bring up a gradient editor window. This is an alternative interface for editing gradients: you can add and remove stops, change their position within the gradient, and alter their colors – exactly the same features that are available by editing using the Gradient tool on the canvas except that the editor won't help you to change the position and angle of your gradients within your objects. The gradient editor dialog has been officially deprecated though, and will likely be removed in a future release in favor of some additions to the on-canvas editing, so I won't go into any more detail about it.


  Throughout this article I've talked about editing the fill. But you can also apply a gradient to your object's stroke. Here we have two thick-stroked rectangles, one with a linear gradient for the stroke, and the other with a radial gradient:
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  Being able to use a gradient for the stroke can be a useful workaround for one of SVG's (and therefore Inkscape's) limitations: strokes are always a fixed width. This restriction makes it difficult to draw lines that taper out, but using a stroke that fades to transparent can often give a similar visual effect, especially with thin lines:
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  There is one feature that crops up when using both fill and stroke gradients which can sometimes feel more like a bug: Inkscape likes to 'help' by snapping the handles of gradients together so that you can manipulate them as one. In this example I've drawn a square with a yellow fill and blue stroke, then clicked the linear gradient buttons in the Fill and Stroke dialog. It looks like there's only one pair of gradient handles, but that's because one set is on top of the other.
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  If you wish to modify just the fill or the stroke gradient, the obvious thing to do would be to grab the visible handles and move them out of the way to reveal the second pair below, right? If you try that, you'll find that Inkscape's propensity for snapping gradient handles together means that both sets of handles move as one.
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  The solution to this conundrum is simply to hold the SHIFT button as you drag the handles around. This will let you separate them, and prevent them snapping back together if they get too close to one another.
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  Now that you can create gradients, perhaps it's time to replace the simple blurred shading on your snowman with some radial gradients, to give him a little more depth. Don't forget linear gradients for his nose, arms, hat and pipe. As a finishing touch, a nicely shaded sky is usually more interesting than a flat plane.
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    BIO: Mark has been using Linux since 1994, and uses Inkscape to create two webcomics, `The Greys’ and `Monsters, Inked’, whichcan both be found at:http://www.peppertop.com/
  


  Drawing with Inkscape – Part 6


  By Mark Crutch


  This instalment is going to introduce the most powerful of Inkscape's drawing primitives: Paths. I say 'introduce' because paths can be created, used and manipulated in many different ways, so we'll come back to them time and time again as these tutorials progress.


  [image: ]But, this month, we'll keep it simple and start with the Line tool (SHIFT+F6, or “b”).


  Select the tool, click once on the canvas, then move the cursor to another part of the canvas before double-clicking to finish your path.


  You've just created the simplest type of path there is: a straight line. Try giving the stroke a color and thickness using the Fill and Stroke dialog or the tools on the status bar that we've covered previously. Now, switch to the Selection tool (remember you can just hit SPACE as a fast shortcut), and confirm that you can resize, rotate and shear it just as you would expect. Double-click on the line to switch to the editing mode and you'll notice something a little out of the ordinary: whereas a double-click on a rectangle, ellipse or star will switch to the appropriate tool, double-clicking on a path switches instead to the Node tool[image: ].


  You'll become familiar with the Node tool soon enough, but, for now, just select the Line tool again. This time, click in several places on the canvas before finishing off with a double-click. You've just created a path with multiple line segments. The chances are that you've got an 'open' path – one in which the two ends are separate. If you draw another multi-segment path, but double-click back at your starting point, you'll create a 'closed' path. The difference between them becomes apparent when you add a fill – and it should remind you of the effect we got when creating arcs back at the start of this series.


  
    [image: ]

    As you can see, if you apply a fill to an open path it will be drawn as though there's a straight line that closes the path. That can sometimes be a handy feature, however it works only when there's a single break in the path – as soon as you introduce another (we'll see how to do that next month), the fill disappears entirely.


    Let's return to the Node tool[image: ]by double-clicking on one of the paths, or by pressing the F2 or “n” keys. The double-click will switch tools and select your path; if you opted for the keyboard shortcut, you might have to click on your path to ensure it's selected. You should see a small diamond-shaped handle marking each transition between line segments. These are called 'nodes' and, as you might imagine, the Node tool is what we'll use to manipulate them.
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    Try dragging one of the nodes around with the mouse. Now hold down SHIFT as you click on several nodes to select them – they are colored yellow when they're selected – and drag all of them around as one. Do you want to move the nodes at either end of a segment? Simply click on the line that joins them. Hold down SHIFT as you do so to add both nodes to an existing selection. You can also press “!” (SHIFT-1 on my keyboard) to invert the selection, which can be especially useful when dealing with very complex paths. Finally, try dragging a 'rubber band' selection box over some of your nodes by clicking on the canvas and, keeping the mouse button pressed, dragging out a rectangle that covers some of your nodes. Release the mouse button and the nodes within the box will be selected (or added to your selection, if you also held SHIFT).


    Of course there's more that you can do with nodes than just move them around. Select a few then enable the 'Show Transformation Handles' button[image: ] on the tool control bar. You'll see the familiar move/resize handles around your nodes; clicking on one of the selected nodes will switch to the rotate/skew handles instead. These operate in the same way as the handles you get with the Selection tool, but the transformations are applied to the selected nodes rather than the whole object.
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    Think back to the previous article when you were editing gradients directly on the canvas. Adding a new gradient stop was as simple as double-clicking on the line where you wanted it to appear. Adding a new node to a path is similar: just double-click on the path. If you want it exactly halfway along a segment, then select the nodes at either end (remember, a click on the segment itself will do that), and press the INSERT key or click on the[image: ]button on the tool control bar. The new node will automatically be added to your selection, so you can repeatedly press INSERT or click the button to add several nodes to a line segment.


    Let's get a little more curvy. Click and drag the middle of one of your line segments to quickly turn it into a 'Bézier curve'. The nodes at each end of your curve should have circular handles attached to them via thin lines. Rough curves can just be dragged out from straight line segments, but you can fine tune them by moving these circular handles around.
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    If you decide that you want to change your Bézier curve back into a straight line, you first need to select the end nodes, then press SHIFT-L or use the[image: ]button on the tool control bar. There's an adjacent button (or SHIFT-U) for converting a straight line to a curve, but most of the time it's more useful to just drag the line segment to get the approximate shape you want, then fine tune it with the Bézier handles.


    The little diamond-shaped nodes that we've played with so far are just one of four types of nodes that can be used in paths. These nodes allow the path segments on either side to extend in any direction, allowing you to create corners in your paths. Sometimes, however, sharp corners are the last thing you want, so, for those occasions, there are three other node types: smooth, symmetric and auto-smooth. You can cycle through the various node types by CTRL-clicking on a node, or you can directly change to the type you want by selecting the node(s) and then using the buttons on the tool control bar:
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    Here's a quick summary of the four node types:


    
      	Corner – Allows the line segments to meet at an angle


      	Smooth – Ensures that the gradient remains constant from one segment to the next


      	Symmetric – Like Smooth, but also ensures that the two handles are the same length


      	Auto-smooth – Moving this node, or its neighbours, will keep the line smooth. If you adjust the handles on this node, however, it will revert to a simple Smooth node.


    


    Of course the best way to understand the differences between these four types is to simply draw a line with a handful of nodes and play around with them.


    Drawing a series of segments from scratch using the Line tool is just one way to create a path, but Inkscape has several others. One of the most common approaches is to convert another object into a path. This lets you easily transform a rectangle, ellipse or polygon into a path whose nodes can be moved and modified freely. The downside to this freedom is that the object loses its original identity – you won't be able to use the Rectangle tool to change the corner radius once its been converted into a path, or the Star tool to adjust the number of sides to your polygon. You also won't be able to convert your path back to the original object type, even if you haven't made any changes to the nodes: conversion is a strictly one-way affair.


    With those warnings in mind, let's draw some objects and convert them to paths. To start with, you just need to create a few shapes, following the instructions in the earlier instalments of this series. An ellipse, rectangle, rounded rectangle, and a star, for example. Then select each object and use the Path > Object to Path command at the top of the menu (or CTRL-SHIFT-C if you prefer). Double-click on each path so that you can see where Inkscape has created corner nodes, and where it's created smooth nodes.
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    Try manipulating these paths: move some nodes, change them from corner to smooth and back, drag the line segments, and adjust the Bézier handles. Add some nodes with a double-click or by selecting a segment and pressing INSERT. Of course you can also delete nodes by selecting them and pressing DELETE (or clicking the [image: ] button in the tool control bar), but there's a bit of a catch to that: Inkscape will try to preserve the original shape of the path as best it can, even though there are now fewer nodes. If you want it to just delete the node without trying to preserve the shape then you need to press CTRL-DELETE. The difference becomes clear when you want to just remove one corner from a rectangle:
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    If you go too far with your node editing (or with anything else in Inkscape), you can always use the Edit > Undo menu (CTRL-Z) to roll back your changes. Inkscape maintains a history of all the edits you make in a session, so you can Undo repeatedly if you want to. Take a look at Edit > Undo History if you really want to travel back in time.


    On the whole, Inkscape is a fairly stable program, but it will occasionally crash. In my experience, this happens most when you're editing paths, and usually when you try to use the Undo facility. Fortunately, it also does a pretty good job of saving your work to a backup file if it can. If Inkscape presents you with a dialog to tell you that it's crashed then usually that will show the path and name of the backup file. Generally, the file is in the same directory as your drawing – or in your home directory if you haven't saved your drawing yet – and will have a name that's based on your file's name but with a numeric date and time string appended to it. Usually you can just open the backup file, save it with a different name, and carry on working as though nothing had happened. As with all computer files, however, it pays to backup regularly – I usually start each of my Inkscape sessions by using File > Save As… to create a copy of my image with a slightly different name so that I can never lose too much work to an Inkscape crash.


    Now that you can convert Inkscape's shapes into paths it's time to make your snowman look a little less pristine. Convert his elliptical head and body, then add a few nodes and move them slightly to produce the lumps, bumps and asymmetry of a typical snowman. You can also add a bit more character to his carrot nose by drawing cuts and marks and by making it a little wonky in parts. The horizon benefits from a little waviness to imply drifting snow. Although you could create more twiggy arms and crush his hat, I'm going to leave those alone for now and deal with them next month when I'll cover some methods for creating and manipulating complex paths quickly and easily.
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      Mark has been using Linux since 1994, and uses Inkscape to create two webcomics, 'The Greys' and 'Monsters, Inked' which can both be found at

      http://www.peppertop.com/
    

  


  Drawing with Inkscape – Part 7


  By Mark Crutch


  At the end of last month's article, I promised that we would take a look at the too pristine hat that's adorning our now-lumpy snowman. The hat was added way back in the second instalment of this series, when all we could draw were ellipses and rectangles, and is a good example of how a few carefully chosen objects can fool the eye into seeing shapes that aren't really there. Here's how it looks when removed from the snowman's head and rotated a little:


  [image: ]


  There's obviously an ellipse at the top, and another for the brim, but what of the main body of the hat? With your new knowledge from last month, it would be easy to create by just converting a rectangle to a path, and curving the top and bottom segments, but this version pre-dates that insight by several months. Exploding the hat into its constituent parts makes things a little clearer:


  [image: ]


  The body is just a rectangle with an ellipse peeking out from beneath it. By giving them matching gradients we could create the illusion of a single object. The curve at the top doesn't exist at all, it's just an optical effect created by putting the rectangle behind the ellipse that forms the top of the hat.


  Fooling the eye for artistic effect can be very useful, but, in this case, it was really just a workaround for our lack of Inkscape skills. It would be better if the body of the hat was just one object with one gradient. Our complete hat would then consist of an ellipse for the top, an ellipse for the brim, and a path for the body. Wecoulddo that by converting the rectangle to a path and changing the bottom edge to a Bézier curve:
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  But we've already got the shape we want in the outline formed by the rectangle and ellipse. What wereallywant to do is to combine those objects into a single path. In order for Inkscape to know which items we want to combine, our first step is to select them both. Switch to the selection tool, click on the rectangle, and then hold down SHIFT while clicking on the ellipse. The status bar should tell you that you have “2 objects of types Rectangle, Ellipse” selected. If not, use Edit > Deselect (or just click on the background, away from any other objects) in order to clear your selection, then try again. Once you're happy that you've got the right two objects selected, use the Path > Union menu entry (CTRL-+) to combine your objects into a single path:
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  If you zoom in closely you'll notice that our new path isn't quite as perfect as we would like. Some misalignment of the ellipse to the rectangle has resulted in extra nodes being created that we'll need to manually edit using the Node tool. Creating paths from other objects in this way can be a fast way to get the basic outline of a shape, but usually you'll need to do some manual editing afterwards.
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  As well as adding shapes together to form a single path, we can also subtract them, cutting one shape out from another. Looking at the top of the hat, we could use the ellipse to cut away a curved section. You don't need to be a mathematical genius to understand that 1-2 doesn't give you the same result as 2-1. Similarly subtracting a rectangle from an ellipse won't give you the same result as subtracting an ellipse from a rectangle, so Inkscape needs some way of knowing which object is the one we're removing, and which is the one we're removing it from. This is done using the stacking order.


  The stacking order was briefly mentioned back in the first part of this series: objects within Inkscape can sit 'on top of' each other, with ones at the top of the stack obscuring those below (assuming they're all fully opaque). When you've got an object selected using the Selection tool you can move it up and down the stack using these four buttons on the tool control bar:


  [image: ]


  To cut one object from another, the shape that is being removed must be on top of the other object – in our case the ellipse needs to be on top of the rectangle-with-a-curved-base. It's probably already on top in the stack, but it doesn't hurt to get into the habit of always moving your cutting object on top of the object to be cut. This is easy to achieve by selecting the ellipse and using the last of the four buttons to bring it right to the top of the stacking order. Now you need to position the ellipse to cut out the shape you want – in this case overhanging the edge of the rectangle. With that done it's a simple case of selecting both objects and using Path > Difference menu entry (or CTRL and the minus key) to subtract the ellipse from the rectangle:


  [image: ]


  Unfortunately there are a couple of problems with the result: the first is that, once again, we have some rogue nodes that will need to be manually tidied up; the second is that our ellipse has now completely disappeared! That's a side effect of the Path > Difference operation: the object you are cutting out is also removed in the process.


  Press CTRL-Z (or use Edit > Undo) to restore your ellipse back to its pre-cut status. Now select just the ellipse and use Edit > Duplicate (CTRL-D). This will create a copy of the selected object(s) at exactly the same location on the canvas, but at the top of the stack. It's worth getting used to the keyboard shortcut for this as it's a particularly useful feature – it not only gives you a disposable copy of your cutting object to use, but also saves you having to manually move it to the top of the stack. It even leaves the new object selected, so you just have to SHIFT-click on the object to be cut, then use Path > Difference. Now our former rectangle has a curved base and a curved top, and we still have an ellipse to form the lid.


  [image: ]


  But still there's a problem. A close look at the join between the curved rectangle and the lid shows a thin line showing through from the canvas or objects below. Inkscape uses “anti-aliasing” when it draws your objects. This tries to approximate edges that don't fall precisely on pixel boundaries by drawing a thin, translucent line to give the visual impression of a smooth curve. Usually it works well, but when two such boundaries meet it can lead to a slight gap where you don't really want one.


  There are a couple of solutions to this anti-aliasing issue: we could add a stroke to one or both of the objects to cover up the gap, but that's not always appropriate and doesn't help if the problem objects already have strokes; alternatively we could avoid relying on our objects perfectly abutting one another by making one of them overlap the edge of the other. In this case we don't reallyneedthe rectangle to have a curved top – we already had the visual effect we were looking for with the ellipse sitting on top of the rectangle.


  Let's CTRL-Z back to our straight-topped hat. It may seem that we've gone round in circles, but, along the way, you've learnedabout Path > Difference, the visual issues that anti-aliasing can sometimes cause, and the fact that sometimes it's better to draw something thatlooksright, even if its underlying structure isn't as pure or correct as you might like. Before finally reassembling the hat it might be worth adding some creases and crumples using the path tools from last month:


  
    [image: ]

  


  While you were in the Path menu looking for Union and Difference, you probably noticed the other entries grouped alongside them: Intersection, Division, Exclusion and Cut Path. Together all these form the “Boolean” path operations – named after 19thCentury mathematician George Boole who formulated the rules for combining binary data that underlie these operations. They all require two objects (though Union can work with more than two), with the result usually differing based on which of the objects is higher in the stack. The following table demonstrates the effect of applying each of these operations to an overlapping square and circle, and shows the difference in results depending on which of these objects is on top of the other (in the case of Division and Cut Path the resultant objects have been separated slightly to make it easier to see the effect of these operations):


  
    
      
        	Original Objects
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        	Union
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        	Difference
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        	Intersection
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        	Exclusion
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        	Division
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        	Cut Path
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  With a bit of practice these Boolean operations will allow you to produce complex paths from a few simple shapes. They provide a fast way to produce rough initial outlines that you can then tweak with the node tool into something more refined. But don't dismiss them solely as a blunt instrument for coarse construction work: they can also be used to sculpt and shape with the precision of a scalpel.


  
    Mark has been using Linux since 1994 and uses Inkscape to create two webcomics, 'The Greys' and 'Monsters, Inked' which can both be found at: http://www.peppertop.com/
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