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HHOOWW--TTOO
Written by Luca De Marini

Well we all know one of the biggest lacks of The Gimp is that is misses a good number of plugins. Photoshop is the one software
everyone loves and uses when they have to apply any sort of mutation/transformation to its images, or when they have to create
outstanding graphics with the help of well projected plugins. For Photoshop there are hundreds of plugins around. Is this a problem for
The Gimp? Not at all.

UUSSEE PPHHOOTTOOSSHHOOPP
PPLLUUGGIINNSS IINN GGIIMMPP

M
any of you may not know
it, but GIMP supports a
large number of

photoshop plugins, both in the
Windows and Linux versions,
thanks to this wonderful tool
called PSPI. Now, let’s see how to
use it and what we can do with
our new toy; paying nothing, of
course!

Getting Started

First we need to install WINE on
our Linux box (In Ubuntu, look for
the WINE package in Synaptic),
then we’ll need GIMP and PSPI, of
course. We also need at least one
Photoshop plugin. To get started
and I downloaded two plugins,
one commercial and one
freeware. The first one is Designer
Sextet from the company Flaming

Pear and for the second plugin, the
freeware one, I’ve chosen
Caravaggio from Xero Graphics.

Installing PSPI and
Photoshop plugins

Now it is time to install PSPI on
your GIMP. The following is an extract
from the PSPI site:

'The Linux packages include three
files: README. linux pspi, a small
shell script pspi. exe. so, the binary
that wine runs'

Copy pspi and pspi.exe.so to your
personal GIMP plug-ins folder,
typically ~/.gimp-2.2/plug-ins .

When you run GIMP it will issue a
warning “wire_read(): error” as
pspi. exe. so can’t be started directly.
(The pspi script can, though, and is

from GIMP’s point of view a GIMP
plug-in.) This warning is
harmless (GIMP just ignores that
file then), but if you want to
avoid it, move pspi.exe.so
somewhere else and modify the
pspi script to point to its new
location instead.

After starting GIMP, go to the
Xtns:Photoshop Plug-in Settings
and enter the folder where you
are going to keep the 3rd-party
Photoshop plug-ins (.8bf files)
that you want to use in GIMP.

Preferably you should use an
empty folder for this, and then
install (copy) Photoshop plug-ins
there one by one, verifying that
each works. It isn’t really useful
to rush and install a great deal of
Photoshop plug-ins at once and

https://www.gimp.org
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assume they all will work under
pspi.

So I did what they wrote in the
instructions and also copied my
freshly downloaded PS Plugins to
a folder in my home that I called
~/.gimp-2.2/psplugins.

Remember that this GIMP folder
we are referring to is a hidden
folder, therefore, you’ll have to
set your file browser so that it
shows hidden files. In my case, I
use GNOME and Nautilus. I can
see hidden files by using the
Nautilus menu View > Show
hidden files.

Setting The GIMP UP

As the guide says, I start GIMP
and it hangs up for some seconds

analyzing the newly installed plugin:

But once
GIMP is
loaded I get
no error
message as
expected
(The PSPI
guide
suggested

that an error may have occurred but I
didn’t see any). All works fine for
now. Proceeding with the settings, I
open the GIMP Menu Xtns >
Photoshop Plug-in Settings and this
window shows up:

Hit the New button (In my
screenshot it is the white sheet of
paper with an orange star over it, on
the upper left corner of the above
screenshot) and choose the path
where you put your Photoshop

plugins. In my case we saw that
it is /home/darkmaster/.gimp-
2.2/psplugins.

Push the OK button and a
message will appear warning
you that the new plugins will be
loaded next time you restart The
GIMP.

Testing the new PS Plugins

To complete the operation I
close and then reopen The GIMP.
Even now I don’t get any error
message. I then load an image
from my HDD and then click on
the Filters menu. The plugins are
at the bottom of the menu.
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Let’s test them! Will they work?
I start with Flaming Pear >
Aetherize and… wow it works!
Here’s a screenshot!

Now it’s Caravaggio’s turn and
wow, it works too! Another
screenshot for the press:

This is the result of applying the
Caravaggio filter (right)

Now doesn’t that look like a real
painting? This Caravaggio plugin
is excellent and it’s freeware.

Conclusions

So I tested two random Photoshop
plugins from around the net and two
of two worked. Guess there’s a very
high compatibility thanks to Wine
getting better and better with each
release.. What can I say now? Enjoy,
and say goodbye to one of the most
deprecated defects of GIMP, the lack
of good and professional plugins! If
you have the money, you can buy
and use serious plugins like those
from Alien Skin in Linux with The
GIMP and PSPI now!

Rating and Credits

Ok, it's not a review but none
the less I rate this PSPI extension
for GIMP as a 5 out of 5, it does
what it promises to do and it
adds vital functionalities to The
GIMP.

A big thank you goes to the
WINE project, PSPI team and to
GIMP creators.

For more PSPI info:

http://url.fullcirclemagazine.org/1fa7e2

http://url.fullcirclemagazine.org/1fa7e2
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HHOOWW--TTOO UUSSIINNGG  GGIIMMPP  --  PPaarrtt  11
Written by Ronnie Tucker

F
irst, let's open GIMP, and 
have a quick look at its 
layout. Please note that a 

first load of GIMP may look 
slightly different from my layout 
(below). First I will briefly discuss 
the GIMP layout.

On the top left we see the tools, 
and on the bottom left we see the 
options for the chosen tool 

This series of tutorials, based on GIMP 2.4.2, will not cover every square inch of GIMP, since that would fill a book (and indeed has 
already filled several), but, by the end, you will be proficient enough in GIMP to create anything from simple web banners to large 
posters suitable for professional printing.

(Paintbrush, in this case). At the top 
right are tabs for Layers, Channels 
and so on, and at the bottom right 
are tabs for Brushes among other 
things. GIMP has a very flexible 
layout system where you can drag 
and drop items from place to place. 
For example, if I want to have my 
Layers 
presented on 
a separate 
window, I 
can click on 
the Layers 
tab (top 
right, shown 
right), and 
drag it out to 
my desktop.

If I want to have the Layers display 
back where it was, I click and drag 

on the word 
'Layers' on the 
window, and 
drag it back to 
the top right 
(left).

You can 
do this 
with 
anything 
you like - 
so feel free 

to configure your layout to 
whatever makes you most 
comfortable. If, by accident, you 
close any of your windows, and 
need to get it back, click on File 
> Dialogs and then the item you 
want shown - or hidden for that 
matter (above).
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Let's create a new image. In the 
main menu, click File > New. 
Before we go any further, let me 
explain what some of these things 
do.

At the top of the window 
(above), where it says 'Template', 
we can choose from a variety of 
different pre-configured sizes. 
Click the drop down menu and 
choose 'A4'. Below that is 'Image 
Size'. This is now set to what 
we've just chosen, A4, so there's 
no need to alter these values just 
yet. To the right of the 'Height' 
value is a measurement type. At 
the moment, mine is set to pixels 
but with a click of the drop down 
menu I can change it to 
millimeters if I want. Below the 

width and height are two small 
boxes. Looking closely at the icons 
on the buttons should help you 
guess that the one on the left is for 
portrait (a vertical image) and the 
other for landscape (a horizontal 
image). For the moment, I'll keep it 
on portrait. A brief summary of your 
chosen options are to the right of 
these two buttons. Lets click 
'Advanced Options', it reveals more 
choices.

First, we have X and Y 
Resolution values. These specify 
how detailed your image will be. 
This is also known as Dots Per 
Inch (DPI), and is crucial in 
printing. Professional print 
houses will usually demand at 
least 200dpi, but mostly 300dpi. 
Near the values you can see a 
small icon which is links in a 
chain. In my image, they are 
linked - meaning that changing 
the X value will change the Y 
value automatically; clicking the 
icon will unlink them and allow 
different X and Y values. If your 
icon shows the chain links as 
open, then you will want to click 
it to have them as shown in the 
image above. For just a basic 
test image, change the X or Y 
value to 100. Next is 'Color 
Space'. I only have two options: 
'RGB Color' or 'Grayscale', so I 
am keeping it at 'RGB color'. 'Fill 
With' lets you choose a starting 
color for your image. Finally, 
'Comment' something that will 
be saved as part of your GIMP 
file. This could be anything from 
copyright information to your 
contact details.
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With my options set, I click OK.

So now I have a fresh image to 
work on - but how do you work on 

an image? We'll get to that in 
more detail later, but for now I 
will do a quick run through of 
some of the more important tools.

As you click on each tool (right), 
the 'Tool Options' (below the 
tools) will change. Each tool has 
its own set of options - which I 
won't go into just now, but play 
around with these options, 
because that's how you'll learn 
more!  is Editor of  

magazine, a proud Kubuntu user, and 
part-time artist whose gallery of work 
can be seen at www.RonnieTucker.co.uk.

Why not give GIMP 2.4 a 
try? Available for Linux, 
Mac & Windows

Check your package manager 
for easy GIMP installation or 
download GIMP from:

www.gimp.org

Windows: www.gimp.org/windows

Mac: www.gimp.org/macintosh

http://www.RonnieTucker.co.uk
http://www.gimp.org
http://www.gimp.org/windows
http://www.gimp.org/macintosh
http://www.gimp.org
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HHOOWW--TTOO UUSSIINNGG  GGIIMMPP  --  PPaarrtt  22
Written by Ronnie Tucker

C
olor correction (or 
adjustment in some cases) 
is probably more associated 

with photography than anything 
else -- so, let's take a photograph, 
and correct any color problems it 
may have.

Above is the original photo. 
First, we will use GIMP to 
automatically correct the image; 

This month, we will focus primarily on colors, but first let me say that GIMP (like Photoshop) has many ways of achieving the same result. 
So, although I may show you one way of accomplishing a task, you can be sure there are several other ways of getting that same result.

then we will change it manually. To 
open an image file, we go to File > 
Open, and choose the image we 
want to manipulate. So, now that we 
have our photo open in GIMP, we go 
to the menu and choose Colors > 
Levels.

This window 
(right) allows 
us to do many 
complicated 
things, but now we'll just click the 
'Auto' button. Voilà! One color-
corrected photo (right).

Satisfactory corrections are 
not always so easily achieved. If 
an item in the photo is too 
bright, for example, GIMP may 
think it should be white. So, 
GIMP makes it white, adjusts the 
rest of the photo accordingly, 
and presents an awful result. 
Yet, in most cases the Auto 
feature gives a satisfactory 
result. When it doesn't, then 
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manual corrections should be 
applied.

Before you make manual 
corrections, you need to know 
how images are colored. In 
painting, the three primary colors 
are the red, blue, and yellow 
pigments. From these, any other 
color can be created. Digital 
images, however, are made 
(essentially) from light, and their 
three primary colors are the red, 
green and blue wavelengths, 
commonly referred to as RGB. 
Don't believe me? Click (or 
display) the Channels dialog, and 
you'll see three items -- one red, 
one green and one blue.

These three 'channels' make up 
the colors in your image. Try 
clicking the little eye icon beside 

each layer, and you'll see what the 
photo looks like without one (or 
more) basic colors. So, in essence, a 
badly colored photo will have a 
combination of too much (or not 
enough) red, green or blue.

Click (or display) the Dialogs > 
Colors tab, then click the Triangle 
button:

Above is the digital equivalent of 
the artist's color wheel (circle with a 
triangle inside) with the three 
primary colors being at each point of 

the triangle, blending in to one 
another around the circle -- with 
dark to light being represented 
by the triangle. Click a color on 
the 'wheel', and the triangle will 
point to it. Now, click inside the 
triangle to get a lighter or darker 
version of that color. Play with 
this for a while to become 
familiar with where the colors 
are and how to get the ones you 
want -- we will be using this later 
when we need to create or pick 
a color.

Let's look through some of the 
color options in GIMP to see how 
they can affect our image. Go to 
the Colors menu, and choose 
Color Balance (below).
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This window will let you fine-
tune the colors in your photo. It 
can alter the colors in each of the 
three main levels: shadow, 
midtone and highlight. Select 
Shadows, Midtones or Highlights, 
and move the sliders to see how it 
affects your photo.

If you don't see the photo colors 
change, check to make sure the 
box beside 'Preview' is ticked. If 
you don't want to keep those 
color changes, simply click 
'Cancel', and your image will 
return to normal. You can also use 
the Edit > Undo feature.

Colors > Colorize will allow you 

to tint the entire photo with a 
particular color. This is most often 
used to give a photo a 'sepia tint' -- 
which makes the image look old and 
degraded. Rather than give you a 
red, green and blue slider, this 
window gives you a 'Hue' slider -- 
which goes from red, through to 
green, to blue, and back to red. 
Tinker with the sliders until you get a 
nice orangey-brown color, and you'll 
see what I mean about the sepia tint.

Colors > Brightness – Contrast will 
let you simply brighten or darken the 
image. This can come in handy for 
simple effects. If I brighten the image 

quite a bit, and slide the contrast 
up, I can make the dull original 
image look like it was taken on a 
scorching sunny day (which it 
definitely wasn't!).

We've already looked at 
Levels, but let's look into it a bit 
more. Click Colors > Levels, and 
you'll see that familiar window -- 
yes, it's the one with the magic 
'Auto' button -- but this time let's 
focus on the sliders below the 
graph. The black, grey and white 
sliders can move left to right, 
and represent the shadows, 
midtones and highlights, 
respectively. They allow you to 
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 is Editor of 
 magazine, a proud Kubuntu 

user, and part-time artist whose 
gallery of work can be seen at 
www.RonnieTucker.co.uk.

manually color-correct the image. 
The 'Output Levels' is almost like 
a brightness control, but with 
three sliders for the shadow, 
midtone and highlights. At the top 
of the window is a dropdown 
menu which says 'Value' -- you 
can click that and select one of 
your red, green or blue channels 
to fine-tune. This is quite a 
powerful window, so play around 
in there and get familiar with it. 
And remember: if you don't see 
your image updating as you move 
a slider, tick the 'Preview' 
checkbox.

Colors > Curves is similar to the 
Levels window (which we just 
looked at), but uses curves, 
plotted on a graph, to give more 
control over your colors. Again, at 

the top of the window is the 
dropdown menu, which lets you alter 
the image as a whole, or just alter 
one of the color channels. To edit the 
curves, you click on the curve (to 
create a point), then move the point 
up, down, left, or right, to alter the 
colors. The most basic color 
correction in the curves window is 
the 'S-curve' -- where you make an 
'S' shape with the curve. Again, this 
gives pretty much the same result as 
the Color > Levels 'Auto' button.

Color > Desaturate will remove all 
color from your photo, leaving you 
with a black and white image. You 
have three options before it removes 
the color, each giving you slightly 
different results, so it's best to try 
each to see which you prefer. As 
ever, try an option; if you don't like it, 

use Edit > 
Undo to 
revert back 
to the 
original.

Color > 
Invert will 
give you the 
negative of 
the photo, 
just like you'd 

get with traditional camera film. 
Clicking Color > Invert again will 
return the image to normal.

There are many other items in 
the Color menu, but the ones I 
have mentioned are the most 
important ones, and probably 
the most used.

http://www.RonnieTucker.co.uk
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HHOOWW--TTOO UUSSIINNGG  GGIIMMPP  --  PPaarrtt  33
Written by Ronnie Tucker

I
n the previous article, I showed 
how to alter the colors of an 
entire image. Now, I'll describe 

how to alter selected parts of an 
image, while leaving the rest 
untouched. This is done using the 
selection tools (below).

From left to right, the first two 
buttons select a rectangle or an 
oval, respectively (hold Shift for a 
perfect circle). The third button 
opens a free-selection tool for 
outlining selected portions on an 
image. Try it. Click the icon, then 
left click your mouse, hold it, and 
draw around an item. When you 
release the mouse button, you'll 
see a region 
selected for 
manipulation 
(right).

Now, all 
modifications 

will affect only the selected region. 
This helpful method is, however, not 
very good for precise selections.

Next is a fuzzy selection. When a 
dot is clicked, this selection enlarges 
until it encounters a different color. 
The enlargement can be fine-tuned 
by editing the Threshold number in 
the tool options (below the icons). 
By holding down Shift, more colors 
can be selected to widen the 
selection. Once a 
selection has been 
made, further 
modifications 
apply to it alone 
(right).

Next is the color-selection tool. 
It is similar to the fuzzy 
selection, so lets move on to the 
last (for now): the scissor 
selection tool. This is more 
precise than the freehand tool 
discussed above, but it only 
works well on items with definite 
outlines. The method is this: 
click to start selecting, and put a 
point on the outline; click again 
to put another point further 
along the item's outline; the 
scissor tool then tries to 
determine the item's perimeter 
(above); continue clicking on the 
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image's outline; more added clicks 
(and points) increase the 
selection's precision; the last click 
should be back at the starting 
point. Before committing to a 
selection, any of the points can be 
clicked and dragged to fine-tune 
the outline.

To create the actual selection, 
click inside the completed loop 
(shown below).

To remove a selection, go to the 
menu and click Select > None.

But how do you make 
a precise selection? Pen 
tool (icon shown left).

The pen tool permits more 
precise curve creation than does 
the scissor tool. First, click the pen 

tool to open it. Then, click around the 
outline of the desired selection, as 
was done with the scissor tool. But 
unlike the scissor tool, the first point 
can not be re-clicked as the last of 
the points to close the selection -- so 
just click near it. Don't worry if a 
point is slightly out of place. After 
inserting all the points, any point can 
be clicked and moved into place 
(below).

Now, the points can be edited to 
produce nice curves between them. 
Hold down the Ctrl key, click on a 
point (keep the mouse button down) 
and move your mouse. A line will 
then come out from that point and a 
curve will begin forming between the 
chosen point and one of the points 

on either side of it (below left).

Each point can have two lines 
coming from it to form a curve 
(above right). So, click on the 
point, hold down Ctrl, and drag 
out the second line. Now you will 
have a curve.

The initial point can still be 
moved, but clicking and 
dragging a box at the end of a 
line can fine tune a curve, or 
create a curve leading in (or out) 
from a point, or form a straight 
line on the other side -- this 
latter was useful in the present 
example where the steps meet 
the doorway.

When all the points are in 
place, and the curves are 
satisfactory, tell GIMP to select 
the area. To do this, click the 
Paths tab (beside your Layers 
tab). If it's not there, display it 
by clicking Dialogues > Paths. 
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The just-
created path 
is shown in 
miniature in 
the Paths 
tab. Right 
click on its 
name and 
select 

.

To hide the path to work on the 
selection, or to show it again, 
click the eye icon.

Combining the selection tools 
with the color-correction items 
can be amazingly powerful, 
especially if all that is needed is 
to color-correct family photos or 
holiday snaps.

 is Editor of 
 magazine, a proud Kubuntu 

user, and part-time artist whose 
gallery of work can be seen at 
www.RonnieTucker.co.uk.

Sometimes, 
even more 
precision is 
needed when 
creating 
selections. The 
zoom tools are 

very handy for this. At the bottom of 
the image window is a drop-down 
menu (above) that gives quick 
access to a variety of settings for 
zooming in or out of images.

The Zoom tool (left) is also 
accessible from the toolbox 
on the left.

With the Zoom tool, clicking on an 
image will zoom in (holding Ctrl and 
clicking will zoom out). In addition, 
holding a click permits drawing a box 
around just a portion of an image 
(below) for zooming (above right).

Don't forget to combine tools. 
For instance, to select a piece of 
an image, zoom in first, then go 
for the tool of your choice.

http://www.RonnieTucker.co.uk
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HHOOWW--TTOO UUSSIINNGG  GGIIMMPP  --  PPaarrtt  44
Written by Ronnie Tucker

T
his month, we will discuss 
probably the most powerful 
feature of GIMP: Layers. If 

you can grasp the concept of 
layers and work them to your 
advantage, you can create 
anything.

First, let's make sure we have 
our layers window showing and 
ready to use.

If you don't 
have the layers 
tab available to 
you, click File > 
Dialogs > 
Layers in the 
main menu.

Here's how layers work: think of 
each layer as a transparent sheet 
of plastic. The idea is that you 
draw all your different things on 
separate sheets of plastic then 
stack the plastic sheets in a 
particular order to achieve your 
result. Similar to how an animator 

works. The background is on one 
sheet, the character on another 
sheet and any foreground details on 
a third sheet. Stack them properly 
and you will have the character with 
the foreground on top of it. Same 
with GIMP layers.

If you open an image in GIMP, and 
display the Layers tab (or window), 
you will see that your image is 
displayed as a single layer with the 
name 'Background'.

Below the list of layers, you 
will see several icons. Think of 
these as shortcuts to menu 
options.

From left to right they are: 
Create New Layer, Raise Layer, 
Lower Layer, Duplicate Layer, 
Anchor Layer and Delete Layer. 
Those are pretty self explanatory.

Using the selection tools from 
last month's article, I'm going to 
use the circle tool to select the 
planet.
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And from the menu choose Edit 
> Copy, then Edit > Paste

You can see that I now have a 
new layer (named 'Floating 
Selection'), but it needs to 
become permanent, so click the 
New Layer icon. It now has a 
preview icon, and is automatically 
renamed to 'Pasted Layer'. If you 
want to rename a layer, just 
double click on its name, and 
enter a new name, followed by 
the Enter key.

If I hide the original 'Background' 
image, you can see that the 
selected, copied and pasted planet is 
now on its own, completely separate, 
layer. Our first new layer!

 You can copy from one image 
and paste in to another image.

Don't worry about the two-tone, 
chess-board pattern in the 
background. It's just there to signify 
complete transparency.

So now, with the planet selected, 
I'll click the Duplicate Layer icon to 
give me a second planet. To move 
the layers, you use the Move tool, 
select the layer you want to move, 
then click and drag it into place. I'll 
use some of our color altering 
techniques to change the color of 
one planet to make it easier for you 

to differentiate between the two 
planets.

: If you have two images 
open, you can drag and drop 
layers between them!

Let's create 
a new blank 
layer. A new 
layer is 
created 
above the 
layer you are 
currently on, 
so I'm going 

to select my (hidden) 
Background layer and then click 
the New Layer icon. Up pops the 
New Layer window (above).
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From top to bottom: We give 
the layer a name (preferably 
something descriptive! I'll call 
mine 'Space'); Width and height 
we won't bother with just now, as 
we want the layer to be the full 
size of the image; Layer Fill Type 
we will leave as transparent. You 
can choose white, or one of your 
foreground or background colors 
if you wish. Now, I'll make my 
foreground color black and fill my 
'Space' layer with black color.

So 
now I 
have 
two 
planets 
out in 
space. I 
don't 
need 

the original image any more, so I 
select that layer and click the 
Delete Layer icon.

So what if I wanted the orange 
planet in front of the blue planet? 
I click the orange planet layer, 
then click the Raise Layer icon.

Think of your layers as going 
from bottom to top. So first, GIMP 

lays down the 'Space' layer, on top of 
that it puts the blue planet layer, 
and, finally, on top of that the orange 
planet layer.

When saving, you want to make 
sure you save your image in the 
GIMP format (XCF). The next time 
you load the image you will still have 
all the layers intact for manipulation. 
Saving as JPG or PNG will flatten the 
image and you will lose your layer 
information, so always keep an XCF 
version! To save, 
you click File > 
Save As from the 
menu, and make 
absolutely sure 
the filename 
ends in .xcf 
(right).

Many effects can be applied to 
layers to make them even more 
powerful. Try moving the Opacity 
slider (above the list of layers).

Each layer can have one 
'mode' applied to it. These are 
listed in the drop-down menu 
above the Opacity slider. Have a 
play with these effects. You can 
get some nice looking accidents 
with these modes.

Above 
is the basics of layers. No doubt, 
we'll talk more about them in 
future articles, but, for now, 
have a play with copying and 
pasting, raising and lowering 
layers, and moving them to 
create a pleasant composition.

http://www.RonnieTucker.co.uk


15

HHOOWW--TTOO UUSSIINNGG  GGIIMMPP  --  PPaarrtt  55
Written by Ronnie Tucker

T
his month, we will focus on 
sizes. GIMP can use several 
types of measurements for 

images. Create a new image by 
clicking File > New and let's 
examine some of the 
measurement types.

If you can't see the X and Y 
resolution section, click the 
Advanced Options text below the 
Image Size and orientation.

Beside Image Size, you see width 
and height values. To the right of the 
height value you see a drop-down 
menu. In my case it is showing 
'pixels'. Put simply, pixels are the 
small dots that make up your display. 
So in this case the image would be 
640 pixels (or 'display dots') wide. 
Click the drop-down menu to see the 
other available options. Now, try 
clicking on inches.

See the 
values change? 
It is now only 
8.889 wide. 
Why? Because 
we are now in 
inches. 8.889 
inches wide is 
the same as 640 
pixels wide.

Why have these different 
measurements? If you were 
working on a banner which was 
to be used on a web site, for 
example, then you would need 
to create your image in pixels, 
say 400 wide by 50 high. But for 
print work, your image may need 
to be 8 inches wide by 12 inches 
high. Switch between 
measurement types as needed.

Just below the Advanced 
Options text is the X and Y 
resolution. This is, by default, set 
at 72 pixels per inch, also known 
as dots per inch (DPI), and is 
sufficient for most computer 
display and web work. Think of 
DPI as being detail. The more 
dots per inch, the more detail 
you can put in the image. Be 
aware, however, that a high DPI 
can slow some PCs down and will 
result in much larger file sizes. 
For print work it should be set to 
about 300, but check with 
whoever is printing the image 
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beforehand. If in doubt, use 300 
DPI.

So, with our new image (below), 
let's move on to rulers.

You'll notice that, at the top and 
the left side of the new image, 
there are rulers displaying the 
current measurement type, inches 
in my case. This allows for precise 
measuring and placement of 
items within the image. If I need a 
circle to start one inch down the 
page and one inch from the left, 
imagine how much trial and error 
it would take to get it absolutely 
right. It'd be almost impossible! 
But with rulers, we can be much 
more precise. Click on the top 
(horizontal) ruler and drag down 
onto the image.

You'll see a horizontal line (or ruler) 
appear on your image (above). This 
ruler does not damage your image in 
any way, it is merely a guideline and 
can be moved by clicking and 
dragging on it with the movement 
tool. Drag it back to where it came 
from to remove it completely. You'll 
notice in the information line below 
the image tells you exactly where the 
ruler is on the page (vertically in this 
case). Drag from the left (vertical) 
ruler on to the page to get another 
ruler one inch from the left (below).

Where those 
two rulers 
converge is where 
you would start 
dragging your 
circle out from 
(inset).

I trust GIMP, I really do. But 
let's play Devil's Advocate and 
double check, using a different 
tool, to make sure there really is 
one inch between the ruler on 
the page and the edge of the 
image. For this, we need the 
Measurement Tool (below left).

This tool is like a tape 
measure. You click to 
create a start point, and 
click to create an end 

point (below). Between the two 
points, a red line is drawn. In the 
information bar (again, below 
the image) you'll see some 
numbers. These represent the 
length of the line, the angle of 
the line, the width of the line 
(from start point to end point) 
and the width of the line (again 
from start to end).



17

 is Editor of  
magazine, a proud Kubuntu user, and 
part-time artist whose gallery of work can 
be seen at www.RonnieTucker.co.uk.

And from my measurement line 
I can see that the ruler is indeed 
one inch out. Good job GIMP! 
Clicking any other tool will 
remove the measuring tape from 
the screen.

One last tool to cover 
in this section is the 
crop tool (left), which 
comes in handy for 

keeping a single, rectangular, 
piece of an image.

Select the crop tool, then click 
and drag a box around the area 
you wish to keep (below).

This area can be moved by 
clicking and dragging inside the 

box, or resized by clicking and 
dragging on one of the inside edges 
of the box. Notice how the area 
outside the box darkens to focus 
your attention inside the box. Use 
the crop tool to remove uninteresting 
areas around photographs. Click 
inside the box area to crop the image.

See how cropping the image has 
forced you, the viewer, to focus on 
the patio step. Previously, you may 
have been focusing on the paving 
stones. If something is unnecessary 
in a photo, crop it out.

Help keep the 
bugs at bay.

Join Launchpad.net

http://www.RonnieTucker.co.uk
http://launchpad.net
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T
his month, we move on to 
some more advanced 
features of GIMP. This group 

of features is primarily used in 
photographic touch-ups (also 
known as air-brushing) to either 
repair or enhance an image.

Let's do the easy photo repair 
first - the infamous red-eye. This 
occurs when the camera's flash 
highlights the inside of the 

eyeball, causing 
the black pupil to 
look red.

The easy way to 
fix red-eye is to go 
to the Filters > 
Enhance > Red-Eye 
Removal menu. 

This will give you a preview of the 
image, and a threshold slider to fine-
tune the red-eye removal.

But wait, it's altering parts of the 
image that aren't her pupils! This is 
because her lips are also red. Really, 
all that GIMP is doing is changing the 
red pixels to black. So, we need to be 
more selective with this image. Use 

the rectangular selection tool to 
draw a box around both her 
eyes; then try the Red-Eye 
Removal filter.

Much better. Just watch that 
you don't overdo the threshold 
slider lest you darken her 
reddish eyebrows.

HHOOWW--TTOO
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Another way of doing red-eye 
removal is to simply create a new 
layer, draw a black dot for each 
pupil, and then multiply the dots 
layer with the original image until 
it looks good. But the Red-Eye 
Removal filter is a nice, quick, 
shortcut.

Our next 
volunteer is 
a celebrity 
who is, in 
this photo, 
looking a 
little bit 
'worse for 
wear' let's 
say. Let's 
help her out; 
she needs to 

have those nasty spots removed.

The Healing tool will let 
you select a spot (no pun 
intended!) on the image 
to act as a reference 

point. GIMP will then give its best 
guess as to what should be under 
your brush - taking into account 
the reference spot. First, click the 
Healing tool icon. You'll see two 
crossed elastoplasts beside your 

pointer with a 'no entry' symbol 
(circle with a diagonal line through 
it). This means you have no 
reference point as yet. Hold down 
CTRL, and the 'no entry' symbol will 
vanish. Click somewhere near the 
blemish then release CTRL. You will 
now see a circle with a cross inside it 
marking your reference point.

Now, simply 
draw over the nearby blemish, and, if 
the reference point is good, the 
blemish will vanish. Sometimes you 
will need to undo what you did with 
the Healing tool, and try again, but 
trial-and-error is no bad thing.

And, just like 
any good spot 
removal cream: 
apply as 
necessary:

Now our celeb 
is ready for the 
front page.

Before you 
start 
pointing 
fingers, no, 
that photo is 
not me! It's 
my 
grandfather, 

and the photo was taken in, 
roughly, 1930, so it's a bit tatty 
and needs some touching up.

For this, we could 
easily use the Healing 
tool, but, this time, we 

will bring in the powerful Clone 
tool. It will, like the Healing tool, 
need a reference point, but, this 
time, it will just clone the 
reference point to where your 
brush is - no guess work. So let's 
try it: same idea, you click the 
Clone tool, hold down CTRL, click 
on the source (near a crack in 
the photo), release CTRL, and 
you're ready to paint out the 
cracks.
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And, just to prove a point, try the 
Healing tool on some photo cracks. 
It'll probably work just as well, but 
it's always better to have a Plan B!

http://brainstorm.ubuntu.com

Think of Wine as a compatibility layer 
for running Windows programs. 

, as it is a completely free 
alternative implementation of the 
Windows API consisting of 100% non-
Microsoft code.

The Wine Application Database 
(AppDB) is where you can get 
information on application 
compatibility with Wine.

http://appdb.winehq.org/

http://www.RonnieTucker.co.uk
http://brainstorm.ubuntu.com
http://appdb.winehq.org/


14

This month, we'll discuss GIMP's 
many Filters, and touch briefly on 
the Xtns (extensions) menu. Both 
menu items provide quick access 
to dozens of special effects. The 
main difference between the two 
is that Xtns items will create a 
new image with the specified 
effect. Filters can be applied to a 
whole image, or a selection of an 
image.

The Xtns menu is beside the File 
menu. You'll see items like Module 
Manager and Script-Fu, but our 
interest lies in the items called 
Buttons, Logos, Misc, Patterns, and 
Web Page Themes. Another limitation 
of these extensions is that most, if 
not all, are not interactive. In other 
words: guess-work, trial-and-error, if 
you will.

Click Xtns > Logos > Chrome.

A window will appear 
presenting you with the available 
options for this Chrome 
extension.

As you can see, there are not 
many options. You can choose a 
font style and size, a background 
color, and some text to apply the 
extension to. I've picked a 
chunky font, and used the text 
'Full Circle', and here's the result:

HHOOWW--TTOO
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Even though I had two yellow 
colors selected, it still gave me a 
black chrome effect. What if I 
want to alter the text? Maybe 
bring the letters closer together? 
I'm afraid not. The thing with 
extensions is that they are pre-
made scripts. To fine tune the 
effect, you would need to go in to 
your /usr/share/gimp/2.0/scripts 
folder, copy the script, then edit it 
in your favorite text editor. Not 
very user friendly. This is one 
reason why I never use them. 
However, I wanted to briefly 
introduce them, and then ignore 
them. Let's move on to the more 
useful, and visual, Filters.

I'll use 
the 
photograph 
shown left 
as my 
starting 
point.

Let's jump right in and apply a 
filter to the whole image. Click 
Filters > Blur > Gaussian Blur.

Just like with extensions, a 
window will appear. This window 
is your preview and controls for 
the selected filter.

At the top of 
the window is a 
preview, which 
can be turned 
on, or off, using 
the check box 
below the 
preview. Below 
that you have 
the Blur Radius for applying how 
much blur you want to the image. 
Beside the numbers you'll see a 
small three-link chain icon - this links 
the horizontal value with the vertical 
value: change one and the other will 
change too. Unlinking the values 
gives you more of a motion blur (as 
either horizontal, or vertical, will 
have more blur than the other), but, 
for now, I'll keep them linked, and 
the values at seven. You can specify 

which measurement type you 
want the numbers to refer to 
(inches, millimeters, pixels, etc.). 
I prefer pixels. Then there are 
two types of gaussian blur, but 
we won't alter them for now. 
Next, I click OK to apply the 
effect.

One blurry photo. Now let's 
use our selection skills to select 
just a part of the image to blur. 
I'm going to use the path tool to 
just quickly make a selection to 
blur.
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Now, when I apply the blur, it 
will affect only the selected area.

Blurring only the background 
(and not the door frame) has 
given it a look of depth, almost as 
though the camera is focused on 
the door frame. Let's play with a 
few more filter effects.

Filters > 
Enhance is 
where we 
used the Red 
Eye Removal 
in last-

month's article. In this set of 
filters, I often use Sharpen. This 
filter has one slider which lets you 
sharpen the image (or selection). 
This is usually one of the first 
effects that I apply to an image to 

correct it.

Filters > 
Distorts > 
Emboss is 
useful for 
picking out 
detail that you 

can't see initially.

While Ripple 
will let you 
make a 
selection look 
almost like it's 
made of liquid.

Easily one of 
the most used 
(and abused) 
effects applied 
in the media 
today is the 
drop-shadow. 

Found under Filters > Light And 
Shadow > Drop Shadow, it will take a 
selection (or text layer, anything 
really) and put a shadow under it. It 
can really help lift an item off the 
page, but it can look very cliché. This 
is also one of the few filters that has 
no preview. Filters > Light And 
Shadow also has many other 
powerful effects such as Lighting, 

which can help give an image 
atmosphere.

The filters named Artistic will 
try to apply a painterly effect. 
Filters > Artistic > Oilify will try 
to turn your photo into an oil 
painting

There are too many effects to 
list in this short article. The key 
is to experiment with them. Play 
around with them to see what 
they will give you. Don't be 
afraid to give them high or low 
values. Sometimes accidents 
give the best results!

Next month, we will take all 
the things we've learned over 
the past seven months, and 
combine several photographs, to 
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end with a fantastical piece of 
GIMP art. But before then, let me 
just mention Layer Masks.

Normally, when we erase part 
of a layer, it's gone for good. But 
with layer masks we can remove 
parts of a layer - but only visually, 
while the original layer is still 
there, untouched. This is 
invaluable as, later on, you may 
want to reinstate a part of a layer. 
This is possible with a layer mask, 
impossible with the eraser.

Let's say I want to erase the 
steps from my photo. First, select 
the layer that's to be affected, 
now go to Layer > Mask > Add 
Layer Mask.

A window will appear, and 
require an answer. Choosing 
White (Full Opacity) will keep the 
image as is, and let you paint out 

what you want 
to remove. This 
is what I choose 
most of the 
time.

You'll notice 
that, beside the 
chosen layer, a 
new thumbnail 
(a white 

square) has appeared. This is your 
mask. It is pure white at the 
moment, and is completely visible.

Here's (briefly) how masks work: 
white is completely solid, and visible, 
black is completely transparent, and 
the shades of grey in between will be 
semi-transparent. Make sure the 
mask thumbnail is selected, choose 
the paintbrush tool, and use the 
colour black to paint with. If you've 
selected the mask layer, then you 
will be hiding parts of the layer, not 
erasing, hiding. To prove the point, 
right click on the layer mask 
thumbnail, and choose Disable Layer 
Mask.

You will see your layer return 
to its old self. Click Disable Layer 
Mask to enable the layer mask 
again.

Layer masks are a very 
powerful feature, and give you a 
great deal of flexibility by 
keeping your layer always 
available for future alterations. 
Think of it as having your cake 
and eating it. 

http://www.RonnieTucker.co.uk
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In this, the last part of this GIMP 
series, I'm going to create a single 
image using three photographs 
taken from Flickr. Although the 
final image won't fool a 
photographic analyst, its creation 
should help you practice what 
you've learned in the previous 
seven articles. What I've also 
done is recorded, in real-time, my 
thirty-minute creation of the 
image, which you can view on 

Google Videos at:

http://url.fullcirclemagazine.org/c44b86 

First, I grab my three source 
images from Flickr, being careful to 
choose only photographs licensed 
under the 

 license - which allows 
editing of photographs. What I'm 
thinking is that I'll use the sky from 
one photo, a middle-distance from a 
second photo, and possibly a 
foreground from a third photo, either 
that or create some water using 
GIMP filters. I'll post links to the 
source images at the end of the 
article, should you want to follow 
along.

With my three images open, I 
create a new image of the same size 
as the source images. I used the 
Flickr preview images as I didn't want 
to have too many large images open 
while recording the screen, but you 
can use the full-size photographs. In 
the case of a landscape, it's better to 
work from back to front with the sky 
being farthest back, so I draw a very 
rough selection line around the sky of 

my first photograph. I copy that 
selection, and paste it into my 
new image. 

I then decided to use the 
mountain range from the second 
photograph, and selected its 
outline using the Pen tool. Again, 
I copy and paste the selection 
into the new image. 

HHOOWW--TTOO
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From the third photo, I select 
the trees and grass area and 
copy/paste it into the new image. 

To add some depth to the 
image, I created a new layer and 
placed it between the mountain 
and tree layers. I airbrushed in 
some white to act as a fog/mist. I 
also selected the furthest away 
trees and applied Gaussian Blur to 
them. 

I had a fourth image that I was 
going to use, but decided against it. 
Instead I copied the sky layer, flipped 
it vertically, made a selection with 
the Pen tool, and erased parts of it. 
This will have effects applied to it 
and will become water. 

The mountains would also be 
reflected, so I did the same with the 
mountain layer: copy it and flip it 
vertically. 

Before applying a ripple to the 
water, I used a soft-edged brush 
with the eraser to soften the 
outline of the mountain. Then I 
flattened the two layers 
(mountain reflection and sky 
reflection) into one layer and 
applied a ripple to them. 

I darkened the foreground of 
the water using the Burn tool. At 
that point, I realised that I hadn't 
reflected the foreground tree! So 
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I did a quick selection of the 
foremost tree, copy/pasted it to a 
new layer, flipped it vertically, and 
applied a ripple effect to it. 
Thankfully, the ripple filter keeps 
your settings from the last time it 
was used, so the ripple on the tree 
was the same as on the water 
layer. 

The components of the final 
image are now all in place. At this 
point, I began playing around with 
various filters to see if any would 
enhance the image. I tried Lens 
Flare and Sparkle but neither did 
anything effective. I tried the 
Gradient Flare, on a new layer, 
and it gave the effect of a sun, so 
I kept that and played with the 
layer effects to make it blend in 
more. 

http://url.fullcirclemagazine
.org/2fba72

http://url.fullcirclemagazine
.org/8a00d5

http://url.fullcirclemagazine
.org/d31f07

Source Images:

video of the above image being created: http://url.fullcirclemagazine.org/c44b86

http://www.RonnieTucker.co.uk
http://url.fullcirclemagazine.org/2fba72
http://url.fullcirclemagazine.org/8a00d5
http://url.fullcirclemagazine.org/d31f07
http://url.fullcirclemagazine.org/c44b86
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I
n the first of this new GIMP

series, I’m going to try and

show you some intermediate

techniques. In other words,

things that people may think are

possible only with Photoshop. If

you’d like to read more about the

absolute basics of GIMP, then I

refer you back to FCM#12-19.

While I used an older version of

GIMP in those issues, the layout of

GIMP has changed little in the

passing years.

For ideas, I’m using Photoshop

tutorials that are freely available

on the web, and, while not copying

them step for step, applying the

underlying principles of them to

GIMP.

I should also state, for the

record, that I’m using GIMP 2.6. As I

write this, a 2.7 version is available,

but, it is not entirely compatible

with the *buntu family, and trying

to install it can give conflicts.

What we’ll be making is shown

left.

Sources:

Sky -

http://www.2textured.com/index.p

hp/Environment/Skies/skies_0347

YouTube Video showing Pt1 being

made:

http://www.youtube.com/watch?v=

NYFTdbzjubg

The Sky Gradient

First thing we need to do is

create a new image (File > New),

and make it A4 in size, portrait in

orientation, and with an X and Y

resolution of 80. The default X and

Y resolution is 300. That’s for

professional printing, and, it

requires high resolution images as

source material, and can slow down

even the hardiest of machines - so

we’ll go with 80 which is more than

adequate for this tutorial.

Select the ‘Blend tool’

icon (shown left), and,

where it says ‘Shape:’,

choose ‘Radial’ from the drop down

menu. No need to change anything

else for now. For a foreground

color, choose a very pale greeny-

yellow (RGB = 220, 229, 189). For

the background, choose a slightly

faded greeny-yellow (RGB = 133,

151, 81).

Next, left click (and hold) in the

middle of the blank image and

move up to the top middle of the

image. Release the mouse button

and you’ll have a radial fill covering

the entire canvas.

http://www.2textured.com/index.php/Environment/Skies/skies_0347
http://www.youtube.com/watch?v=NYFTdbzjubg
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No, Not The Layers!

Click File>Open, and choose

your sky image. To quickly get the

sky into our main image, we go to

the ‘Layers’ tab and (as shown

above) drag it onto our main image

With the sky now in our main

image, you can close the opened

sky image.

The sky image is quite

high resolution, larger

than we require, so we

need to resize it. Click the ‘Resize’

tool (shown left), and click the sky.

In the resize window that pops up,

you need to make sure that the

little chain link icon is linked. If the

icon looks like a broken chain, then

your sky image will resize

disproportionately and squish.

Make the width of the sky about

300 wide, and click OK. This gives

us some room to play with.

Click the ‘Move’ icon

(shown left). Now, left

click and drag the sky

icon to where you think it looks

best.

TIP: The gradient is one layer and

the sky is another. If we add several

more layers, it’ll get quite

confusing. To make things easier

you can double click on a layer

name and rename it.

Now for some layer magic. With

the sky layer still selected, click the

drop down menu above the layers

and choose ‘Value’.

Color Curve

You’ll now have a greeny sky,

but it doesn’t look very dramatic

does it? With the sky layer still

selected, click Colors > Curves from

the menu. We’re going to create

what’s known as an S-curve. The S-

curve is a great way of quickly color

correcting your photos too. Click

two boxes across and two down in

the grid, and drag your mouse up

and to the left slightly, and two

boxes in and up from the bottom

HOWTO - GIMP: THE BEANSTALK Pt1
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HOWTO - GIMP: THE BEANSTALK Pt1

left of the grid, and click and drag

down to the right.

Which will give you an S-curve

(shown above) which you should

play around with until you get a

nice dramatic sky with good darks,

but not too bright lights.

Let’s finish off this sky and

that’ll do us for this first part of the

tutorial.

Layer Mask

Right click on the sky layer, and

from the menu, choose ‘Add Layer

Mask’ (shown below).

From the window that pops up,

choose ‘White (full opacity)’ and

click ‘Add’. You’ll see a box appear

next to your sky thumbnail in the

list of layers.

That box is a thumbnail of the

layer mask. The idea is that if you

select that layer thumbnail, and

draw in black, you’ll erase parts of

the sky image. Draw over the

erased area with white and the sky

will reappear. This means you can

show/hide parts of the sky - using

the mask - without destroying the

original sky image. We’ll use the

mask to fade the sky into the

background.

Make sure the mask

thumbnail is selected, it

should have a white

outline, and click the “Rectangle

Select’ icon (shown below left).

Left click and draw a box around

the bottom third of the sky.

Now click the ‘Blend Tool’ icon

(that we used at the start of this

tutorial), but make sure the

‘Shape:’ is Linear this time. You’ll

need a foreground colour of black,

and a background colour of white.

With that all set, click and drag just

up from the bottom middle of the

selected area, to just below the top

middle of the selected area, and

release the mouse button.
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Your sky will now magically fade

into the background. And since it’s

a layer mask, the original sky is

untouched. You can right click on

the layer mask and delete it and

the sky will return to its original

state.

Next month we’ll add a piece of

landscape below the sky, and

maybe, just maybe, start growing

that beanstalk. Class dismissed!

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some

great guests on the show, telling

us first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://www.youtube.com/watch?v=NYFTdbzjubg
http://ronnietucker.co.uk
http://podcast.ubuntu-uk.org/


full circle magazine #61 21 contents ^

HHOOWW--TTOO
Written by Ronnie Tucker GGIIMMPP -- TThhee BBeeaannssttaallkk PPtt22

O
K, so, we’ve got our sky

recoloured and fading

into the background;

next, we want to have

a little village below the sky.

Sources:

Village:

http://www.sxc.hu/browse.phtml?f

=view&id=1215281

Tree:

http://alfoart.com/flash/beanstalk

_tutorial/625100_53361668.jpg?ht

tp://www.2textured.com/main.php

?g2_itemId=281

YouTube:

http://www.youtube.com/watch?v

=KTmehu8x2j4

The Village

Bring the village photo into

your scene. How? This is where I

test if you’ve read part one or not.

Same idea: open the village image

and drag it into our main scene.

You’ll probably have to resize it to

about 750 pixels wide, though.

Should you see something like

this, don’t panic

If you look at the list of layers,

you’ll see that the village layer is

sandwiched between the sky and

background images. We need the

village to be at the top of the list.

Simply drag it up above the sky

layer.

Click the move icon, and drag

the village layer down to the

bottom of the image.

We’re going to chop away some

excess trees that are behind the

village to give us a nice landscape.

Selections

The selection tools are some of

the most important tools in GIMP

as they allow you to be as detailed

as you need to be when selecting

an outline. For this, our first big

tutorial, we’ll go with a quick and

dirty selection.

Click the ‘Free Select Tool’

(shown left) and draw around the

treeline keeping only

full trees. Draw out the

side of the image, and

loop back to where you started.

Press the Enter key on your

keyboard to complete the

selection.

You can, of course, go clockwise

if you prefer.

Press the Delete key on your

keyboard, and anything inside that

selection will be removed.

TIP: If you press the Delete key

and the selected area shows black,

then you’ll have to go to the menu,

click Edit > Undo. Right click on the

layers thumbnail, and choose ‘Add

Alpha Channel’. Now you can press

Delete to remove your selection.

This extra ‘Add Alpha Channel’ step

isn’t always necessary.

http://www.sxc.hu/browse.phtml?f=view&id=1215281
http://alfoart.com/flash/beanstalk_tutorial/625100_53361668.jpg?http://www.2textured.com/main.php?g2_itemId=281
http://www.youtube.com/watch?v=KTmehu8x2j4
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You can, if you like, go around

the treeline and tweak it with the

eraser, but for now we’ll cover it up

with a layer mask. You do

remember how to create a layer

mask, don’t you? Yep, right clicking

on the village layer, and choosing

to add a white layer mask.

Use the rectangle select tool to

select the top half of the village

(below left) and, like last time, use

a black and white linear gradient to

fade the top part of the village.

Remember last time

how I spoke about the

layer mask as being

non-destructive? Well,

here’s your chance to try it out. We

created a white layer which was

completely transparent, so choose

a foreground colour of white and

click the ‘Paintbrush’ icon (shown

left).

TIP: If you need to enlarge/shrink

the paintbrush you can use the

square bracket keys (that’s [ and ]).

The idea here (shown below

right) is to (on the layer mask!)

paint white over some of the

foreground trees to remove them

from the fog effect in the

background.

OK, let’s get our whopping

great tree inserted and we’ll finish

up part two.

I’ll show you another quick way

of inserting an image. Click the link

above for the tree source. In your

browser, right click the image and

copy the image to the clipboard.

Go to your main image in GIMP,

and, in the menu, click Edit > Paste

As > New Layer. Voila!

HOWTO - GIMP: THE BEANSTALK Pt2
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You’ll have to resize the layer to

about 600 pixels wide, and move it

down to have the tree roots

halfway down the grassy part of

the village. Clicking resize, and

then on the tree, I’m unlinking the

width and height numbers as I just

want to stretch the tree vertically

to about 650 high.

Like we did with the village, it’s

time to trim out the excess

background, we just want to keep

the tree. Time to click the free

select tool and get to work.

This time we want to keep

what’s inside the selection, so, in

the menu, click Select > Invert and

press Delete. One tree. But I think

I’d like it growing up to the right,

so click Layer > Transform > Flip

Horizontally. I’d also like it to have

a tint of green like the rest of the

image, so click Colors > Colorize,

and move the ‘Hue’ slider until you

get a greenish tint to the tree.

Finally, apply a layer mask to

the tree layer, and select the top

third of the tree and use the blend

tool to fade the tree into the

clouds.

One last thing, your homework

for this lesson: use the

Dodge/Burn tool on the village

layer to paint a shadow from the

tree across the grass.

In the final part of the

Beanstalk image we’ll add some

pizazz to the image.

http://www.youtube.com/watch?v=KTmehu8x2j4
http://ronnietucker.co.uk
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W
e’re almost done

with the beanstalk

image, but I’d like to

add some random

bits and bobs to give it some

pizzazz.

Sources:

Moon:

http://www.sxc.hu/photo/1126941

Stars:

http://www.sxc.hu/photo/1005288

YouTube Video:

http://www.youtube.com/watch?v

=HZcoOx94ox8

Moonshine

Copy/paste the moon image

into the beanstalk scene. I’m

keeping the moon layer at about

150 wide and have flipped it

horizontally.

This time, in the dropdown

menu above the list of layers,

choose ‘Screen’; the black in the

layer will vanish, and the moon will

blend in nicely.

Although, a glow around it

wouldn’t go amiss. We’ll cheat with

the glow and use a filter. Click

Filters > Artistic > Softglow. Move

the sliders until you get something

pretty. I used a high brightness and

glow radius.

The good thing about doing this

in a non-destructive manner is that

you can change anything at any

time without having to completely

redo chunks of the image. I’m

going to use an S-curve now on the

tree as I think it needs to have

brighter highlights on it and that

hollow should be nice and dark.

One last thing is that I’m going

to add some stars to the sky, so it’s

time to bring in the image of the

stars: place the layer below the

moon layer, and make it about 300

pixels wide. This time though,

make the layer mode ‘Lighten only’

from the dropdown menu. The last

thing to do is give the stars a layer

mask that will fade them out

midway down the image.

Next month we’ll have a tutorial

from Thomas Standiford on

making your photo look retro.

http://www.youtube.com/watch?v=HZcoOx94ox8
http://ronnietucker.co.uk
http://www.sxc.hu/photo/1126941
http://www.sxc.hu/photo/1005288
http://www.youtube.com/watch?v=HZcoOx94ox8
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I
n this GIMP how-to, we're

going to do some basic curves

adjustments to make this

photo have a cool stylized

retro-type look.

We'll start with the image

above right, and end with the

image shown bottom right.

Get the Retro Colors

Most of the effect for this

photo is simply from adjusting the

curves of each channel (the red,

green, blue, and alpha channels)

like so:

Note: To change which channel to

adjust, select the channel from the

channel drop-down. You can switch

back and forth between channels.

All of these curves adjustments

should be done in ONE

COMMAND, not a series of four

commands.

After making the adjustment,

your photo should look pretty cool,

but we need to tone the contrast

down a bit.

Next, do another curves

adjustment like so:
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Not bad, now if only those

bubbles didn't disappear in the

process.

Enhance the Bubbles

The bubbles seem to have

disappeared in this photo. We're

going to use a combination of

selections, and soft brushes to put

some pop back into them.

Create a new layer, name it

"bubbles".

Now we will select the bubbles.

Using the path tool, trace around

the outer edge of each bubble.

Once all of the bubbles have

been outlined, right-click on the

path in the path menu (located in

the same window as the layers),

and click "path to selection."

Set your foreground and

background to a lime green and

hot pink.

Using a fairly large and soft

brush, carefully brush in a few

spaces of pink and green in each

bubble, like so:

Now that we have added the

color to the proper areas of the

bubbles, let's change some layer

styles and adjust the opacity to

make the bubbles look realistic.

Set the layer mode to Overlay.

Duplicate the layer. Name the

duplicated layer "bubblebrighten".

Set the duplicated layer mode

to addition.

Adjust the opacity of both the

"bubble" and "bubblebrighten"

layer until you end up with

something you're happy with. My

opacity settings are set to 23 and

40 respectively, and they look like

this:

Now that our bubbles are a

little more visible, let's dramatize

the photo a bit.

Final Touches

Create a new layer, name it

"dramatize", set the layer mode to

Overlay, and fill the layer with

black.

Add a layer mask to the

dramatize layer.

Using the blend tool, set the

gradient mode to radial, and use a

gradient that goes from black to

white. Create a gradient that goes

from the center of the photo

outward. Adjust the opacity of the

layer to something you're happy

with. Here is what I ended up with:

Next month we'll begin a video

editing series using Kdenlive.
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Nicholas has worked himself into
a hospital bed this month, and
will be back next month.

O ne thing that GIMP is well

known for is its filters. Think

of them as Photoshop plugins. One

GIMP filter that is incredibly

powerful – yet not so well known,

it seems – is G’MIC. Meaning

‘GREYC’s Magic for Image

Computing,’ it comes with an

incredible amount of filters

covering deformations,

degradations, details, film

emulsion, patterns, rendering,

repair, and even a section for

filters still in testing. In this quick

example, I ’ll talk about the Inpaint

feature. This allows you to mask an

area which Inpaint will fix for you.

INSTALLING

Go to:

http://gmic.sourceforge.net/gimp.s

html and download the

appropriate file (32/64 bit) .

Unarchive the download to your

GIMP plugin directory (this is

usually /home/.gimp2.8/plug-ins or

thereabouts, so you may need to

show hidden files to find the

.gimp2.8 folder). Now, when you

start GIMP and click the ‘filters’

menu, you should see G’MIC at the

bottom of the list.

USING

When you have a photo loaded

(in GIMP), you use the pencil tool

(not the paintbrush) to cover the

parts of the photo you want

Inpaint to remove. I started with

the photo shown above.

http://gmic.sourceforge.net/gimp.shtml
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I decided to test Inpaint by

seeing if it could remove the red

and white tape. I simply drew over

it with the pencil tool using bright

red (pure red, no green or blue) as

shown on the previous page

(bottom image).

Next, I opened G’MIC (filters >

G’MIC), clicked REPAIR, then

‘Inpaint (Patch Based)’:

From the default settings I

raised the Patch Size setting to 1 5

and the Lookup Size to 22. After

that I clicked OK and waited. It

does take a fair bit of

computational power to do this, so

now is the time to grab a

tea/coffee.

And below left is the final

result.

Is it perfect? No. Is it quick and

easier than using the cloning tool?

Definitely!

I purposely chose this photo as I

thought maybe the railings would

catch it out, but InPaint worked

fine. There are a couple of bits on

the railings where it isn’t perfect,

but I ’ll let you see if you can spot

them.

G’MIC has literally dozens of

great filters in it so have a play

around with them!

http://ronnietucker.co.uk
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