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I
t's kind of odd to start an

article with a Youtube link, but

I believe that if you like what

you'll see in there, you will

love the rest of these tutorials.

Feel free to follow the link

below and come back here in

about 15 minutes, multiplied by

the number of times you'll enjoy it:

http://www.youtube.com/watch?v

=eRsGyueVLvQ

Sintel (www.sintel.org) is not

the reason I mess with Blender, but

I believe that if I hadn't till then,

after that I surely would have

“started my journey”.

So, lets talk about Blender

(www.blender.org), the program

behind Sintel and many similar

movies. (Actually Blender is behind

a lot of 3D things). Blender is

available for Linux, Windows, Mac

OS X and FreeBSD (32-bit and 64-

bit systems).

When this article was written,

the latest version was 2.64 but

we'll work with version 2.62, which

you can find in the Ubuntu

repositories. If you haven't already

installed it, go ahead and install it

from the repository.

In these tutorials we will use a

3-button mouse and a keyboard

with number pad. Blender assumes

that you have that. But, if you

don't, you can change these

setting under File > User

preferences. Select the input tab

and, on the left, mark Emulate 3-

Button Mouse and Emulate

Numpad.

You will encounter a splash

screen showing the version of

Blender at the top right corner and

some links. Ignore them for now

and press any mouse button

outside that area.

If you are new to 3D animation

software, don't worry. Give it some

time and you'll get used to it:

practice, experiment, and practice

are the only three ways to excel in

Blender. If you are familiar with

other similar programs (Maya, 3DS

Max, etc), you will find some

differences but the main

philosophy is here.

So, we are in Blender and we

see the 3D view editor, some

buttons at the left, some buttons

and numbers at the right, and a

timeline at the bottom. Working in

Blender mainly means “working in

3D view editor”.

Working in Blender is modeling,

animating, lighting, compositing,

texturing (where we will use all

editors), but the 3D view editor (or

3D view window) is still the place

where everything is revealed.

The 3D view editor is the big

window at the center of our

screen. What you see there is a

cube, a camera, and a light.

Press F12

What's going on? Well, you just

rendered your first scene in

blender!

TIP: You can inspect the

previous rendered image anytime

by pressing F11. Pressing F11 again

http://www.youtube.com/watch?v=eRsGyueVLvQ
http://www.sintel.org
http://www.blender.org


full circle magazine #68 20 contents ^

HOWTO - BLENDER Pt 1

will return you at the 3D view

editor.

Move the mouse on the image

and press Esc or press F11 to exit

the rendered image window and

return to the 3D view editor.

All that you need to have a

scene is a capture device (the

camera), a theme to capture (the

cube), and some light.

Now, lets focus on the bar on

the bottom of the 3D view (shown

below) called Header

Notice the tiny little

box (shown left) on the

left-most side. This is the

editor type selector.

Press your LMB (Left Mouse

Button) on the little 3D box to

change the editor type.

From the list select Python

Console (the very first selection at

the top).

Hey! Where is my box?

Don't worry, your cube is right

there where you left it. From the

same menu select the 3D View.

Voilà! Your box is there. See?

In Blender, you can change any

window to any editor type window

you want. This will be very handy in

the future when we will want to be

more productive. Go ahead and

locate the four other window

headers on your screen. (There are

five in total.)

Notice that every window has a

different header with different

options, and every time you

change editors, the header

changes as well.

Now, change every editor to

info (the header at the top of your

screen is already in info so you

don't have to change it.)

At any time, press File > New in

info header to reload your default

setup.

Ok. Let's start a new project;

press File > New in info header.

Everything is back in place.

Move the mouse in the 3D view

editor window, and press the MMB

(Middle Mouse Button) while

moving the mouse around. You are

rotating the view. Moving the

mouse wheel up and down, you

zoom in and out.

Alt+Shift+MouseWheel rotates

the view up and down.

Alt+Control+MouseWheel

rotates the view left and right.

Also you can pan the view.

Shift+MMB and you can pan the

view, with Shift+MouseWheel up

and down and

Control+MouseWheel for left and

right.

You can zoom in and out

without using the middle mouse

wheel. Use Control+MMB and

move the mouse up (zoom in) or

down (zoom out).

Enough with rotation and

panning. Lets go to selection!

Start a new project: File > New.

By default, when you start a

new project, the cube is selected

(indicated by the highlighted-

orange edges of the cube)
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Now press the A key. You

deselect the cube (nothing in the

scene is highlighted).

Pressing A key again will select

All objects on-screen. The cube,

the camera and the light. Press A

one more time to deselect

everything.

Now press the RMB (Right

Mouse Button) on the cube. You

select the cube and it's

highlighted.

Press the RMB on the light. You

have selected the light but you

deselected the cube as well.

Press A to deselect the light.

Shift Selection

Press RMB on the light and then

press Shift+RMB on the cube. You

selected the light AND the cube

(notice the more redish edges on

the light).

Now Shift+RMB on the camera

(notice the redish light). This is

cumulative selection, meaning that

you added the camera to the

selection.

Shift+RMB to the cube.

The redish edges become

orange. Shift+RMB again on the

cube and you deselected the cube.

Now you have in your selection the

light and the camera. Press A to

deselect all.

Now, using the MMB, rotate the

view, in order to see all 3 objects,

and deselect all with the A key.

(You can instead load a brand new

scene by clicking File->New or

Control+N, and, on the new

project, press A to deselect the

cube.)

Box Selection Tool

Assuming that you have loaded

a new project or you have a similar

view, move the mouse over and

right of the light and press the B

key. A cross appeared. Now hold

LMB and drag the mouse down and

to the left in order to Box select all

3 objects.

Great! Everything is selected

with a different and faster way

than the Shift+RMB selection.

Press A key again to deselect all.

Circle Selection Tool

Press C and a Circle appears.

Circle selection works in a

cumulative manner like shift

selection, so pressing LMB on the

cube will add the cube to the

selection.

Moving the mouse wheel up

and down, you can adjust the circle

radius making selection more

precise or general.

Remember, any time you press

LMB you add the object to the

current selection.

Press MMB to remove an object

from the selection.

Press Esc to exit the selection

mode.

Lasso Selection Tool

Press and hold Control+LMB

and drag your mouse to put the

border around an object. You can

select multiple objects in a more

accurate way than the box

selection.

You can add objects to the

selection with the Control+LMB,

and you can abstract objects from

the selection with the addition of

the Shift key to the combination:

Control+Shift+LMB. Press and hold

Control+Shift+LMB and abstract

objects from the selection.

Go to File->New or press

Control+N. Start a new project.

Practice, Experiment and

PRACTICE! Rotate the view, pan

the screen, zoom in, zoom out,

make multiple selections and

deselections.

Next month, we will actually

create something.

Go to

http://www.youtube.com/watch?fe

ature=player_embedded&v=R6MlU

cmOul8

Enjoy “Tears of Steel”

(www.tearsofsteel.org) by the

Blender Foundation.

http://www.youtube.com/watch?feature=player_embedded&v=R6MlUcmOul8
http://www.tearsofsteel.org
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A s I promised last month, today

we are going to create

something. But first let’s destroy a

cube!

Start a new project in Blender:

File-> New, or just open Blender.

Press Numpad-1 to have a front

view. At the upper-left corner you

can check what you are viewing.

Now press Numpad-5. You

change your view from Perspective

to Orthographic. Pressing

Numpad-5 toggles the view from

perspective to orthographic and

vice-versa.

TIP: Perspective view is the way

our eyes see the world. Objects

that are closer seem bigger than

objects that are further.

Orthographic view, on the other

hand, is like seeing an object from

an infinite distance. All objects

seem as they are at the same

distance relative to the eye.

Orthographic projection is a means

of representing a three-

dimensional object in two

dimensions

(http://en.wikipedia.org/wiki/Orth

ographic_projection), very useful

for modeling!

On the bottom left image, we

have an orthographic view. Our

brain cannot understand which

side is the front. But it is great for

creating models, as we don't

actually care for one perspective

but for the actual dimensions of

our model. The perspective is

going to be more realistic if we

create models ignoring the

perspective!

In the bottom right image, we

see the cube from perspective

view, so our brain can understand

which side in nearer, knowing that

is a cube.

Of course, this is my opinion.

Maybe you can model better and

faster using perspective view. It's

up to you.

A few months ago, Mark started

to demonstrate the great program

Inkscape (we will see in the future

how we can use Inkscape with

Blender) creating a snowman. I

really liked his example, so let’s

create a snowman as well. But

first, destroy the cube!

Select the cube with the RMB

(Right Mouse Button) and press

the X key or Delete key and

confirm the destruction by

pressing Enter.

Now press Shift+A to add

something, and, from the menu,

click Mesh->UV Sphere or, from the

header, press Add->Mesh->UV

Sphere to add a new mesh to your

scene. A sphere appears.

I guess that you are in front-

orthographic-view (check the top

left corner on your 3d view

window) with the sphere selected.

If not press Numpad-1.

Press Shift+A to add a new

mesh. A UV sphere again. You

don't see any difference in your

monitor. Don't worry. LMB and

hold the blue arrow pointing

upwards, to move the sphere up on

the Z-axis. Place it near the top of

the revealing sphere.

Press S to scale down the

sphere moving your mouse to the

center of the cursor. Move your

sphere down again to be a little

“in” the big sphere.

Now press Shift+D key to

http://en.wikipedia.org/wiki/Orthographic_projection
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duplicate the selected sphere.

Press Z to lock the movement to Z-

axis, and press and hold LMB to

move it up near the top of the

second sphere.

Press S and scale down the

third sphere.

Ok, we have something.

Press File->Save As to save your

work so far. Select where you want

to save your file, give it a unique

name (snowman.blend for

example), and press the Save As

Blender File button on the upper

right corner. Great!

Now, select the first sphere by

pressing the RMB on it. Press S and

then Z to scale down your sphere

altering only the Z-axis.

Do the same for the other two

spheres to make them look more

“real” (shown middle left). The

gravity pulls the snowballs to the

ground.

Press N to open or close the

properties window on the right of

your 3D view. There, you can

inspect and alter your object's

properties by actual numbers

(shown middle right).

On the Front Ortho view, press

LMB somewhere right of the

snowman body. Press Shift+A to

add Mesh->Cone. Press R for

rotation, and 90 for the rotation

degrees.

TIP: You can manually input values

by pressing directly a value. Your

cone rotated 90 degrees clockwise.

You can also use negative values

for rotating your object counter-

clockwise.

Press Numpad-3 for the right

view. Press S for scale and Shift+X

to constrain the X value and alter

the Y and Z values together. Scale

the cone down to look more like a

carrot-size nose relative to the

third-created (snowman head)

sphere.

OK, press Numpad-1 for front

view, and press S and X to alter the

X value alone. Now create a long or

a short carrot-nose.

Press R and -10 to rotate the

nose 10 degrees counter-

clockwise.

Using the front view and the

right view, place the nose

somewhere in the middle of the

snowman's head.

Now let’s create some buttons.

Press Shift+A to add a Mesh-

>Cylinder. Use the same tools to

create a little coin-like button as

the ones we use to create the

carrot-nose. Scale it, rotate it, use

your imagination! Don't forget to

duplicate with Shift+D to be more

productive.

When you are happy with your

model, save your work.

Press F12 to render.

Your snowman seems a little bit

silly. The snow doesn't have this

kind of edges like well crafted

crystals! We have to smooth that

up.
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So, press T key to bring up the

toolkit on the left. Under the

Shading section, you have two

options: Smooth and Flat. With one

sphere selected (or all) press the

Smooth button. Your snowman is

smoother now!

You can see the differences. On

the image shown middle right, the

spheres are flat with a more crystal

like cut, and on the one shown

middle left, we have applied the

smooth shader giving a more

smooth and natural feel of snow.

Using the box selection tool

that we mentioned last month,

select all objects that, united,

represent “the snowman”. The

spheres, the cylinders, and the

cone.

Using the blue arrow, move the

snowman up as shown in the

images above, a little bit down the

red axis.

Press Shift+S. From the Snap

menu that appeared, select Cursor

to Center. Press numpad-7 for the

top view. Press Shift+A to add a

new mesh. A plane. Press S for

scaling the plane and 10 to scale it

up 10 times.

We have a ground.

Save your work under a unique

name.

Render your snowman by

pressing F12.

If your camera doesn't capture

your model as you like, move your

camera.

Every month, I'll suggest an

interesting site for Blender. For

this month, I highly recommend

http://www.Blendernation.com. A

very useful site with hot news

about Blender.

Also for this month I have a

video for you. Go to

http://www.youtube.com/watch?v

=TLkA0RELQ1g, and enjoy

“elephants dream” a short film

created with Blender in 2006, by

orange open movie project.

Next month, we will add a hat,

maybe a pipe, and his brush-like

hands. Also, I will introduce you to

the edit mode – the place where

you are going to spend most of

your Blender time!!

http://www.Blendernation.com
http://www.youtube.com/watch?v=TLkA0RELQ1g
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Many, many times in your

blender sessions you will

press the TAB key. It’s the

keyboard shortcut for switching to

Edit Mode.

Load the snowman.blend file

that we created last month, and,

on the header, locate the button

showing that you are in Object

Mode (it's called header, but it is

placed by default where a footer

should be).

Select with the RMB (Right

Mouse Button) the head (top

UVsphere) of our snowman.

Press the TAB key. The entire

header changes and now you are

reading “Edit Mode” on the same

button. (You can alternatively

press that button, and, from there,

you can select the edit mode. For

now, we don't need to know what

the other modes are).

Also the UVsphere changes to a

orange-wired sphere.

You are in edit mode. While in

edit mode, you are able to adjust

and manipulate only the selected

object. Try, for example to select

with the RMB the lamp or the

nose. You can't. You can select only

a vertex or group of vertices of the

object that you are in.

Vertex is a 3-dimensional

coordinate,

Edge is a line connecting two

vertices and

Face is the planar field in between

3 or more vertices.

In edit mode, you can select

vertices, edges and faces – the

same way we saw in the first part

of this series, 2 months ago. Use

the box selection tool, the lasso

tool, the circle selection tool, RMB

and Shift+RMB to select multiple

vertices.

Also in the

header,

observe three

small buttons representing the

vertex, edge and face selection.

From these buttons you can

change what you select (vertex,

edge or face). Alternatively, press

the keyboard shortcut Ctrl+Tab.

Go ahead and switch back to

object mode by pressing the TAB

key.

On the header again, you can

see that the buttons that we

mentioned before have

disappeared, and some others

came back. Let’s focus for a minute

on the buttons showing below

These are called Layers

Buttons. The yellow dot in the

upper left button indicates that we

have objects in that layer selected,

or recently selected, and the

darker gray color that we are

currently in that layer.

Press the number 2 on your

keyboard (NOT the numpad) or the

second button from the upper left

corner. Everything disappears – as

we are now on a different layer.

Press Shift+S for Snap menu, and

select Cursor to Center. Press

Shift+A to add a new object. From

the Mesh group select Cylinder.

Notice now the Layers Buttons.

It shows us that we have

objects in two layers, and the

second layer is the active one with

something selected. Press S for

scale, and 0.3 to scale it down 30%.

Press G for grab, Z to lock it to Z-

axis, and 0.3 to move your cylinder

up 30% of a blender unit.

If it’s not selected already,

press Numpad-5 to switch to

orthographic view (explained in

issue #69) and Numpad-7 for top

view.

Press the TAB key to enter the

edit mode. Press Shift+S and

Cursor to Center to move your

cursor again to the center of your

grid – in case you have moved your

cursor. Press Shift-A to add a Circle

from the Mesh group. After that,

press F6, and, from the window
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that appears, change the Fill Type

from Nothing to Ngon. After that,

press S for scale, and 0.5 to scale

down your circle by 50%.

Press the TAB key to return to

object mode. While in edit mode,

the objects that you add (in this

example the circle) are all parts of

a single object and blender

manipulates them as a single

object.

We have the hat. Now let’s

create the hands of our snowman.

Press 3 on your keyboard (NOT

Numpad-3) to work in Layer

number 3.

Shift+S again to move our

cursor to center. Shift+A to add a

new Mesh. A cylinder again. Press S

for scale, Shift+Z to keep the

dimensions of Z-axis, and alter the

other 2 axis, X and Y. Press 0.02 for

scaling 2%. After that, press S

again, Z to alter only the Z-axis

dimensions, and 0.5 to make it half

long. Lets go to edit mode again.

With the cylinder selected, press

TAB. Add a new cylinder, scale it

down, rotate it, and move it in

order to create a branch arm.

When you are done with your

branch, Press Alt+1 on your

keyboard (NOT Numpad-1) to

select Layer Number 11.

TIP: Press 1, 2, 3... to 0 on your

keyboard: you select your active

layer from 1 to 10. This is the upper

row on your Layers Buttons

mentioned earlier. Pressing Alt+1,

Alt+2... to Alt+0 selects the lower

row of layers from 11 to 20.

With Layer 11 active, add a new

Cylinder (by now you have to know

how to add a new Mesh).

Press TAB to switch to edit

mode. Press Z key to display your

cylinder as wireframe. This is a very

useful view of your object, and I

personally use it a lot to toggle the

view from solid to wireframe. Press

A to select all vertices (if not

already selected). (When in object

mode, pressing the A key selects

all objects, but, when in edit mode,

this key selects or deselects all

vertices.)

Now it's time to create a pipe.

Assuming that you

have a front

orthographic view,

and the small button on the right

of the mode selection button

indicates the wireframe

symbol...select all vertices.

Scale down your cylinder to 8%.

Press A to deselect all vertices.

Now, box select (using the B key)

only the upper vertices.

Scale up a little by pressing S

key and moving your mouse away

from the center of your selection.

Press A to deselect all vertices, and

box select the lower vertices only.

Scale down a little by pressing S

key and moving your mouse

towards the center of your

selection. After that, add a new

cylinder, scale it down, and create

the rest of your pipe.

It is a good time also to replace

that nose that we did last month

(using a cone) with a new one

based on a cylinder – because we

don't actually want a so sharp edge

for our carrot-nose.

Now we have almost what we

need.

Do the same as we did with the

cylinder a little earlier to create

another branch arm. Place it in a

new layer or in the layer where you

have the other branch. You can

also duplicate your branch arm by

selecting it and pressing Shift+D.

Now that you have all the

elements in your layers, you can

either move all objects to the

starting layer (Layer 1), or by

pressing Shift and the Layer-
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buttons that have objects in them

– to combine the view of all layers

that are selected.

TIP: To move an object to another

layer, select the object and press M

key. From the Move to Layer

window, select where you want to

move your object.

Next month, we will add some

color in our lives, introducing

textures!

For this month, I'll suggest

http://www.blenderartists.org – a

forum where you can find the

latest news, job ads, artworks, and

much more blender-related stuff.

Also for this month, I have a

video for you. Go to

http://www.youtube.com/watch?v

=USyoT_Ha_bA, and have a look

back in 1963 at the ancestor of all

computer graphics, Ivan

Sutherland's Sketchpad (my

Wacom tablet almost cries).

CCOODDEEWWOORRDD

Solutions are on the second last page.

Every number in the grid is 'code' for a letter of the alphabet.

Thus the number '2' may correspond to the letter 'L', for instance.

All - except the difficult codeword puzzles - come with a few

letters to start you off

Puzzles are copyright, and kindly provided by,

The Puzzle Club - www.thepuzzleclub.com

http://www.blenderartists.org
http://www.youtube.com/watch?v=USyoT_Ha_bA
http://www.thepuzzleclub.com
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Textures and materials are very

crucial. Without them, for

example, what we have created so

far is a grey snowman, with a grey

nose, grey hands and a grey hat.

Not so realistic. So, materials and

textures is a way to add realism to

the look of our models with

images, plain colors, etc.

You must have a material to

apply a texture on it (by default

blender adds a material to your

objects in order to see their

surfaces).

So, for this month we will

introduce materials – leaving

textures for next month, as it is

impossible to fit them both in an

article.

But, before anything else, let’s

upgrade blender. A new release

(2.66a) is available at

http://www.blender.org/download

/get-blender/ with a bunch of new

features and over 250 bugfixes.

Let’s load the snowman blend

file that we created last month. It

has to look something like this in

object mode (shown below).

Notice the small icons at the

right of your 3D view window. The

fourth icon from the right

(highlighted) is the Materials tab.

Select the hat and press the

New button:

Name your material “Hat”. Your

material tab has to look something

like the one shown right.

As you can see, there are a lot

of things that we can tweak, but

we will introduce the very basics to

create a kind of realistic

environment (maybe, in a later

stage of this article-series, we can

focus on materials and textures

explaining all in detail, but, for

now, feel free to experiment with

those).

Blender gives us a preview

window where we can inspect the

http://www.blender.org/download/get-blender/
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color of our material. Also, on the

right, we can change the basic

object that we are previewing (this

doesn't affect our object at all, but

helps us to understand how the

color looks – for example on

spheres or boxes).

Under Diffuse, there is a white

strip. Press with your LMB (Left

Mouse Button) on it to change the

color. Select the color of your

choice from the color wheel, or

enter manually the values of Red,

Green and Blue below the wheel,

or you can use the color picker –

well known from other graphic

applications.

You can use the HSV button to

choose your color by Hue

Saturation and Value, or you can

use the Hexadecimal numbers that

are commonly used on web pages

to specify colors. I personally use

only the RGB values. The values

can vary from 0 to 1 indicating the

percentage of the color (0.2 = 20%

for example).

On the right of the wheel there

is a slider controlling the intensity

of the color. If you slide it all the

way down we have absolute black.

Also notice that values of Red,

Green and Blue are all changed to

0.

Under Specular, there is also a

white strip. From there we choose

the color of the reflection on

shining objects. For example

choose for diffuse: color Red =

0.015, Green = 0, Blue = 0.24, and

for specular: Red = 0.915, Green =

1, Blue = 0.

Also on the preview window,

change the basic object to monkey.

Looks like the image below?

NOTE: The monkey of blender is

actually a chimpanzee, called

Suzanne. This 3d mode, created by

Willem-Paul van Overbruggen, was

introduced to the blender

community as a test model for

materials, textures, lights, etc. The

Suzanne awards (something like

the Oscars awards) are held

annually for blender artists.

http://en.wikipedia.org/wiki/Suzan

ne_Award

Now, let’s go back to our

snowman. Reload the

snowman.blend file, select the

plane that we use as ground and

LMB on the material tab.

Press New to create a new

material and rename it from

“Material” to “Ground”.

Under Diffuse, press LMB on

the white strip and put the values

0.5 for Red and Blue and 0.8 for

Green. On the 3d view window, you

can see that the color of the

ground changes to a green looking

surface.

Select one button of the

snowman, and press the new

Button on the material tab. Name

it “Button”, and, under Diffuse,

color it red (by now you must know

the way to do that, but, in case you

don't, just put R = 1, G and B to 0):

Now, with your RMB, select

another button of the snowman.

Under the material tab, you can

see the New button that we used

earlier to create a new material.

Left of this there is an icon similar

to the “materials” one in blender.

Press it and select

Button from the list:

http://en.wikipedia.org/wiki/Suzanne_Award
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The materials that we create

are stored for later use in the

blend file, and many different

objects can share the same

material.

Keeping that in mind, create

materials for the hands, the hat,

the nose, and the pipe. Also assign

the Button material to the other

buttons, or create a new material

for each button if you like.

For the hat I created a material

with a Halo behavior – just to make

a Saint snowman with two Halos!!!!

Very Saint!

You can experiment with the

other two kinds of materials

behavior: Wire and Volume.

For this month, I recommend

that you download and play a

game created in blender with the

blender game engine. Yo frankie!

http://www.yofrankie.org/

Also you can check out

blenderguru.com. A site dedicated

to blender, with a lot of tutorials

for beginner and advanced users,

created and hosted by Andrew

Price, a very talented blender

artist. Enjoy.

http://www.blenderguru.com

CCOODDEEWWOORRDD

Solutions are on the second last page.

Every number in the grid is 'code' for a letter of the alphabet.

Thus the number '2' may correspond to the letter 'L', for instance.

All - except the difficult codeword puzzles - come with a few

letters to start you off

Puzzles are copyright, and kindly provided by,

The Puzzle Club - www.thepuzzleclub.com

http://www.yofrankie.org/
http://www.blenderguru.com
http://www.thepuzzleclub.com
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Having a lousy model is not

something that you want for

your models, of course, but, as a

good friend of mine (and

experienced 3D artist) told me:

“you can save a lousy model with

good texturing.”

This month, I will try to explain

the very basics of texturing (the

truth is that I know the very

basics). There are a lot of books

out there describing texturing

techniques—as textures are a very

important matter for 3D modeling.

Low poly is a polygon mesh in

3D computer graphics that has a

relatively small number of

polygons. We usually use low poly

models for performance reasons,

in real-time applications such as

games.

High polymodels are usually

used for animated movies or high

detail pictures, in conditions, in

general, where we don't have real-

time performance restrictions.

(http://en.wikipedia.org/wiki/Low_

poly)

I will give you an example to

make it more clear what textures

are and what they are capable of.

In the image below, we have a

sphere with a plane, and

illuminated by 3 lights.

Next, we have the same

objects, but this time with textures

and image mapping to create the

surface filling on earth.

Next, we have the same objects

with different textures on them.

And, finally, we have ball of

aluminum foil garbage on a beach

(very sad).

For the last picture I used an

image for the sand, and, for the

foil, the cloud texture with some

normal map displacement.

But enough with the examples.

Let’s load our snowman.blend file.

Select the three spheres (body)

of our snowman, and press Ctrl+J

to Join the three meshes to one.

Name it “body” under the object

tab.

Now, go to the material tab and

press the New button to create a

material for the body of our

snowman.

Name the material with a

unique name—for example,

“body_Material”.

Next, press the tab next to the

material tab called Textures.

http://en.wikipedia.org/wiki/Low_poly
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Press New to create a new

texture. Name it body_Texture, or

whatever you like.

Find a picture of snow to use as

a texture. There is a very

interesting site that I use a lot at

http://www.cgtextures.com. You

can register and have access to

thousands of images that you can

use as a texture (with the free

registration you can download up

to 15MB of images per month.

Download the low resolution

images and you will be just fine).

For our snowman, I downloaded

the image Snow0041_5_S.jpg.

Under the type button, select

image or movie.

Then press Open under the

Image section, and navigate to

your file system to select your

image.

Under the Mapping section,

select Sphere for the Projection

and leave Coordinates as it is

(Generated).

Under the Influence section,

tick on Emit and put the value

-0.800 to light up your image a

little, and, under Geometry, tick

Normal and enter 4 for value to

give a hard surface feeling.

Leave the rest to default, or

experiment with them to see what

you get (remember that

experimenting is one of the three

things that you need to master

blender, the other two are

practice!).

Now, for the ground, here’s

what I have done (of course, you

can use an image instead). I

created a texture from the type

Clouds, adjusting some of the

settings.

with these settings:

Finish the snowman by creating

and applying textures to the rest

of the meshes (hands, nose,

mouth, etc.)

Feel free to send me your

creations of the snowman project

at blender5d@gmail.com, and I'll

present the best here at Full Circle

Magazine.

Next month, I'll introduce you

to the Cycles render engine—a

very powerful renderer that has

been included with the blender

distribution ever since version

2.64. Also, we will start a new

project. Send me your ideas.

For this month, I have a game

called Dead Cyborg created by

Endre Barath

(http://www.deadcyborg.com).

Another game created with the

blender game engine. Enjoy!

mailto:blender5d@gmail.com
http://www.cgtextures.com
mailto:blender5d@gmail.com
http://www.deadcyborg.com
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By default, blender has its own

renderer called Blender

Render, but my favorite is one

called “Cycles”. It is included as an

enabled add-on since version 2.64

(we are now at 2.67), and I find it

fantastic because among others

things, you can actually see the

rendered result of your models in

real-time!

But, first things first. Locate at

the top of your blender window

the pull-down button that says

“Blender Render”.

Press it to open the menu and

select “Cycles Render”.

Now, let’s arrange our windows

to take advantage of the

interactive cycles renderer.

On the upper right corner of

the 3d view window (main

window), press the

LMB and drag the

mouse left to create

a new 3d view

Then do the same with the left

window that you have, but this

time drag the mouse down to

create a third window. You must

have something like the image

below.

Move the mouse on the upper

left window, and press Numpad-0

to have camera view on it.

On the lower

left window,

press the small

white sphere

next to Object

Mode button to

display the

Viewport

shading menu

From that menu select

“Rendered”.

Now, what is actually happening

is that, in this window, the cycles

render engine creates “on the fly”

a photorealistic image of your

model. You can navigate in that

window, you can zoom in or zoom

out using the mouse wheel or +, -

from the numpad, you can pan the

view by holding the shift key and

moving the mouse, rotate the view

by holding the middle mouse

button and moving the mouse,

and, in general, any movement of

the view that we examine in part

one (FCM#68) of these articles.

This is a good time to save our

setup. On the info header (the one

that by default is the upper

window), locate the screen button

with the “Default” value in it

(foolishly named, as a bunch of

setups are the defaults in blender).

By pressing the small icon on

the left (red square), you can select

from a list of default setups. Press

the + sign next to “Default”. A

“Default.001” value appears.

Change it to a distinctive name for

example “Model” to indicate that

you use this setup when you model
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objects. Then save your file with a

unique name, I saved mine as

“Basic_shapes.blend”. The next

time you open this file, the

“Model” setup will be opened as

well.

TIP: If you start a new project, or

load an old one, your custom setup

will NOT be there. Just the

defaults with blender. To have your

custom setup available anytime

you start a new project, you must

save it as the startup file by

pressing Ctrl-U. Note that if you

overwrite the startup file (by

pressing Ctrl-U), ANYTHING that

you have changed will be saved as

well. For example, if you delete the

cube and you overwrite the startup

file, then the next time the cube

won't be there! Of course you can

revert to the original startup file

(File > Load Factory Settings).

Move your mouse over the right

3d view window, and press

Numpad-5 and Numpad-1 for

Orthographic

Front view.

Grab the blue

arrow of the

cube and

move it up just

over the grip

as shown:

Press Shift-S and select Cursor

to Center if it isn't already or Press

Ctrl-C. Now add a plane and scale it

up by 10 times (by now you must

know how to do that). Create a

Cone and a UV Sphere. Also

smooth them. Move them in order

to have them in good view on the

upper left 3d view window (the

camera view window).

Like the image below.

Select the plane and press the

material tab on the right under

properties window (shown top

right).

A different set of things to

tweak than the Blender Render!

Press the New button (as in

Blender Renderer) to add a new

material. Name it “ground”. Under

Surface, you see the default value

that is “Diffuse BSDF”. This is like

the Diffuse that we used in

FCM#72 to paint our objects. Press

it and from the menu select

“Glossy”.

Almost instantly (depending

upon your CPU power) you can

inspect the Rendered 3d window

what you’ve achieved so far.

Impressive for just few clicks! Now,

if you like, press the color button

and assign a color to your glossy,

mirror like, surface. I made it

purple (R:0.5,G:0.4,B:0.8). As you

change the color, Cycles starts to

render the result. You have a

preview really fast.

Now select the cube, add a new

material, and set the surface type

to Anisotropic BSDF to give a

metallic feeling to our cube. Maybe

my favorite material shader.

Above is what we have so far.

More on this subject next

month...

mailto:blender5d@gmail.com
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Last month we used Cycles

Render to create the image

shown below left.

Let’s create a similar image

(below right) with the Blender

engine.

The first thing that we notice

(at least me) is shadows. The

shadows that our point lamp casts,

with blender render, are almost

black. This phenomenon is

happening because in Blender

renderer, the light is been emitted

by the lamp only. This isn't

realistic, as in the real world every

object emits or reflects light.

On the other hand, Cycles

renderer calculates the light that

every object has from the

surroundings. You can observe the

cone and see how the shadow

from the cube smoothly fades

(contrary to the cone from the

Blender renderer), and we have a

mirroring ground and a shiny metal

cube in our scene.

One other thing that is very

crucial, and a main difference

between Blender and Cycles, is

more technical.

Navigate to File > User

Preferences > System (above).

At the lower left corner of the

System Tab you can check if your

computer has Nvidia CUDA

support under Compute Device

My GPU has CUDA support so I

can enable it. You can also check it

at the official CUDA support url:

https://developer.nvidia.com/cuda-

gpus

If you are lucky and have an

Nvidia CUDA card, you have to

enable it under the Compute

Device Tab that I mentioned

before AND under the Properties

Panel, Render Tab -> Device -> GPU

Compute in order to have the full

power for your rendering.

https://developer.nvidia.com/cuda-gpus
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Cycles can use your GPU CUDA

cores to render, and is much faster

than the CPU. Check out CUDA at

wikipedia :

http://en.wikipedia.org/wiki/CUDA

If you don't have a CUDA GPU,

you can use Open Shading

Language, but it's a little bit buggy

and I couldn't recommended this

method of rendering, for now. In

the near future I have a feeling

that it’s going to be much faster

than the CUDA render procedure.

But enough with the technical

stuff.

Let’s see another great thing

about Cycles. Open the .blend file

that we started last month, or just

create a new one. Don't forget to

check that the Cycles Render at the

top is selected

Also change one of your 3d view

windows to show the rendered

result.

Select the sphere, navigate to

the Properties Panel and change

the Surface shader from the

default Diffuse BSDF to Emission.

You can check in the Preview

window the cool effect that we

create. You can adjust the Color

and the Strength of the light that

your object emits. Also for every

shader you can adjust a lot of other

things (as textures, for example) by

pressing the little dot right next to

color and strength values.

Select our metallic-looking

cube, press the little dot next to

color, and change its texture to

Brick Texture. Check the result in

your 3d view window and select

different textures until you find

something that you like.

http://en.wikipedia.org/wiki/CUDA
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TIP: The little dots are in every

shader, not only emission, and I

personally find them very useful to

quickly create interesting stuff.

Another interesting shader is

the Mix Shader. As you can easily

understand from its name, this is a

shader that you can use to mix

other shaders. Two other shaders

to be more precise. So, let’s select

our cone and change the Diffuse

BSDF shader to Mix Shader. Add a

Glass shader and a Diffuse shader

or a Glossy Shader and an

Anisotropic Shader to our cone.

Change the value of the Fac

parameter to adjust the

percentage of the second shader

(0.000 means 0% while 1.000

means 100%)

Check the result on your

preview window and adjust the

settings as you like.

Another thing that I want to

mention in this tiny little

introduction on the Cycles

Renderer, is the use of planes

instead of lamps.

Most people working in Blender

and Cycles use planes to illuminate

their scenes. Looks like more “real

world” lighting, and I have no

reason to argue with them.

Below is where I am so far.

For this month, follow this link

http://vimeo.com/68010380 to

enjoy a wonderful work by 3

people and Blender

(congratulations goes to Javier

Trapiella, Baol Bardot Bulsara and

Robert Green).

Also visit www.blendernews.org

to enter and share with thousands

of professional artists!

http://blendernews.org/xe/?mid=F

eature_Articles&document_srl=12

74

mailto:blender5d@gmail.com
http://vimeo.com/68010380
http://blendernews.org/xe/?mid=Feature_Articles&document_srl=1274
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A fter a month off, we are back

together to explore modifiers.

One of my favorites is subdivision

surface!

Tip: Modifiers are automatic

operations that work with how an

object looks and renders but

without changing the actual

geometry of your object.

Subdivision Surface (Subsurf in

short) is a method of subdividing

the faces of a mesh to give a

smooth appearance, to enable

modeling of complex smooth

surfaces with simple, low-vertex

meshes (source: wiki.blender.org).

Open a new project in blender

and select (if not already) the

cube.

Now, let’s look to the modifiers

tab (shown below) under the

properties window.

Notice a little wrench. This is

the symbol of modifiers in blender.

Press with your left mouse button

the wrench icon and then press the

“Add modifier” button.

A large window appears with all

the available modifiers in blender.

For now we will stick with the

Subdivision Surface (Subsurf from

now on). Locate it (highlighted in

the image above) and select it to

add this modifier to your cube.

Your cube changes to a 24-faces

shape! But if you render your

image, you will get a 96-faces

object... Weird! Let see why this is

happening.

When you add the Subsurf

modifier to your cube by default

the modifier subdivides the cube

faces (6 faces) by 4, giving you a

new shape with 24 faces. You can

control how many times to

subdivide your object’s faces under

Subdivisions section as shown in

the image below. The “View:1”

indicates that you subdivide your

object one time.

There is another control button

under Subdivisions section to

change the subdivisions when you

render your image (Render:2).

That’s why in the 3D view window

you have a 24-faces shape

(subdivided one time), but, when

you rendered it, you had a

6x4x4=96-faces shape (subdivided

two times). Press the right arrow

to increase the View subdivisions

to 2. Now what you see is what you

render.

Increase the View and the

Render subdivisions by one. Now,

under Subdivisions you should

have 3 subdivisions for View and

for Render:

On the left of your 3D view

window, under object tools

(shortcut T for show/hide), smooth

your cube’s shading
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Your “cube” now has to look

something like this:

The secret of the power that

Subsurf has is revealed when you

press the TAB key to enter the edit

mode

You can see the sphere that we

created with the Subsurf, and your

original shape, the cube. You

cannot edit the sphere (remember

that your actual object is the cube)

but you can edit the cube.

Select the top face of your cube

and press E key to extrude and

Enter key to confirm the extrusion.

Scale it down to 50% by pressing

the S key and 0.5.

Move the extruded face down

by 2 units (Press G key, then Z key

to lock the movement to the Z-axis

and then press -2 to move it down).

You created a highly detailed

pot!

By editing the cube, dynamically

you edit the sphere in an organic

way. Without the Subsurf you’d

need a lot of time and effort to

create this pot.

Another critical tool to use with

Subsurf is the loop cut.

Tip: Loop Cut or Loop Subdivide

(shortcut Ctrl-R) splits a loop of

faces by inserting a new edge loop

intersecting the chosen edge

(source: wiki.blender.org)

Deselect all by pressing the A

key, and then press Ctrl-R. Hover

your mouse over the cube faces

and you will notice a purple line

“cutting” the edges as shown to

the image below:

Press 2 or scroll your mouse

wheel to add 2 loop cuts. Press

enter to confirm.

After that, you have 2 yellow

edge loops selected and by moving

your mouse you can slide them

freely. Press the right mouse

button to place them to the center

of your edge (default position).

Press A key to deselect

everything.

Now, to select one of the two

edge loop cuts that we just

created, we have to use the

shortcut Shift-Alt-Right Mouse

Button

Tip: The actual shortcut for Loop

Cut Select is Alt-RMB but under

linux it conflicts with the functions

that are assigned by the system to

the alt key.

With the leftmost edge loop

selected, press Ctrl-E to open the

edge special menu, and select

edge slide as shown in the image

on the next page.
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You can slide the edge loop by

moving your mouse or by entering

directly the value of the movement

(for example -0.8). Deselect all by

pressing the A key, and select the

other edge loop. Slide it by 0.8

units.

Create another two edge loop

cuts to the other side of your cube

(check image above right)

Select and deselect anything

you like. Grab a simple vertex and

move it around to see what is

happening to your shape. Select

two vertices and scale them up or

down. While in the edit mode, add

a new shape, for example a plane,

and see what is going on.

Next month we will continue

our journey with Subsurf, and we

will try to create something. Please

send me your suggestions or

questions at

blender5d@gmail.com

LIBREOFFICE SPECIAL EDITIONS:

http://fullcirclemagazine.org/libreoffice-
special-edition-volume-one/

http://fullcirclemagazine.org/libreoffice-
special-edition-volume-two/

INKSCAPE SPECIAL EDITIONS:

http://fullcirclemagazine.org/inkscape-
special-edition-volume-one/

http://fullcirclemagazine.org/inkscape-
special-edition-volume-two/

mailto:blender5d@gmail.com
mailto:blender5d@gmail.com
http://fullcirclemagazine.org/libreoffice-special-edition-volume-one/
http://fullcirclemagazine.org/libreoffice-special-edition-volume-two/
http://fullcirclemagazine.org/inkscape-special-edition-volume-one/
http://fullcirclemagazine.org/inkscape-special-edition-volume-two/
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Last month, we introduced

SubsSurf (Subdivision Surface),

a very useful modifier to create

smooth, high quality models. You

have to practice a lot to get

familiar with this tool to reveal its

powers. Let’s see some examples

CREATE AN EGG

Start a new project in blender

and add (if it’s not already present)

a cube.

With the mouse in the 3d view

window, press the tab key to enter

edit mode. Press the A key to

deselect all vertices and select the

four upper vertices.

Press the S key and 0.5 to scale

down the selected face by 50%.

Then press the G key (G for Grab)

and 0.1 to move the selected face

up. We have something like a

Mayan pyramid now. Press the tab

key to exit edit mode and return to

object mode.

This is the power of Subsurf –

from a pyramid we can have an

egg! Now go to the properties

panel on the right and select the

modifiers tab indicated by a

wrench to access the subsurf

modifier. Add the modifier, and

increase the View and Render

values to 3. On the left, under the

objects tools tab, apply the

smooth shader. We got an egg.

Tip: The “non-destructive way” is

something that you can get when

you use modifiers. You create an

object by using a modifier, but, if

you decide not to use the modifier,

it’s very easy just to delete the

modifier or alter it. The actual

starting model is there

“underneath” your effects. When

you hit apply under the modifier's

tab, you “destroy” this

functionality.

OK. We have seen subsurf in a

non-destructive way. Now we can

see what mesh we can actually

create by applying our modifier to

the models.

CREATE A BULLET

To tell you the truth, I'm not a

big fan of guns and bullets. But,

when you have to model an object,

you have to know what it looks

like. Thank God we have google

and a lot of image banks for that.

So, after some clicks, I found a

bullet image to work with. (In the

next article I'll show you how we

use images as a blueprint to model

objects).

Let’s start a brand new project

with a cube in it. On the cube, add

a subssurf modifier, and increase

View and Render to 3. Press S to

scale your cube, Z for the Z axis,

and 1.5 for the scaling. Press the

tab key for edit mode. Select the

four upper vertices and press the E

key for extrude. Around 1 will be

fine. Press Ctrl-R for an edge loop-

cut. You must have something like
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the image below.

As you press the mouse button

to accept the loop-cut, move it

down – near the base of your

model. Notice that the modified

object changes its shape. Switch to

object mode to apply the modifier.

Now we can accept the modifier by

clicking Apply under the modifier's

tab.

Go back to edit mode to see

what just happened. We have a

mesh created by subsurf modifier!

Press Alt-Ctrl-R for edge ring

selection.

Press E and Enter key to confirm

the extrusion. Press S to scale your

selection a very little bit. Press G to

move your selection down almost

at the center of your bullet. Scale it

up a little to create something like

the image below.

Ok. We have a basic shape of a

bullet. Adjust anything you like,

start a new project and create a

rocket or something using the

subsurf modifier. When you are

happy with your modified shape,

apply the modifier and continue

from there to finish your project.

Remember that when you apply a

modifier, you have a new mesh and

you can re-apply a modifier if you

like. In a later stage we can talk

about modifiers stuck and how it

works.

Next month, we will introduce

Bezier curves, and I'll model my

favorite team's logo.

For this month, I can suggest

blendswap.com community. 3D

artists around the world can post

their work in blender there and

have actual job opportunities!

mailto:blender5d@gmail.com
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A s I promised for this month,

we will introduce Bezier

Curves.

Bezier curves (named by the

French engineer Pierre Bezier) are

used in computer graphics to set

the coordinates for a smooth curve

really easily.

Lets see what we are talking

about. Start a new project in

Blender and get rid of the cube

(select the cube, press X to delete

and confirm).

Now, press Ctrl-A to add a

Curve-->Bezier

Press R for rotation, X for the X-

axis, and 90 for the degrees of the

rotation. Then, press Numpad-1 for

Front view and Numpad-5 for

orthographic view.

You should have something like

the image below

Lets press the Tab key to enter

the edit mode. You can see a

strange looking shape of

something like a fish skeleton or

pointing arrows – whatever you

prefer to call it ...

The interesting stuff is the two

pink lines representing the edges

of the shape (this “shape” is the

actual segment of the curve). Let’s

focus on the right pink line. Press

the A-key to deselect everything.

Select the middle vertex (called

control point) as shown below:

Notice that the other 2 vertices

(called handles) are selected as

well. Press the G-key to move the

control point. Your curve's right

edge moves. Press the RMB (right

mouse button) to cancel or the

LMB (left mouse button) to

confirm the movement. Now,

select the right-most vertex

(handle for now on). Move it as we

did earlier with the control point.

The control point stays in place

but the handles are moving. Also,

the curvature of the curve is

changing! Moving the other

handler also changes the curve.

Moving the handler towards the

control point changes the

curvature of the curve

respectively.

With the right control point

selected, press Ctrl+LMB. You

create another control point and

actually extrude your curve. The

newly created control point is the

last now, the last one represents

where your curve is finished. If you

want to extend your curve from

the starting edge, select the

starting edge and press Ctrl+LMB

to add a new control point as the

starting edge. If you want to close

the curve, select the two edges

and press the F-key to add a

closing segment. This is all we

need in order to create our logo

with Bezier curves.

For more details about Bezier

Curves go to

http://wiki.blender.org/index.php/

Doc:2.6/Manual/Modeling/Curves

Our goal is to create a three-

dimensional logo from a two-

dimensional logo, and we will start

from an easy one. My favorite

Greek team is Panathinaikos, so

let’s google to find the team's

logo.

I came across this jpg that is just

http://wiki.blender.org/index.php/Doc:2.6/Manual/Modeling/Curves
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fine for the work.

I don't really care about the

text so if I want to I can crop it

using Gimp. It's fine for my

purposes, so I'll leave it the way it

is. The good thing is that we have

to model just a clover. An easy task

for bezier curves.

So start a new project, remove

the cube, and have a Front

Orthographic view on your 3d view

window.

One powerful tool is the ability

blender gives us to have as a

blueprint an image at the

background, for easy modeling.

Press N-key to toggle

hide/unhide the right side panel

(properties panel) at the 3d view

window. Leave it unhide, scroll it

down, and “tick” the Background

Images

Press the Open button and

navigate to the location that you

downloaded the image. Select and

open that image.

The image appears at the

background. You can alter some of

its properties (the transparency or

the position, for example) from the

panel that appeared just below the

open button that we pressed

earlier.

Tip: The background images are

visible only at orthographic view

and only at precise angle (front,

left, top etc). At a later stage, I can

show you techniques to handle

images as 3d objects viewable

from any angle and any view.

Now, add a Curve-->Bezier.

Press Tab-key to go to edit mode

and using the Ctrl+LMB to add the

necessary control points, create an

outline of the clover as shown at

the image below. Use the handles

in order to create the curves that

you need:

After that, we don't need the

background image. Untick it at the

properties panel or press the X

icon just below and to the right of

the Add Image button.

Up to now, we have a two-

dimensional shape, and we have a

little more work to do for the third

dimension.

To be continued...

mailto:blender5d@gmail.com
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Last month, we created a clover

using Bezier curves and also

we used a background image to

model it. Now it's time to add the

third dimension of our model.

On the right, under the

properties window, select the

curve tab:

Scroll down and you will find

the Geometry panel. Enter the

value 0.2 to Extrude as shown in

the image below:

You can check the 3D view

window to observe that your

image starts to have depth.

Now, a very interesting thing is

under the Shape panel in the

properties window:

You can see that the 3D button

is selected. Press the 2D button.

Under Fill, select Back. Your model

“filled” in the back. Now select

Front. As you may have expected,

your model “filled” in front. As you

can guess, if you choose None,

nothing is “filled”. Let’s select

Both.

Now you have a solid 3D model

– as you can see in the 3D view

window.

Lets tweak it a little. Under the

Geometry panel that we

mentioned earlier, you have a

Bevel parameter. In Depth, enter

the value 0.03, and in Resolution

enter 2 as the value. You can alter

the Depth parameter if you want

to Bevel the edges of your model

more or less. For me 0.03 is fine.

Now it is time to add materials

to your model. Refer to earlier

issues of Full Circle Magazine if you

don't remember how to add

materials. My favorite material is

glass, so I gave a green glass to my

clover. Also, add a white plane as a

background to have a better visual

result.

Next month, we will introduce

text. We will add text to our image

that we created this month, but

also we will examine a technique

to create interesting stuff with our

model using a very interesting

modifier. Stay tuned!

On the 3rd of November,

www.blender.org changed its

looks. So, I don't have to suggest

another site. Explore the new site

and have fun!

http://www.blender.org
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T his month we are going to have

some fun with text in Blender.

So, start up blender and delete the

default cube (select the cube, press

X, and confirm the deletion). Now,

press the A-key to add a new

object in your scene. Add text (see

image below)

The first thing that you notice is

that, for some reason, blender

adds text object facing the top

view. I prefer to change that to

face the front view so let’s rotate

our text object 90 degrees on the

X-axis (Press R-key, then X-key, and

then press 90).

Now, using the num-pad, press

1 for front view and 5 for

orthographic view. You must have

something like the image below.

Now that we have a better look

of our text, let’s change it. Press

the tab-key to enter the edit mode.

Change the default “Text” to “Full

Circle Magazine”. Exit edit mode by

pressing the tab-key again. Great!

But we have a very boring text

(although it says “Full Circle

Magazine”) . With your text object

selected, examine the properties

window. Select the tab with an F as

an icon to reveal some interesting

stuff about our object.

First of all, change the name of

our object from the default “Text”

to “FCM”. Then, change the

extrude value under Geometry to

0,2. You don't see any difference to

your text. But, if you rotate your

view (by holding the middle mouse

button and moving your mouse, or

by pressing 2,4,6 and 8 on the num-

pad), you can see that we extrude

our text. Great!

Also we can adjust the depth of
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our bevel factor.

Change the value of Depth to

0,05 and the Resolution to 1 0.

Ok. Now we are going to change

the Fonts.

Press the file icon (the icon

between F and X), and navigate to

your Fonts folder. Select the font

of your desire. I choose Isabella

(search the repositories for

ubuntustudio-font-meta package).

The Geometry values that we

changed earlier are not suitable for

this font. I ' ll make extrude = 0,05

and Bevel = 0,02.

Ok, now let’s add a box and

rotate, scale, move it. Also use

textures! It will be easy to create

something like the image below.

To be continued...

mailto:blender5d@gmail.com
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L ast month we created a text

object, and we manipulated it

(rotate, scale etc.) Now let’s see

some other adjustments that

blender gives us.

On the right, under the F tab,

we have as you remember from

last month, all the good stuff to

alter our font object. We will stay

with the basics for now, although

blender giving us many tweaks. So,

under Font, we have Size and

Shear. You can make your text

bigger or smaller by altering the

size value, and you can shear your

text to the left by giving a negative

value to Shear or to the right with

positive values.

Also, under Shape, you can

change the resolution of your text

object or the Fill of your text.

Experiment with these and you’ll

understand them better than I can

explain to you.

Now, lets start a new project to

examine something else (I will

explain later why we have to create

a new project for this example).

Don't delete the cube, just move it

a little and add a new text object

by pressing Shift-A ! Text or by

the menu under the Add button

(you know these things by now!).

Rotate the text object to face the

front view, and increase the

extrude value under the F tab to

0,5. Move your objects (text and

cube) until you have something like

the image below:

It is critical for our example that

the two objects intersect.

Now, it is time for something

interesting. With the text object

selected, press Alt-C. From the

menu that pops-up, select Mesh

from Curve/Meta/Surf/Text.

Something very interesting just

happened. Blender created a mesh

object that you can manipulate just

like any other object. Press the tab

key to enter edit mode, and see for

yourself what I am talking about.

The reason that I converted the

text object to a mesh object is to

use a modifier that I really like and I

want to challenge you to

experiment with – the boolean

modifier. So, let’s select our cube

and select the modifier tab.

Add a new modifier called

Boolean.
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Under the Operation choose

Difference, and under Object

select your Mesh object that you

created from Text (I didn't rename

it so it's called “Text”) . Then hit

Apply.

After a while, depending on

your machine's power and memory,

the boolean operation will be

completed. Now, if you move the

text or the cube you can see what

we created.

Blender has calculated the

difference between the two mesh

objects and cut-out the object on

which we applied the boolean

modifier.

If we had tried it with a more

complex object, such as the ‘Full

Circle Magazine’ text (with an

elegant font and with the curves

that we had applied), blender

would have crashed. That’s why,

for our example, we used a much

simpler text object. Also, the

convert-to-mesh command would

have been more demanding for

blender to handle.

But, the boolean modifier is

very useful and very light – if you

have simple objects as cubes or

pyramids, for example.

For this month, I would suggest

http://gooseberry.blender.org/. It

is a new project that the blender

institute has just started.

Next month, we will continue

with text, but this time we will

introduce a little bit of movement

called animation. We will try

something like the Star Wars

introduction: “A long time ago in a

galaxy far, far away...”

Enjoy!

mailto:blender5d@gmail.com
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