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The LibreOffice Golden Jubilee Edition...

We continue our assembly of Elmer Perry's LibreOffice series in this

Jubilee Compilation.

Here is a special reprint of the series 'Libre Office', Parts 1 -50 from

issues #46 through #98, which the observant among you will note is

not an unbroken run. Fear not, you are missing nothing: Elmer took a

couple of issues off.

Please bear in mind the original publication date; current versions of

hardware and software may differ from those illustrated, so check

your hardware and software versions before attempting to emulate

the tutorials in these special editions. You may have later versions of

software installed or available in your distributions' repositories.

There was a slight problem with Part 32 - Issue 79 which is

explained in Appendix 1 .

Enjoy!
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I
n this how-to, I will introduce

you to the LibreOffice suite,

and give you a description of

each of the modules in the

suite. As we go through the series, I

will go into greater detail on each

module of the suite, as well as

ways to share information between

the modules.

LibreOffice is slated as the

default office suite for Ubuntu

1 1 .04, and the suite contains

several modules that allow you to

create text documents,

spreadsheets, presentations, and

drawings. The suite is multi-

platform, and available for Linux,

Windows, and Mac OS. The suite

allows you to save and read

documents in the default Open

Document Format (ODF), as well as

several versions of Microsoft

Office, rich text format (RTF), and

DocBook. This feature alone makes

it a great suite for both the home

and office.

One of the most powerful and

useful features of the suite is the

ability to create a PDF file from the

current document. Exporting to

PDF gives you greater control over

a finished document. The recipient

can easily change a file in the ODF

or Microsoft Office format.

However, the PDF format makes

tampering with the document

more difficult. You’ll find the

Export or Export to PDF in most of

the modules under File > Export or

File > Export to PDF.

Start LibreOffice from the

Applications menu: Applications >

Office > LibreOffice. With no

HHOOWW--TTOO
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If you can't wait until April to try LibreOffice in

Ubuntu, you can install it through the PPA. Type the

following three commands in the terminal

(Applications > Accessories > Terminal) :

sudo add­apt­repository ppa:libreoffice/ppa

sudo apt­get update

sudo apt­get install libreoffice

The last command may take a while to complete. On my system, I had

to completely remove OpenOffice before LibreOffice would install

from the PPA. Not sure if this glitch was specific to my machine or if it

is impossible to have both installed using PPAs. If you want to use

both OpenOffice and LibreOffice, your best choice is to install them

manually by downloading them from libreoffice.org and

openoffice.org.

[Editors note:When I installedLibreOffice from the above PPA it

automaticallyuninstalledmyOpenOffice.]

NEW
SERIES!
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documents open, LibreOffice

displays the Welcome screen. The

Welcome screen gives you quick

access to the different modules in

the suite.

Text Document opens the

Writer module. Writer is a full-

featured word processor. You can

write everything from a simple

letter to a novel in Writer. With the

Writer word processor, you can

create layouts for term papers,

technical documents, and product

or software documentation. Writer

sometimes has problems

translating complex layouts from

Microsoft Word's format, but, as a

general rule, you will not have

many problems.

Spreadsheet runs Calc. Calc is

compatible with Microsoft Excel.

Calc allows you to create a

spreadsheet with automatic

calculations and formulas. You can

also use Calc for data collections to

import into other documents. With

Calc, you can add graphs and charts

to display your data and

calculations visually. Tables,

graphs, and charts from Calc are

easily imported into other

LibreOffice documents. Calc gives

you the ability to have more than

one spreadsheet in one document,

allowing you to have monthly,

yearly, or other related

spreadsheets in one document.

Presentation opens Impress.

Impress is LibreOffice's version of

Microsoft's PowerPoint, and holds

up nicely as a replacement for

PowerPoint. Impress has all the

features you would expect from a

presentation program: slide

transitions, object embedding,

sound, text effects, graphics, etc.

I 've used Impress for teaching and

seminars, and Impress always gives

me what I need.

Drawing starts the Draw

module. In Draw, you create simple

vector drawings for use in other

documents. You could easily make

a organizational chart or logo in

Draw.

Database opens the Base

module. Use Base to create a

database using several different

engines, depending on what is

installed on your system. Base is

handy for importing data into

other documents in the suite. If

you have a need for an inventory or

sales database, you might want to

give Base a try.

Formula runs the Math module.

Have you ever needed to embed a

complex math formula into a

document? Formula is your answer.

Formula gives you the power to

create well-formatted formulas for

use in other documents. Formula is

ideal when you are creating

scientific or technical documents,

and need to insert a formula or

algorithm along with your text.

Before we get started with

LibreOffice, let's look at some of

the options that relate to all the

modules. Open Tools > Options >

LibreOffice > User Data. Here you

enter what personal data you want

to make available to the program.

You can transfer some of the

information entered here into

documents. Some of the document

properties come from the data in

these fields. For example, the

document author is taken from the

name fields. The program also uses

the name fields for revision

authors.

Next, if you are new to

LibreOffice, access Tools > Options

> LibreOffice > General, and check

the Tips and Help Agent. While you

learn LibreOffice, you might want

to turn on extended tips. Extended

LIBREOFFICE - PART 1
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“
If you need to

always save in one
of the Microsofts
formats, you can set
LibreOffice to do
this automatically...

tips will show a detailed pop-up

balloon for every item as you move

the mouse over it. Without

Extended tips, you get a two or

three word description for toolbar

buttons only. With the Help Agent

on, a help box occasionally displays

in the bottom right corner. Clicking

on the box will take you to the

documentation page for the

current task. This greatly speeds up

the learning process with

LibreOffice. The Help Agent is

similar to Microsoft's Office

Assistant.

Now, Tools > Options >

Save/Load > General. Here you can

set the default format for different

document types. If you need to

always save in one of the Microsoft

formats, you can set LibreOffice to

do this automatically rather than

having to always select the needed

format. Select the document type

LIBREOFFICE - PART 1
from the drop-down box under

Document Type. Select the default

format for the document type

under Always Save As drop-down

box.

Under Tools > Options >

Language Settings > Languages,

you set up your language options.

There is a check box under the

language settings that allow you

to change the options only for the

current document. Language

Settings > Writing Aids sets

options for dictionaries, spell

check, and hyphenation.

Feel free to browse the rest of

the options. We will touch on the

options for each module as we get

to it. Next time, we will begin with

the basics of using the Writer

module.
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In my last article, I introduced

you to the different modules of the

LibreOffice program. Today, I want

to show you the basic setup and

manual formatting methods for

the Writer module. The Writer

module allows you to create

formatted text-based documents.

You can use Writer (below) for

something as simple as a letter or

journal, or something as complex

as a manuscript or thesis paper.

First, we will look at the Writer

window. Starting from the top, you

have the menu bar. The menu bar

gives you access to all the different

tools and actions you can perform

on a document. Below the menu

bar sits the standard toolbar. This

gives you quick access to common

commands such as open, save, and

print. Beside the standard toolbar

sits the search toolbar. Below the

standard toolbar, you find the

formatting toolbar - it displays

icons for often-used formatting

tools. The toolbar is context-

sensitive, and will change when you

are working with elements like

drawing objects. If you have tips

turned on, hovering the mouse

pointer over the icons in the

toolbars will show a pop-up

description of what the icon does.

Below the formatting toolbar,

and to the left, you have the

horizontal and vertical rulers. The

rulers are guides to help you when

laying out a document. By default

for the English language, the rulers

display in inches. There are two

ways to change the measurement

units of the rulers. Right-click

anywhere on the rulers (shown

left) , and Writer displays a pop-up

menu of the different

measurement units. This method

works best when you need the

change just for the current

document. However, if you need a

different measurement unit as the

default, you need to change it in

the Options. Go to Tools > Options

> LibreOffice Writer > View. Here

you can set the defaults for the

vertical and horizontal rulers, or

chose to work without rulers.

Now, we will create a simple

letter, and I will show you how to

manually format the different

paragraphs of the letter. Open

LibreOffice and start a new Writer

document. We will place the

current date at the top of the

document, and align it to the right.

Go to Insert > Field > Date. This will

give you the date in the default

date format (MM/DD/YY). You will

notice the date highlighted in gray.

This lets you know it is a field you

have inserted into the document.

Let's change the formatting of

our date. Double-click the date,

and a dialog window (above) will

display showing the different

options for displaying the date.

Select the one you want and click

OK.

We need to right-align our date,

so, find the alignment icons on the

formatting toolbar, and click on the
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right-align icon. Our date will move

to the right margin. Use the End

key on your keyboard to move to

the end of the current line, and

press Enter. We don't want to stay

right-aligned for a new paragraph,

so click the left-align icon to move

the start of the paragraph back to

the left. Type in your salutation

and press Enter.

For the body paragraphs of our

letter, we want to indent the first

line of each paragraph. When you

are not concerned with accuracy,

you can apply the indentation

using the horizontal ruler. On the

horizontal ruler, you will notice

two triangles on the left margin

(above left and right) , one pointing

up and the other pointing down.

The bottom triangle - the one

pointing up - manually adjusts the

left indent for the entire

paragraph. You will note there is

one just like it on the right, which

is used to adjust the right indent

for the paragraph. The top

triangle on the left - the one

pointing down - adjusts the

paragraph’s first-line indent. Click

on the top triangle and drag it to

about 0.5” (1 .27 cm).

If you need more accurate

indents, you can access the

paragraph style dialog (below left)

by double-clicking on the gray

part of the horizontal ruler. You

can also access the paragraph

style dialog by going to Format >

Paragraph. Here you have many

options for formatting your

paragraph. Today, we are

concerned with only the first line

indent, so change First line to 0.5”

(1 .27 cm). Click OK. You will notice

the top triangle (first-line indent,

shown below) has changed to the

position you gave it in the dialog.

Now, we can type our

paragraph. Type in your first

paragraph, and press Enter.

Notice that the next paragraph is

indented just like the previous

one. Writer will use this paragraph

style until we tell it to do

differently.

Once we have typed the body

of our letter, we need to add a

signature block, but we don't want

our signature block the same as

the rest of the body paragraphs.

Using either the drag method or

the paragraph style dialog, change

the indent to 3” (7.62 cm). Now,

type in your closing and press

Enter. Rather than typing in your

name, let's use the name field to

insert your name. This will work

only if you filled out the User data

in the options: Insert > Fields >

Author. Your letter is now done,

and you can print and send it.

While manual formatting is

okay on small documents, larger

documents need more control. If

you decide to change the

formatting of paragraphs on a

larger document, going through

each paragraph and changing the

style is tedious. In a larger

document, we will need a way to

change all like paragraphs at once.

Next time, we will talk about using

styles to accomplish this.
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I
n my last article, I wrote about

changing the layout of

paragraphs to format your

document. While this

approach is okay on short

documents, it creates a lot of work

should you decide to change

something in a large document.

This is where the use of styles will

make things easier.

LibreOffice writer has five

different style types: paragraph,

character, frame, page, and list.

You can access all the styles by

clicking on the Styles and

Formatting button on the

formatting toolbar. This will pop up

the Styles and Formatting window.

You can dock the Styles and

Formatting window on the left by

holding down the Ctrl key and

double-clicking the empty space in

the Styles and Formatting window

toolbar.

The styles toolbar (right)has

seven icons. The first five give you

access to the different style types.

In order from the left, they are

paragraph, character, frame, page,

and list. We will concentrate on

paragraph and character styles in

this article.

Open a new text document and

type in a title. Open the Styles and

Formatting window. The paragraph

icon should be selected by default.

At the bottom of the Styles and

Formatting Window is a drop-down

box. Click on the box and select

Chapter Styles. Double-click “title”.

Your title will center, enlarge, and

become bold. Now, let's change the

default styling for titles. In the

Styles and Formatting window,

right-click on the “title” style and

select modify. The dialog that pops

up looks a lot like the dialog from

the last article, but there are a few

new tabs that are not in the

standard paragraph dialog. The

first is the organizer. The organizer

(below) shows you the name for

the style, the next style to use, and

the linked style. You will see that

the next style is “subtitle”, but we

don't want to use a subtitle, so we

will change this to the “text body”

style. This makes it so that when

we hit Enter to start a new

paragraph the next paragraph will

use the “text body” style. The

“title” style is linked with the

“Heading” style. When styles are

linked, any changes to the parent

style affects the styles linked to it.

As an example, if you change the

text in the “Heading” to blue, all

the styles linked to it will have blue

text as well.

Now, let's format our title

differently from the default. Click

on the Font Effects tab. The Font

Effects (next page, top left) allow

you to change the look of the font,

including color, strike-through,

underline, shadow, and relief. The

dialog shows you how the effects

make your text look. Change the

color to blue, underlining to

Double Wave, and underline color

to blue. Click OK.
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Press Enter to start a new

paragraph. Notice the style

changed to “text body” just like we

set up in the organizer tab. Now,

type in three paragraphs of text to

use for our example document.

Next, we will modify the “text

body” style and create two new

ones based on the “text body”

style. Back in the Styles and

Formatting window, click the drop-

down box and select the Text

Styles category. Right-click on

“text body” and select modify. On

the Indents & Spacing tab, change

the line spacing to 1 .5 lines, and

the First Line to 0.50. Click OK.

Notice that our changes affected

all three paragraphs.

Now, let's create a paragraph

for long quotes. Move the cursor

to anywhere in the second

paragraph. In the styles window,

right-click text body and select

New. On the organizer tab, give it

the name of “Blockquote.” Change

the next style to “text body”, as

we rarely have two long quotes in

a row. You will notice that because

we created the new style by right-

clicking on text body, it is

automatically linked to “text

body”. To create a new style not

linked to another, change the

Linked with to “None”.

Now, let's change the

formatting of our new style. On

the Indents & Spacing tab, change

the “before text” and “after text”

to 0.50. Change the First Line back

to 0.00. On the Font tab, change

the typeface to italic. Click OK, and

you will notice a new paragraph

named “Blockquote” has been

added to your list. Again, move

your cursor to anywhere in the

second paragraph and double-click

“Blockquote.” Now, you will see

the first line indent has been taken

away, the paragraph is indented on

both sides, and the text is

italicized.

Now, we want to change the

first paragraph, giving it some

drop caps. Since we want the first

paragraph of each chapter to look

this way, we will create another

style. Again, right-click on “text

body” and select New. Name the

new style “First Paragraph”, and

change the next style to “Text

Body.” On the Indents & Spacing

tab, change the First Line back to

0.00. On the Drop Caps tab (shown

below), check “Display drop caps”,

set “Number of characters” to 1

and set “Lines” to 2. Click OK.

Again, no changes are seen yet.

Move your cursor into the first

paragraph and double-click your

new style.

We need this new paragraph

style to follow every new chapter
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title. Modify the “title” style so the

next style is “First Paragraph.”

Character styles affect only

selected text rather than entire

paragraphs. In the third paragraph,

select some of the text. Click on

the character style icon in the

styles window, and double-click

“Emphasis.” This will italicize the

text you have selected. You can

modify the character styles much

in the same way you do the

paragraph styles.

The key advantage to styles is

making the formatting of like text

the same throughout a document.

In the next article, we will talk

about adding frames to your

document.
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I
n the last article we used

paragraph styles to format our

document by creating

reusable styles for consistency

in our document. In this article we

will create a more advanced layout

using frames. While there are

programs, like Scribus, which are

designed more specifically toward

more advanced layouts,

LibreOffice gives us several tools

which allow us to produce

documents with more than just a

simple, letter-style layout. One of

the most useful of these tools is

the frame.

You can think of frames as

boxes used to control the flow of

text, graphics, and other elements

in your document. One of the key

features of frames is their ability to

link together. When two frames are

linked, the text from one frame

automatically flows into the other,

even if the two frames are on

different pages. This feature makes

frames ideal for newsletters and

other article-based documents.

We will create the beginning

article layout, shown in figure 1 ,

using frames to control the flow of

the article text. Start by creating a

new document. Now, in the menus,

go to Insert > Frame. The frame

dialog will pop up. On the type tab,

check Relative for both Width and

Height. Set the Width to 1 00% and

the Height to 25%. In the position

section, set the Horizontal to From

Left by 0.00” to Paragraph area. Set

the Vertical position to From Top

by 0.00” to Margin.

On the Options tab, name the

frame “Article Header.” The frames

are automatically named using the

format “Frame#” where # is the

number of frames in the document.

It is a good practice to give your

frames meaningful names to help

you remember their purpose.

By default, frames have a

border on all four sides, but we

want a border only at the bottom

of our frame. On the Borders tab,

select the first box under the Line

Arrangement defaults. This will

HHOOWW--TTOO
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clear all the borders. Check at the

bottom of the the User-defined

box to create a bottom border.

We are now done with the

setup of this frame. We will come

back to it when we are ready to

link our frames together. For now,

click on OK. You will see your new

frame in your document.

Now, let’s create a frame for

the bottom half of the article.

Click below the header frame.

Once again in the menus, choose

Insert > Frame. Again, we want a

relative width and height. Set the

width to 1 00% and the height to

75%. Set the horizontal position to

From Left by 0.00” to Paragraph

area. On the Options tab, name the

frame “Article Body.” On the

Borders tab, clear all the borders.

Now, we need the body of our

article to have two columns. This is

done on the Columns tab. Change

the number of columns to 2, and

set the spacing to 6%. Click on OK,

and your new frame appears. You

may need to manually adjust the

position of your frames to get

them to line up correctly. You

adjust the frames position by

clicking on the border of the

frames. You will see green handles

appear on the border. The green

handles are used to adjust the size

of the frame. We shouldn't need to

change the size - just tweak the

position. Click and drag on the

border where there are no handles

to adjust the position of the

frames. To make fine adjustments

to the position of your frame use

the Alt+Arrow keys.

We now have our frames where

we want them. Before we start

writing our article, we need to link

the two frames together. Double-

click on the border of the header

frame (the first frame we created).

This displays the frame dialog. On

the Options tab, click the drop-

down box for next link and select

the “Article Body” frame. This links

our two frames together. Click OK

to accept this change and return to

the document.

In the document, click inside the

header frame. Format a title and

byline using any of the methods

discussed in previous articles. Now,

begin to type the paragraphs for

your document. You will notice

that when you get to the bottom

of the first frame, Writer will

automatically move you to the

lower frame, and when you reach

the bottom of the first column,

writer will take you the top of the

second. If your article is more than

one page long, you could link

“Article Body” frame to a frame on

another page. This linking is a

powerful way to control the layout

and flow of an article to create a
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very professional looking

document.

Let's add a graphic to our

header frame: Insert > Picture >

From File. Select the graphic you

want to insert, and click Open. If

the image is too big for your

document, you will want to resize

it. To keep from distorting the

image, hold the Shift key while

dragging the handles. To put the

image into the frame drag it to the

lower right corner of the frame,

right-click, and Anchor > To Frame.

Double-click the image to bring up

its properties dialog. On the Wrap

tab, increase the left spacing to

give the image some white space.

Graphics in LibreOffice are

actually frames. When you double-

click on a graphic in a document,

you get a frame dialog with two

new tabs: Picture and Crop. On the

Picture tab, you can flip the image

vertically or horizontally. You can

specify whether the flip happens

on just certain pages or on all

pages. On the Crop tab, you can

adjust the left, right, top, and

bottom to crop out certain parts of

the image. This is handy when you

need only a part of the image, or

need to force the image to a

certain size without distorting the

image’s aspect ratio. Also, you can

scale the image to a certain size

based on a percentage of the

original image size. You can see or

change the image size by

measurement units as well.

On the right-click menu of an

image, you can add a description or

caption to the image. Adding a

caption creates a text frame around

the image with the text at the

bottom. This feature is useful for

marking illustrations or diagrams in

your document. Once you have

created the caption, you can

highlight it and format it just like

you would any other text in a

document.

Hopefully, you have gotten

some idea of the power of using

frames. While our example was

fairly simple, you could easily create

a more complex document layout

using frames. With the ability to link

frames, you can create a newsletter

layout where articles start on one

page, jump to another, and end on

yet another.

Next time, we will look at

another powerful layout feature

available in LibreOffice Writer:

Sections.
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I
n the previous part of this

series, we discussed using

frames for document layout. In

this part, we will turn to

another useful layout tool in

LibreOffice Writer: Sections.

Sections differ from frames in

several respects, but, in some ways,

they can achieve the same results.

While both will allow you to divide

a portion of your document into

columns, when you use sections,

you have no control over the width.

Sections will take the entire width

from the left margin to the right

margin. Sections also cannot break

in the middle of a paragraph. You

cannot link sections together the

way you link frames. While you

cannot link sections together,

sections give you the ability to link

to other documents, or to a section

in another document.

Perhaps the best way to think

about sections is as a way to divide

your document into different

pieces like introduction, argument

1 , argument 2, etc. Sections can

also allow you to separate a

portion of a document for use in

another document. Sections can

become a powerful tool for

allowing you to pull content from

other documents.

Using Sections

For our example, we will import

quotations from a document of

quotes. Start a new document, and

add a list of different quotes. Do

the following for each of the

quotes:

Select the entire quote.

On the menus, got to Insert >

Section.

Give the quote a name that will

remind you what the quotation is

about. (For example, one of my

quotes is from Albert Einstein on

science. I named it quote_science.)

Once you have made each of

the quotes its own section, save

the file as quotes.odt.

Next, let's create a new

document, and add some

paragraph body text. (Hint: You can

add dummy text to your document

by typing “dt” and pressing the F3

key.) Write a lead-in to your quote,

and press enter. To get our quote

from our quotes document, Insert

> Section. As always, give the

section a name that helps you

remember what it is. Select the

Link checkbox. Click on the file

browser button (…) next to File

name. Select the document

containing your quotes, and Open.

Use the Section dropdown box to

select the quote you want to insert

into your document. If you want to

write-protect your quote from

editing, check Protected under

Write-protection. You can also

protect the section from editing

with a password. (NOTE: Write

protection, even with a password,

does not guarantee someone

HHOOWW--TTOO
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thing to remember is changing a

linked section in a document will

not be reflected in the original

document, but changes in the

original document may be reflected

in the linking document.

You can control how updates

are done in the LibreOffice Writer

options: Tools > Options >

LibreOffice Writer > General. Under

Update, you can choose to have

links updated automatically,

manually, or never. Automatically

will update the links when a

document with links is opened.

Manually will ask you whether you

want to update links. Never will not

update links when a document with

links is opened.

Manually Updating
Links

LIBREOFFICE - PART 5

cannot hack your document and

change its content.) You can add

the other quotes from your quote

document using the same method.

Editing Sections

Now that we have added our

quotes, let's make them stand out

by indenting them and giving them

a background color. Format >

Sections. The edit Sections dialog

presents you with a list of sections

in your document. Select the

section you want to edit. In the

main window of the dialog, we can

change the link document, or the

section in the document the

section is linked to. Here we can

also change the write-protection

and visibility of the section. (I can't

think of any practical reason why

you would hide a portion of the

document, but the option is there

should you need it.)

Click the Options... button to

bring up the options dialog. On the

Indents tab, change the Before

section and After section to 0.30”.

On the Background tab, select a

color for the background of your

quote. Click OK. Change the other

quotation sections, and then click

OK on the Edit Sections dialog.

Your quotes now have an

indentation and a background

color.

Changes Made in
Linked Document

If you need to change the

information in a section linked to

another document, you might ask

whether it is better to change the

original document or within the

new document. Both are possible.

The choice is really yours. The one
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If you make changes in the

original document, and you want to

update the linked document to

reflect those changes, you have

two ways to update the linked

document. Edit > Links... will

display the Edit Links dialog. Here

you can select individual links and

update them. To update all the

links at once, use Tools > Update >

Links.

Frames or Sections?

In some cases, whether you use

frames or sections matters little.

There are situations where either

can accomplish the tasks. However,

taking the time to consider the

functionality of each can help you

make the best choice. For example,

if you are doing a research paper,

and you have compiled your quotes

and data into a Writer document,

sections would probably be your

best choice for inserting pieces of

the data into your paper. However,

if you need to start an article on a

page, skip a page, and finish it on

another page, linked frames is a

better choice. Taking some time to

think about the purpose, layout,

and content sources of your

document, and the functionality of

frames and sections, will help you

decide the best tool for your

document.

While frames and sections are

similar in many ways, they have

different functionality that makes

them suitable for different

purposes. The powerful ability to

link to portions of another

document makes sections unique.

Remember to plan your layout and

decide ahead which tools you will

use to accomplish the task.

In the next article, we will

look at page styles, headers, and

footers in Writer documents.

Z e r o D o w n t i m e
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I
n this month's article, we will

discover a few new ways to

format our documents using

page styles, headers and

footers. In past articles, I have

discussed the use of paragraph and

character styles. Page styles are

similar, but deal with the overall

geometry and formatting of the

entire page. Headers and footers

are the area at the top and bottom

of the page, and are usually the

same on every page of the same

style.

We will start by setting up our

document and styles. Start a new

writer document, File > New. In

order to have access to the

document's title, we will change

some of the document's

properties, File > Properties. On

the description tab, put “This Is The

Title” as the title of the document.

We will use this later when we start

creating our headers and footers.

Click OK to save your changes.

Now, we need to set up our

page styles. We will use three page

styles, First Page, Normal Page, and

Landscape. First Page and

Landscape already exist, but we

will modify them. We will create

our Normal Page style first. For our

normal page style, we want a

header area at the top with a light

gray background. Open the Styles

and Formatting dialog, Tools >

Styles and Formatting, or click on

the Style and formatting

button (right). Click on the

page styles button (right) ,

right-click in the window, and

select new. The Page Style

dialog appears. On the

Organizer tab, name the

style “Normal Page.” Change the

next style to Normal Page. This

tells Writer that when we get to

the end of the page, it will create a

new page with the same style. On

the Header tab, check Header On.

This inserts a header area on the

page. Still on the Header tab, click

the More button. A new dialog

comes up. This dialog allows us to

add borders and background colors

to our header. On the Background

tab, pick the light gray color for the

background. Click OK on both

dialogs, and we are finished with

our Normal Page style.

For our First Page, we will

modify the one that already exists.

We want a 3” (7.5cm) margin at the

top (for first page graphics added

at another time), and a light gray

footer area at the bottom. Right-

click the First Page style in the

Styles and Formatting dialog, and

select modify. On the organizer

tab, make our Normal Page the

next style. The Page tab allows us

to change the margins for the

page. Make the top margin 3”

(7.5cm). This time we will go to the

footer tab, check Footer On, click

on the More button, and choose

our light gray background.

For our Landscape page style,

we will modify the existing

Landscape style. For our Landscape

style, we will add both a header

and footer. Right-click on the

Landscape style and modify. Take a

few moments to look at the page

tab and notice the orientation for

the page is landscape, which is

exactly what we wanted. Turn on

the header and footer on their

respective tabs, and select the light

gray background for both.
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“
Writer makes it easy

to add pages with
different styles and
orientation, as well
as automatic
headers and footers.

Now, we are ready to create our

document. Double-click the First

Page style, and the page in your

document will change to the

formatting we added. You will

notice the light gray footer area at

the bottom. Click inside the box to

edit the footer. We will first add

our title, Insert > Fields > Title. This

inserts the title we added in the

document properties. You can use

this method to insert the title of

the document anywhere you need

it. If you change your title later in

the document properties, you can

update all instances of the inserted

field with Tools > Update > Fields

or by pressing F9 on your keyboard.

Type “ Page “, remembering to put

spaces on either side of the word

Page, and insert the page number,

Insert > Fields > Page Number.

Move your cursor to the beginning

of “Page” and press the tab key on

your keyboard until the page

number is flush against the right

side of the footer area. Click out of

the footer area into the main body

of the page.

Once this is done, you can begin

to type in your text. Once you

reach the end of the page and a

new page is inserted, you will

notice it is formatted with the

Normal Page style with a header

area at the top. Fill in the header

information just like we did for the

footer of the first page. Make sure

you use the fields, especially on

the page number. The page

number field comes in handy when

we get to the third page. You will

then notice the header

information has been copied for

you and the page number updated

to reflect the current page.

Next, we will insert a Landscape

page. Before you get to a new

page, Insert > Manual Break. Select

Page Break, and under the style,

select Landscape. This will take

you to a new page with a

Landscape layout. Because this is a

different style from our Normal

Page style, we will need to fill in

our header and footer

information. This is handy should

you need different header or

footer information on some

pages, just insert a page with a

different page style. Once you

have completed your landscaped

page, create another page break

(Insert > Manual Break) with a

style of Normal Page. You will

notice your page numbering

continues, including the inserted

landscaped page(s) . If you do not

want the inserted landscape pages

included in the page count, you

can manually adjust the page

number in the Manual Break

dialog.

Writer makes it easy to add

pages with different styles and

orientation, as well as automatic

headers and footers. You can make

the headers and footers as big as

you want, and they can contain

whatever information you want to

put in them. Fields help keep

certain information consistent in

your document, and let you write

without worrying about page

numbers.

In my next article, I will move

away from Writer and show you

how to make a poor man's

database using a Calc spreadsheet.

After that, we will use our

spreadsheet to create a form

letter.

http://eeperry.wordpress.com
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U
puntil now we have

been working in

LibreOffice Writer, but

today we will step away

for just a second to do something a

little different. We're going to

create a poor man's database in

Calc and then return to Writer and

create a mail merge. This will give

you some ideas about how you can

use a spreadsheet as a database. In

order to do a mail merge, we need

to work with some sort of

database. We could create our own

in Base, but for a simple address

book, Calc is an easier solution.

We will start by opening

LibreOffice and clicking on

Spreadsheet. This will open Calc

with a blank spreadsheet. We

won't go into a lot of details about

the layout of Calc; we'll save that

for another day. What you do need

to know is that a spreadsheet is

laid out as a series of columns and

rows. The columns are labeled

above with letters (A,B,C,...) and

the rows are down the left side

labeled with numbers (1 ,2,3,...) .

When we use Calc as a database,

the first row must contain the field

titles for the database. These are

the database field headers. We will

put the following field headers in

the first row: Title, First Name, Last

Name, Street Address, City, State,

Postal Code, and Country. Each

field must be in a separate column

starting at column A, so put the

cursor in column A of the first row

and type in Title. You can use the

right arrow key on the keyboard to

move to the next column, and fill in

the rest of the fields.
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Addresses). The database you just

created is linked to the

spreadsheet. Any updates you

make to the spreadsheet will show

in the database. The only catch is

you cannot edit the spreadsheet

when you have Writer opened.

Basically, your spreadsheet

database can be the only

LibreOffice document open.

Otherwise, LibreOffice will open

the spreadsheet in read-only mode.

Now that we have created our

database, and registered it in

LibreOffice, we can use it to create

a mail-merge. Mail-merge is great

for sending form letters to

customers or prospects. The cool

thing is you can put any kind of

data you want in your database and

then use it in the letter. For

example, if you have a rewards

program for your customers, you

could have a field for points, and

include the points each

customer has earned in

the letter, but you

would have to type the

letter only once.

Click on the Data Sources icon

(shown left) , View > Data sources,

or press F4. This will display the

registered databases below the

LIBREOFFICE - PART 7

Starting with the second row,

we begin to fill in our data. Each

row is a record. Think of a record as

all the information on one person.

For our purposes today, you don't

need to worry too much if the data

is wider than the columns. If you

want to adjust the width of the

columns while you input your

information, just place your mouse

over the line separating the two

columns. The cursor will become a

double arrow, and you can click

and drag to increase or decrease

the width of the column. Once we

have entered all our data, we need

to save the spreadsheet. I saved

mine as Poorman_db.ods. Once it

is saved, close it.

Before we can use our poor

man's database, we need to

register it in LibreOffice. File >

New > Database will bring up the

database wizard. Select “connect

to an existing database”, and in the

drop-down box, select

spreadsheet. Click the Next

button. Use the Browse button to

find your spreadsheet. Click Next.

Make sure “Yes, register the

database for me” is selected, and

uncheck “Open database for

editing.” Click Finish, and give the

database a name (I named mine

formatting toolbar. In the left part

of the data sources, Addresses (or

whatever you named your

database) > Tables > Sheet1 . On

the right side, you will see your

data laid out much like you

entered it in the spreadsheet. We

insert the fields into the document

by clicking on the field header and

dragging it into the document. This

will create a field placeholder for

every field you drag into the

document. Make sure you drag the

field header and not a data block

in a record.

Now, you can type the body of

your letter. When you need a field

from the database in your letter,

you can drag it into the document.

The database fields can be used

any place in the document. As I

said before, your database can

contain whatever information you

need it to contain. A teacher could

even use it to report students'

grades in a letter to parents.

Once you have finished typing

your letter, you can print or send

to a file. You might want to send a
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letter to file when you need to go

back and add personal information

for certain individuals. Like a

teacher might want to request a

parent-teacher conference for a

student failing the class. File >

Print, just like you would for a

normal document. However,

LibreOffice will tell you that your

document contains address

database fields and asks you if you

want to print a form letter.

Answer yes. The Mail Merge dialog

will appear. In the dialog, you can

choose to print to the printer or to

a file. Also, you can choose to print

a letter only for selected records

or a range of records. You select

records by clicking on the gray box

at the beginning of the record, or

use CTRL-click to select only

certain records, or SHIFT-click to

select a series of records. When

you print to a file, you can choose

to print to one file, in which case

each letter will begin on a new

page, or save as individual files, in

which case each letter should have

its own file. You can select which

database field to use for the file

name. On my version of

LibreOffice (3.3.3) , I got one

document whichever I chose.

Apparently, they are still working

on this feature.

You can also use your database

to generate labels. File > New >

Labels opens the labels dialog.

Select your database and table.

Move the fields over into the label

information box. Select your label

type and click New Document. As

with the form letters, when you

get ready to print, you will have an

opportunity to select the records

you want to print, and you can

print to a printer or a document.

You can also create envelopes

much in the same manner.

There is another way to create

a form letter, using the Mail

Merge Wizard: Tools > Mail Merge

Wizard. The wizard has some

restrictions, and when I tried to

use the wizard, I found it more

difficult to get good results. I

found the manual method I have

described here to give better

results, giving the creator more

control over the output.

Mail merge is a great time

saver. Bang out your letter, drop

in some database fields, and print.

Sure beats typing 1 00s of letters

or manually editing each one to

change the information. In my next

article, we will start to learn more

about Calc by creating a simple

budget spreadsheet.

http://eeperry.wordpress.com


full circle magazine 23 Return to ContentsLibreOffice

HHOOWW--TTOO
Written by Elmer Perry LLiibbrreeOOffffiiccee -- PPaarrtt 88

C
alc is the spreadsheet

module of LibreOffice,

which is compatible with

Microsoft's Excel. We

already saw one use for Calc when

we created our poor man's

database in my last article, but Calc

is capable of more than just data

collection. As the name implies,

Calc can do calculations using a

rich number of functions built

into the program. This means

we don't have to manually

calculate the total of some

column; we can insert a

formula to add it up for us.

Calc also allows you to do a

“what if..” scenario to play

with the numbers in your

spreadsheet.

Before we get into building

our budget spreadsheet, you

need to know a few things

about how a file, sometimes

referred to as a workbook in Calc,

works. Each file can contain several

different spreadsheets. In a new

workbook, you get three

spreadsheets by default named

sheet1 , sheet2, and sheet3. They

are listed on tabs at the bottom of

the window. Each spreadsheet

consists of individual cells. You

identify the cells by their column

letter and row number. For

example, the first cell in the upper

left hand corner is A1 , the first

column, first row. Each spreadsheet

is capable of having 1 ,024 columns

and 1 ,048,576 rows.

The layout of the Calc window is

a little different than the Writer

window. You still have a menu bar

and formatting bar, but below the

formatting bar, you have the

formula bar. The formula bar is

your friend when you work in Calc.

The leftmost box is the current cell

name box. It tells you the currently

selected cell or range of cells. The

three buttons are the function

wizard, the sum button, and

function button. The text box is the

input line. Use it to edit the

contents of a cell.

At the top of your spreadsheet,

you have the column headers

(A, B, C...) , and along the left

hand side, you have the row

headers (1 , 2, 3...) . The

columns and rows are marked

on the sheet by light gray

lines. You will find this grid

handy when you are laying

out your spreadsheet.

You have several choices

in the way you enter data into

the cells. You can click on the

cell and just start typing.

When you have finished,

press enter and you will move to

the cell below. You can also click on

a cell and enter your data in the

input line of the formula bar. This

method has a drawback, which I will

explain in a minute, but sometimes,

it is the best method for editing

the content of a cell. You can edit

directly in the cell by double-

clicking the cell. This puts you in

cell edit mode. This mode is similar

to editing in the formula bar.

To navigate within your

spreadsheet, you can always grab

the mouse and click on the cell you

want. However, since often your

hands are already at the keyboard,

keyboard shortcuts work better.

Tab moves you one cell to the

right. Shift-Tab moves you one cell

to the left. Enter moves you one

cell down, and Shift-Enter moves

you one cell up. While not in edit

mode or not using the input line,

the arrow keys move you in the

direction of the arrow. The arrow

keys are disabled for navigation

while in the input line and in edit

mode to allow you to move within

your content.

Now, with these tools on your

belt, let's build the first section of

our budget spreadsheet. Open a

new Calc file. Click on the blank

gray spot to the left of the column

header and above the first row

header. This will select the entire
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sheet. In the formatting bar, set

the font to a nice sans-serif font

like Arial, and set the font size to

1 2pt. By doing this, we have set

the default font and size for our

entire sheet.

In cell A1 , enter the text

“Income for This Period,” and press

Enter. For now, don't worry if the

text overruns the cell. We will fix

that in a minute. On the second

row of column A, type in “Sources”.

Down column A starting with row

3, type in the different types of

income you have, e.g. Work,

Freelancing, Bonus. I usually add a

“Misc” for those things that don't

fit into other categories, like

winning the lottery and quiting

your day job.

At this point, some of your

income sources may overflow their

cells. We can adjust the width of

the column by clicking between

the cell headers for A and B and

dragging. We are still not

concerned with the cell A1 . At this

point, A1 's overflow is okay, just

make sure all your income sources

fit in the column.

Move to cell B2. Type in

“Amount”. Press Enter. Down

column B, enter an amount for

each of the income sources. You

will notice the default for numbers

is just some unformatted numbers.

Let's make them look like currency

amounts. We will change them all

at once. You can select all the

numbered cells by click with the

left mouse button and dragging

until you have all the numbers

highlighted. You can also click on

the first cell, hold down the Shift

ke,y and click on the last one. With

the keyboard, use Shift in

combination with the arrow keys.

Format > Cells > Numbers. Select

the Currency category. Above the

format box, select the correct

currency type for your country.

Select a currency format from the

format box. This is entirely up to

you. Since you should never have a

negative figure in your income

cells, you don't need to worry too

much about formats that deal with

negative numbers.

Now, we will take care of A1

overflowing into B1 . Since this text

is a heading for the section, we

want it to span across the width of

the section. Cell Merge is the

answer. Highlight cells A1 and B1 ,

and Format > Merge Cells > Merge

and Center Cells. We will use
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will give you a vertical line

between the cells. If you click in

the middle, it will create a vertical

and horizontal line, which is not

what we want. Change the color to

gray and click OK.

This completes the Income

section of our spreadsheet. In the

next article, we will continue with

our budget spreadsheet by adding

the Assets section. And we will

begin looking at making our

spreadsheet do some math for us

using the Sum function.

Elmer Perry is a children's minister in
Asheville, North Carolina whose
hobbies include web design,
programming, and writing. His
website is eeperry.wordpress.com
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merge cells a lot, and it should

become one of your favorite

formatting features.

Unfortunately, there is no

keyboard shortcut. You can create

one in Tools > Customize >

Keyboard, but take care that you

don't assign the keyboard

shortcut to a common or

predefined functionality.

Now, let's make it look like a

header. Let's make the font bold,

Format > Cells > Font tab. Select

bold under Typeface. Let's put a

border around it to make it stand

out just a little more. Click on the

Borders tab. Under Default, click

the second box, Set All Four

Borders. Leave the style at the

default, but change the color to

gray. Click OK.

With our Source and Amount

headings, we want them to stand

out as well, but they need to look

a little different to distinguish

them from the section header.

Select the two cells with Source

and Amount in them. Format >

Cells > Font tab. Select bold again.

Click on the Borders tab. This time

we just want a border between

the two cells. Click in the User-

defined box between the two gray

boxes with a white X in them. You

will see a line between the two.

Change the color to gray. On the

Alignment tab, change the

alignment for horizontal to center

and vertical to middle. On the

Background tab, select a light blue

(Blue 8) for the background color.

Click OK.

For our income items, we could

put a border around them, but that

can be hard to read sometimes.

Instead, let's highlight the even

numbered rows. Start with the

second item, highlight both the

name and its amount. Format >

Cells > Background tab. Select a

light gray for the background. I

used Gray 1 0%. Click OK. Repeat

for all the even rows.

It would be nice to have a

divider between the name and the

amount and a border around the

whole list. Click on the first name,

hold the Shift key, and click on the

last amount. This should highlight

all the items and their amounts.

Format > Cells > Border tab. Under

Default select the second box, Set

Outer Border Only. You will notice

the User-defined box is different

this time. There are four gray

boxes with white X's in them. Click

between the top two boxes. This

http://eeperry.wordpress.com


full circle magazine 26 Return to ContentsLibreOffice

HHOOWW--TTOO
Written by Elmer Perry LLiibbrreeOOffffiiccee -- PPaarrtt 99

I
n Part 8, we looked into

formatting our spreadsheet

cells to look a certain way, but

the true power of Calc comes

from its ability to calculate

formulas using basic math and its

built-in functions. Calc formulas are

just what you think, mathematical

expressions that use data to create

a result. Calc functions give us

predefined calculations and

decision making. With just a little

knowledge of formulas and

functions, Calc becomes a powerful

data analysis tool. When entering a

formula or function into a cell, your

formula or function must begin

with the = (equals) , - (minus) , or +

(positive) signs.

Arithmetic Operators

Calc has five basic arithmetic

operators:

+ (Plus) – add two numbers

together, or as a sign for a number.

Ex. =2+5 or +5

- (Minus) – subtract one number

from another, or negate a number.

Ex. =5-2 or -5

* (Asterisk) – multiplication. Ex.

=2*3

/ (Slash) – division. Ex. =21 /7

^ (Caret) – exponentiation. Ex. =5^2

Just like in real math, you can

use parentheses to group

expressions together to create

more complicated formulas. For

example, if you enter the equation

=5-2*3 in a cell, when you press the

Enter key, you get -1 for the result.

However, if you enter the equation

=(5-2)*3 in a cell, you get 9 for the

result when you press the Enter

key. This happens because Calc

obeys the rules of precedence. In

the first equation, the

multiplication is done first, as per

the rules, which gives us 5-6, which

equals -1 . In the second equation,

we change the order of operation

by using parentheses. In this case,

5-2 is calculated first because of

the parentheses, giving us 3, and 3

x 3 is 9.

Cell References

Hard coding our numbers

doesn't make much sense. We

could just use a calculator for that.

To unleash the power of Calc's

calculating abilities, a reference to

the data in our spreadsheet is

needed. Cell references allows us

to use the data within our

spreadsheet in our calculations.

Cells are referenced by the column

letter and row number. The first

cell of the first column is A1 , the

second cell of the first column is

A2, the first cell of the second

column is B1 , the second cell of the

second column is B2, etc. If we

enter 5 in cell A1 and 6 in cell B1 ,

we can enter the equation =A1 +B1

in any other cell in the spreadsheet,

and the result will show as 1 1 .

In some functions, you will need

to reference a range of cells rather

than just individual cells. To

reference a range of cells, start

with the first cell in the range,

followed by a colon (:) , and the last

cell in the range. To access the first

9 items in the B column, use B1 :B9.

To access the first 5 items in row 1

use A1 :E1 .

What if you need to reference

multiple rows and columns? You

just start with the first cell in the

block and end with the last cell in

the block. For example, to

reference all the cells in the first 5

columns and rows, you would use

A1 :E5.

Mathematical
Functions

If you need to sum a column of

numbers, using basic mathematical

operators could become laborious

very quickly. Calc provides many

functions for mathematic

calculations, from finding the sum

of given cells to trigonometry

functions. These functions speed

up your entry of formulas.

SUM() is the bread and butter of

mathematical functions. This

function is used so often, it has its

own button on the function

toolbar. SUM() can take up to 30

numbers or cell references

between parentheses. You can also

use range references with SUM(),

which allows you to quickly total a

column, row, or range of rows and

columns. Multiple numbers, cell

references, or range of cells are

separated by a semicolon (;) .

SUM() Examples
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=SUM(A1 ;C2;D5) – sum of the

three cells

=SUM(2;A1 ;C5) – sum the number 2

with A1 and C5

=SUM(A1 :A5) – sum the first five

cells in column A

=SUM(A1 :B5) – sum the first five

cells in columns A and B

=SUM(A1 :A5;C1 :C5) – sum the first

five cells in columns A and C

Calc provides many other

mathematical functions. See the

LibreOffice Calc documentation

for a complete list, including the

trigonometry functions.

Conditional
Calculations

Sometimes, you only want to

perform a calculation when certain

conditions are met. A good

example of this is avoiding division

by zero. If you try to divide-by-zero,

you get an error. The conditional

function IF() helps us accomplish

this. The basic syntax of the IF()

function is:

IF( Test; ThenValue; ElseValue)

So, if we want to divide A1 by

B2, but we want to avoid the

operation if B2 is zero, we could

use the IF() function:

=IF(B2>0;A1 /B2;”Can't div by

zero”)

This translates as “If B2 is

greater than 0, divide A1 by B2;

else, output the text 'Can't div by

zero'.”

Conditional calculations can

help you avoid errors in your

spreadsheets. Use them any time

you think problems might pop up,

like division-by-zero, or a number

not being entered.

ComparativeOperators

Calc provides six comparative

operators we can use in our test.

= (equal to)

> (greater than)

< (less than)

>= (greater than or equal to)

<= (less than or equal to)

< > (not equal to)

In addition to the comparative

operators, we can use the NOT()

and AND() functions in our test.

The AND() function allows us to

test more than one condition and

NOT negates the condition. This

time, let's make sure neither of the

numbers equal 0:

=IF(AND(NOT(A1=0);NOT(B2=0))

; A1/B2; “Can't div by

zero”)

In this formula, we make sure

than A1 is NOT zero AND B2 is

NOT zero before we do our

calculation. While this formula

shows both the AND() and NOT()

functions being used, a more

practical formula would be:

=IF(AND(A1>0;B2>0);A1/B2;”Ca

n't div by zero.”)

We have only begun to scratch

the surface of the possibilities

using Calc's formulas and

functions. Next time, we will take a

look at some practical uses for

some of these functions.

The Ubuntu Podcast covers all the

latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but aren’t

overly technical. We are lucky

enough to have some great guests

on the show, telling us first hand

about the latest exciting

developments they are working

on, in a way that we can all

understand! We also talk about

the Ubuntu community and what it

gets up to.

The show is presented by

members of the UK’s Ubuntu Linux

community. Because it is covered

by the Ubuntu Code of Conduct it

is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://podcast.ubuntu-uk.org/
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I
n part 8 of this series, we

began our work in Calc, and

created and formatted an

income section for a budget

worksheet. Last month we began

our discussion of functions and

formulas. In this part, we will

continue working on our budget

worksheet, and use formulas and

functions to do calculations in it.

Setting Up the Assets
Section

If you recall, we had set up a

section that contained all of our

income items in columns A and B.

We will begin our Assets section in

cell D1 . Move to that cell and enter

“Assets” in it. Select cells D1 -G1 ,

and merge and center the cells

(Format > Merge Cells > Merge and

Center Cells) . In cell D2, enter

“Type”. Merge and center this cell

with E2. Enter “Beginning” and

“Ending” in cells F2 and G2

respectively. In cell D3, enter

“Period Income Total,” and merge

it with cell E3 (Format > Merge

Cells > Merge Cells) . In rows D4-D9,

enter the following text in order:

Checking Balance, Savings Transfer,

Total Expendable, Savings Balance,

Retirement Balance, Gross Assets.

After entering the text in the cells,

go back and merge these cells with

their adjacent cell in column E (i.e.

merge D4 with E4, D5 with E5...) .

Initial Calculations for
Asset Section

In cell F1 , we will place our first

calculation using the SUM()

function. For this cell we need to

total the numbers of column B in

our Income section. Enter this

formula in cell F3:

=SUM(B3:B6)

This formula uses the SUM()

function to total the numbers

entered in cells B3, B4, B5, and B6.

If your Income section contains

more or less income items, adjust

the cell reference given to the

SUM() function. If you pull out a

calculator and add up the numbers,

you will find you get the same

number as the total calculated by

LibreOffice Calc.

In cells F4 and F5, enter

amounts for the Checking Balance

and Savings Transfer. In cell F6, we

will need to sum the three amounts

above for the Total Expendable

item, but this time, we will use a

different method. Select

cell F6 and click on the sum

button (shown left) in the

formula toolbar. You will notice

that LibreOffice automatically finds

the three amounts above and

creates a SUM() function formula

with the range inside. Press Enter

to accept the range.

Enter amounts for the Savings

Balance and Retirement Balance in

cells F7 and F8. Select cell F9, and

click the sum button in the formula

toolbar. Notice that, once again,

Calc has selected the two numbers

above it, but for an accurate total

of the Gross Assets, we need to

include the Total Expendable

amount. Left click and drag to

select the three cells. You should

now see the corrected range in the

SUM() function. Press Enter to

accept.

Setting Up the
Expenses Section

We will come back to the Assets

section to do some more
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where the total payments is

calculated.

For the ending balance on our

savings account, we need to take

the beginning total, add the

deposit, and subtract the transfer.

If you put the Savings as your first

item in the Expenses section, the

formula will look like this:

=F7+D13­F5

For the Retirement ending

balance, we just need to add the

deposit. If you added Retirement

as the second item in the Expenses

section, the formula will be:

=F8+D14

Finally

, we will

make the

final

adjustme

nt to the

Gross

Assets by

summing

the three

numbers

in the G

column.

Select G9,

and click
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calculations once we get the

Expenses section set up. In cell

A1 1 , enter “Expenses”. Merge and

center the cells A1 1 -G1 1 . In cell

A1 2-E1 2, enter the following text

in the cells: Type, Due, Amt Due,

Amt Pay, and Notes. Merge and

center the cells E1 2-G1 2. This

becomes our header row for this

section.

In cell A1 3, enter “Savings”, and

in cell A1 4 enter “Retirement”.

These two expenses will represent

deposits into these two accounts,

and we will use them in our final

calculations in the Assets section.

Beginning with cell A1 5, and going

down the A column, enter other

expenses like Food, Fuel,

Mortgage, Phone, etc. In columns

B and C, enter due dates and due

amounts for all the items you

entered in the Expenses section.

Select a few of the items and put

payment amounts in the D column.

Merge the E, F, and G rows for

each of the items.

Formulas in the
Expenses Section

In the cell below the last item

(column A), enter “Total

Expenses:”, and merge it with

column B on that row. Select the

cell in column C for that row. Click

the sum button in the formula

toolbar. Calc should select all the

amounts in the Amt Due column.

Press Enter. In the D column of the

same row, type “Total Payments”

and merge it with column E on the

same row. Select column F of the

same row and click the sum button

on the formula toolbar. This time

Calc jumps all the way up to the

last amount in our Assets section,

but this is not what we want. This

happens because this is the first

number Calc found in the column.

Select the numbers in the Amt Pay

column of the section to change

the range. Press Enter.

Final Calculations for
the Asset Section

Going back to the Assets

section, we will use some of the

numbers in the Expenses section

to do a few more calculations.

Select cell G6. This is the total for

our expendable income after all

payments have been made. Enter

the formula:

=F6­F##

where ## is the row number

the sum button in the formula

toolbar. Calc should select the

three numbers we need. Press

Enter.

Our budget spreadsheet is now

complete, but it doesn't look very

pretty. Next time, we will format

our spreadsheet using styles.
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I
n the last part of this series,

we added the data and

formulas for our budget

worksheet. The end result,

while functional, is not very pretty

or easy to read. Now, we will add

some styles to our spreadsheet to

help make the worksheet not only

more pleasant to look at, but

easier to read and find specific

data. We will accomplish this using

cell styles.

Back in part 3 of this series, we

used paragraph styles to format

the paragraphs in our documents.

Cell styles are Calc's equivalent to

paragraph styles. Cell styles allow

us to specify the border, font,

background color, font effects,

number format, alignment and cell

protection. Styles help to create

consistency throughout the

spreadsheet.

Section and Column
Title Styles

We'll start by creating styles for

our section titles and column titles.

Click on the styles icon (above).

Now, we will create a style for

our column titles based on the

Section style. Basing one style on

another style makes it quick and

easy to just add and change the

differences between the styles. In

the Styles and Formatting

windows, right-click on the Section

style and select New. Give the style

the name “Column Title.” You will

notice that the style is linked to the

Section style. If you browse

through the tabs, you will see all

the settings we made for the

Section style are already set. To

distinguish column titles from

sections, we will give them a

different background color. On the

Background tab, select a suitable

light color for the background, such

as Blue 8.

Applying the Section
and Column Title Styles

Now, we can apply our two new

styles to cells in our spreadsheet.

The sections are “Income This

Period”, “Assets”, and “Expenses”.

Select the cells for these items and

double-click on the Section style in

the Styles and Formatting window.

You can select more than one cell

and apply the style all at once. For

example, highlight all the column

titles under Income (Source and

Amount) and double-click on the

Column Title style. Do the same for

the column titles under the other

two sections.

Editable, Total, and
Date Styles

Editable items are the items in

our budget spreadsheet that we

will need to change from use to

use. These are most of the cells

under the column titles, except

those that contain formulas - which

are our total cells. We will first

create the Editable style and use it

as the link for our Total and Date

styles.

In the Styles and Formatting

window, right-click on the default

style and select New. Give the new

style the name “Editable”. On the

Number tab, select currency and

your currency type. Set your font

and font size on the font tab. I

suggest a font size of at least 1 2

points. Make sure the font style is

regular (not bold or italic) . On the

border tab, create light gray

borders on the left and right. You

can accomplish this by clicking on

the third box under defaults. Make

sure that the Protected box is

unchecked on the Cell Protection

tab.

Now, we will create the Total

styles by linking it with the Editable

style. Right-click on the Editable

style in the Style and Formatting
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effect of changing our dates again,

but that is easily fixed by doing the

same thing with the Date style.

Select all the dates in the Expenses

section. Format > Conditional

Formatting. Once again use the

formula ISEVEN(ROW()) . Click on

the New Style button and name the

new style “Dates Highlight”. Link

the style with Dates style. Change

the border color to gray and the

background to light gray. OK to

save the style, and OK to apply the

conditional formatting.

Finishing Touches

Just a few simple things to

make all things even. If you have

more than two items in the Income

section, you can add the highlights

to it as well using conditional

formatting and the Highlight

Editable style. Also, you can right

justify the “Total Expenses” and

“Total Payments” labels at the

bottom.

Now, to test run your

spreadsheet. Remember, we

protected the cells we didn't want

to change. Tools >

Protect Document >

Sheet. You can enter a

password to

window, and select New. Once

again, we are starting with an

exact copy of the style we right-

clicked. Name the style “Total”.

We will make changes to

distinguish our totals from

ordinary items. On the Font tab,

change the style to bold. On the

background tab, select a darker

gray color than the light gray we

used for the borders - like gray or

gray 40%. Finally, check Protected

on the Cell Protection tab.

Apply the styles much in the

same manner as we did previously.

You will notice that if you apply

the Editable style to the date

column under expenses, you get a

strange result for your dates

(probably ####). That's because it

was converted into currency.

Right-click the Editable style and

create a new style named “Dates”.

All we need to do here is change

the number type to Date and

select a simple numeric date style

on the Numbers tab.
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Conditional Formatting

We need a way to break up the

big block of data under the

Expenses section. We could just put

borders around them, but large

groups of bordered boxes look dull.

Instead, we will highlight all the

even rows with light gray. We also

want to do this quickly. For this we

will use conditional formatting.

ISEVEN(ROW())

With this formula, whatever

style we choose will only apply to

the even rows. For the cell style,

click on the New Style button. Give

the style the name “Editable

Highlight” and link it to the Editable

style. On the Borders tab, change

the border color from light gray to

gray. Move to the Background tab

and change the background color

to light gray. Click OK to save the

changes. You will notice the Cell

style is now Editable Highlight.

Click OK and you will see the even

number rows are highlighted in

light gray.

Unfortunately, this has the side

password-protect the document,

or just click OK to protect it

without a password. If you try to

edit one of the protected cells you

will get a message window saying

the cell is protected. However, the

unprotected cells are easily edited

as before. Using cell protection is a

good way to keep your formulas

from getting changed once you

have the spreadsheet set up and

working the way you want it.

In the next part of this series,

we will prepare our spreadsheet

for printing by adding a header and

footer to the page, and looking

into our printing options.
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I
n my last article, I discussed

setting up styles in LibreOffice

Calc. This month, I will show

you how to prepare, examine,

and print your spreadsheet. We will

add headers and footers to our

sheet, use the Page Preview to

examine how our sheet will look

when we print it, and review the

print dialog and how it affects the

final printed pages.

Renaming Sheets

When you first create a new

spreadsheet file, the default

workbook starts with three sheets

named Sheet1 , Sheet2, and Sheet3.

You can use these names in other

places in your sheet, and we will

use them when we create the

header and footer for our budget

spreadsheet. However, the default

names are not very informative, so

we will rename them. The names

are located on tabs at the bottom

program window. To rename a

sheet, right-click on the tab and

select Rename Sheet from the pop-

up menu. The Rename Sheet dialog

will display. Type in a meaningful

name for the sheet, i .e. “February

24, 201 2” and click OK.

Headers and Footers

Headers and footers allow us to

create consistency between pages.

Doing this on the sheet would

mean shuffling cells as the sheet

changes and grows. Using the page

settings, we can create the same

look for multiple pages.

Open the page settings dialog,

Format > Page. Click on the Header

tab. Here you can adjust the

margins, width, and height of the

header area. I would recommend

checking the Autofit Height

checkbox, otherwise your header

may get cut off. Click on the Edit

button to bring up the header area

format dialog. You will notice the

header is divided into three areas,

left, center, and right. Along the

bottom, you will notice a toolbar.

The toolbar lets you insert

placeholders into the header and

format the text. For our budget

spreadsheet, we will place

something in each of the areas. In

the left area type “201 2 Budget”.

For the center area, we will place

our sheet name. To get the sheet

name, click in the center area and

delete any content that already

exists, then click on the third

button on the toolbar. This inserts

the name you gave the sheet. For

the right area, we will insert the

current date. Click in the right area

and delete any content that

already exists. The next-to-last

button on the toolbar inserts the

current date. To change the font,

size, color, etc, of the text,

highlight the text in any of the

areas and click on the first button

on the toolbar. This brings up a

font dialog, where you can change

the attributes of the text. Click the

OK button when you are finished

editing your header.

We also might want to separate

our header from the rest of the

sheet with a border or background

color. We can do this by clicking on

the More button on the Header tab

in the Page dialog. For mine, I just

put a 0.50pt line at the bottom.

The Footer tab is the same as

the Header tab, but let’s put some

different information in the three

areas. On the Footer tab, click the

Edit button. In the left area, place

the sheet name using the third

button on the toolbar like we did

with the header's center area. In

the center area, delete the content

that is already there and type the

word Page and a space. Click on the

fourth button in the toolbar. This

creates a placeholder for the page

number. This placeholder will

increment for each page of the

sheet. In the right area, click on the
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page or the last page. There are

also zoom in/out buttons for

closer examination of the page.

The Margins button gives you

the ability to adjust the page,

header, footer, and column

margins. Click the Margins button

to activate margins mode. The

dotted lines let you manually

adjust the page, header, and

footer margins. The black markers

at the top allow you to adjust the

widths of the columns. Click the

Margins button again to exit

margins mode.

Close Preview exits the

preview mode.

Printing

Finally, we have completed all

our preparation and it is time to

print our sheet. File > Print brings

LIBREOFFICE - PART 1 2

last button on the toolbar to insert

a current time placeholder. This will

print the time when you print the

sheet. Having the current date and

time on the sheet can come in

handy when you have to do

revisions and need to know which

one is the most current. As with the

header, we can edit the attributes

of the text by highlighting the text

we want to change and clicking on

the first button in the toolbar. Click

OK when you are done editing.

To separate the footer from the

rest of the document, we can use

the More button to create a border

or background color. I used a 0.50pt

border on the top.

In our setup, we used all the

buttons in the header/footer edit

dialog except for two. The second

button inserts the filename of the

workbook, and the fifth inserts the

total number of pages.

We are finished editing the page

setup. Click OK to close the page-

setup dialog.

Page Preview

The page preview allows us to

make final adjustments to our

sheet before printing. With the

preview, we can make sure

everything fits on the page the

way we want it, and the data

shows as we intended.

To open the page preview, go

to File > Page Preview. The current

window is replaced by the page

preview window. You can make

several adjustments while in page

preview mode.

The slider in the toolbar is the

scaling factor. This allows you to

make the cells bigger or smaller so

they fit on the page the way you

want. You can increase the size by

clicking on the plus (+) or reduce it

by clicking on the minus (-) . You

can also click and drag the

adjustment handle.

The Format Page button

displays the Page Style dialog.

Here you can change your overall

page margins and background

color, and make corrections and

adjustments to your header and

footer. Two things we haven't

mentioned yet are the table

alignment and the print order.

Table alignment is found on the

Page tab. It allows you to center

the table horizontally, vertically, or

both. On the Sheet tab, the page

order controls how the cells are

printed on the page. This allows

you to make your data layout in

the order and way you intended. If

you have more columns than can

fit on a page, you can change it

from the default to left-to-right,

then down. You can also set the

beginning page number should you

need something other than 1 . You

can also specify what prints and

what does not. Finally, you can

manually adjust the scaling here as

well.

The page preview gives you

buttons to page forward and

backward, and jump to the first
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up the print dialog. On the General

tab, you can select your printer.

Click on the Properties button for

settings specific to your printer.

You can choose to print just the

selected sheets, all sheets, or just

selected cells. You can also specify

whether to print all the pages or

just selected pages. If you don't

feel like ordering your pages after

you print, you can also choose to

print them in reverse order. You

have an option to print multiple

copies, and whether or not to

collate them.

On the LibreOffice Calc tab, you

can choose to print or not print

blank pages. The Page Layout tab

gives you options for printing more

than one page on a sheet of paper,

what order to print them, and

whether to put a border around
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Quick Opinion
Tune out, Drop Out, Get things Done
by Allan J Smithie

I
turned off the Internet today. I

don’t mean the whole thing. I mean

my access to it. I unplugged the

router from the wall.

I also killed my music player and left

the mobile phone in another room.

Something mystical then happened.

Concentration.

I love the Internet. I ’m probably addicted. It’s a huge

resource for information and an unparalleled research,

educational and entertainment resource, but every so often I

have to shut it all out just to Get Things Done.

Turn off the TV, radio, iPod, Xbox, PSP and Wii. Close the

browsers (both of them), kill the chatroom, the IRC, AIM,

Facepunch, Twiddle and anything else that’s running. The fact

checking can wait. Contrary to contemporary systems of belief,

your status doesn’t have to be updated in real time. It will all

still be there. After you get something DONE.

the page. On the Options tab, you

can choose to print to a postscript

file, and, if you are printing

multiple copies, whether to do it as

one print job or multiple.

Once you have everything set,

click Print.

This may seem overkill for a

single document, but you need to

always consider how often you will

use and change the document. If

you use the sheet often, as in a

budget, once the header and

footer is set, you will never have to

change them again. By considering

the reusability, you decrease the

setup time the next time you use

it.

Next month, we will look at

some quick tips and tricks for

working with spreadsheets in

Calc.
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S
ofar, we have covered

many topics for using

LibreOffice's Calc, but Calc

has many minor operations

that are worth knowing. In this

article, I will give you my top-1 0

quick tips for using Calc. Most of

them have to do with manipulating

the current sheet. You can use

these tips in most any sheet you

are working with.

1 . Naming Sheets

The default name for sheets is

SheetX, where X is a number. You

have 3 ways to name a sheet. The

first is when you create a new

sheet, using Insert > Sheet. In the

dialog, you have a choice of how

you want to name the sheet. You

can also choose to insert multiple

sheets. When inserting multiple

sheets, you have no control over

the sheets' names. They will get

the default SheetX naming

convention.

However, you may need to

rename a sheet after it has been

created. This is where the second

and third methods apply. The

second way to name a sheet is by

right-clicking the sheet's tab and

selecting Rename Sheet from the

menu. The Rename Sheet dialog

will come up, and you can change

the name of the sheet. The third

method is simply to double-click

the sheets tab. This brings up the

rename Sheet dialog, where you

can change the sheet's name.

NOTE: The sheet name must start

with a letter or digit. Then, sheet

names can include spaces, letters,

digits, underscore, and some

special characters, i .e. -, &. When

saving in the Microsoft Excel

format, sheet names cannot

contain the :, \, /, ?, *, [, and ]

characters. If you have an invalid

character in the name, Calc will give

you an error message.

2. Deleting Sheets

Sometimes, you will want to

delete a sheet, or multiple sheets,

from the workbook. To delete a

sheet, right-click on the sheet's tab

and select Delete from the menu,

or select Edit > Sheet > Delete

from the menu bar. Calc will verify

that you do want to delete the

sheet. To delete multiple sheets

hold down the Ctrl key while

clicking on the tabs for the sheets

you want to delete. Use either the

right-click or the menu method to

delete the sheets. Once again, Calc

will verify that you want to delete

the sheets.

3. Move/Copy Sheets

Sometimes, you need to

rearrange or copy sheets. For

example, you might want to order

a multiple sheet workbook in order

of predominate use, or by date.

Copying a sheet comes in handy

when you need to create an exact

duplicate of the current sheet,

thereby creating a history. When

you copy a sheet, you get an exact

duplicate of the sheet you copied;

however when you make changes

to the new sheet, those changes

are not translated to the old sheet.

For example, you can create a copy

of a budget spreadsheet for each

pay period of the year and keep

them all in one workbook.

Moving sheets is accomplished

in one of two ways. The first

method is to drag the tab of the

sheet to the position you want it.

Double arrows will show the

location the sheet will occupy

when you release it. The other

method is through the Move/Copy

Sheet dialog. You can access the

Move/Copy dialog by right-clicking

the tab you want to copy or move

and selecting Move/Copy Sheet, or

through the menu bar, Edit > Sheet



full circle magazine 36 Return to ContentsLibreOffice

become a double arrow. Drag the

thick bar down to the position

where you want it. To split the

screen vertically, do the same with

the thick bar to the right of the

horizontal scrollbar. To get a quick

horizontal and vertical split, just

select Window > Split. The spits are

shown by a thick heavy line. Each

area of the split screen is

manipulated by the various new

scrollbars that appear.

To undo a split screen, grab the

thick heavy line and drag it up to

the top for a horizontal split or to

the right for a vertical split. To
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> Move/Copy Sheet. Under the

Action section, you can select to

copy or move the current sheet.

NOTE: If you have only one sheet

in the workbook, move and copy

are grayed out, and copy is

selected. In the Location section,

you can select to move/copy the

sheet to the current document, to

another open document, or to a

new document. The Insert Before

section controls the placement of

the move/copy. The sheet will

move/copy to a position before

the selected sheet. A special

choice here is the “- move to end

position -”. Selecting this last

choice will move/copy the sheet

to the end of the sheet list. The

Name section allows you to give

the sheet a new name. Renaming

your sheet is a good idea when

copying. If you do not give it a

new name, it will keep the existing

name and append an underscore

and a number, i .e. MySheet_2.

4. Color Tabs

Visual aids can often help get

things done quickly while working

with a large workbook with

multiple sheets. Color is an easy to

deploy visual aid. Giving each sheet

tab a different color can help you

find it and go to it quickly. The tab

of the current sheet is always

white, but you can still give it a

color for when it is not selected. To

set the tab color of a sheet, right-

click the tab and select Tab Color

from the menu. A color dialog will

pop up. Simple select the color you

want for the tab and click OK.

5. Freeze
Row(s)/Column(s)

Long and wide sheets often

require scrolling to view some of

the content in the sheet. However,

in many cases the first columns or

rows contain information you need

in order to make sense of the

information. Luckily, Calc provides

you with a way to freeze rows and

columns in place.

To freeze a row or rows, select

the row below the row(s) you want

frozen by clicking on the row

number, then Window > Freeze. To

unfreeze the rows, select Window

> Freeze again. The same is done

with the columns by selecting the

column letter to the right of the

columns you want frozen, then

Window > Freeze.

To freeze both rows and

columns, select the cell below the

rows you want frozen and to the

right of the columns you want

frozen, then select Window >

Freeze.

6. Split Screen

Another way to view large

sheets is using the split screen. To

split the screen horizontally, grab

the thick bar just above the vertical

scrollbar. The mouse cursor will
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The selection list is a text

function. The selection list works

only for text, and will contain only

text from the current column your

selected cell is in. To activate the

list, select an empty cell and press

Alt + Down Arrow on your

keyboard.

1 0. Remove Data from
Cells

Sometime, you need to not just

change the data in a cell but

completely remove it. Removing

data can be done in one fell swoop,

and you can select the type of

information that is removed. For

example, you can select a group of

cells and choose to remove only

the formating, or only the text.

in a cell, select the cells you want

to repeat, then Edit > Fill > (the

direction you want to fill: left, right,

up, or down).

However, the real power of the

fill tool come through using the Fill

Series. Edit > Fill > Series. The Fill

Series tool allows you to create

many different types of serial

information, from numbers to

dates. There is also AutoFill, which

uses a series of text predefined in

the program. Examples of the

AutoFill are Days of the week and

months. You can define your own

AutoFill ranges in

Tools > Options >

LibreOffice Calc >

Short Lists.

9. Selection
List

cancel all spits, use Window > Split.

7. Print Rows or
Columns on Every Page

Printing a sheet which will span

multiple pages may require key

information in certain rows or

columns in order to help make

sense of the data. To control how

the pages print, you can define

whether certain rows or columns

repeat on each page.

Open format > Print Ranges >

Edit. Under Rows to repeat, you

can define the rows that need to

repeat on each page, i.e. to repeat

the first two rows enter $1 :$2.

Under Columns to repeat, you can

do the same for the columns, i.e.

to repeat the first column type $A.

8. Fill Selected Cells

At its most basic use, the fill

tool is a way to repeat information

in a cell. To repeat the information

Elmer Perry's history of working, and
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Apple I IE, adding some Amiga, a
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There is also a remove all to

remove all the information from

the cell(s) . You activate the Remove

Content dialog by selecting a cell or

cells and pressing the Backspace

key on the keyboard. You can also

do this through the menus: Edit >

Delete Content.

So, there you have it; my top-1 0

quick tips for LibreOffice Calc.

In my next article, we will

continue our journey in Calc by

learning how to create charts and

graphs.
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W
hile data collection is

useful and helpful in

determining results,

or whether goals

were met, charts and graphs

simplify data so others can quickly

digest and interpret results. The

art of charts and graphs is well

beyond the scope of this article,

but I will show you how to create a

chart in Calc, which you could use

in Writer or Impress. There are

many predefined charts and graphs

available in Calc.

We will use a simple collection

of data to create our chart. The

data represents the boat rentals

for a six month period. We will use

a bar chart to show the relationship

between the different types of

boat rentals for each month.

The Chart Wizard

The chart wizard allows us to

get the basics of our chart

completed quickly and easily. In

fact, sometimes the chart wizard is

all you will need to complete your

chart. The wizard is your jumping

off point for all chart creation.

Before starting the wizard, you

need to highlight the data used for

the chart. You will want to make

sure you just highlight the data and

their labels. Although you can

modify the ranges for the data

series later, getting it as close as

possible helps Calc to better

render the final results.

You have two ways to

start the chart wizard.

You can click on the chart

wizard icon (shown right) on the

main toolbar, or through the menu

with Insert > Chart. The chart

wizard consist of four steps. We

will walk through each of the steps,

but it is possible to click the Finish

button at any time to end the

wizard process.

1 . Chart Type

The chart type (above) is where

you select the type of chart you

want to create. For some chart

types, you have the option of 3D

effects, and for others you do not.

For our chart, we will select the

basic bar chart. Since we have the

option of 3D effects for a bar chart,

we will also check the 3D Look

checkbox. In the 3D Look

dropdown box, you have the

options of Realistic or Simple. This

helps determine the look and

shading of the 3D effect. We will

use Realistic. Finally, you can select

different shapes for your data

series. We will use cylinder. Click

the Next button to move to the

next step.

2. Data Range

In step two we define the data

range and how Calc will use the

data range to create the chart. If

we need to change the range from

what we selected, we can type in

the range or select the range from

the spreadsheet. The small button

at the end of the data range

textbox will shrink the wizard

dialog so more of your spreadsheet

is visible.

We need to tell Calc whether

our data series are defined by row

or column. For our example, we

used columns. Also, since we

selected the labels as well as the

data, we need to check both First

row as label and First column as
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label.

Click the Next button to move

to the next step.

3. Data Series

The third step (below) lets us

redefine, add, change the order,

and remove data from our data

series. You will see the data series

for the chart defined by their label

in a listbox. You can change the

range of the series much as you

could in the data range step;

however, keep in mind, this is only

for one set of data and not the

entire chart. You can add another

series by clicking on the Add

button. You can remove a series by

selecting it and clicking the

Remove button. Change the order

of the series by selecting the

series you want to move and use

the up and down arrow buttons.

We don’t need to change

anything here, so click the Next

button to move to the last step of

the wizard.

4. Chart Elements

The fourth step (above right) of

the wizard allows us to define

names for the different parts of

our chart, including title, subtitle,

and x and y axis. We can also set

the location of our legend and the

grid for the chart area. For our

chart sample, give it the title

“Sample Bar Chart”. We also want

to label our Y-Axis as “Num of

Rentals”. Since our X-Axis is the

months of the year, we don’t really

need a label for the X-Axis. It is

self-explanatory. Set the legend to

appear at the bottom, giving our

data more room to spread out.

We are now finished with the

Chart Wizard. If you ever need to

revisit any of the steps, you can use

the Back button or select the step

from the list on the left. Click the

Finish button to complete the

wizard and display the chart in

your spreadsheet.

Formatting Chart
Elements

After creating the chart with

the Chart Wizard, it is possible to

change the elements of the chart.

After clicking on finish, you will

notice that the newly created

chart is selected and your toolbar

has changed. You have the chart

formatting toolbar instead of the

standard edit toolbar. The new

toolbar has a dropdown box which

allows you to select the different

elements you can change. After

selecting an element from the

dropdown, click on the Format

Selection button to display the

dialog for that element.

There are also buttons for

changing the chart type, and
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displaying the chart grid and

legend. The button with the double

arrow beside the capitol A is used

to scale the text with the chart

when you resize it. I highly

recommend this, as it keeps things

proportional. In addition to the

changes in the toolbar, you will find

changes in the Insert and Format

menus as well. These changes allow

you to insert and format elements

of your chart.

You can move the chart by

clicking and dragging the borders.

Resize the chart by clicking and

dragging one of the eight handles.

If you selected the text scale

button, the size of the text will

scale with the chart as you change

it.

Now, let’s make some changes

to our chart. In the dropdown list in

the toolbar, select Chart Title and

click on the Format Selection

button. On the Font tab, change

the size to 1 8 and the style to bold.

Click OK. Next, select Chart Area

and click Format Selection. The

chart area is the entire background

of the chart. On the Area tab, select

a background color of light gray.

You will notice this changes the

color of our data area as well, but

we want the data area to stand

out. Select Chart from the

dropdown list and click Format

Selection. On the Area tab, select

to fill with color and pick white.

Since we are using a 3D chart, let’s

change the perspective a little:

Format > 3D, check the

Perspective checkbox and change

the percentage to 50%. You will

see this changes the perspective

of the chart.

There are other things to do on

your own. Try changing the color of

one of the data series or adjusting

the placement of some of the

elements. All can be done through

the dropdown list, and the Format

and Insert menus. When you

deselect the chart, you are taken

back to normal toolbars and

menus. To edit the chart later, just

double-click the chart, and you get

the specialized toolbar and menus

back.

We have only touched the

surface of the chart and graphs in

Calc, but I encourage you to play

around with the different types

and elements. The type of chart

you use is dependant upon the

type of data you have and the

information you want to convey.

Next time, we will begin our work

in Impress, LibreOffice’s

presentation program.
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I
mpress is LibreOffice's

presentation program and is

equivalent to Microsoft

Office's Powerpoint. With

Impress, you can create

professional visual presentations

that include graphics, pictures,

videos, audio, spreadsheets, and

charts. Impress has a presentation

wizard that is very useful for

setting up a new presentation and

getting you started on the right

track, and a main window that

helps break the process down into

tasks.

The Presentation
Wizard

You can create a new blank

presentation by going to File >

New > Presentation. However, to

start the presentation wizard, click

on File > Wizards > Presentation. If

you want to start with the wizard

every time you create a new

presentation, you can turn it on in

the settings. While in Impress, click

on Tools > Options > LibreOffice

Impress > General, and check “Start

with wizard” under New document.

The first screen of the wizard

(right) lets you pick from an empty

presentation, a template, or open

an existing presentation. If you

select “From template”, there are

two default templates in Impress.

Both come with predefined slides. I

recommend you have Preview

checked as it allows you to see a

visual of your presentation as you

create it in the wizard.

TIP: At any point in the wizard, you

can click the Create button to

create a new presentation. This

allows you to use only the parts of

the wizard you need.

Click Next >> to move to the

second screen of the wizard. On

this screen you can pick from many

different backgrounds for your

presentation. You can change the

background for individual slides

later, but this will become the basic

background for your presentation.

You will also want to select the

output medium for the

presentation - normally screen -

but other options are available

should you need them.

Click Next >> to move to the

third wizard screen. You can pick a

slide transition for changing from

one slide to the next. There are

many different transitions to

choose from. When you select a

transition, you get a preview on the

HHOOWW--TTOO
Written by Elmer Perry LLiibbrreeOOffffiiccee PPtt11 55 :: IImmpprreessss



full circle magazine 42 Return to ContentsLibreOffice

your name if your presentation is

not for a company), and the ideas

behind your presentation. The

information you use here will plug

into your opening slide.

Click Next >> to move to the

fifth wizard screen. If you selected

a template on the first screen of

the wizard, you can use this screen

to preview each of the slides after

your changes. You can select

whether a slide will be included in

the presentation or not. Check

“Create summary” to create a

summary of your slide.

SIDEBAR: You can always use

the << Back button to move back

and change elements of your

presentation.

Click on the Create button, and

effect in the preview window. You

can also adjust the speed of the

transition. You can change the

transition for individual slides

later, but the transition, along with

the background, is one of the

things that create consistency in

your presentation. On this screen

you can also pick the presentation

type. “Default” advances the

elements and slides through

mouse clicks or the keyboard.

“Automatic” allows you to set each

slide to advance after a certain

amount of time. The choice will

depend on the presentation and is

beyond the scope of this article.

Click Next >> to move to the

fourth wizard screen. Here you can

give a topic, company name (or
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Impress will create the slides for

your new presentation.

The Main Window

The main window for Impress

(above) is divided into three

sections, the Slide pane, the

Workspace pane, and the Tasks

pane. You can hide the Slide and

Tasks panes by clicking the X in

the upper corner of each pane. To

show the panes again use View >

Slide Pane or View > Tasks Pane.

Alternatively, you can use the

Hide/Show markers (circled in red

in the image) to hide and show the

panes.

The Slide Pane

The Slide pane shows

thumbnails of all the slides in your

presentation in the order in which

they will appear in the

presentation. In the Slide pane,

you can add, delete, copy, paste,

move, duplicate, rename, or hide

slides. Clicking on a slide in the

Slide pane places it in the

Workspace pane where you can

change and modify it.

The Workspace Pane

The Workspace pane is the

main work area for editing slides.

You have five tabs in the

Workspace pane.

Normal View
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Normal View is where you make

changes to individual slides. Here

you can add images, modify and

add text, animation effects, and

more.

Outline View

The outline view displays an

outline of all the text in the default

text boxes on each slide. Each slide

is numbered. You can use the

outline view to proof and change

the text on your slides, as well as

add text to the slides. The slide

names are not included in the

outline.

Notes View

You can use the Notes View to

add notes to individual slides. You

can change the size of the note

box under the slide by clicking on

the border and dragging the

handles. The notes will not show in

the presentation, but you can print

them and use them during your

presentation or as handouts.

Handout View

In Handout View, you can setup

how your handout of the

presentation will print. If you select

Layout in the Tasks pane, you can

set the number of slides that show

on each page of the handout (up to

9 slides per page). You can also use

this view to determine what

information will print on the

handouts.

Slide Sorter View

The Slide Sorter view works

much like the Slide pane but gives

you more space to work. You can

add, delete, move, copy, paste,

duplicate, rename, and hide slides.

You can also work with groups of

slides by selecting more than one

slide.

The Tasks Pane

The Tasks pane has five

sections. You expand a section by

clicking on the section name. You

can only expand one section at a

time.

Master Pages

Here you define the page style

for your presentation. Impress

contains many predefined master

pages you can use. You can modify

the look of a master page using

styles. A single presentation can

contain more than one master

page, allowing you to use more

than one visual style in the

presentation.

Layouts

The prepackaged layouts are

shown here. You can select a

layout - and use it as it is or modify

it. Unfortunately, you cannot save

custom layouts to the layout lists.

Table Design

Standard table layouts are

shown here. You always have the

option of changing the layout, and

the table will behave much like a

table in Calc.

Custom Animation

With custom animations, you

can control when and how

elements appear on the slides. You

have many different options that

help create the visual effects you

need as you give your

presentation. Don't go overboard

here unless you have a good

reason. While animations can make

your presentation visually pleasing

and interesting, they can also make

your presentation look

unprofessional and overwhelming.

On the other hand, if you need to

make an emphasis on a certain

point, custom animations can help

you accomplish such emphasis.

Slide Transition

The Slide Transition section

gives you access to changing how

one slide replaces the next. You

have the choice of many different

transitions as well as the speed of

the transition. If you use automatic

transition, you can also control how

long the slide will display.

This has been a quick overview

to get you started working in

Impress. I encourage you to begin

to play with the different views,

sections, and layouts to get a feel

for how they work and what you

can do with them. Next time we

will begin work on editing slides,

adding text, and adding graphics to

our slides.
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A
great presentation

begins with a pleasing

and well thought out

slide design. You also

need consistency between your

slides, elements that fit them

together. In LibreOffice, you can

use the Master Pages to create the

base design for your presentation.

Master Pages become the

framework for the entire

presentation, binding the elements

of our presentation together. Much

of this is accomplished through

styles, and Master Pages are the

main style. You can think of Master

Pages being equivalent to Page

Styles in Writer.

Editing Master Pages

To edit master pages, you must

switch to the Master View. Start

Master View through View >

Masters > Slide Master.

Alternatively, you can right-click

the master page you want to edit

in the Master Page section of the

Tasks pane, and select Edit Master.

When you enter Master View,

the master toolbar appears. The

master toolbar gives you options

specific to editing master pages.

Use add to add a new master page.

Delete allows you to delete the

selected master page. Delete is

grayed out when you have only one

master page, because you must

have at least one. Rename lets you

r

ename the currently selected

master page, and Close Master

View exits master page editing.

You have five predefined

editable areas in a master page:

Title Area – The title area

contains the title of the slide. Think

of it as the subject of the slide.

Object Area – The object area

contains the data of the slide,

whether it is text, an image, a

chart, or a table. As you will learn,

the data of the slide is not confined

to the object area. You can add

elements outside the object area,

but it's a good idea to keep data

generally in this area for

consistency in your presentation.

Date, Footer, and Slide Number

Area – By default, these areas do

not show up on the actual slide. To

change, go to View > Header and

Footer, and you can change

whether or not these objects will

appear on the slides.

Modifying the Master
Page

We will start with the default
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style for your master page. First,

let's change the background.

Format > Page. On the background

tab, use the dropdown box and

select gradient. In the gradient list,

select Radial red/yellow. Click OK.

This gives you a bright, sunny

background to work on.

NOTE: You can download the icon

graphic used in this tutorial at

http://eeperry.co.cc/resources/mo

dules.png.

Next, we will add a graphic to

your master page. The graphic will

show up on all slides that use this

master page. I created a ribbon

graphic containing the icons for all

the LibreOffice applications. We

want it to sit just below the object

area. Insert > Picture > From file.

LIBREOFFICE - PART 1 6

Select your picture and Open.

Move the image to the position

you want it, just below the object

area. You want the image centered

at the bottom. Rick-click the image

and select Alignment > Centered.

You also want the image to appear

behind any objects which might go

over it. Right-click the image again,

and select Arrange > Send to back.

Now, let's add a line under the

title. Select the line tool from the

drawing toolbar at the bottom of

the window, and draw a line under

the title area. You can change the

line style using the line toolbar.

Change the style of the line, the

thickness, color, and the start and

end arrow styles.

Finally, let's edit the date,

footer, and slide number areas

(below). While in Master View, you

can change the size and placement

of these objects, but actually filling

them with content can be done at

any time. View > Header and

Footer. On the slide tab, there is a

checkbox for each of the three

areas: date, footer, and slide

number.

Under date and time, you can

choose a fixed date or a variable

date. You can use fixed date when

you have a presentation that is

presented one time, or you want

the date to appear in a non-

standard way. Place your date text

in the textbox beside the variable

selection. What you place in the

textbox is what will show in the

date textbox on the slide. Use

variable date when a presentation

date is unknown, or you will give

the presentation more than once.

Variable will place the current date

in the date textbox. With variable,

you need to select a format in the

dropdown. You can also change the

language.

For the footer area, you type

the text you want in the footer

area in the textbox. Whatever you

type in the textbox appears in the

footer area.

There's not much to the slide

number. You either check it to

show or not show. When checked,

the slide number will show up in

the slide number area.

NOTE: The date, footer, and

slide number areas are disabled on

the first slide, the title page.

Click the Apply to All button to

apply the settings to all the slides

except the title page. Click the

Apply button to apply it to only the

current slide.

Impress Styles

Just like in Writer and Calc,

Impress can use styles to keep

everything uniform. Styles are also

a time saver. However, styles are a

little different in Impress. Impress

only has two different style types,

Presentation and Graphic.

An easy way to think about

presentation styles is as the styles

related to the master pages. You

have styles for backgrounds,

background objects, outline text,

notes, titles, and subtitles. You can

modify these styles any way you

want. However, you cannot create

new presentation styles.

http://eeperry.co.cc/resources/modules.png
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Graphics styles are styles for

objects and text not directly

related to the master pages. You

can modify these styles in any way

you want, and you can create new

ones.

Editing of styles is done from

the Styles and Formatting dialog.

You can open the Styles and

Formatting dialog by clicking on

the button in the line and filling

toolbar, pressing the F1 1 key on

the keyboard, or by going to

Format > Styles and Formatting.

Let's do a couple of

modifications to the presentation

styles to show how they work.

First, enter master view mode,

View > Master > Slide Master, and

open the Styles and Formatting

dialog, Format > Styles and

Formatting. Right-click Title in the

dialog and select Modify. On the

font tab, select a suitable serif or

slab font. Maybe make it bold.

Switch to the area tab and change

the fill to gradient. Select the first

gradient in the list (black to

white). On the transparency tab,

switch the mode to transparency

and the percentage to 50%. Click

OK, and you will see the font for

the title has changed and it has a

semitransparent gradient

background.

Now, select Outline 1 in the

Styles and formatting dialog.

Right-click and modify. All we want

to do here is change the font. Click

OK. Switch to Master View and you

will notice that the font is changed

for all the outline levels. This is

because each of the outline levels

links to the previous one. You can't

change the linking, but you can

change each of the levels to be

different. This cascade effect can

be useful, especially with the font

in helping to create uniformity.

In this how-to, we learned

about creating and modifying

master pages in Impress. Master

pages are key to helping create

consistency in your presentation.

We also looked at presentation

styles and how they help create

the style for your slides. I

encourage you to play around with

the master page settings and

presentation styles. The

presentation styles have 1 4

different tabs, making them very

flexible. You can create a very

professional and visually appealing

presentation with these tools.

Next time, we will begin work

with individual slides.
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I
recently got a request for a

tutorial on LibreOffice macros,

so we will take a short break

from our work in Impress to

briefly cover macros. Macros allow

you to automate repetitious

actions like typing a letterhead.

This frees you from having to type

or do the same task over and over

again. In this how-to, we will cover

how to record macros and use

them. LibreOffice has a Basic

scripting language which is beyond

the scope of this particular how-to.

Perhaps we will revisit macros at a

later time to discuss the Basic

scripting language.

NOTE: You can find information on

LibreOffice Basic in the help, or

download the documentation at

http://wiki.documentfoundation.or

g/images/d/dd/BasicGuide_OOo3.

2.0.odt.

Enabling Macro
Recording

By default, macro recording is

disabled. Apparently, macros are

considered an “experimental

(unstable) feature”. To enable

macro recording, Tools > Options.

Select the General options under

LibreOffice, and check “Enable

experimental (unstable) features”.

This enables the “Record Macro”

option under Tools > Macros.

Recording a Macro

When in macro record mode,

the macro recorder tracks every

action you make and all the text

you type, and records it in the

macro. Remember how we had to

enable experimental features to

get the Record Macro option? Well,

that's because sometimes the

macro recorder does fail. I haven't

experienced this myself, but I

thought I should point that out.

As a demonstration of recording

a macro, we will create a macro

called Closing. Every time you write

a letter, you have to end with a

closing, so why not make it into a

macro.

Start with a new text document.

Tools > Macros > Record Macro to

start the macro recorder. The

macro recorder toolbar will show.

There is only one choice on this

toolbar, Stop Recording. Press the

Tab key on your keyboard three or

four times (this should place the

cursor close to the center of the

page). Type Best wishes, love, or

your favorite closing. Press Enter

twice to leave room for a signature.

Press Tab the same number of

times you did before. Change the

text to bold by clicking the Bold

button on the formatting toolbar,

and type in your name. Lastly, let's

add a title under the name. Press

Enter, Tab the same number of

times as before, click the Bold

button to turn off bold, and click

the Italic button to change to

italics. Type in your title. Press

Enter. Click on Stop Recording.

The Basic Macros dialog box will

show. Select the library where you

want to save your macro, usually

My Macros. Enter a name in the

Macro name textbox, and click the

Save button.

Testing Your Macro

You will want to test your macro

to insure everything recorded

correctly, Tools > Macros > Run

Macro. The macro dialog box will

show. Select the library where you

saved your macro, select your

macro, and click on the Run button.

http://wiki.documentfoundation.org/images/d/dd/BasicGuide_OOo3.2.0.odt
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The macro will run, repeating all

the text you typed and the

formatting you did.

If something didn't turn out just

right, you can delete the macro

and create a new one. To delete a

macro, Tool > Macros > Organize

Macros > LibreOffice Basic. Find

your macro in the library, select it,

and click the Delete button.

Create a Shortcut to
your Macro

If you use a macro a lot, you

don't want to go to Tools > Macros

> Run Macro every time you need

to use the macro. LibreOffice

allows you to add your macros to

menus, toolbars, keyboard

shortcuts, and application events.

You can add your macros through

Tools > Customize.

As an example, let's add a menu

named Macros in Writer and add

our Closing macro to it. Tools >

Customize. Select the Menus tab.

Click the New button. Name the

new menu Macros. Use the arrow

buttons to move it from the

bottom to the position before

Help. Click OK. Your new menu is

empty right now. Click on the Add

button. Under category, find

LibreOffice Macros and navigate

through the tree to find your

macro. Select the Closing macro

and click the add button. The

macro is added to the menu. Click

on the Close button. Click OK on

the Customize dialog box. You will

now have a menu item named

Macros, and, under it, the Closing

macro. Now, you can select it from

the menu when you need it, which

is faster than having to navigate to

Run Macro.

This has been a very short

introduction to macros. Before

deciding to use a macro, make sure

there isn't a better way to

accomplish what you are trying to

do, but for often repeated action,

macros might just be the solution

you are looking for. There is a

LibreOffice Basic scripting

language, and perhaps we will

cover it in the future. You can also

download macros from the web

that you can import and use in

LibreOffice.

Next time, we are back to

Impress and working with slides.
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W
hen building a

presentation, it is

important to present

the information in a

pleasing and informative way.

Using slide transitions provides a

visual move from one topic to the

next, and using animations helps to

inform viewers or provide

emphasis on the current point.

Overuse of transitions and

animations can cause your

presentation to look less than

professional. However, the

appropriate use of these features

will give your presentation a

polished and professional

appearance.

Slide Transitions

Transitions are the visual

changes made when moving from

one slide to the next. Transitions

provide a visual clue to the

audience that you are moving to a

new topic. In general, you will use

the same transition for all the

slides, but, in some cases, you will

want to use a different transition

to show the viewers a change of

topic.

With the slide you want to

change displayed in the main view,

select Slide Transition from the

Tasks pane. The selection list

provides you with a collection of

different slide transitions. If you

have Automatic preview checked at

the bottom of the Slide Transition

pane, you will see a preview of the

transition when you select it or

change its settings.

You can further modify the

transition in the Modify transition

section of the pane. Speed will

change the rate at which the slide

is displayed. Sound lets you play a

sound with the transition. You can

select a sound from the defaults

provided, or select your own. Once

you select a sound, you can select

Loop until next sound. You will

rarely have a use for this, but it is

there should you need it.

In the Advance slide section, you

set how and when you want the

slide to advance. On click means

the slide will display until you click

the mouse or press the space-bar.

Automatic after allows you to

automatically advance the slide

after a set number of seconds.

When selected, you can adjust the

number of seconds in the spinner

box.

At the bottom of the pane, you

have three buttons. Apply to All

Slides does what it says; it applies

the transition to all the slides in the

presentation. Play causes the

transition to run in the main view.

Slide Show starts the presentation

beginning with the current slide.

Animations

Animations are similar to

transitions, but instead of acting on

the slide, it acts on individual

objects in the slide. Animations

help create emphasis, flow, and

visual interest as you present the

objects on a slide. They keep the

audience aware of the current

subject, and act as a visual clue to

the presenter.

To create animations, first

select the slide which you want to

create animations for. Select the

object(s) you want to animate, and

open the Custom Animations pane
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in the Tasks pane. Click on Add,

which opens the animations

dialog. Here you can select the

animation you want for the

object(s) selected.

Impress provides four different

animation types:

Entrance: These animations play

as the object appears on the page.

Emphasis: These animations are

used to create emphasis such as

changing colors, blinking, etc.

Exit: These animations play as the

object leaves the page.

Motion Path : These animations

cause the object to follow a

defined path.

There is a fifth tab in the

animations dialog related to

media objects. They allow you to

start, stop, and pause media

objects.

Once you have selected your

animation, click OK.

The Effect section of the

animation pane give you the

ability to fine-tune your animation.

Start controls what event will

trigger your animation. On Click

will trigger the animation when

the mouse button is clicked or you

press the space-bar. With Previous

triggers the animation when the

animation before it plays. After

Previous plays the animation after

the previous animation. The

second control relates directly to

the type of animation you select. If

it is a motion animation, it asks you

for a direction. If the animation

changes colors, it will asks you for a

color. Finally, the Speed controls

the speed at which the animation

plays.
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Animation Example

The real power of animations

comes when you combine them to

create interesting effects for your

objects. In our example, the effect

we will create will display items in a

list one at a time. As the next items

displays, the previous one will gray

out. Finally, all the list items will

fade out before the slide transition.

Create a new slide, and, in the

text area, add four list items. Select

Elmer Perry's history of working, and
programming, computers involves an
Apple I IE, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
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all four list items, and click Add in

the Custom Animation pane. On

the Entrance tab, select Fly In and

click OK. Select each of the

animations in the animations pane

and set the start to on click,

direction to from bottom, and the

speed to a speed that looks good

on your machine.

For the color change effect,

select the first three items in the

text area of the slide, and click the

Add button. On the Emphasis tab,

select Change Font Color, and click

OK. For each of these three new

animations, change the start to

with previous, the color to gray,

and the speed to a speed that

looks good on your machine. Move

the color change animation for the

first item up using the Change

order arrows. Move it up under the

entrance animation for the second

item. Move the second change

color animation up under the third

entrance animation, and leave the

third color change under the

fourth entrance animation.

Finally, we will create the fade

for all the items. Select all four list

items in the slide's text area. Click

on Add in the animation pane. On

the Exit tab, select Dissolve and

click OK. Set the first exit to start

on click and the other three to

after previous. Select a speed for

the dissolve that works for your

machine.

Test your animations by clicking

on Slide Show in the animation

pane. If you set everything

correctly, each item should fly in

from the bottom and gray out

when you click the mouse. At the

end, all four items should dissolve.

Transitions and animation are

key to creating a professional

looking presentation. If you are

careful to not get carried away,

you can create a polished and

memorable presentation for your

audience. Remember that the idea

behind a presentation is to present

your ideas to your audience, not to

impress them with fancy, overdone

transitions and animations.

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://podcast.ubuntu-uk.org/


full circle magazine 52 Return to ContentsLibreOffice

HHOOWW--TTOO
Written by Elmer Perry LLiibbrreeOOffffiiccee PPtt11 99:: BBaassee

M
any people collect

things like sports

cards, books, comic

books, or butterflies.

Sometimes, it is helpful to catalog

these collections, so you create a

catalog. You decide which

characteristic about the items you

want to track, you determine that

some items share some of these

characteristics in common, and you

create a system for identifying

each item uniquely. Finally, you

begin to build your catalog. You

can think of a database as a catalog

of similar items. You have

something you want to track, and

what better way to track it than

through your computer.

Base is the database module for

LibreOffice. Base is not a database

engine, but a front end for

interacting with databases. By

default, Base uses the HSQL

database engine, which is an open

source engine, but you can connect

to other engines like MySQL or

Oracle. You can even use a

spreadsheet as the basis for a

database, as we did in part 7 of this

series (see Full Circle issue 52).

When creating a database, you

get better results by sitting down

and taking some time to plan out

how your database will look and

behave. You map out the

characteristics you want to track,

determine the common

relationships, and create a unique

way to identify each of the items in

the collection. Taking the time to

plan will save you time and effort

later in the process when you begin

to build reports and searches for

your database.

What Makes a

Database

Before we get into the actual

planning of a database, let's talk

about the parts making up a

database. The smallest element of

a database is the field. Think of a

field as a single characteristic of

the object we are defining in the

database. A collection of fields is a

record. A record defines all the

characteristics of a single object we

are collecting. We create tables to

hold records. Tables define the

fields for each record and contains

the datum for each field in the

r

ecords.

Think of a database table as a

spreadsheet in Calc. Across the top,

you have columns. The columns are

the fields. Down the side, you have

rows. The rows are records. The

entire spreadsheet, containing all

the data, is the table.

Planning Our Example
Database

Through this series of articles

on Base, we will use a database I

created for tracking my book

collection. I kept the database

fairly simple, but including many

elements to show the nature and

aspects of relational databases,

mostly the relational part. In this

part, we will track the steps I took

for planning the creation of the

database. We will use the steps I

have mentioned.

What Characteristics to
Include

When I began planning my

Books database, I knew I didn't
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programming diagrams. Dia is

available in the Ubuntu

repositories. You don't need to

know a lot about UML to lay out a

database. I will walk you through

the process in this section.

The main table for our database

is the Books table. We know we

need the fields Title and

Published, but we also need a

unique field to identify each

record. Since two books could

potentially have the same title, we

will create an auto generated field

named BookID.

For the Authors table, we need

a field for the author's name

(Name) and a unique auto

generated field (AuthorID). Two

fields for the Media table, too:

MediaID and Type.

Now that we have our three

Many to Many – For many

characteristics, you have many

matching characteristics. As an

example, in a school, you have

many students who have many

different teachers.

For our database, we have two

one-to-many relationships. For

every one book, we can have

multiple authors, and for every

one book, we can have multiple

media types. We will take these

relationships into consideration as

we begin to map our database.

Mapping the Database

I t is a good idea to lay out your

database on paper, or using a

diagram program, before you

begin to work in Base. I used the

open source program Dia, because

it has a Unified Modeling Language

(UML) module designed just for

multiple authors in one field, but

that would make searching for

books by a single author difficult.

We could create multiple fields for

multiple authors, but how many do

you create? If it is an anthology,

the book could have many authors.

The same is true for the media

types.

The answer is relationships.

Relationships help us link data in

different tables to each other.

There are three different

relationships defined for relational

databases.

One to One – For every one

characteristic, you have one

matching characteristic. As an

example, for every one person, you

can have one spouse.

One to Many – For every one

characteristic, you have many

matching characteristics. In our

case, for every book, you can have

multiple authors.

want a big complicated thing with

information I would never use. I

knew I needed the basics, title and

author. However, I decided on

including the year of publication,

too. With all the different ways to

“read” books today, I decided I

needed to track the different types

of media as well. So, in the end, I

decided on these characteristics:

• Title

• Author

• Publication year

• Media type

• Relationships

Relationships put the

“relational” in relational databases.

When we first look at our

characteristics list, we might think

we just need a table with four

fields. However, we would run into

trouble when we have a book that

has more than one author, or we

own a book in more than one

format. We could just stuff

LIBREOFFICE - PART 1 9
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contains a table. The name of the

table appears at the top of the box.

Underneath, we list all the fields in

the table and their types. We will

discuss types in the next part of

this tutorial. The lines between the

boxes show the relationships from

one table to the next. The notation

1 ..1 shows that field has a one-to-

one relationship with the field in

the other table. The

notation 1 ..n shows that

field has a one-to-many

relationship with the

field in the other table.

For example, BookID in

the Books table is

connected to the

BookID in the

BooksAuthors tables. On

the Books table BookID,

the notation is 1 ..n,

meaning this book can reference

more than one record in the

BooksAuthors table. On the

booksAuthors, BookID has a

notation of 1 ..1 , meaning this is a

reference to one specific record in

Books.

With all this planning, we can

easily create our database without

having to make many changes. We

know what tables we need and how

they will relate to each other. While

tables, we need to link them

together. Linking is done by what

is known as foreign keys. A foreign

key is a field used to create a

relationship with a record in

another table. Since both of our

relationships are one-to-many, we

can't just stick a field in the Books

table to reference authors and

media types. We will use

intermediate tables to

link the authors and

media types together.

These intermediate

tables will contain

foreign keys for the IDs

to create the link.

We will need two

intermediate tables.

We will name them

BooksAuthors and BooksMedia.

BooksAuthors will have two fields

named the BookID and the

AuthorID, which link back the the

ID fields in the Books and Authors

tables. We do the same with the

BooksMedia table. Two fields

named BookID and MediaID,

linking to the IDs in Books and

Media.

I created a UML diagram

showing the relationships

between our five tables. Each box
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this may seem like a lot of work, it

saves us a lot of time in the end,

because we have actually put

thought into how we will

construct our database and how it

will work.

Next time, we will build our

tables and create the

relationships in LibreOffice

Base. Because of our planning,

the process is quick and easy.

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://podcast.ubuntu-uk.org/
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D
atabases are used to

store information about

objects or data. In the

previous tutorial, we

mapped out how our books

database would look. We designed

tables for our data, and defined

relationships between those

tables. Now, we will put our

planning into action by actually

creating the database file, adding

the tables, and creating the

relationships.

Creating the Database
File

As I mentioned before, Base is

not a database file but an interface

for accessing and manipulating a

database file. Although it is

possible to connect to many

different database types, we will

use the default HSQL database for

our books database.

To start the database wizard,

select Database from the

LibreOffice Home screen or File >

New > Database. The first screen of

the database wizard lets us choose

whether we want to open an

existing database or create a new

one. Select Create a New Database,

and click Next.

The second screen of the wizard

asks us whether we want to

register the database and what we

want to do once the database has

been created. Registering a

database in LibreOffice makes it

available in all our documents. We

won't need this for our database,

so select No – do not register the

database. Check Open the

Database for Editing, and click

Finish. LibreOffice will open a file

dialog to define a location and

name for the database. I simply

named the file: books

Once you have a name and

location for the database file, the

main Base screen opens. Down the

left side, you have the different

pieces which can make up a

database file. The top right gives

you access to the different actions

you can take for each part, and the

lower right shows the objects

already created.
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Field Types

Before we create our first table,

we need to discuss some of the

common database field types.

When you select a type for a field,

you are presented with many

options for the type. Many of the

types are identical, and are there

for compatibility reasons. The most

common types are:

Integer – a whole number, eg. 1 23

VarChar – a variable length string

of characters. You will define the

maximum length for the VarChar.

Date – a date value, of course, eg.

1 0-1 5-201 2 (the exact format is

location specific)

Time – a time value, such as

09:1 5:25

decimal – a real number including

the whole (integer) number and its

fractional part, eg. 1 23.25 (the part

separator is location specific)

For our purposes, we will use

Integer and VarChar.

Creating the Tables

Base has three different ways to

create tables: through a table

wizard, through design view, and

by SQL statements. The table

wizard is good only to create

specific types of tables by picking

from a list of predefined field

names. The SQL method requires

you to know and understand the

SQL language and is beyond the

scope of this article. The design

view is usually the best choice, and

presents you with a list you fill in to

create your table. We will use the

design view to create our tables for

this project.

We will start with the Books

table. Select Tables from the

Database pane on the left. In the

Tasks pane, click on Create Table in

Design View... to open the Design

View dialog. Across the top you

have labels for each of the

elements of a field: Field Name,

Field Type, and Description. The

Description is optional but is useful

for making notes about how a

field is used. At the bottom, we

see the Field Properties. This

section will change according to

the type of field we select.

In the first field, enter the

name BookID. From the dropdown

box in Field Type, select Integer.

Adding a description is up to you.

Under the field properties, change

AutoValue to Yes. This will place a

key icon in the box beside the field

record showing it is the primary

(or key) index. In the second row,

type Title for the name. Give this

one a type VarChar. Again, a

description is up to you. In the

field properties, leave the length

at 1 00, the default for VarChar.

The third field is Published with a

type of VarChar. Change the

length in the field properties to

1 2. I chose VarChar rather than

date because we just want the year,

and if the publishing date of a book

is unknown, I can enter just

“Unknown”. Click on the save icon,

and Base prompts you for a table

name. Enter Books.

Our tables for Authors and

Media are created in much the

same way. For Authors, create two

fields: AuthorID, integer

(AutoValue Yes); and Name,

VarChar (length 50). For Media,

MediaID, integer (AutoValue Yes);

and Type, VarChar (length 25).

Our two foreign key tables need

a little different treatment. In

BooksAuthors, create two integer

fields named BookID and AuthorID.

Click on the icon box beside the

first record. Holding down the Shift

key, click in the icon box for the

second. At this point, you should

have both records selected. Right-

click the icon box and select

Primary Key from the context

menu. This creates a combination

key. The two values together

create the primary key, which

uniquely identifies each record in

the table. For the BooksMedia

table, create two integer fields

named BookID and MediaID. Select
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both fields, right-click, and select

Primary Key.

Create Relationships

Once we have all our tables

defined, we can create the

relationships that bind everything

together. We will create

relationships between our three

main tables and our foreign key

tables. The direction in which you

drag the fields is important, so pay

close attention to how you do it.

To start the Relation Design

dialog, go to Tools > Relationships.

You are presented with a list of

tables. Select a table and click Add

to add the table to the Relation

Design. Add the tables in the

following order to make it easy:

Authors, BooksAuthors, Books,

BooksMedia, Media. Once all the

tables are added, select Close.

Drag the BookID field in Books

to BookID in BooksAuthors. A

Relation dialog pops up. Under

Update option, pick Update

cascade and OK. This will cause the

field to update when the Books

table updates. Drag the AuthorID in

Authors to AuthorID in

BooksAuthors. Select Update

cascade in the Relation dialog.

Next, drag the BookID in Books to

BookID in BooksMedia. Select

Update cascade. Finally, drag

MediaID in Media to MediaID in

BooksMedia. Select Update

cascade. Your relation design

should look something like the one

pictured below.

With our tables and

relationships created, we are ready

to begin work on creating forms

for data input. In our next How-To,

we will create the forms for data

entry. Everything will come

together to create a usable data

entry system.

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://podcast.ubuntu-uk.org/
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S
ofar in our series on

LibreOffice Base, we have

planned the layout for our

database, created the

tables, and created the

relationships between those

tables. Now, we need to think

about how we will input the data

into our tables and link them all

together. You can edit the tables

manually in the tables section of

the program, but the best way is

through input forms. We will

create three forms: Authors,

Media, and Books. We will handle

the forms for authors and media

first as they are the easiest. The

form for books will bring

everything together in one place.

Create the Authors and
Media Forms

Select forms from the Database

pane on the left. You can create

forms in two ways, through the

wizard or through the Design View.

We will use the wizard for Authors

and Media. Click on Create from

wizard... in the tasks pane. This

starts the wizard.

On the first step of the wizard,

select the Authors table from the

dropdown, and move Name to the

Fields to use. This is done by

selecting the field and using the

arrow keys. Click Next.

The second step deals with

subforms, which we do not need

for the Authors form. Click Next.

You will notice that steps three and

four are skipped. Those steps deal

with setting up a subform. We will

not use them in the our

implementation of our database.

Step five asks us for a layout for

our fields. Since we have only one

field, we will choose the table

layout. Select the table layout and

click Next.

The sixth step is about how the

form is used. We want the form to

display all data, so select all data

and click Next.

Step seven deals with the styles

of the form. You can select

different background layouts for

your form. You can also select

whether your controls are

displayed with no border, 3D

borders, or flat. Click Next.

On the eighth step, we give the

form a name, Authors, and choose

whether we want to edit it more or

use it. After naming the form, click

Finish. The new form will pop up on

your screen. Close it and save your

work.

The Media form is created in the

same way, only using the Media

table instead of the Author table.

Create the Books Form

Although we will use the wizard

to start our Books form, we will

need to edit it afterwards to add

the connections to authors and

media. Go through the wizard again

with the Books table, adding the

fields Title and Published. You will

skip the subforms again. We will

add our subforms manually. For the

layout, use either Columnar –

Labels on Top, or Columnar –

Labels Left. I used Columnar –

Labels on top. After naming the

form Books in step eight, select

Modify the form, and click Finish.

This time the form is opened for

editing. We will add two subforms

to make a connection to the

Authors and Media tables.

On the toolbar at the bottom of

the form, select the Form

Navigator. This opens a small

dialog containing the elements of

our form. Right-click MainForm,

then New > Form. A new form is

added to the list. Since it is already

selected, just start typing to

rename it FormAuthors. We will

use this subform to create the link

to our Authors table through the

BooksAuthors table. Right-click the

FormAuthors and select

Properties. On the Data tab, select

table for the Content type, and

BooksAuthors for the Content.

Now, click on the ellipse button

next to List Master Field. A link-

fields dialog pops up. This is where

we create our link between the

Books table and the Authors table.

Under BooksAuthors, select

BookID and under Books select

BookID. Click OK, and you can close

the Form Properties dialog.

Create another subform under
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We will create the Media

control in the same way we did the

Authors. Select the FormMedia in

the Form Navigator. Draw the

table control to the right of your

statement to fill our list box with

the names from the Authors table.

You can click on the down-arrow to

give yourself a small edit box to

work in. The SQL statement is:

SELECT “Name”, “AuthorID”

FROM “Authors”

This statement will select all

the records from the Authors

table. Set the Bound field to 1 . The

Bound field selects which field will

fill the list box. Since we selected

the Name field first, the bound

field of 1 will fill the list box with

the data from the Name fields.

Close the list box properties and

save your work.

Navigator. Click on the Table

button in the More Controls

toolbar. Underneath the two input

boxes for title and published, draw

the table on the page. Right-click in

the header section of the new

table and select Insert Column >

List Box. Right-click the newly

created column and select Column.

This displays the List Box

properties. On the General tab,

change the label to Authors.

Switch to the Data tab. For the

Data field, select AuhtorID. This

tells Base we want to relate this to

the AuthorID field in the

BooksAuthors table. For Type of

list content, select Sql. In List

Content, we will write a short SQL

MainForm named FormMedia. Edit

the properties, setting the Content

Type to table, and the Content to

BooksMedia. Click the ellipse next

to List Master Field, and select

BookID under both BooksMedia

and Books. Click OK and close the

Form Properties dialog.

Now, we need to create our

controls that will contain our

authors and media. Remember, we

need the ability to select more than

one, so a table is our best choice for

the control. Click on the More

Controls button on the toolbar on

the left side. A More Controls

toolbar will pop up.

Make sure you have the

FormAuthors selected in the Form

LIBREOFFICE - PART 21
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We now have a working

method for entering data into our

database. While it works, there is

one disadvantage to this setup. If

you find that you need an author

or media type that is not there,

you have to close the books form

and open the authors or media

forms. In a later How-To, we will

attempt to overcome this

inconvenience.

In the next HowTo, we will

create a query and a report for

extracting information from our

database.
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title and published controls. Create

a column in the control. Open the

column properties and change the

label to Media. Set the Data field to

MediaID, and the Type of list

content to Sql. The SQL statement

for the List Content is:

SELECT “Type”, “MediaID”

FROM “Media”

Set the Bound field to 1 .

We are now finished with the

form. Save and close it.

Using the Forms

The Authors and Media forms

are simple to use. Just select an

empty row and type in the name or

type. You will want to add your

authors and types before using the

books form. The books form is easy

to use as well. Fill in your Title and

Published year (or Unknown if you

don't know the year). The authors

and media tables give you a list box

from which you can select your

authors and media types. Note that

you can select more than one

author and media type. To create a

new record, click on the new record

or next buttons in the form control

toolbar.

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://podcast.ubuntu-uk.org/
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I
f you have been following

along in this series on

LibreOffice Base, you now

have a database file with

tables and relationships. You can

enter information into your

database through forms, but what

about getting information out of

the database? Queries and Reports

are used for extracting data from

your database - the Queries define

what data is extracted, and the

Reports define the appearance of

the extracted data. We will create a

query and a report to show how

you can generate a report of your

data.

CREATING A QUERY

Queries poll the database for

certain information in your

database. You have three ways to

create a query: a wizard, design

view, and SQL. The wizard doesn't

work with the type of relational

database we have created and SQL

is beyond the scope of this How-to,

so we will use the design view to

create our query. We will create a

query that contains all the

important fields in our tables: title,

published year, author(s) , and

type(s) .

Click on Queries in the Database

pane, then click on Create Query in

Design View in the Tasks pane. A

Query design form will display with

a Add Tables or Query pop-up

dialog. Add all the tables to the

Query Design form, and close the

pop-up. You will end up with a form

that looks a lot like the

relationships design we created

previously. Below the tables, you

see a form that will contain the

fields which we want to include in

our query. From the Books table

drag Title and Published into the

form. Drag Name from Authors,

and drag Type from Media. That is

all we need for this query. Save it

as AllFields. Close the Query

Design form.

You now have a query to use in

creating multiple reports for your

database. If you're curious about

the SQL used to create your query,

you can right-click on the newly

created query and select Edit in

SQL View. This brings up the SQL

View with the complete SQL

statement for the query you just

created. I wouldn't recommend

changing this unless you are well

versed in SQL, but creating

multiple queries in Design View,

and then viewing them in SQL

View, could help you begin to learn

SQL.

CREATING A REPORT

A report runs a query and

formats the query results into

something you can use. You can

create many different reports with

the query we created – depending

on how you group the data from

the query. We will create a report

for sorting our books by media

type, and I will suggest how you
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There are several for each, and

they change the look of the report.

I left mine at the defaults, but feel

free to play around with these

options. Under the Layout of data

list box, you can select whether the

report is landscape or portrait. For

this report, I think portrait will

work best. Click Next.

The final step is where we

create the report. You can give it a

title, indicate how the report is

used, and what to do with the

report. For this report, give it a title

of TitleByType. Now, we need to

answer the two questions. What

type of report do you want to

create? A static report is a one time

report. It cannot change. Once it is

created, the data is fixed. If,

however, you want a report you

can re-use, you want a dynamic

report. A dynamic report is just a

template you can use over again.

exclude the Name field because if

there is more than one author, we

want them listed together. Click

Next.

Sorting is done in step 4, but we

don't have much use for it here.

You will notice that you can change

only whether the sorting is

ascending or descending for our

groupings. In the fourth box, select

Name and leave on Ascending.

Click Next.

In step 5, we can choose a

layout for the data and the header.

Step 2 is labeling our fields.

Here we specify how the fields are

labeled in our report. Change the

label for Type to Media Type, and

Name to Author(s) . Click Next.

We create our groupings in step

3. Groupings control how the fields

are consolidated and arranged in

the report. Grouping is important,

because we can use it to create a

whole different report depending

on how we group the fields. For

example, if you wanted to create a

report of titles by author, you

would make Name your first

grouping, then Title as a sub-group.

For our report, we are creating a

report of Titles by Media Type, so

our grouping order is Type, Title,

Published. We add published

because, if there is more than one

author, the published date will

repeat in the report template, a

byproduct we don't want. We

LIBREOFFICE - PART 22

might create other reports using

the same query.

There is only one way to create

a report – use the wizard. Select

Reports in the Database pane and

click on Use Wizard to Create

Report. A report template window

will appear with the report wizard.

You can actually watch your

template fill in as you go through

the steps of the wizard, giving you

some ideas about how your final

report will look.

In step 1 , you will pick your

query and the fields to use in the

report. If not selected already,

select the AllFields query we just

created. Move all the fields into the

Fields in report box by clicking on

the >> button. If you wanted to

create a report that uses just some

of the fields, you would just select

the required fields. For our report,

we will use all the fields. Click Next.
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For this report, we want a dynamic

report we can use again, so select

Dynamic. How do you want to

proceed after creating report?

Modify report layout will allow you

to edit the report as a writer

document. Create report now is

obvious; it will fill in the data and

generate the report. We can

always edit the layout later, so we

will select Create report now. Click

Finish.

Base generates our report and

displays it in a Writer window. This

generated report is read-only. If

you want to edit the text or layout

of the report, close it. In the

Reports pane, right-click your

report and edit. This opens the

report template in Writer, where

you can add text, graphics, etc, just

like you would in any Writer

document. Just take care when

changing anything in the cells

where the data is plugged in.

In this How-to, we created a

query and a report. Play around

with the grouping and sorting

settings in the report wizard and

see just how many different

reports you can create from the

one query we created.

Next time, we will use macros

to create enhancements to our

database and make it act more like

an application.
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F
or the previous four parts

of this series, we have

slowly built a database

document using

LibreOffice's Base module. We

have a database with forms to

enter our data, and queries and

reports for extracting the data. We

now have a usable document for

recording our book library.

However, our current design has

one flaw we need to overcome. If

we need to enter a new author or

media type while we are in the

books form, we have to close the

book form and open one of the

others. If we could enter new

authors and media types directly

from the books form, it would

behave more like an application

and make data entry even easier.

We can accomplish this through a

few short macros.

The LibreOffice Basic language

is very similar to other Basic

languages, such as Visual Basic for

Applications. To manipulate the

underlying LibreOffice document,

we access the Uno framework

controlling the document. The Uno

framework is quite complex, but I

will explain, as best I can, the

properties and objects we will use.

The goal is not to teach you how to

write LibreOffice macros, but how

you can use them.

MACRO SECURITY AND
OPTIONS

While macros allow us to do

cool things in our documents, they

can also cause problems. Some

people use macros to compromise

other people's systems, therefore,

we need to take a few minutes to

talk about macro security. Whether

you are running LibreOffice on

Linux, Mac, or Windows, malicious

code in a macro can compromise

your data and possibly your entire

system.

Macro security in LibreOffice is

simple. Tools > Options opens the

Options dialog for LibreOffice.

Under LibreOffice, select Security.

Click on the Macro Security button

to pop up the macro security

options. You have four options.

Never use the Low security option

– it will run macros without asking

you. I recommend the Medium

security level. With this level, you

are prompted whether to run the

macros when you open a document

containing macros. The High and

Very High options require a

certificate or folder you designate

as trusted. While this is great, I

believe nothing trumps the

instincts of the user. You usually

know whether you were expecting

a document to contain macros.

When in doubt, click No. Click OK

to save your choice and OK to close

the options dialog.

Now, on to the fun stuff.

THE MACROS

We will write four macros for

our database document. Three will

deal with opening forms, and the

last will update the list boxes for

authors and media types. The

general idea behind macros is to

accomplish tasks that are not built

into the program, or to simplify

complex tasks. Our macros really

accomplish both, as we will simplify

the tasks of adding authors and

media types and provide

functionality not built into the

program.

Before we can begin to write

our macros, we need a container to

hold them. Macros are contained in

a module. Modules can live in the

program itself or within a

document. Since our macros are

specific to our database file, we

will embed them in the document.

Macros embedded in a document

are available only when the

document is loaded. Macros

contained in the program are

available as long as the program is

running.
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not use it. The argument oEv is a

reference to the object making the

call. We will use this to our

advantage later, in the last

subroutine, but here we do it

because it is required. These two

subroutines are pretty simple. We

just make a call to OpenAForm

passing the name of the form we

want to open, Authors or Media.

The final subroutine deals with

our problem of refreshing the data

in the list boxes for authors and

media when we add authors or

media using the two subroutines

above.

Sub ListRefresh(oEv as

Object)

oEv.source.model.Refresh

End Sub

Once again, since we will call

this subroutine (shown right) from

a control, we need a reference to

the control making the call.

However, this time we will actually

use the object. This subroutine

call is complete, the variable

GetForm is the object of the form

name passed to the subroutine.

The fourth line calls the Open

method of the form. On the fifth

line, we tell Basic this is the end of

the subroutine with the command

End Sub.

We will call the OpenAform

subroutine twice. Once to open

the authors form, and once to

open the media form. Add the two

subroutines shown below to your

editor.

The signature on these two

subroutines are a little different.

Since we will call them from a

control within a form, we need to

pass the object making the call as

an argument, even though we do

variable named FormName which

is a type String. In the second line

of the subroutine, Dim is another

keyword. Dim initializes a variable

as a type, and, optionally, a value.

We define a variable named

GetForm as a type Object. The

third line assigns a value to the

variable GetForm through a chain

of commands in the Uno

framework.

ThisDatabaseDocument refers

to the currently open database

document. In our case, book.odb.

FormDocuments is a collection of

all the forms in the document.

Finally, GetByName retrieves a

specific form object from the

collection. Notice, we pass the

variable FormName from the

signature to this method. Once the
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Sub OpenAForm (FormName as String)

Dim GetForm as Object

GetForm = ThisDatabaseDocument.FormDocuments.GetByName(FormName)

GetForm.Open

End Sub

Sub OpenAuthorsForm(oEv As Object)

OpenAForm("Authors")

End Sub

Sub OpenMediaForm(oEv As Object)

OpenAForm("Media")

Tools > Macros > Organize

Macros > LibreOffice Basic. The

LibreOffice Basic Macros dialog

pops up. Select book.odb from the

Macro from-list. Click the New

button. A dialog pops up asking

you for a name for the module.

Name it FormCalls. Click OK. This

brings up the LibreOffice macro

editor. The macro comes with a

default main subroutine. We will

not use this subroutine. Highlight

Sub main and End Sub and press

the backspace key to delete them.

Our first macro is a generalized

subroutine for opening a form. A

generalized subroutine is written

for reuse. We will call this routine

twice from other routines we

write. Type the subroutine shown

above into the editor.

The first line of the subroutine

is called the signature. The

signature determines how the

subroutine is called. A signature

starts with the keyword Sub, which

defines this call as a subroutine.

Next, the name of the subroutine.

In our case, OpenAForm is the

name of the subroutine. Finally in

the parenthesis, we have the

arguments used when calling this

subroutine. In our case, we have a
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FINAL THOUGHTS AND
REFERENCES

Again, I would like to emphasize

that writing macros in LibreOffice

Basic is complex. Documentation is

pretty sparse, but it is out there. If

you are interested in taking up the

challenge, here are some

references to get you started:

LibreOffice Basic Guide:

http://wiki.documentfoundation.o

rg/images/d/dd/BasicGuide_OOo3.

2.0.odt

Andrew Pitonyak's OpenOffice

Macro Information :

http://www.pitonyak.org/oo.php

You can find the macros used in

this How-To on pastebin.com at

http://pastebin.com/MU2Ztizi

Next time, we will move on to

another part of the LibreOffice

suite and explore the Math

module.

Macro Selector dialog. In the tree

list under Library, select book.odb

> Standard > FormCalls. Select

OpenAuthorsForm from the Macro

Name list and click OK. Click OK to

close the Assign Action dialog.

Close the buttons properties

dialog.

Do the same with the button

under the Media table, only name

it AddMedia, make the label Add

Media Type, and assign the macro

OpenMediaForm to the Execute

Action event.

Finally, we need to add the

Elmer Perry's history of working, and
programming, computers involves an
Apple I IE, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
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makes a method call to the

underlying model of the list box

and refreshes the data in the list,

thus updating our list of authors or

media types. Save your module and

close the Basic editor.

MAKING CONNECTIONS TO
MACROS

At this point, our macros do

nothing. We need to connect them

to objects in our form to activate

them when needed. First, we will

connect the open form subroutines

to buttons in our form, and then we

will connect the ListRefresh to the

list boxes.

In the database pane, click on

Forms. Right-click the Books form

and select edit. Add two push

buttons to the form, one under the

Authors table and another under

the Media table. Right-click the

button under the Authors table and

select Control to bring up the

buttons properties dialog. On the

General tab, change the name to

AddAuthors and the Label to Add

Authors. On the Events tab, click

the ellipses (…) button next to

Execute Action – which brings up

the Assign Action dialog. Click the

Macro button to bring up the

refresh subroutine to our list boxes.

Right-click the Authors column in

the authors table and select

Column. On the Events tab, click the

ellipse (…) button beside “When

receiving focus”. In the Assign

Action button, use the Macro

button to assign the ListRefresh

macro to the action. This will cause

the list to update data from the

Authors table when you click on a

list box in the column. Do the same

for the Media column in the media

table. Save your changes to the

Books form and close it.

TESTING YOUR CHANGES

Any time we make changes to

our forms, we will want to test

them and make sure we got

everything right, especially in cases

where we have used macros. One

simple typo could cause things to

not work. Double-click the Books

form to open it. Add a new book

with an author and media type you

have not added already. Click the

Add Authors button to make sure it

opens the form. Add some authors.

Close the Authors form. Click on the

authors dropdown list box and

verify that the authors you added

are there. Do the same test with the

Add Media Type button and listbox.

http://wiki.documentfoundation.org/images/d/dd/BasicGuide_OOo3.2.0.odt
http://www.pitonyak.org/oo.php
http://pastebin.com/MU2Ztizi
http://wiki.documentfoundation.org/images/d/dd/BasicGuide_OOo3.2.0.odt
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H
ave you ever been

working in a word

processor and needed

to insert a formula into

the text? Perhaps you were writing

a math or scientific paper for

college, or even answering a

question about statistics. If you

need to enter anything beyond

elementary math, you will quickly

run into formatting issues.

LibreOffice overcomes this

problem by providing us with the

Math or Formula module. You can

use the module independently to

create formulas, or use it directly in

the other modules of LibreOffice.

Today, we will learn how to enter

formulas in the Math editor, and, in

later articles, we will learn how to

use formulas in Writer.

Open a new Math window by

clicking on the Formula button on

the LibreOffice Start Center, or

through the menus with File > New

> Formula.

THE FORMULA WINDOW

The formula window has three

pieces: the preview pane, the

formula editor, and the elements

window. The preview pane at the

top shows you your formula as it is

created. The formula editor at the

bottom is where you enter your

formula. The floating Elements

window provides you with

shortcuts to different formula

elements. Think of the elements as

building blocks for creating your

formula.

THREE WAYS TO ENTER
FORMULAS

There are three ways to enter

formulas into the formula editor:

through the Elements window,

through a context menu, or by

direct entry.

THE ELEMENTS WINDOW

The Elements window is divided

into two sections. The top section

is the category section, and the

lower section contains the

elements in that category. If you

select a category then click on one

of the elements in that category,

the program will enter the element

into the editor with <?> as

placeholders for the variables of

the element. The first placeholder

is highlighted. Use the F4 key to

move to the next element. Shift-F4

will move backwards through the

placeholders.

To get you familiar with the

Elements window, I will walk you

through the steps to write a

formula using the Elements

window. Starting with a new

formula window, select the

Relations category, then the equals

element. <?> = <?> appears in the

formula editor. The first <?> is

highlighted. Enter the letter “h”.

Press F4 to move to the other <?>.

Select the Functions category, then

the square root element. The <?> is

replaced with sqrt{<?>} and the

placeholder in the brackets is

highlighted. Select the

Unary/Binary category, then the

addition element. The program

inserts <?> + <?> into the square

root's brackets. Select the Formats

category, then the Superscript

Right element. <?>^{<?>} replaces

the highlighted placeholder. Enter
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the letter “a” and press F4 to move

to the next placeholder. Enter the

the number “2”. Press F4 to move

to the next placeholder. Select the

Superscript Right from the

Formats category. Enter the letter

“b” and press F4 to move to the

last placeholder. Enter the number

“2”. The final result will look like

this:

and the text in the formula editor

is:

h = sqrt{a^{2} + b^{2} }

THE CONTEXT MENU

The context menu (shown

below right) is much like the

Elements window. Right-click in

the formula editor, and you get a

menu of all the categories. Each

category has a submenu of the

elements. Click on the element to

insert it into the formula editor.

Follow the example above again,

but this time use the right-click

context menu to create the

formula. You should get the same

results.

DIRECT ENTRY
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As you work with Math and

learn the elements, you can enter

the formulas directly in the

formula editor. By far, this is the

quickest way to enter a formula.

Now that you have created the

formula twice, using the Elements

window and context menu, see if

you can enter it directly into the

editor without using the element

tools. If you need help, just

reference the editor text shown

above.

SPECIAL CHARACTERS

You won't find everything you

need in the Elements window and

context menu. Many equations

use Greek characters and other

symbols. LibreOffice Math allows

you to enter special characters

into your equation. If you find you

need a special character not listed

in the special characters, you can

even add your own.

ADDING GREEK
CHARACTERS

Through the menus Tools >

Catalog, you can access the Greek

letters through the character

subsets Greek and iGreek. Greek is

the letters in plain text and iGreek

is the letters in italics. Just select

the letter you want and click the

Insert button. When finished, click

the Close button.

For direct entry, type in %

followed by the Greek letter name.

For example, to get the Greek

letter pi, enter %pi. To get the

uppercase letter, make the name

uppercase, %PI . To make the

character italics, place a lowercase

“i” before the letter's name, %ipi.

OTHER SPECIAL
CHARACTERS

Other special characters are

found in Tools > Catalog under the

Special subset. Select the symbol

you need and click the Insert

button. As you use and learn the

names of the symbols, you can

enter them directly using the %

and then the name of the symbol.

NOTE: The lowercase “i” for italics

works with only the Greek letters.

We will discuss inserting italics for

other elements in the next How-

To.

ADDING SPECIAL
CHARACTERS

If the catalog does not have the

special character you need, you can

add it to the catalog. One such

character is the prime symbol. Let's

add it to our special subset.

Tools > Catalog and select the

Special symbol set. Click on the

Edit button. This bring up the Edit

Symbol dialog. For the font select

DejaVu Sans, and for the subset

select General Punctuation. The
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symbol you want is Ux2023. For the

symbol name type in prime. Click

the Add and OK buttons. The prime

symbol has now been added to the

Special symbols list. You can use it

by selecting it from the catalog, or

enter it directly by typing %prime.

CONCLUSIONS

Math allows you to create

formulas you can insert into your

documents. You have three

methods for entering formulas into

the formula editor: through the

Elements window, through the

context menu, and by direct entry.

The Elements window and the

context menu help you to learn

how to enter the different

elements of a formula, but once

you know how to enter an element,

direct entry is the quickest way to

create a formula.

In the next LibreOffice How-To,

we will look at ways to format our

formulas so they look the way you

want them.



full circle magazine 70 Return to ContentsLibreOffice

A
syou create more

complex formulas in

Math, you will soon

discover that things

don't always display the way you

were expecting. There are a few

tricks to making formulas display

the way we want them, especially

complex formulas. Today, we will

look at many of these tricks to

make our formulas come out right.

GROUP ELEMENTS WITH
BRACKETS

The curly brackets, {}, have a

special use in formulas. They help

you to group elements together.

Without them you can get a

different formula than the one you

were expecting. Here are a couple

of examples to show you what I

mean.

Enter the following into the

formula editor:

2 over x + 1

You will get the

following result:

But what if you actually wanted

the x + 1 in the denominator of the

fraction? You can use curly brackets

to group the two elements

together.

Enter the same formula in the

editor, but with curly brackets

grouping the addition:

2 over {x + 1}

You then get the

result you wanted:

Any time the formula doesn't

flow the way you were expecting,

you can use curly brackets to group

items together to make things

come out right. You will see more

use of brackets as we work through

other examples in this How-To.

EQUATIONS SPANNING
MORE THAN ONE LINE

Some equations make more

sense if they are broken into

multiple lines, or you need to show

the progression of a formula

through each step to its conclusion.

Doing this all on one line would

make the formula difficult to read.

However, just pressing the Enter

key in the editor does not result in

a new line. In order to get a new

line in the formula, you use the

newline element.

Editor example:

x over 250 = 5 over 100

newline

100x = 250(5) newline

100x = 1250 newline

100x over 100 = 1250 over

100 newline

x = 12.5

Result:

SUM / INTEGRAL LIMITS

The sum and int commands can

take optional parameters to signify

the range of the sum or integral.

The keywords ‘from’ and ‘to’

generate the lower and upper

range of these commands. The

following markup demonstrates:

sum from x=0 to x=n f(n) "

or "

int from x to n f(n+1)

Result:

SCALED BRACKETS

Sometimes, you need a bracket

to span more than one line. A good

example of this is with a matrix. If

you just use the bracket characters,

you get an ugly looking matrix.

The markup:

(matrix {x#x+1##y#y+1})

The result:

To get brackets that scale to the

size of our matrix we use the

markup “left (“ and “right )”. This

results in a much nicer looking

matrix.

HHOOWW--TTOO
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Example:

c^2 = a^2 + b^2 newline

"The Pythagorean Theorem."

Result:

CHEMICAL FORMULAS

Math was designed for

mathematical equations, but you

can make chemical formulas, too.

Since variables are usually in italics,

you will want to turn off the italics

for variables (explained later) .

Example:

matrix {

"molecules" # H_2 SO_4 ##

"Isotopes" # U lsub 92 lsup

238 ##

"Ions" # SO_4^{2­{}}

}

Result:

Note the “lsub” and “lsup” in

matrix {

3x + 2x # `=` # 45 ##

alignr 6x # `=` # 45

}

The result:

You will notice the back tick or

grave ( ` ) marks around the equals

signs. This is necessary because the

equals sign is a binary operator and

requires an expression on both

sides. The back tick ( ` ) is the small

space mark in Math. You could

accomplish the same thing with the

Math symbol for a long space (~) or

empty brackets ({}) . Remember in a

matrix that everything between

the hashes is an independent

expression.

You will also notice, in the

second row, I use the command

“alignr” to align the 6x to the right

in its column. Use “alignl” to align

to the left and “alignc” to align to

the center. Center alignment is the

default, except in a matrix, which

defaults to left alignment.

TEXT IN A FORMULA

Sometimes, you will need to

add notes or text to your formula.

You can add text by enclosing the

text in quotation marks (“”) .

1 # if n = 1; ##

L_{n­1} + L_{n­2} # if n >

1.}

right none

The result:

Notice that I ended the

definition with “right none” to get

our definition to show correctly.

ALIGNING ELEMENTS USING
MATRIX

You will notice (in the Lucas

numbers definition) I used a matrix

to get everything to line up

correctly. The matrix command is

useful for this because Math

doesn't have a command for

aligning on a certain element. With

the matrix command, we can use

the columns and rows to get

elements to align the way we want

them. A good example of this is to

get equations to align on the

equals sign.

For example:

The markup:

left(matrix {x#x+1##y#y+1}

right)

The result:

To get scalable square brackets

use “left [“ and “right ]”. To get

scalable curly brackets use “left

lbrace” and “right rbrace”. You can

find a full list of all the brackets in

the LibreOffice help

documentation.

UNPAIRED BRACKETS

Sometimes, you only need a

bracket on one side, but not the

other. If you don't put a closing

bracket, you get an inverted

question mark and the equation

will look messy. To fix this

problem, use the mark up “left

none” or “right none”, depending

on your needs, to indicate you have

no opening or closing bracket.

A good example of this is the

mathematical definition of the

Lucas Numbers.

The markup:

L_n = left lbrace

matrix{2 # if n = 0; ##

LIBREOFFICE - PART 25
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Sometimes, it is necessary to

change the spacing and alignment

of the overall formula. Format >

Spacing bring up the spacing

dialog. In the Category dropdown,

you select the type of element

spacing you want to control. You

set the different spacing for the

elements as percentages of the

elements width or height,

depending on the spacing type.

For example, if we wanted to

change the spacing for the

alignment on the equals signs we

did earlier, we would select matrix

from the category. If we set the

column spacing to 0%, the

expressions will butt up against the

equals sign.

Result:

from eight colors: black, white,

cyan, magenta, red, blue, green,

and yellow.

CHANGING THE FONT AND
FONT SIZE

Sometimes, you will want to

use a font or font size other than

the defaults. Format > Fonts

brings up the dialog to change the

fonts for variables, functions,

numbers, and text. You can also

set some custom fonts here as

well. Format > Font Size brings up

the dialog for font sizes. You set

the base font, and then the

element sizes are set as

percentages of the base.

CHANGING ELEMENT
SPACING AND ALIGNMENT

the isotope formula. The “lsub”

makes a left subscript, and the

“lsup” makes a left superscript.

You will also need to add some

special double arrows to your

catalog for chemical formulas.

COLOR, BOLD, AND ITALICS

The color, bold, and ital

commands allow you to

emphasize certain parts of your

formula. They affect only the

elements which follow them. To

affect more elements you need to

group them together with

brackets.

Example:

bold color blue c^2 = color

red {a^2 + b^2} newline

ital color green "The

Pythagorean Theorem"

Result:

Notice that I put brackets

around the elements in the square

root to make them red. Also, for

the c2, I combined color with the

bold command. You can choose
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Format > Alignment brings up

the alignment dialog. Here we can

change the default alignment for

the formula, left, right, or center.

CONCLUSION

All the different options for

formatting your formula can seem

overwhelming, but you will get the

hang of it with practice. The first

and most important thing to

remember is using curly brackets to

group elements in a formula. Look

in the Elements dialog or the

context menu when in doubt about

how to do something, and you

might want to keep this article on

hand as a reference.

Next month, we will discuss

using formulas in LibreOffice

Writer.
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B
eing able to create

formulas in the

LibreOffice Math module

is great, but what if you

need to insert a formula into a text

document? The integration

between Writer and Math allows

you to insert formulas into your

text, to number equations, to

reference numbered equations,

and to insert equations created in

the Math module.

INSERTING A FORMULA INTO

WRITER

Insert a formula through the

menus with Insert > Object >

Formula. A formula editor window

will open at the bottom of the

Writer window, and the floating

Elements window will open. A

frame border will appear in the

document where the formula will

be displayed. You can use the

formula editor just as you would in

the Math module. When you are

finished creating your formula,

press the ESC key, or click

anywhere in the document outside

the formula frame.

In Writer, formulas are OLE

objects, and, by default, are

inserted as characters, meaning

they stay in line with the text. You

can change the way text flows

around the formula by changing

the anchor point. Right-click on the

formula, Anchor > To Page. With

the formula anchored to the page,

you can move it to wherever you

want in the document.

FORMULA EDITOR AS A
FLOATING WINDOW

If the formula editor being at

the bottom doesn't work for you,

you can detach it as a floating

window by CTRL double-clicking

the border. You can also click and

drag the border to detach the

formula editor. Once it is detached,

you can move it to wherever best

suits you. CTRL double-click to

reattach the formula editor back to

the bottom of the screen.

NUMBERING AND

REFERENCING EQUATIONS

Many times you will need to

number equations in order to

reference them in your text. Writer

makes this easy for you by

managing the references for you.

Numbering equations is one of

Writer's best hidden features.
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category of the Styles and

formatting window.

CREATE A FORMULA
LIBRARY

If you use formulas often in

your documents, you might want

to create a formula library. When

you save formulas created in the

Math module, they save as ODF

files. You can save formulas from

your documents by right-clicking

them and selecting “Save Copy

backgrounds, borders, word wrap,

and margins to your formula. To

change a formula object frame,

select the formula by clicking it

once, and Format > Object/Frame

from the menus. The object dialog

will open. You can also open the

object dialog by right-clicking the

formula, then click Object.

If you need to set defaults that

apply to all formula objects, you

can edit the formula frame style in

the styles window. You will find the

formula style under the frames

In most cases, you will number

and reference your large formulas.

Sometimes, you will need to use a

larger formula in running text.

When you do, use Format > Text

Mode while editing the formula.

Text Mode will attempt to make

the formula fit the height of the

text. Numerators and

denominators are shrunk, and

limits for sums and integrals are

pushed to the right rather than top

and bottom.

EDITING THE FORMULA OLE
OBJECT

As I mentioned earlier, formulas

are displayed in OLE object frames

in Writer. This means you can add

On a new line in Writer, type

“fn” and press F3. The “fn” is

replaced by a numbered equation.

Double-click the equation to edit it

and insert your own equation.

To create a reference to the

numbered equation, choose Insert

> Cross-reference from the menu

bar. Under type, select Text. In the

Selection list, select the equation

you want to reference. Under the

Insert reference to list, select

either Reference or Numbering.

Reference will include the

parenthesis but numbering will use

just a number.

TEXT MODE

LIBREOFFICE - PART 26
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QUICK REVIEW: UBUNTU 4.1 0
by Anas Alsaidy

I was reading that the magazine needs us to help, so I decided to write about my experience with this

old distro. Usually the reviews are about new and modern stuff, but I wanted to make this a little more

quirky than the others.

After downloading the ISO file I burned it to a CD, rebooted my computer, and started the CD. I did have

a problem with the CD not booting. It would hang on loading. So, I had to try it VirtualBox. In VirtualBox I

had no problems with booting it at all and it worked exactly as expected.

The first thing I noticed was the good old GNOME desktop environment that I really liked. The second

thing was the old versions of modern apps such as GIMP, OpenOffice, Gedit, etc.

CONS:

• I really didn't like the horrible wallpaper even for an OS released in 2004.

• I also didn't like the ugly brown theme. Luckily though, there were lots of theme that I could change

between.

• I had a problem that it wouldn't allow me to save anything, but I think that was my computer at fault.

PROS:

• It's fast. Really fast.

• I didn't have any problems with multi-tasking

• I really liked the old GNOME panels the settings manager. Although, not the theme!

I said before that it was fast, because it really is I ran lots of applications

and nothing went wrong, except for GIMP. It made the whole system lag

and I had to restart the machine, but no problem as I 'm using VirualBox. But

everything else was very fast.

Ubuntu 4.1 0 was definitely a great OS but apparently it can't replace the

newer versions of Ubuntu. But honestly I did like this OS and it really

looked like the the newer versions would be good, and that really is what

happened.

as”.

To insert a formula from your

library, select Insert > Object > OLE

Object from the menu bar. Select

“Insert from file” and browse or

type in the path for the file ODF

file to insert.

CONCLUSIONS

Using formulas in Writer is

actually very easy, making the

creation of documents with

advanced mathematics a fairly

simple task. You can number

formulas and reference them in

your text. Using text mode, you can

create formulas in your paragraph

text which aligns as well as possible

with the flow of the text. Change

the appearance of your formula by

editing the frame of the inserted

OLE object. Import formulas you

create in the Math module into

your document by inserting an OLE

object.
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T
he LibreOffice Draw

module is a vector

graphics application

included in the

LibreOffice suite. Draw lets you

create graphics you can use in your

documents. While there are more

advanced vector graphics

programs – such as Inkscape –

Draw provides you with more tools

than most drawing packages

included in other office suites.

Vector graphics create images

by defining geometric shapes such

as circles, rectangles and polygons,

rather than by pixel points on the

screen. Because of this, vector

graphics scale without distortion.

As with the other modules in

LibreOffice, Draw integrates well

with the others, making it the tool

of choice when creating graphics

for your documents.

THE DEFAULT LAYOUT

The default layout for Draw is

rather sparse. You will probably

want to modify it to include the

toolbars you use most often. The

layout includes the basic elements

you need to create a graphic image.

The center of the screen is the area

where you will create your graphic.

To the right, you have the page

pane, showing the different pages

of the graphic. Multi-page graphics

are used mostly for presentations,

and I will cover them at a later

time.

By default, you have three

toolbars. The standard toolbar is

the topmost toolbar. This is the

toolbar you see in most of the

LibreOffice modules. It controls the

new, open, save, copy, cut, paste,

and other functions that pertain to

most modules. The line and fill

toolbar sits below it. This toolbar

controls how the lines and fill of an

object will look. At the bottom of

the window sits the drawing

toolbar. From this toolbar, you can

create most of the objects for your

graphic. You can move the toolbars

by grabbing the handle at the

beginning of the toolbar and

dragging it to the location where

you want it.

The status bar at the bottom of

the window gives you a lot of

useful information about the

object you are editing. An object’s

type, dimensions, angle, and other

useful information will show up

here. I will refer to the status bar

often during the How-tos on Draw.

At the top and along the left

edge sit the rulers. The rulers are

guides to where you are in the

image. If you want to change the

unit of measure in the rulers, you

can right-click the ruler and select a

different unit of measure. When

you have an object selected, the

ruler shows double lines to indicate

the object’s position on the

drawing.

THE COLOR BAR

The color bar displays the
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happy medium is usually better

than too much. You can set certain

snap options on by default under

the snap section, but I recommend

leaving these all off by default,

and using the options toolbar

when you need to turn them on.

Use the snap range to control how

close to a snap point you are

before your object snaps to the

points are useful for such guides.

You can set the program to snap to

these guides, which help you

precisely place your objects in the

drawing.

To set up the grid, go to Tools >

Options > LibreOffice Draw > Grid.

If you want objects to snap to the

grid by default, check the Snap-to-

grid checkbox under grid. You also

have the option to make the grid

visible by default. Resolution sets

the vertical and horizontal settings

for the grid. Subdivision sets the

number of markers between the

horizontal and vertical grid points.

The more subdivisions the more

precise the changes when snap-to-

grid is on. But like most things, a
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current color palette under the

drawing area. You can use it to

select colors for your objects

rather than having to use the

dropdown list in the line and fill

toolbar. The first box – the white

box with an X in it – is the no color

(or invisible) selection. To display

the color bar, go to View >

Toolbars > Color Bar. To use the

color bar, left-click the color you

want for the fill color of the object,

and right-click to select the line

color.

TEAR-OFF TOOLBARS

Many of the icons on the

toolbars have a triangle or arrow

to the right. This indicates the item

is expandable. Clicking on the

arrow gives you more choices. You

can detach these items from the

toolbar, creating a floating toolbar.

When you expand the item, you

will see a grab bar at the bottom.

Click and drag the grab bar to

create a floating toolbar of the

items. This is helpful when you

need to use the items repeatedly,

and is quicker than having to

expand the items each time. When

you are finished, just close the

floating toolbar by clicking on the

close button in the title bar.

GRID, SNAP LINES, AND
SNAP POINTS

When creating an image, I find

it useful to have guides to work

from. The grid, snap lines, and snap
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point.

Unlike the grid, snap points and

snap lines are inserted when you

need a more exact location. Snap

lines are great for aligning objects

vertically or horizontally. To create

a snap line or point, Insert > Insert

Snap Point/Line from the menu

bar. The X position controls the

distance from the left of the

image. The Y position controls the

distance from the top. The type

controls whether you are inserting

a snap point, vertical snap line, or

horizontal snap line. You can also

create snap lines by clicking and

dragging from either the

horizontal or vertical rulers. To

delete a snap line, click and drag it

back to the ruler. To delete a snap

point, right-click the snap point

and select Delete Snap Point.

OPTIONS TOOLBAR

The options toolbar contains all

your snap options. If it is not

showing, select View > Toolbars >

Options. On the toolbar, you can

toggle whether your guides are

displayed, and toggle on and off

the snap options. You might want

to dock this toolbar to the bottom

or side of your window as I suspect

you will use it often to toggle

these options.

There is one more guide on the

toolbar we have not discussed yet.

It is the helplines. When you select

the helplines on the options

toolbar, then, when you move an

object, dashed lines appear from

the corners of your object to the

rulers. The helplines are just one

more tool to help you accurately

place your objects.

CONCLUSION

LibreOffice Draw is the graphics

application of the LibreOffice

suite. Draw saves graphics in a

vector graphic format for use in

your documents created with

other applications in the suite.

Draw provides you with the tools

to combine text and geometric

objects to create your graphics.

Guides, and the ability to snap to

the guides, help you to precisely

place your objects.

In the next LibreOffice How-

To, we will look at creating basic

objects in Draw.

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://podcast.ubuntu-uk.org/
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W
hen I was a child, I

enjoyed playing with

building blocks. I

didn't have the finely

finished and polished blocks like

you can buy for children these

days. Instead, I had wood scraps

from my father's woodworking. I

ended up with a collection of

various geometric shapes and

sizes. These blocks became forts

for my toy soldiers, roadways for

my cars, and even a cityscape

complete with airport. The only

limit was my imagination.

While my artistic skills never

advanced much beyond 9th grade

art class, I still enjoy putting things

together and have always enjoyed

geometry. My blocks taught me

that most things can break down to

basic geometric shapes like circles,

rectangles, and other 2D geometric

shapes. With these objects you can

create, even if only rudimentary,

anything.

At the heart of LibreOffice

Draw are these basic geometric

shapes. They allow you to draw

almost anything, and the only

limitation is your imagination. You

will find all the basic objects on the

Drawing toolbar. Starting with the

most basic of all drawing elements,

the line, let's take a look at how to

use the basic objects available to us

in LibreOffice Draw.

LINES AND ARROWS

The line is the second tool on

the default Drawing toolbar, the

first being the selection tool. To

draw a line, click in the drawing

area where you want to start your

line and drag to the end point. If

you look at the status bar while you

draw your line, you will notice it

tells you the size and angle of your

line. To restrict the angle of your

line to increments of 45 degrees (0,

45, 90, 1 35, 1 80, -1 35, -90, -45),

hold down the Shift key while

drawing your line.

Sometimes, you need to draw

your line from a center point rather

than an end point. Hold down the

Alt key while drawing your line, and

the line will grow outward from the

center point. You can hold down

Alt and Shift together to draw a

line from the center point and

restrict the angle to increments of

45 degrees.

There is also an extended

toolbar for lines on the Drawing

toolbar. It allows you to draw lines

with different arrows and start

points. There is also a line for

showing dimensions. You can use

all the same methods for drawing a

line with arrows that you use to

draw an ordinary line.

Use the line and filling toolbar

to change the line style and

thickness, and to color your line.

Make sure your line is selected

when you make these changes. You

can also select different arrow

styles for your line using the

arrows tool on the Line and Filling

toolbar.

RECTANGLES AND SQUARES

If you wanted, you could use the

snap to grid function and the Shift

key to draw four lines to create a

rectangle or square, but Draw does

provide you with an easier way to

create them. The rectangle is the

fourth tool on the default Drawing

toolbar. With it you can create

rectangles and squares.

To draw a rectangle, select the

rectangle tool from the toolbar.

Click where you want to place one

corner, and drag to the location of

the opposite corner. You make a

square by holding down the Shift

key while dragging. The shift key

ensures the width and height are
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always the same.

Just like the line, you will

sometimes need to create a

rectangle or square starting from

the center point rather than a

corner. Again, the Alt key causes

the rectangle to expand from the

center. Use the Shift-Alt

combination to draw a square from

the center out.

Rectangles and squares by

default are drawn with the

currently selected line and fill

colors. You can change these using

the Line and Fill toolbar. You can

also use the color bar. Right-click

for line color and left-click for the

fill color. You can also control the

thickness and style of the border

line using the Line and Fill toolbar.

ELLIPSES AND CIRCLES

The ellipse tool is the fifth tool

on the default Drawing toolbar.

Ellipses are drawn much in the

same manner as for rectangles and

squares. Basically, you are drawing

a rectangle which will contain your

ellipse or circle. Just like with the

square, the Shift key lets you draw

a circle. The Alt key is used to draw

your ellipse from the center, and

the Shift-Alt combination lets you

draw a circle from the center.

As with the rectangle and

square, ellipses and circles are

drawn with the currently selected

line and fill colors. You can change

them with the Line and Fill toolbar

or the color bar. The Line and Fill

toolbar also lets you change the

border line style and thickness.

SHAPES AND SYMBOLS
EXTENDED TOOLBARS

Besides the lines extended

toolbar, you have several other

extended toolbars to choose from,

including basic shapes (2D

geometric objects) , symbols

(smiley face, moon, heart, etc) ,

block arrows, flowchart symbols,

callouts, and stars. These extended

toolbars give you a broader set of

objects for building your graphic.

They are drawn in much the

same manner as rectangles,

squares, ellipses, and circles. You

draw a containing rectangle for the

object. The Shift and Alt keys also

work on most objects in the same

way as with rectangles. You can

use the Line and Fill toolbar to

change the line thickness, line

style, line color, and fill color of the

object.

SAMPLE DRAWING – A
SIMPLE ROCKET

As I said in the beginning, I 'm

not much of an artist, but I do have

a sense for putting shapes

together to create an object, so

let's walk through creating a very

simple rocket image. Along the

way I will introduce a few new

tools and concepts for working

with basic shapes.

First, we will set up a grid for

our drawing, Tools > Options >

LibreOffice Draw > Grid. Set the

vertical and horizontal resolution

to 1 inch. Set both subdivisions to

1 0. This will create a nice 1 -inch

box grid on our drawing surface.

Check the snap-to-grid. This will

help us get our objects to the

right size.
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center of the rocket body. Use

your best judgment on the size.

The top point of the triangle

should overlap the bottom part of

the rocket body. Make the line

color black and the fill color gray

60%. Make sure the nozzle is

centered at the bottom of the

body. Right-click the triangle and

Arrange > Send to Back. This

pushes the triangle behind the

other objects so we can see only

the bottom part.

There! You have a very simple

drawing.

CONCLUSION

The basic shapes are the

building blocks for images in

Draw. From them, you can create

as simple or as complicated a

drawing as you need for your

documents. You can arrange your

objects on the image to overlap

each other and flip to change the

horizontal or vertical orientation.

Elmer Perry's history of working, and
programming, computers involves an
Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
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UBUNTU TOUCH SDK BETA

T
oday we [Canonical] are announcing the Ubuntu SDK

Beta . The SDK provides a set of APIs that includes the UI

toolkit, enabling developers to create responsive and

interactive applications with a native Ubuntu mobile UI .

Qt Creator is an IDE with a visual interface for writing, testing and

deploy applications; its API documentation and a developer site

full of resources and tutorials make it easy to produce quality

applications.

Together with a vibrant and ever-growing community of app

developers, Ubuntu and the SDK provide the best ecosystem for

your apps to thrive.

GET STARTED - GUIDE TO INSTALLING THE SDK

To get started with the Ubuntu SDK, including easy installation

instructions, tutorials and detailed API documentation, visit

developer.ubuntu.com/get-started

To help you design and build beautiful apps, the App Design

Guides include everything you need to know about UX and visual

design best practices. Find them at design.ubuntu.com/apps

You can keep your development phone up-to-date with the

latest build by following the instructions at

wiki.ubuntu.com/TouchInstallProcess

ANNOUNCEMENT FROM CANONICAL
Let's start with the nose cone.

Select the isosceles triangle tool

from the basic shapes extended

toolbar. Draw the triangle, 2 grid

squares by 2 grid squares, at the

top of the image. Make the line

color black and the fill color gray

30%. For the body of the rocket,

use a rectangle, 2 grid squares

wide and 6 grid squares tall, line

color black, and fill color gray 30%.

Let's add some stabilizing fins

to our rocket. Select the right

triangle from the basic shapes

extended toolbar. Draw the right

triangle at the bottom right of the

rocket body, 2 grid squares tall and

1 grid square wide. Set the line

color to black and the fill color to

gray 40%. With the newly created

fin selected, Edit > Copy, then Edit

> Paste. The copy will appear over

the top of the first fin. Drag and

drop the copy to the left side of

the rocket body. Right-click the

copy and Flip > Horizontally. Move

it to the lower left of the rocket

body. With the copy still selected,

down-arrow three times to move it

just below the rocket body. Do the

same with the right fin.

We will finish off our drawing

with the engine nozzle. Create an

isosceles triangle at the bottom

http://developer.ubuntu.com/get-started
http://design.ubuntu.com/apps
http://wiki.ubuntu.com/TouchInstallProcess
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A
sI mentioned last time,

the building blocks I

owned as a child were

the result of my father's

woodworking. Not every block was

perfectly proportioned into neat

geometric shapes. Sometimes, they

were oddly shaped, or, as wood

often is, shaped by splitting along

the grain line rather than being cut

by the saw. Some had curved

patterns where their opposites

were used to trim a chair or

cabinet. I didn't discard these

irregular shapes but embraced

them. Not everything in our world

is created from straight lines,

ellipses, and circles.

With this in mind, we continue

our look into LibreOffice Draw by

learning how to create polygons,

arcs, and curves. A polygon is a

plane object with at least three

straight lines and angles. In

geometric terms squares,

rectangles, and triangles are types

of polygons. For our purposes, we

will discuss polygons with more

than four sides. An arc, in Draw, is a

partial circle or oval. You can make

them filled or empty. A curve is a

bent line. We will look at two

methods for creating curves, the

curve tool itself and the Bezier

method.

DRAWING POLYGONS

As I said, a polygon is an object

with multiple sides. In Draw, you

have four polygon tools. Two

enclosed and filled polygon tools,

and two open and unfilled polygon

tools. The unfilled polygon tools

are good for making a series of

lines. For both types, you have a

free-form version and a version

restricted to angles that are

multiples of 45 degrees.

To create a polygon, select one

of the polygon tools from the Lines

extended toolbar. Click and drag to

create the start point of the first

line. When you release the mouse

button, the end point of the first

line is created. Move the mouse to

the position where you want the

end point for the next line and

click. Continue until you have

created all the lines for your

polygon. Double-click on the last

point to end the polygon. If you are

using one of the filled polygon

tools, the end point of the last line

will automatically connect to the

start point of the first line,

enclosing the polygon.

If you use one of the filled

polygon tools, Draw fills the

polygon with the currently selected

fill color and sets the lines to the

currently selected line color. You

can change these using the Line

and Fill toolbar or the color bar.

ADD CIRCLES AND OVALS

TOOLBAR

For quick access to the arcs and

segments tools, we need to add

the Circles and Ovals toolbar to the

Drawing toolbar. Right-click the

Drawing toolbar and select

Customize Toolbar. This opens the

Customize dialog. Click the Add

button. Select Drawing under the

Category list. In the Commands list,

find the Ellipse tools – there are

two. You want the one with the

description “Using Customize

toolbar, you can add the Ellipse

icon which opens the Circles and

Ovals toolbar.” Click the Add

button. Click Close to close the

selection dialog.

Using the up and down arrows,

move the new icon to where you

want it on the toolbar. I placed

mine below the Ellipse tool. We

don't really need the Ellipse tool

any longer as it is included in the

Circles and Ovals toolbar. Uncheck

the Ellipse tool. Click the OK

button, and you should see the

toolbar is now on your Drawing

toolbar.
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second time to create the end

point for the arc or segment. The

status bar will show you the angle

from center of the points as you

move around the circle or oval. This

can help you create accurate and

precise arcs and segments.

DRAWING CURVES

A curve is a bent line rather than

a segment of a circle or oval. To

draw a curve, select the curve tool

from the line toolbar. Click on the

start point and drag to draw a line.

Release the mouse button at the

peak point for your curve. Move

the mouse to bend the line to the

point where you want the curve to

end. Double-click to complete the

curve.

BEZIER CURVES

A Bezier curve is a smooth curve

with a start point, an end point, and

DRAWING ARCS OR
SEGMENTS

To draw an arc

or segment, select

one of the tools

from the Circles

and Ovals toolbar

you just added.

Click and drag to create a

containing circle or oval. Release

the mouse button. Click in the

circle or oval where you want the

arc or segment to begin. Move the

mouse around the circle or oval to

create the arc or segment. Click a
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two control points. The

mathematics behind the Bezier

curve is beyond the scope of this

article, but you don't need to

understand the math in order to

draw one.

To draw a Bezier curve, select

the curve tool from the lines

toolbar. Click at the start point,

drag to the end point and double-

click. Click on the Points tool on the

Drawing toolbar (F8 on the

keyboard), and the Edit Points

toolbar is displayed. Select either

the start or end point (the start

point is the larger square). Select

the Smooth or Symmetric

Transition tool from the Edit Points

toolbar. A dashed line and circle will

appear indicating the control point

for that point. Move the control

point to create the curve for that

point. Repeat these steps for the

other point.

CONCLUSION

Since not all things are created

from straight lines, ellipses, and

circles, the creators of Draw gave

us more tools for creating objects.

A polygon can create an object

with more than four sides. Arcs and

segments gives us parts and

segments of a circle or ellipse.

Curves give us the ability to bend a

line into different shapes. With

these extra tools in hand, Draw

lets you create more advanced

images for your documents.
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W
hen working with

physical blocks, you

sometimes need to

change the shape of

a block, customizing it for a special

purpose. You may use a plane or

sandpaper to make a side slant or

to round an edge. You might use a

saw to whack off a corner. All to

create a special custom block

unlike any other block in your

collection.

Sometimes, we need to do the

same with our digital blocks. The

editing tools built into LibreOffice

Draw become our digital plane,

sandpaper, and saw. In fact, you

can do things I never dreamed of

doing to my blocks as a child.

THE LINE DIALOG

The Line dialog lets you edit the

look of the lines in your object. To

access the Line dialog, right-click

your object and select Line. From

here, you can change the style of

the line (solid, dashed, dash-dot,

etc.) , the color, width, and

transparency. You can also add

arrow styles to the start and end of

your line. Keep in mind that for

enclosed objects (triangles,

squares, circles, etc.) , arrows are

not drawn on the lines. Underneath

the arrow styles, you can adjust the

width of the arrow. Center places

the center of the arrowhead(s) on

the endpoint(s) of the selected

line. Synchronize ends

automatically updates both arrow

heads when you change the style,

width, or center of one of the ends.

Corner style controls how the

corner of your object is drawn. Cap

style controls how the endpoints of

lines without arrows will look.

If you are working with an open

object, you get a shadow tab. This

allows you to create a shadow for

the line by defining the position,

distance, color, and transparency of

the shadow.

The Line Styles and Arrow Styles

tabs allow you to add, modify,

delete, and save different line and

arrow styles. You can play around

with these, but usually you can find

what you need in the predefined

styles. If not, feel free to create

your own.

AREA DIALOG

The Area dialog applies to

objects that are enclosed, and

deals with the space inside the

object. You can change the color of

the fill as well as the manner in

which the object is filled. To access

the Area dialog, right-click the

object and select Area.

The Area tab controls what fills

the object. You can choose from

color, gradient, hatching, and

bitmap in the Fill drop-down list.

Once you have selected the type of

fill, you can select a fill from the

list. The preview box shows you the

result of your selections.

The Shadow tab allows you to

add a shadow under your object.

Check Use shadow to create a
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POSITION AND SIZE DIALOG

Besides controlling the position

and size of an object, the position

and size dialog also allows you to

control the rotation, slant, and

corner radius of an object. To

access the Position and Size dialog,

right-click your object and select

Position and Size.

The Position and Size tab does

what you would expect. You can

control the XY position on the

canvas of the object, and its width

and height. The base point for

you can also define an angle for

the gradient area. The border

setting reduces the size of the

transparent area. The bigger the

percentage, the smaller the

transparent area. Use the start and

the end values to change the

beginning and ending opacity

levels. For example, if you don't

want any totally clear places on

your object, you can start with a

value of 1 0 or 1 5%.

The colors, gradients, hatching,

and bitmaps tabs allow you to

create new fill styles by defining

new colors, gradients, hatchings,

and bitmaps.
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shadow. The position determines

the location of the shadow, and

the distance how far from the

object. Color determines the color

of the shadow, and transparency

sets the opacity of the shadow.

On the Transparency tab, we

determine the opacity of the fill of

the object. We have three options

for the transparency of the fill. No

transparency means the fill is

completely opaque. With

transparency, you can set a

percentage for the whole area.

Gradient is the option with the

most settings and the chance to

create the most interesting

effects. You have six choices for

the gradient types, linear, axial,

radial, ellipsoid, quadratic, and

square. For all except the linear

and axial, you can control the XY

center of the gradient. The XY

center is the point where the

object is the clearest, or most

transparent. Except for the radial,

each of the options gives nine

points on the object from which

position or size is calculated. There

is a Keep ratio checkbox under size

to help maintain the aspect ratio

of the object (any change in height

will create a change in width and

vice versa). You also have options

to protect the position or size to

prevent accidentally changing

them. The adapt option only

relates to text frames and allows

you to fit the width and/or height

to match the text.

On the Rotation tab, you can

control the rotation of the object.

This is usually much more accurate

than using the rotation tool. You

can select the pivot point through

the input boxes, or by selecting a

pivot point on the Default settings

box. Select your angle through the

input box or by selecting a point

on the angle Default settings
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interesting shapes. The corner

radius is blocked for some objects.

ARRANGE, ALIGN, FLIP,
CONVERT

Sometimes, it just becomes

necessary to stack objects, make

them line up, mirror them, or just

convert them into something that

you can edit in a different way. All

the following commands are

found by right-clicking the object.

They are also available in the

Modify menu.

The arrange options allow you

to control the stack position of

objects. When you have multiple

objects which overlap, you may

need to change the order in which

Elmer Perry's history of working, and
programming, computers involves an
Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com
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compass.

Finally, the Slant & Corner

Radius tab allows you to control

the roundness of the corners and

the slant (think italics text). Think

of the corner radius as using

sandpaper to round off a corner.

The more you sand, the rounder

the corner. The bigger the number,

the rounder the corner. If you set

the corner radius high enough on a

rectangle, it will become an oval.

The slant, given as an angle, skews

the object to the right for a

positive angle and to the left for a

negative angle. Using the corner

radius and slant, you can get some

they are stacked. By default, they

stack in the order in which they

were created, the last on top.

Using the arrange options, you can

push objects forward or backward

in the stack until you get the

results you want.

Align allows you to align objects

in reference to each other or to the

page. If you have only one object

selected, the object will align to

the current page. If more than one

object is selected, they will align

according to each other. The larger

of the objects usually controls the

final location, and the other

objects are moved to align to the

selected position of that object.

The alignment options are left,

right, horizontal center, vertical

center, top, and bottom. Draw has

an align toolbar in addition to the

right-click menu and Modify menu.

The flip options are

straightforward. You can flip an

object vertically (top to bottom) or

horizontally (left to right).

There are many options under

the right-click > Convert option,

but one in particular that I want to

draw your attention to, Convert >

To Curve. By converting any object

to a curve, you can edit the points

within that object, allowing you to

achieve completely original

shapes. Once an object is a curve,

you can add points, remove points,

and use the point transition tools

on the points of the object. Turn a

rectangle into a curve, then start

adding, moving, and manipulating

the points, and see what you can

create.

CONCLUSION

The options in Draw for editing

an object are numerous. By

applying the right tools to an

object, you can create almost any

shape you can imagine (maybe a

few you never imagined). I

encourage you to play with these

tools and see what you can come

up with. You never know, you

might discover that little piece of

artist or designer in you.

http://eeperry.wordpress.com
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I
f you work in LibreOffice

much, you will find yourself

using the same formating over

and over. Whether you use it

to write letters or to create the

next best-seller, you spend a lot of

time setting up the same styles

over and over again. Templates are

the answer to this problem. A

template is a document model

used to create other documents.

All the LibreOffice applications can

use templates. In fact, every time

you create a new document,

LibreOffice is using a default

template.

Styles are the key to creating

templates. Styles are a preset way

of displaying information. I first

discussed the importance of using

styles all the way back in part 3 of

this series, discussing how styles

help create a uniform look in your

document as well as saving you

time. In the spirit of saving you

time, we can add one more use for

styles, creating templates.

SETTING UP A TEMPLATE

Everything from a business

letter to a scientific research paper

has a required layout and format.

Let us say we are writing a

document that requires a

numbered outline format with

sublevels. Another requirement is

that the title and author appear at

the top of each page, and the page

number at the bottom in the

format of “Page # of #”.

We will tackle the numbering

style first. In a new Writer

document, open the Styles and

Formatting window. Click on the

list styles icon (the last one on the

Styles toolbar). Select Numbering

1 . Right-click Numbering 1 and

choose Modify. On the Outline tab,

pick the style that is labeled

“Numeric with all sublevels” when

you hover the mouse over it. Click

the Apply and OK buttons.

Now, to take care of the header

and footer. Open the Styles and

Formatting window and click on

the Page styles icon (next to last on

the Styles toolbar). Right-click the

Default Style page style and select

Modify. On the Header tab, check

Header On, then switch to the

Footer tab and check Footer On.

Click OK to save the changes. Click

into the header area of the first

page, Insert > Fields > Title. Type a

space and “by”, then Insert > Fields

> Author. Move your cursor down

to the footer at the bottom of the

page. Type “Page”, a space, then

Insert > Field > Page Number. Type

space “of” space, then Insert >

Fields > Page Count.

SAVING THE TEMPLATE

We are now ready to save our

template. File > Save as Template

will open the Template Manager.

Select the template folder where

you want to store your template.

Click Save. A dialog will prompt you

to name the template. Enter the

name you want to show for the

template and click Accept. Close

the Template Manager.
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to the folder where you have your

template and select it. Click on the

“Set As Default” button. Now,

anytime you start a new document

of that type, LibreOffice will use

your template instead of the

default template that comes with

LibreOffice.

DIFFERENT SOURCES FOR
TEMPLATES

Creating your own templates is

great, but you will not always need

to put in all that work. The official

template repository at

http://templates.libreoffice.org

has hundreds of templates for you

to try and use. To use individual

templates, import them into the

template manager.

Some templates are collections.

They have a extension of .OXT. To

import these templates, you use
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USING THE TEMPLATE

Let's use our newly created

template. File > New > Templates.

Open the folder where you saved

your template and double-click

your template. The title shows as

the title you gave the template.

Let's change it. File > Properties.

Select the Description tab and

change the title to something else.

Click OK. The title in the header

will change to whatever you typed

in.

Let's try out that outline

numbering system. Open the

Styles and Formatting, click on the

List styles icon, and double-click

Numbering 1 . Your input will

change to the list style we defined

for the Numbering 1 when

creating the template. Add some

text and be sure to add several

levels to make sure it is all

working. Now, you can save your

document like you normally

would. This does not save it as the

template, but as a new file on your

computer.

SETTING A NEW DEFAULT
TEMPLATE

If you need to use your new

template most of the time, why

not make it your default template?

This is easily done in LibreOffice.

File > New > Templates. Navigate

http://templates.libreoffice.org
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the Extension Manager, Tools >

Extension Manager. Click Add, and

browse to your downloaded OXT

file. Select the file and click Open.

The Extension Manager will

process the file and add the

collection to your Template

Manager.

CONCLUSION

Templates are a way to repeat

the formatting of a document

from one document to the next.

Creating and saving templates

relies mostly on the use of styles.

Though I demonstrated creating a

Writer template, you can create

templates in the other modules of

LibreOffice, too. You can even set

your template as the default for

that type of document. Templates

are just one more time-saving tool

within the LibreOffice suite.

PYTHON SPECIAL EDITIONS:
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U
sing the default HSQLDB

database management

system (DMS) in

LibreOffice Base is great

for creating new databases, but

sometimes you need to connect to

an existing database on another

DMS like MySQL, dBase, JDBC,

Oracle, PostgreSQL, and others. I

showed you how to connect to a

simple spreadsheet database back

in Issue 52. Today, I will show you

how to connect to a database

created in MySQL.

MySQL is a DMS used on many

websites. Wordpress and other

content management systems use

MySQL for their databases. You

might have many reasons to access

a database created in MySQL.

MySQL is open source, and you can

install it from your software

manager.

INSTALL MYSQL

Installing MySQL from your

software manager requires the

installation of two packages. The

first package is “mysql-client” – the

client program for MySQL. It allows

you to interact with MySQL.

If you are installing MySQL on

your current machine, you will need

to install the MySQL server

package as well: “mysql-server”.

When you install the server

package, it prompts you for a

“root” password and asks for

confirmation. This is your master

password for MySQL. Jot it down

somewhere. You will need it later.

If you are connecting to a database

on a different machine, you don't

need this package.

The last package we need to

install is “libreoffice-mysql-

connector”. This package will allow

us to connect to MySQL without

using an OBDC or JDBC wrapper.

CREATE A TEST MYSQL
DATABASE

If this is the first time you are

connecting to an external database

using LibreOffice Base, I

recommend you create a test

database in MySQL where you can

make mistakes and learn. You can

install a program like PHP

MyAdmin or EMMA, but I think it is

easier just to use the MySQL

command-line client.

To connect to MySQL on your

local machine, use the command:

mysql ­h localhost ­u root ­p

MySQL will prompt you for the

“root” password. Enter it and you

are greeted with a welcome

message and the “mysql>” prompt.

To connect to a MySQL server on

another computer, replace

“localhost” with the server name or

IP address. Keep in mind that you

will need to set up MySQL to

accept remote connections. For

details on setting up MySQL to

accept remote connections, read

this tutorial:

http://www.cyberciti.biz/tips/how-

do-i-enable-remote-access-to-

mysql-database-server.html

To create a database use the

following command at the MySQL

prompt:

CREATE DATABASE <dbname>;

where <dbname> is the name you

want to give the database. To

create a databases name

“myTestDB” enter:

CREATE DATABASE myTestDB;

MySQL responds with a

message that the query was

executed. Enter

SHOW DATABASES;

to generate a list of all the

databases. You should see your

new database among those listed.

An empty database is all we need

to connect to MySQL from Base,

but you can also connect to a fully
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database for editing”. Click Finish.

Base will prompt you for a file

name. Enter a name and click Save.

You can now interact with the

MySQL database in the same way you

would an HSQLDB database. You can

create tables, queries, reports, and

forms just like you would with the

default DMS. You will need to pay

attention to the data types as they

are slightly different in MySQL. For an

overview of the HSQLDB data types

see my article at http://wp.me/pvwht-

8Q. For a list of MySQL data types see

http://dev.mysql.com/doc/refman/5.0

/en/data-type-overview.html.

While using the default DMS for

Base is good for new databases,

sometimes it becomes necessary to

connect to existing databases. In this

article, we showed how this is done by

connecting to an external database

we created in MySQL. We installed

MySQL and created a blank database.

Using the database wizard in Base, we

connected to that database where we

can create tables, forms, queries, and

reports to interact with the database.

Base can also connect to other

database types like dBase, JDBC,

Oracle, PostgreSQL, and others.

Click Next.

Step 4: The user name you need

to connect to MySQL from your

computer. Use “root” if you are

connecting to MySQL on your local

computer. Check “Password

required”. Click “Test Connection”.

You are prompted for your

password. Enter your password

and click OK. If you set everything

correctly, you will get a message

back saying Base successfully

connected to the database. OK on

the message and click Next.

Step 5: Select Register or Don't

Register according to your needs

for the database. A registered

database is available in other

LibreOffice modules. Check “Open

down list select MySQL. Click Next.

Step 2: Since we installed the

“libreoffice-mysql-connector”, we

have no use for the ODBC or JDBC

connections. Select “Connect

directly”. Click Next.

Step 3: The database is the

name of the database we just

created in MySQL. Our example

database was “myTestDB”. The

server is “localhost” for the local

computer, or the server name or IP

address of another computer.

Leave the Port as the default

unless you changed it in your

MySQL settings or have been told

to do so by your IT department.
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functional database as well; but,

like I said, it is better to practice on

a test database first. Type “quit”

and press Enter to exit your MySQL

session.

CONNECT BASE TO MYSQL
DATABASE

Now for the part we have been

working for – actually connecting

Base to the MySQL database. Start

by creating a new database

document in LibreOffice, File >

New > Database. We will use this

document to connect to the

database we created before. Using

the database wizard

(recommended), it is a five step

process.

Step 1 : We want to connect to

an existing database. Don't

confuse this with connecting to an

existing database file. You want

the last selection. From the drop

http://wp.me/pvwht-8Q
http://dev.mysql.com/doc/refman/5.0/en/data-type-overview.html
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W
ith the release of

LibreOfffice 4 came

some new features

and improvements.

Among the most interesting is the

Experimental Sidebar. The new

sidebar puts a lot of the operations

and tools in one easy location. The

sidebar eliminates the need for the

formatting toolbar for many

objects.

Today, we will look at the

sidebar and how it adapts in

accordance with the document you

are currently working with. Just

remember that the sidebar is an

experimental feature, which means

it can crash the program without

warning. So, when using the

sidebar, I recommend saving often.

SETUP

Since the sidebar is

experimental, we need to activate

it. From any LibreOffice screen,

Tools > Options > LibreOffice >

Advanced. Check “Enable

experimental sidebar (on restart)”

and click OK. You will need to

restart LibreOffice in order for this

change to take affect.

OVERVIEW

The sidebar for LibreOffice is

similar to the sidebar in Calligra or

the ribbon in Microsoft Office.

While it can't replace everything,

you will find yourself using it

instead of the formatting toolbars

and dialogs. The sidebar actually

has more features than the

formatting toolbar by default.

By default the sidebar is docked

to the right side of the main

window. You can show or hide the

sidebar using the show/hide button

on the inside border, or through

the menus View > Sidebar. From

the sidebar menu you can

undock/dock the sidebar. You can

also customize the sidebar by

removing the panels you will not

use.

The sidebar is a collection of

panels. The available panels

depend on the program you are

using. You can access each of the

panels by selecting their icon from

the right side of the sidebar or

from the sidebar menu. Each of the

panels serves as a shortcut to

different tools in the program. Of

these, I personally use Properties,

and Styles and Formatting most

often. Let's take a closer look at

each one.

PROPERTIES

The Properties panel shows you

the properties for the current item

in the document. You can adjust

the different properties using the

icons in the panel. Changing

properties using these icons is the

same as making manual changes

through the dialogs and formatting

toolbar, meaning it has no effect

on the underlying style assigned to

the item – only the current item. If

you cannot find a property, you can

click on the ”More Options” button

in the corner of each property type

to get a complete properties dialog
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document to another by reference

to an object. This becomes quite

handy in large documents, and is a

good argument for giving

meaningful names to your OLE

objects and images.

MASTER PAGES (IMPRESS
ONLY)

The Master Pages panel is used

for selecting and creating master

pages in Impress. I discussed

Master Pages in part 1 6 of this

series, FCM#63:

http://fullcirclemagazine.org/issue

-63/. This panel is just a translation

of the old Master Pages section of

the Impress Tasks pane.

CUSTOM ANIMATIONS
(IMPRESS ONLY)

The Custom Animations panel

is used to animate objects on an

Impress slide. I discussed

animations in part 1 8 of this

series, FCM#65:

http://fullcirclemagazine.org/issue

-65/. This is also a translation from

the old Impress Tasks pane into

the new format.

SLIDE TRANSITIONS

images for use in your documents.

The Gallery panel presents a list of

categories, called themes, at the

top, and a list of images

underneath. You can use this

library of images to insert clip-art

and backgrounds into your

documents, as well as sounds into

your presentations. You can add to

and create new themes in your

Gallery. A complete how-to on the

Gallery library is for a future

article.

NAVIGATOR

The Navigator is a catalog of

your document headings, tables,

sections, images, etc. The

Navigator allows you to quickly

move from one point in your

The sidebar takes the Styles and

Formatting window and docks it in

the sidebar. This allows you quick

access to your different styles.

Though you could still just use the

button on the Formatting toolbar,

the new sidebar does provide a

central location for this tool and

others like it. The window still

provides styles broken down by

type (characters, paragraphs,

frames, pages, and lists) , as well as

the subcategory drop-down list.

You still create and modify styles in

the same manner as with the Styles

and Formatting window.

GALLERY

The Gallery is a collection of

with tabs. You can collapse and

expand any of the blocks using the

expand / collapse button next to

the block title.

As an example, when typing in a

Writer document, you will see three

property blocks in the Properties

panel: Text, Paragraph, and Page.

The Text block allows you to

control different settings related to

text – font, bold, italics, color, etc.

The Paragraph block allows you to

control the paragraph's alignment,

spacing, margins, etc. The Page

block lets you change the page's

size, orientation, margins, and

columns.

STYLES AND FORMATTING
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(IMPRESS ONLY)

Slide Transitions control how a

presentation moves from one slide

to another. For more details see

part 1 8 of this series, FCM#65:

http://fullcirclemagazine.org/issue-

65/. This panel is another copy from

the old Impress Tasks pane.

FUNCTIONS (CALC ONLY)

The Function panel gives you

access to all the Calc functions. A

drop-down list divides the

functions into categories, including

“Recent Used” and “All” categories.

Below is a list of all the functions in

Elmer Perry's history of working, and
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Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
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http://eeperry.wordpress.com
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the selected category. You can

insert the function into the current

cell by double-clicking the function

name or selecting the fx button

next to the drop-down list of

categories. This gives you quick

access to the functions and is much

easier (in my opinion) to use than

the function wizard.

The experimental sidebar is a

tool that makes access to common

tools quicker and easier.

LibreOffice has accomplished this

by making the panel’s expansions

and combinations of common

toolbars, and translating older

panels and wizards to the new

format. You can compare it to the

sidebar in Calligra or the Microsoft

Office ribbon bar. I have found it

handy to use, but keep in mind that

it is experimental and might crash

LibreOffice occasionally.
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C
ollecting clip art for use in

your newsletter,

spreadsheet,

presentation, or other

document can become a timely

task. Especially when it comes to

organizing – and later finding – the

image you want to use. LibreOffice

provides a built-in Gallery for

collecting and organizing images,

sounds, and videos. The Gallery

collects files into categories called

themes. You can add files from the

Gallery directly into your

document. Creating new themes

allows you to add your own files

into the collection.

THE GALLERY

You can access the Gallery in

three different ways, through the

menus (Tools > Gallery); by a

button on the standard toolbar;

and through a panel on the

experimental sidebar. By default,

the Gallery is docked under the

formatting toolbar. You can undock

and dock the Gallery with the

combination of CTRL + double-click

on the border of the Gallery. Use

the hide/show button on the lower

border to display and hide the

Gallery while it is docked. If you

hover over the lower border, your

mouse cursor will turn to a double

arrow, and you can resize the

docked Gallery's height.

On the left side of the Gallery is

the themes list. Selecting a theme

changes the files which display in

the main panel. The main panel

shows the files available in the

currently selected theme. Above

the main area are two buttons for

displaying the files – in tile or detail

view. Beside the buttons, it shows

the theme name, file name, and

path for the selected file.

USING THE GALLERY

The Gallery allows you to insert

a file as a copy, a link, or a

background. When you insert the

file as a copy, the file is embedded

into the current document and is

not reliant on another file. If you

insert the file as a link, a reference

to the file is created in the

document. If you opened a

document with linked files, the

files will show only if they are in

the location referenced in the

document. If the file needs to

travel among multiple computers,

insert a copy. If the document will

reside on only one computer, you

can safely insert a link.

To insert a copy of a file from

your Gallery into the document,

select the theme containing the

file and select the file. You can

then drag and drop the file into

your document, or right-click the

file and Insert > Copy.

To link a file from your Gallery

into a document, select the theme

and file. Hold down SHIFT + CTRL

while dragging and dropping the

file into the document, or right-

click then Insert > Link.

Sometimes, you will want to use

an image as the background for a

page or a paragraph. To set an

image as the background for a

page, select the theme and image.

Right-click the image and Insert >

Background > page. To set the

image as the background for the

current paragraph, right-click the

image and Insert > Background >

Paragraph.

MANAGING THE GALLERY

A nice feature of the Gallery is

the ability to add your own files to

the collection. You cannot,

however, add to, remove from, or

delete the default themes. In order

to add your own files to the

Gallery, you will have to create

your own themes. You add your
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own theme by clicking on the “New

Theme” button, which opens the

“New Theme” dialog. In the

“General” tab, enter the name for

your new theme. You can now add

files to your theme in the “Files”

tab or just click “OK” to save the

theme.

Adding files to the theme you

just created is easy. You can add

files one at a time by dragging and

dropping them into the main panel

with your theme selected. To

selectively add files or to add an

entire folder, right-click on the

theme title and click “Properties.”

A theme “Properties” dialog will

display. This is the same dialog you

get when adding a theme, so you

can use this method to add files

when you create a new theme.

Select the “Files” tab, then click

“Find Files.” Use the file dialog to

navigate to the folder containing

the file(s) you want, and click

“Select.” A list of files in the folder

will display in the list box. Use the

drop-down box above the list to

filter the files if needed. Take time

to scroll through the filter list to

get an idea of the many file

formats the Gallery accepts. For

image files, you can get a preview

by checking the “Preview” check

box. Once you find the file you

want, you can select it and click

“Add” to add it to the theme, or

click “Add All” to add all the files in

the list box.

You won't always add files to

the Gallery with the intention of

keeping them there indefinitely.

You may want to just add them

while working on a certain project.

Once the project is done and you

no longer need them, you will

want to delete the files and

themes created for the project. To

delete a file from a theme, right-

click the file and select “Delete.”

You can also delete a theme with

all its files by right-clicking the

theme title and selecting “Delete.”

Keep in mind that there is no undo

for these actions, and that

deleting a file from the Gallery

does not delete it from the

computer, just from the Gallery’s

theme list.

LibreOffice provides a media

library called the Gallery. The

Gallery is divided in collections

called themes. You can add your

own themes and files to the

Gallery. If a file or theme is added

only for a certain project, you can

delete them when the project is

finished. The Gallery is available in

all modules of the suite, and helps

you to maintain consistency for

newsletters, spreadsheets,

http://eeperry.wordpress.com
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I
f you work with Base long

enough, you will run into a

situation where you need a

table structured a little

differently, or you’ll need the

results of a query as a table you

can use. The answer to these

problems is ‘Views’. A view is a

query which acts like a table you

can use in other queries, forms, or

controls. Today, I will show you an

example of how this is useful when

creating forms.

OUR TABLES

We are going to create a simple

database with two tables. The

database will track projects for a

company and allow us to assign a

team member to each project.

Below is the structure of the tables

we will create.

Project Table

Field|Type|Properties

ID|Integer|Primary Key, Auto

Increment

Title|varchar(50)|Not Null

Description|varchar(250)

Due|Date

MemberID|Integer|foreign key

TeamMember Table

Field|Type|Properties

ID|Integer|Primary Key, Auto

Increment

FirstName|Varchar(25)|Not

Null

LastName|Varchar(25)|Not Null

Shown right is the SQL to create

the tables. Create a new database

document, then go to Tools > SQL,

and type the commands in by hand

or copy and paste.

You can also get the above SQL

commands on pastebin.com at

http://pastebin.com/Wyb3R5Fz.

The key to our task is the

foreign key “MemberID” in the

“Project” table, which connects to

the “TeamMember” table's “ID”

field. When we create our form we

will create a drop-down list for

selecting the team member who is

responsible for the project. Notice

that the “TeamMember” table

provides first and last name fields.

The list control allows us to use

only one field in the list. We could

display just the last name in the

drop-down list, but what if two

team members have the same last

name. We will solve this problem

by creating a view that will

combine the first and last name

into one field called “Name”. We

will use our view to populate the

drop-down list box.

If the tables do not show in your

table list after running the

commands, Review > Refresh Table

will populate the list.

CREATE QUERY / VIEW

To create our view, we will use a

two-step process. First, we create a

query, then convert the query into

a view. In our query, we combine

the first and last name fields to

create one field. We will also get

the “ID” field, as we will need it to

connect back to the “Project” table.

To create the query, we select

the “Queries” option in the

“Database” pane. In the “Actions”

pane, select “Create Query in SQL

View.” The follow SQL command

will create our query:

SELECT "FirstName" | | ' ' | |

"LastName" AS "Name",

HHOOWW--TTOO
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drop table "Project" if exists;

drop table "TeamMember" if exists;

create table "TeamMember" (

"ID" integer generated by default as identity

(start with 1) not null primary key,

"FirstName" varchar(25) not null,

"LastName" varchar(25) not null

);

create table "Project" (

"ID" integer generated by default as identity

(start with 1) not null primary key,

"Title" varchar(50) not null,

"Description" varchar(250),

"Due" date,

"Member" integer,

constraint FK_MEM foreign key ("Member")

http://pastebin.com/Wyb3R5Fz
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"ID" FROM "TeamMember";

If you are familiar with SQL, this

looks like a standard query except

for the double pipe symbols “| | ”.

They are used to concatenate

strings together. In the command,

we select each “FirstName” and

join it to a space, then take the

result and join it to “LastName.”

Finally, we name this string

“Name.” We also get the “ID” as it

identifies each record. You can test

the query to make sure it works,

but at this point your results are

blank, but the query should run

without error. Save the query as

“QueryTeam”.

Turning the query into a view is

as simple as right-clicking the

query name and selecting “Create

as View.” Name the view

“TeamView.” If you select “Tables”

under the “Database” pane, you

will see “TeamView” listed under

the tables.

CREATE THE FORMS

We will create a team member

form and a project form for data

input. The team member form is

the easiest, so let's make it first.

Click on the “Forms” icon in the

“Database” pane and select “Use

Wizard to Create Form.” The form

wizard will display.

On the first screen, select

“Table: TeamMember” from the

drop-down box. Move the

“FirstName” and “LastName” fields

into the list box labeled “Fields in

the form.” Click the “Next >”

button. There is no subform so just

click “Next >” again. On step 5, use

any of the options for arranging

the controls except tabular. On

step 6, just accept the defaults.

With Step 7 pick a style that you

like. When you get to step 8, name

the form “TeamMemberForm” and

leave it on “Work with the form.”

When you click the “Finish” button,

the form will open for input. Add a

few names for testing the project

form when we finish it.

For the project form, we need

about the same thing, except use

“Table: Project” from the drop-

down in step 1 , and select all the

fields except for “ID” for inclusion

in the form. Name the form

“ProjectForm” and select “Modify

the form” on step 8. This time,

instead of the form opening for

input, it opens for editing.

When you create forms using

the form wizard, the wizard groups

a text box for most data types with

a label for each field. In order to

change the control for the data

field, you have to ungroup the text

box from the label. In our case, we

want to change the “Member”

field, so right-click the “Member”

label and text box and select

Group > Ungroup. Click on the

form background to unselect both.

Right-click on the text box and

select “Delete.” From the forms

toolbar, select the list box. If the

form toolbar is not showing then

View > Toolbars > Form Controls to

display it. Once you select the list

box, your cursor will become a

crosshair, +. Click and drag to

create the list drop-down box.

When you release the mouse

button the list box wizard will pop

up.

Select “TeamView” as your

table and click “Next >”. The field

we want to fill the list box is

“Name”, so select “Name” and click

“Next >”. Finally, we need to match

the fields from the two tables. For

the “Value Table” select “Member”.

“ID” is the field to select for “List

Table” as it is the primary key that

matches up with the “Member”

foreign key field in the “Project”

table.

Save your changes and close the

design window.

Now, if you entered names in

“TeamMemberForm”, you can

open the “ProjectForm” and those

names will appear in the drop-

down list box we created. You will

want to test creating several

projects and assigning members to

them to test the workability of

your forms.

In this article, we discussed the

use of a LibreOffice Base view to

create a new table from an existing

table. We used this view in the

construction of a form that

automated the retrieval and

selection of records from that

view.

http://eeperry.wordpress.com
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I
n my article in issue 83 of Full

Circle Magazine, I walked you

through creating a form that

used a view, but I left things

unfinished in the forms: I didn't do

anything to format the controls to

ensure data integrity. If you

haven't already done so, read the

article in Full Circle 83, and follow

along to create the tables and

forms. We will work with the

“ProjectForm,” and see how we can

improve data integrity. I ' ll wait if

you need to work through the

How-To in issue 83.

DATE AND TIME CONTROLS

Now let's get down to work. On

the “Forms” pane in the database

file you created, right-click the

“ProjectForm” and select “Edit”. As

I have said before, the wizard

usually joins a label with an input

box, but in the case of date and

time fields, it actually pairs them

up with date and time controls.

Without any formatting, they just

look like text input boxes, but trust

me, they are date and time

controls. We will need to ungroup

the control from its label in order

to work with the date control.

Right-click the “Due” label or date

control, then select Group >

Ungroup.

Double-click the date control to

bring up the control's properties

dialog. On the “General” tab, you

find all the adjustments you can

make to the control. We are

interested in the ones that create

adjustments for date entry.

Date Min / Date Max – These

two options allow you to control

the minimum and maximum date

values allowed in the fields. These

fields have default values of

01 /01 /1 800 for minimum and

1 2/31 /2200 for maximum. In

general applications, these

defaults should work, but if you

have different needs, feel free to

adjust. An example is an inventory

database, where no shipping

invoices dated before the inception

of the company is necessary. You

could set the minimum date to the

opening day.

Date Format – There are 1 2

different date formats. This option

determines how the control will

display the date. Scroll through the

options and see which one best

suits your application.

Default Date – This is a default

value for the field. If you have a

date that users should use most of

the time, then use that date. It will

speed up data entry. It can also

show the user the format in which

to enter dates. Unfortunately, at

this time, you cannot easily set the

default to the (current) date the

record was added.

Spin Button – Setting this

option to Yes will put an up-and-

down spin button on the control.

The user can use this button to

adjust the month, day, and year.

The user clicks into the part of the

date they want to adjust and

makes changes by clicking on these

buttons. Very handy for data entry.

Repeat – The Repeat option is

related to the spin button option. It

controls whether to repeat when

you hold down the mouse button

on the spin button. Use at your

own discretion. Sometimes, it

makes sense. Other times, not so

much.

Delay – The Delay option

controls the speed of the repeat

option. A longer delay means you

have to hold the button down

longer before it will repeat. The

default is “50 ms” (milliseconds).
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Dropdown – Dropdown adds a

listbox style arrow to the control.

Clicking it displays a calendar

where you can select the date you

need.

NOTE: You can use the Spin Button

and Dropdown options together to

create a flexible control.

After you make your

adjustments to the control, save

the form and close it. Open the

form and test your newly adjusted

date control. Feel free to

experiment with the different

control options to get a better idea

of how they work. The options for

a time control are the same as the

date control except you don't have

the Dropdown option.

MAKING THE TITLE
MANDATORY

Now that we have set up the

date control, let's tackle some

possible issues with the “Title”

field's input box. When we created

the field, we set its maximum

length at 50. However, as the input

box stands now, we can type more

than 50 characters into the box.

Trying to save the record with

more than 50 characters in “Title”

results in an SQL insert error. Also,

when we created the table, we

declared “Title” as “NOT NULL.”

We want to make the “Title” a

mandatory entry for each record.

The “NOT NULL” status prevents

the input box from being left

empty, but it is still possible to

type just a space and the form will

accept the entry as valid. So, we

have a few things to fix in our

form.

Open “ProjectForm” for editing.

Right-clicking the “Title” label or

input box, Group > Ungroup. Now,

double-click the “Title” input box

to bring up its properties dialog.

On the “General” tab, set the value

for “Max Length” to 50. This will

prevent the user from entering

more than 50 characters. On the

“Data” tab, make sure that both

“Empty String Is NULL” and “Input

Required” are set to “Yes.” These

two settings become a redundancy

check for making sure there is a

valid value in the input field.

However, we still have an issue

with the fact that the user can just

create a “Title” with spaces. To fix

this issue, we will need to use a

little SQL. I have looked for a

graphical way to get the same

result, but sometimes, when you

work with databases, SQL is the

best, if not only, choice. We will

add a CHECK constraint to the

“Project” table. Click on Tools >

SQL. To enter the SQL, Tools >

SQL... Use the following SQL

command to add the constraint to

the table:

ALTER TABLE “Project”

ADD CONSTRAINT NOSPACES_CK

CHECK(TRIM(BOTH FROM

“Title”) <> '');

The ALTER TABLE command

means we are making changes to

the table, in this case the table

“Project.” To indicate the change

we are making, we use the ADD

CONSTRAINT command.

NOSPACES_CK is the name of the

constraint we are adding. It's not
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At the end, we tag on an

ORDER BY command to sort the

names by “LastName”, then

“FirstName.” This means the

names will first sort by

“LastName”, then if there is more

than one of the same “LastName”,

it will sort by “FirstName.”

With adjustments to the

controls and a little SQL, we were

able to make many improvements

to our forms, making data input

not only easier but more reliable. If

you are interested in a better

understanding of the SQL used in

this How-To, I have a couple of

resources for you.

My blog “What the Tech Am I

Doing?” LibreOffice Base posts

http://eeperry.wordpress.com/cat

egory/libreoffice/libreoffice-base/

W3Schools SQL Tutorial

http://www.w3schools.com/sql/de

fault.asp
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required that you make your

constraint names all caps. I just do

it as a matter of convention. The

last line is the CHECK constraint.

Using the built-in function TRIM, it

removes all the spaces from both

sides of the string and checks to

make sure it is not equal to an

empty string. Now, if someone

tries to use a string of spaces for

the “Title”, an SQL constraint error

is generated.

You can do the same thing for

the “FirstName” and “LastName”

fields in the “TeamMember” table.

The “Max Length” for the name

fields is 25. I suggest the following

SQL for adding the constraints:

ALTER TABLE “TeamMember”

ADD CONSTRAINT

RNAME_NOSPACES_CK

CHECK(TRIM(BOTH FROM

“FirstName”) <> '');

ALTER TABLE “TeamMember”

ADD CONSTRAINT

LNAME_NOSPACES_CK

CHECK(TRIM(BOTH FROM

“LastName”) <> '');

IMPROVING THE VIEW
QUERY

The view we create for putting

the names in the drop down list

box in the “ProjectForm” is good,

legal SQL, but there are a couple of

problems. First, although we have

prevented a name from being just

spaces, the users can still add a

legal name with spaces added to

the beginning or end. Also, the

names are not in any order.

Luckily, we can edit our view

and make some additions to

address these problems. Select

“Tables” from the “Database” pane.

Right-click “TeamView” and select

“Edit in SQL View...” This brings up

the SQL we used to create the

view. Change the current SQL so it

looks like the following:

SELECT TRIM(BOTH FROM

“FirstName”) || ' '

|| TRIM(BOTH FROM “LastName”)

AS “Name”, “ID”

from “TeamMember” ORDER BY

“LastName”, “FirstName”;

We already saw TRIM when we

created our CHECK constraints. It

removes all spaces from the

beginning and end of ”FirstName”

and “LastName”.

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://eeperry.wordpress.com
http://eeperry.wordpress.com/category/libreoffice/libreoffice-base/
http://www.w3schools.com/sql/default.asp
http://podcast.ubuntu-uk.org/
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I
magine a scientist, let's call

him Doc Brown, who has just

written a manuscript for a

book describing his new

theory on time travel. The

manuscript is a few hundred pages

long. He has broken it down into

chapters and sections, but he

needed to add a table of contents

and an index that the other

scientists, who will praise and

adore his work, can use to navigate

his book with ease. Luckily, he

knew about LibreOffice and how to

use Writer's indexes and tables

tools to create a table of contents

and an index. Let's see how he did

it.

SETTING UP THE STYLES

In many of my articles, I have

emphasized the importance of

using styles, but just in case you

haven't got the message yet,

“Using styles is the best way to

save time and create uniformity in

your documents.” Luckily, Doc

Brown knew the importance of

using styles, and he used styles to

help simplify the creation of his

table of contents. These are the

heading styles “Heading 1 [...1 0] .”

He could edit the styles in any way

he wanted for appearance, but we

are interested in how he used them

in the overall outline of the

document.

To set up the overall outline of

his document, Doc Brown opened

the “Outline Numbering” dialog,

Tools > Outline Numbering.

Selecting each of the different

levels, he noticed that each one

was already assigned to a heading

styles in order from 1 to 1 0.

Working with these defaults he

selected level 1 with the paragraph

style “Heading 1 ” assigned as its

style. For the “Number” setting, he

selected “1 , 2, 3,...” For the

“Before”, he entered “Chapter ”

(note the space), and for the

“After”, he entered a colon “:”.

Using this method, each “Heading

1 ” inserted into the document

would have the format of “Chapter

N: Title”, where N is the chapter

number.

Doc Brown has also decided

that the second and third levels

needed a numbering scheme of 1 .1

for the second level and 1 .1 .1 for

the third level. On the second level,

he changed “Number” to “1 , 2, 3,

...”, set “Show sublevels” to 2, and

added a period and space to

“After.” For the third level, he set

“Number” to “1 , 2, 3, ...”, set “Show

sublevels” to 3, and added a period

and space to “After.”

With all the styles set, Doc

Brown went to work on his

document. He used “Heading 1 ” for

all the chapter headings, and

“Heading 2” and “Heading 3” for

the subheadings within the

chapters. Because he took the time

to set up his styles, he could easily

create his table of contents once

his document was finished.

CREATE THE TABLE OF
CONTENTS

With the writing all done, Doc

Brown was ready to create his
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table of contents. Placing the

cursor below the last line of the

title page, he decided the table of

contents should start on a new

page. Insert > Manual Break

brought up the “Insert Break”

dialog. He selected “Page Break”

and clicked OK. The cursor moved

to the start of a new page.

Now, to create the table of

contents. Insert > Indexes and

Tables > Indexes and Tables. The

“Insert Index/Table” dialog

appeared. He changed “Title” to

“Regarding the Mathematics of

Time Travel.” For the “Type”, he

made sure that “Table of Contents”

was selected.

The “Create Table/Index for”

gave him two options: “Entire

Document” or “Chapter.” If he

wanted, he could have placed a

table of contents at the beginning

of each chapter by inserting a table

of contents after the chapter

headings and selecting “Chapter”

for the “Create Table/Index for.”

However, he was creating the table

of contents for the whole book, so

he selected “Entire Document.”

Finally, he had the “Evaluate up

to level” option. Here he selected

the depth of his table of contents.

If he changed this to 1 , only the

chapter titles would show. He

could then create a table of

contents for each chapter to show

the subheadings. In the end, he

decided to show 3 heading levels

in the table of contents and set

this option to 3.

Doc Brown clicked OK, and the

table of contents was created.

Without any editing, the page

numbers for the first three levels

were added to the table of

contents. Each new level was

indented just a little to show that

it was a lower level. Each title in

the table of contents was a link to

the heading in the document. This

became handy when he converted

the document to PDF and Ebook.

He could have left his table of

contents like this and it would

have worked great, but he decided

it needs just a few more added

touches.

EDIT THE TABLE OF
CONTENTS STYLES

To change the appearance of

the different levels in the table of

contents itself, Doc Brown would

need to edit the “Contents 1 [...1 0]”

styles. There was also the

“Contents Heading” style which

was used to style the table of

contents title.

Doc Brown wanted the title

centered, enlarged, and bold. He

opened the “Styles and

Formatting” dialog through the

new sidebar (no longer

experimental in version 4.2). He

could also open the “Styles and

Formatting” dialog by clicking on

its button in the “Formatting”

toolbar, or through the menus,

Format > Styles and Formatting.

He right-clicked the “Content

Heading” style and selected

“Modify”. On the “Font” tab, he

selected bold and set the size to

20pt. He switched to the “Align”

tab and selected “Center.” He

clicked OK to save his changes.
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Since Doc Brown was only

including the first three levels, he

only needed to change the

paragraph styles “Contents 1 ”,

“Contents 2”, and “Contents 3.”

The first level he wanted a little

bigger and bold, since these were

the chapter titles. He modified the

“Contents 1 ” style by selecting

bold and changing the size to 1 6pt

on the “Font” tab. To distinguish

the second level from the third, he

set the second to bold but left the

size at the default. For the third, he

changed the font to italic but left

the size at the default.

Doc Brown saved his document

with its newly formatted table of

contents. He was now one step

closer to publishing his book and

becoming world famous. He smiled

as he imagined the raving peer

reviews it would receive, but wait...

what about the alphabetical index?

CREATE THE INDEX ENTRIES

In a book of such scientific

importance, an index at the end

would help researchers find a

reference to certain scientific

knowledge contained in the book.

With the final edit completed, Doc

Brown began reading through his

manuscript to determine which

words he would need to include in

the index.

Before he created the index

itself, he needed to create the

index entries for the words he

decided to include in the index. To

get started, he selected the first

word he wanted indexed; then

from the menus, he selected

Insert > Indexes and Tables >

Entry. The “Insert Index Entry”

dialog appeared.

He left the “Index” at the

default, “Alphabetical Index.” If he

had planned to create a custom

index, he would create one using

the button beside the dropdown

list.

“Entry” is the word or phrase

for the index, and it doesn't

necessarily have to appear the

same as in the manuscript. For

example, he changed the term

“supplementary angle” to “angle,

supplementary”in the index. Even

though the order of the words has

changed, it continues to refer to

the same place in the manuscript.

Writer allows for two levels of

“Keys” or categories for grouping

indexes together. For example, Doc

Brown decided that all indexes

concerning angles should appear

together in the index, as well as the

different operators used. For the

angle entries, he entered “angle” in

“Key 1 ”, and for the operator

entries, he entered “operators” in

“Key 1 .” Though he only created

one key level in each case, he could

have created two by entering a

second value in “Key 2”.

Whenever he was on the page

where the main text for a topic

appeared, he would check “Main

Entry.” This makes the page

number appear in bold numerals

for that entry by default. (You can

change the appearance of the main

entry page number by editing the

character style “Main index entry.”)

Doc Brown checked the entry

“Apply to all similar text” as this

creates an entry for every time the

word or phrase appears in the

manuscript. He left “match case”

unchecked, as sometimes the word

or phrase appears in a different

case. He checked “Whole words

only” as he does not want

variations to the word or phrase

indexed.

Once finished with a word, Doc

Brown clicked “Insert.” Leaving the

dialog open, he selected the next

word or phrase in his document.

When he clicked on the dialog, the

new word or phrase appeared in

the dialog's “Entry” field. He made

the changes needed for this entry

and clicked “Insert.” This ability to

switch between the dialog and the

manuscript makes creating the

index entries quicker than if he had

to open the dialog each time.

CREATING THE INDEX

Once Doc Brown completed

creating his index entries, he was

ready to create the actual index. He

went to the last page of his

manuscript, and deciding the index

should start on a new page,

inserted a page break (Insert >

Manual Break; select “Page Break”;

click OK).
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Insert > Indexes and Tables >

Indexes and Tables, brought up the

“Insert Index/Table” dialog. On the

“Index/Table” tab, he selected

“Alphabetical Index” for the

“Type”, changed the “Title” to

“Index”, and unchecked all entries

except “Combine identical entries.”

This prevents the index from

creating separate entries because

of upper or lower case.

Doc Brown decided that the

index should have two columns to

conserve some space. On the

“Columns” tab, he changed the

number of columns to 2. To create

some space between the two

columns, he changed the spacing

to 0.20'' (0.50cm).

Satisfied the index was set up

the way he wanted it, he clicked

on OK. The index then appeared

on the page the way he formatted

it.

Now, Doc Brown's manuscript

was ready for publication. He

began to dream of the raving peer

reviews he would receive. Thanks

to LibreOffice, he was able to add

his table of contents and index

rather quickly.
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W
hen I was in school, I

was very focused on

writing, and I didn't

see the value in

many other subjects, especially

mathematics. As I grew older, I

began to appreciate and enjoy

mathematics. Through the years, I

have studied mathematics on my

own. While I studied, I created

many documents containing my

mathematics notes. I decided it

was time to put them all into one

document with chapters, a table of

contents, and an index. But how

does one combine a bunch of

documents into one?

I guess I could have just copied

the text from one document into

another big document, but this

could get messy, especially since I

wasn't sure about the best order

for the documents. I wanted a

method where I could work on the

documents individually then

combine them into one, and I

wanted the ability to rearrange the

order of the documents. In

LibreOffice, you can do this with

‘master documents’. You can think

of a master document as a

container that joins together

separate Writer documents. Just

the kind of thing I needed. So, I

decided to use a master document.

PREPARING THE DOCUMENTS

Since the documents were

scattered through several years,

they were created with different

versions of OpenOffice and

LibreOffice. They had no style or

template in common. I needed to

create a template for consistency

throughout all the documents and

the master document.

To create my template, I started

with a new blank document. While

creating my template, there were a

few things I took into

consideration. I knew I wanted to

create a table of contents, so I

would need to edit the “Outline

Numbering.” I also wanted each

chapter to start on a new page.

Finally, I would need a unique title

page style.

To edit the “Outline

Numbering”, I went to Tools >

Outline Numbering. I edited the

top level to put “Chapter” and the

chapter number before the top

level headings, just as I discussed in

Part 38 of this series (Full Circle

issue 85). I decided to leave the

other levels bare, although I would

probably include some of them in

the table of contents.

To make each chapter start on a

new page, I edited the outline top

level style, “Heading 1 .” I opened

the “Styles and Formatting” tab in

the sidebar, right-clicked on

“Heading 1 ” in the paragraph

styles, and selected “Modify.” On

the “Text Flow” tab under “Breaks”,

I checked “Insert”. For the type I

selected “Page,” and for the

position, I selected “Before.” OK

saved the changes.

NOTE: You can also open the

“Styles and Formatting” window

from its button on the Formatting

toolbar, the menus (Format >

Styles and Formatting), or by

pressing F1 1 .

I created a page style named

“Title Page” based off the “First

Page” style. The only real change I

made was to set the top to halfway

down the page to center the title

on the page vertically. I modified

the “Title” paragraph style to a

font and size of my liking. I also

created the paragraph style

“Byline” based on the “Subtitle”

style. Not many changes here, just

selected a font to go with the title

font.

To save the template, File >

Save as Template opened the

Template Manager. I clicked on

Save, and the program prompted

me for a name for the template. I

named it “Math Reference.” I

clicked OK, and I had a new

template.

HHOOWW--TTOO
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When you are creating a

template, you may have other

changes you want to make. These

were the ones that I felt were a

good starting point for me. You

can go as far as you want with a

template. In the end it is up to you.

If you decide, while working on

sub-documents, that you need to

make more changes to styles,

make the changes to the template

rather than the individual

document.

To make changes to my

mathematics template, File > New

> Templates. I selected the

template and clicked the Edit

button. This opened the template

rather than a new document using

the template. I made my changes

and then saved it as though it was

a normal document (Click the save

button on the main toolbar, File >

Save, or CTRL-S). When I opened
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one of the documents that uses

the template, LibreOffice notified

me that the template had changed

and asked me to update the

document with the new version of

the template. I clicked “Update

Styles”, and the styles updated in

the document.

Now, I needed to apply my new

template to my existing

documents. I opened each of the

documents and Edit > Select All. I

then created a new document

using my template, File > New >

Templates. I selected my template

and clicked Open. Edit > Paste and

the text and objects from the

original file were pasted into the

new file. I closed the old

document because I wanted to

save it with the same filename. I

saved the new document and I had

the old file contents using the new

template. I repeated this

procedure for all the existing

documents.

CREATING THE MASTER

DOCUMENT

To create my master

document, I opened a new

document using my “Math

Reference” template. Selecting

the “Title” style from the

paragraph styles, I typed in my

title. I then created the subtitle

and byline. Once I had something

in the document, I saved it as a

master document, File > Send >

Create Master Document. I gave

the document a name and clicked

Save. I then went to the page

styles in the Styles and Formatting

dialog and changed the page style

to “Title Page.”

INSERTING DOCUMENTS

Once I had a master document, I

could start adding files to it. When

I saved the master document, it

opened the Navigator in a floating

window automatically. I could have

worked in this floating window,

but I closed it and used the

Navigator panel in the sidebar.

They are both the same, so it's

your choice which one you use. The

Navigator window is opened by

pressing F5 on the keyboard, or

from the menus, View > Navigator.

The Navigator in master

documents is different from other

documents. By default it is in

document list mode. The first

button in the toolbar is a toggle

button that allowed me to toggle

between the document list and a

standard Navigator panel. While

working in the master document, I

did not see any reason for

switching to normal mode, but it is

there should you have a reason for

navigating to an object or

subheading in one of the sub-

documents.

I noticed that one document

was already in the list of files. This

was the Text of the master

document itself, at this point, my

title page. I would add other Text

blocks as needed in the master

document using the insert button.

To add my documents to the

master document, I clicked and

held on the Insert button <image>.

Dragging down to the File

selection, I released the mouse

button. An insert file dialog

appeared for me to find and select

my file. I clicked open and the file

was added to my master

document. When adding a file to

the master document, Writer

always adds it above the currently

selected file. I used the “Move Up”

and “Move Down” buttons

<image> to get my documents in

the order I wanted them. All

references and chapter numbers

adjusted automatically as I moved

the documents up and down in the
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list.

EDITING FROM THE MASTER

DOCUMENT

All documents linked to the

master document are read only in

the master document. To edit a

document from the master

document, I selected the

document in the Navigator list and

clicked the edit button. A new

window containing the document I

wanted to edit opened. I made my

changes to the document, saved,

and closed it. In the master

document, I clicked and held the

Update button. Dragging I

released on Links. A message

window appeared asking me

whether I wanted to update all the

links in the document. I clicked

Yes, and the document I just

edited updated in the master

document. I was also able to open

the document through normal

methods and edit it that way. The

changes still appeared when I

updated the master document's

links.

I inserted a table of contents by

inserting a page break after my

title page and using the same

methods discussed in Part 38 of

this series (Full Circle issue 85). I

did the same for an index, but I had

to insert a Text block at the end of

the master document through the

insert button. This text block was

needed to create an editable block

at the end of the master

document.

Master documents are a great

way to create large documents. In

my case, I wanted the flexibility to

work on the individual documents

and the ability to rearrange the

order of the documents. A master

document works best with a

template shared by all the

documents. Just like normal Writer

documents, you can add a table of

contents and indexes. While a

master document is not always

the best choice, it is a good choice

if you need the ability to move the

different parts around or have

different people authoring the

different parts. This was just one

example of using a master

document. If you plan things well,

you can start from the very

beginning before you even write

the first document.
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I
t probably won't surprise you

to learn that I use LibreOffice

to write these articles. For the

longest time, I would print out

each draft of an article, mark it up

with a red pen, then transfer my

changes to the computer. This old-

school method came from my years

editing papers as a student and as

a professional. As I began to write

on a regular basis, I accumulated a

growing stack of recycle paper

from writing. I tried to use both

sides of the paper, and even ripped

some in quarters for use as note-

paper. Before long I was burning

through a lot of paper and ink.

At some point I decided I

needed a digital solution. I already

knew that Writer provided editing

markup, but had never tried to use

it for editing my documents. With

some hesitation, I began to use it.

The whole “old dog, new trick”

issue. After using it for a couple of

months, I began to wonder why I

hadn't used it before. From right

inside Writer, I can track my

changes, make notes (comments),

and accept or reject the changes. In

many ways, it is quicker and even

more efficient than the hard-copy

method.

PREPARING TO RECORD
CHANGES

Once I finish the first draft of

my article, I save it as a version and

turn on recording changes. (More

on version control later.) ‘Edit >

Changes > Record’ sets Writer to

begin recording changes. Edit >

Changes > Show sets Writer so it

shows me the changes that have

been made. I have debated with

myself the wisdom of showing

changes while I am actually editing.

On the one hand, I can see the

changes as I make them. On the

other hand, showing the changes

while I edit can make reading the

text difficult. I have tried it both

ways, and see some logic in not

showing changes during the actual

edit process, but waiting until the

accept and reject process to

actually show the changes. In the

end, the choice is yours.

NOTE: If you are passing the

document to someone else to edit,

you might want to take some

precautions. File > Properties;

select the Security tab; check

“Record Changes”, and click on

“Protect”. Enter and confirm a

password. This will prevent the

other person from making changes

and then accepting or rejecting

them. When you get the document

back with their changes, File >

Properties, click on “Unprotect”,

and enter your password. You can

now accept or reject their changes.

RECORDING CHANGES

If I set Writer to show changes,

and I add text, it is underlined and

changed to the color I have set.

When I remove text, it is shown as

struck-through just as I would when

editing a hard copy. The strike-

through text is shown in a different

color from the added text. The

colors used for added and deleted

text are controlled by the settings

at Tools > Options > LibreOffice

Writer > Changes.

If I hover over a change, it will

show the author, date, and time of

the change in a tool-tip box. If I

have “Extended tips” turned on in

Tools > Options > LibreOffice >

General, the tool-tip will show the

author, date, time, and any

comments attached to the change.

The author's name is controlled by

the information in Tools > Options

> LibreOffice > User Data.

To add a comment to a change, I

place the cursor anywhere within

the changed text. Edit > Changes >

Comment brings up the comment
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dialog. I can then enter my

comment for the change. This is

sometimes useful to remind myself

of why I made a certain change.

Once I am finished, I click on OK

and the comments are added to

the change.

ACCEPTING / REJECTING
CHANGES

After editing the draft, I am

ready to review my changes. If

changes are not currently showing,

Edit > Changes > Show. Edit >

Changes > Accept or Reject brings
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up the “Accept or Reject Changes”

dialog, which displays a list of all

my changes. Each listing shows the

type of change, author, date, time,

and any comments. Selecting any

of the items in the list highlights

the change in the document. If I

want to keep the change, I click the

Accept button. If I don't want to

keep the change, I click the Reject

button. If I know I want to keep all

my changes, I can just click the

Accept All button. However, if I

decide to throw out all my

changes, I can click the Reject All

button.

On the Filter tab, I can narrow

down the kind of changes that are

displayed in the list. There are four

different filters for me to choose

from: Date, Author, Action, and

Comment.

The Date filter allows me to see

only changes that were created

earlier than, since, equal to, and

not equal to a certain date. I can

also select changes that occur

between two dates. The buttons

with the clock face at the end of

the date entry fields allow me to

set the date to the current date

and time by clicking them. The last

setting for the date filter is to

show only the changes made since

the last time the document was

saved.

I never have much use for the

Author filter, as I am usually the

only one who is making changes.

However, if I did have someone

else editing for me, I could pick

between my own changes and the

changes made by another editor of

the document.

The Action filter allows me to

display just a certain type of

change. The four change types are

insertion, deletion, formats, and

table changes.

If I feel the need to add a lot of

comments to my changes, I can use

the Comments filter to filter

changes based on the text

contained in the comments. I just

check the Comment filter and

enter the text I want to look for.

MARGINAL NOTES OR
COMMENTS

Sometimes, I need to make a

note to myself. Using the hard

copy method, I would just write a

note in the margins. These usually

don't represent an actual change,

but an idea or action to act on at a

later time. For example, needing to

expand on an idea, or save an idea
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back to a version, I can open the

Versions dialog, select the version

I need, and click Open. For more

information on version control,

see my blog post at

http://wp.me/pvwht-9k.

NOTE: The version control in

LibreOffice is okay for small to

moderate size documents, but less

than ideal for very large

documents.

The editing tools built into

Writer are useful for single-person

editing or multi-person editing. I

can have the program track my

changes and allow me to later

accept or reject the changes. I can

add comments to the changes to

help me remember why I made the

change. I can also add margin

notes to the document through

the comment tool. After each edit,

I can save a version of the

document in case I decide to

revert back to a previous version.
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for a later article. Marginal notes

are accomplished through

Comments. Do not confuse these

with change comments.

To create a comment, I

highlight the information it applies

to. Insert > Comment. A box in the

color assigned to the author by

LibreOffice appears in the right

margin. The name that appears at

the bottom of the comment is

controlled by the data entered in

Tools > Options > LibreOffice >

User Data. Placing my cursor inside

the box, I type my comment. I can

even format the text within the

comment box using the format

tools in the formatting toolbar or

the side-bar. I right-click or click on

the down-arrow to get a menu that

allows me to delete comments

when they are no longer needed.

SAVING VERSIONS

After each cycle of changing

and then accepting / rejecting, I

like to save a version of the

document in its current state. File

> Versions opens the Versions

dialog. I click on Save New Version

and give the version a name like

“Rough Draft”, then maybe any

comments I may need like “image

markers in place.” I click OK to save

the version. If I ever need to go
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B
ack in parts 8-1 2 (FCM

issues 53, 55-58), I took

you from a blank

spreadsheet to a full

working budget spreadsheet.

Something similar is what I use

twice a month to do my home

budget. I keep a whole year of

budget spreadsheets in one

document, which means twice a

month I copy the sheet, rename it,

and make sure I get all the settings

correct to put a copy of the current

sheet at the end of the sheet tabs.

Believe me, mistakes have been

made. Curses have been breathed.

Innocent computers have been

threatened.

In time, I decided, since I was

such a fallible, flawed human

being, I needed to reduce the

number of steps necessary to

complete this task in order to

lessen my chances for mistakes.

The result was a macro where all I

have to do is give the sheet a new

name. The macro handles all the

rest, making sure it is copied and

placed at the end of the tab list.

The task fits perfectly into the idea

behind macros, a repeatable

process that automation can speed

up, or prevent mistakes. Today, I

share it with you.

THE MANUAL METHOD

In order to appreciate a macro,

you really have to understand what

it's doing for you, and the mistakes

you can make. Therefore, I will start

with the description of the manual

process that the macro makes

simpler. There is actually more than

one way to copy a sheet in Calc, but

I will show you the dialog method

with all the options.

Right-click on the tab of the

sheet you want to copy and select

Move/Copy Sheet. The Move/Copy

dialog appears. You then select

Copy. One of the mistakes I have

made is to forget this. I end up just

renaming my sheet. Under “Insert

Before” select the option at the

end “-move to end position-”. If I

forget this one, the sheet is placed

before the current sheet rather

than at the end where I want it.

Finally, I have to rename the sheet.

There have been times while trying

to remember to get the other

settings right, that I have forgotten

to actually change the name. When

I do, the copied sheet gets the

name of the current sheet with a

“_2” appended to the end. Click OK

to execute the settings.

I know, you're thinking that it's

not that bad, but after a few times

getting it wrong, your inner Hulk

comes out and you want to smash

things. Okay, maybe that's just me.

Trying to balance the home budget

is frustrating enough without the

bonus of mistakes while copying

the spreadsheet.

THE COPYSHEET MACRO

The macro is not very long (next

page, top right) and you can easily

type it in. You can also copy it from

http://pastebin.com/s3iTGjN6.

The micro starts by declaring 3

variables used in the body of the

macro. “Sheet1 ” and “Sheet2” are

strings that will contain the names

of the current sheet (Sheet1 ) and

the new sheet (Sheet2). The “Doc”

variable will hold a reference to the

current document. It is declared as

a type Object because the

reference is to a LibreOffice API

object.

Doc = ThisComponent

ThisComponent is the current

active document in LibreOffice. In

this case, the macro is looking for a

Calc spreadsheet.

HHOOWW--TTOO
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Sub CopySheet

dim Sheet1 as String

dim Sheet2 as String

dim Doc as Object

Doc = ThisComponent

If NOT Doc.supportsService("com.sun.star.sheet.SpreadsheetDocument") then

MsgBox "This Macro Only Works with Calc Spreadsheets"

Exit Sub

End If

Sheet1 = Doc.CurrentController.ActiveSheet.Name

Sheet2 = InputBox("Enter Name for Copied Sheet:", "Copy Sheet", Sheet1)

If Sheet2 = "" Then Exit Sub

Do While Doc.Sheets.hasByName(Sheet2)

Sheet2 = InputBox(Sheet2 + _

" already exists, select a different name:", "Copy Sheet", Sheet2 + "2")

If Sheet2 = "" Then Exit Sub

Loop

Doc.Sheets.CopyByName(Sheet1, Sheet2, Doc.Sheets.Count)

If NOT

Doc.supportsService("com.sun.

star.sheet.SpreadsheetDocumen

t") then

MsgBox "This Macro Only

Works with Calc Spreadsheets"

Exit Sub

End If

The “If” statements check to

make sure that the current

document is a Calc spreadsheet. It

checks to see whether the

document supports the

SpreadsheetDocument service,

identifying it as a Calc spreadsheet

and not some other document type.

If it is not a spreadsheet, the macro

pops up a message box telling the

user the macro works only with

spreadsheets. The macro then

executes an “Exit Sub” that exits

the macro without running any

more of the code.

Sheet1 =

Doc.CurrentController.ActiveS

heet.Name

The macro uses the Doc object

to extract the name of the current

sheet. The breadcrumb dot notation

goes through a progression of

getting more specific.

CurrentController is a reference to

the service that controls the

document. ActiveSheet is a

reference to the currently active

sheet in the document. Finally,

Name gets the name of the current

sheet and this is assigned to the

variable Sheet1 .

Sheet2 = InputBox("Enter

Name for Copied Sheet:",

"Copy Sheet", Sheet1)

To get the name of the new

sheet, the macro uses an InputBox

function. The InputBox takes 3

arguments:

• The prompt to show the user

(“Enter Name for Copied Sheet:”) .

• The title of the InputBox window

(“Copy Sheet”) .

• The default text (it just uses the

name of the current sheet [Sheet1 ]

as the default text).

If the user clicks the OK button,

the InputBox will return the string

entered in the text box or the

default text when no changes are

made. If the user clicks the Cancel

button, a blank string is returned.

If Sheet2 = "" Then Exit Sub

Do While

Doc.Sheets.hasByName(Sheet2)

Sheet2 = InputBox(Sheet2

+ _

" already exists,

select a different name:",

"Copy Sheet", Sheet2 + "2")

If Sheet2 = "" Then Exit

Sub

Loop

Now, the macro must use some

logic to determine how to proceed.

The “If” checks to see if the

returned string is blank. If so, that

means that the Cancel button was

pressed, therefore the “Exit Sub” is

executed. “Exit Sub” exits the

macro without running any more

of the remaining code.

The Do While...Loop checks to

see if another sheet in the Calc

document has the same name. The

hasByName method checks the

supplied name against the names

of all the sheets in the collection. If

a match is detected, the macro

uses an InputBox to prompt the

user for a new, unmatched name.

The Do While...Loop will loop until
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The last line of the macro

brings all this preparatory work

together to finally execute the

copy. Sheets is a reference to the

collection of sheets in the

document. CopyByName is the

method that actually copies the

sheet and moves it to the end of

the sheet tabs. The CopyByName

method has 3 parameters:

• The sheet to copy from (Sheet1 ) .

• The sheet to copy to (Sheet2).

• The position of the new sheet

(Doc.Sheets.Count).

Count is the total number of

sheets in the collection (Sheets).

Since the sheet numbers are

referenced starting with 0, the use

of Count here puts the new sheet

at the end.

CREATING THE CALC MACRO

the name in Sheet2 does not

match the name of any other

sheet. The “If” inside the loop exits

the macro if Cancel is pressed. If

the name is unmatched from the

start, the loop never runs. This

prevents two sheets from having

the same name.

NOTE: The underscore (_) in the

InputBox statement is used to

break a long line up into shorter

lines. LibreOffice Basic requires

that the underscore is the last

thing on the line. Nothing, not

even a space, can follow it. When

lines are joined in this way,

LibreOffice Basic sees them as one

line.

Doc.Sheets.CopyByName(Sheet1

, Sheet2, Doc.Sheets.Count)
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MODULE

When I developed and wrote

the CopySheet macro, I created a

macro module for Calc. Here I

could store this macro as well as

any future macros designed for

the Calc program. It's a good idea

to group like macros together.

To create the module, Tools >

Macros > Organize Macros >

LibreOffice Basic. The LibreOffice

Basic Macros dialog opens. Click

Organizer to get the LibreOffice

Basic Macro Organizer dialog.

Under My Macros > Standard,

there is a default module named

Module 1 . Select it and click

Delete. With Standard selected,

click New. Name the new Module

“Calc” and click OK. Click Close.

Now back in the LibreOffice

Basic Macros dialog, select the new

“Calc” module you just created and

click Edit, opening the LibreOffice

Macro Editor. Delete the

automatically created “Sub Main”

and “End Sub”. Type in or copy and

paste the SheetCopy macro into

the editor. Save the module and

close the editor.

TEST THE MACRO

After typing in the macro and

saving it, you will want to test it to

make sure you typed everything



full circle magazine 1 1 8 Return to ContentsLibreOffice

correctly. First, open a Calc

document or create a new one.

You can then test the macro by

going to Tools > Macros > Run.

Under Library, select My Macros >

Standard > Calc. Under “Macro

Name” select CopySheet and click

Run. Enter a name for the sheet

like “New Sheet.” Click OK. If all

goes well, a new sheet is created

with the name you gave it. You will

want to repeat the test and not

change the name to see if the

macro prompts you to change the

name. Also, test to make sure the

macro stops when you click on

Cancel rather than OK. For the

final test, open a text document

and run the macro. You should get

the message telling you that the

macro works only on spreadsheets.

NOTE: Back in Full Circle issue 64

(LibreOffice Part 1 7: Macros), I

showed you how to create a menu

shortcut to a macro. This is a good

candidate for such a shortcut.

Create the menu and shortcut in

Calc.

Macros like CopySheet can

speed up your processes and

prevent you from making

mistakes, which is the whole idea

behind macros. This is just an

example of something you can do

with macros, but you can write

your own macros that can expand

the use or capabilities of any of the

LibreOffice programs, or just

reduce a task you do often. A

Google search for “LibreOffice

Basic” is a good place to start

learning more.

EXTRA! EXTRA!
READ ALL ABOUT IT!

Our glorious news reporters

are now posting regular news

updates to the main Full Circle

site.

Click the NEWS link, in the site

menu at the top of the page,

and you'll see the news

headlines.

Alternatively, look on the right

side of any page on the site,

and you'll see the five latest

news posts.

Feel free to discuss the news

items. It's maybe something

that can spill back from the site

into the magazine. Enjoy!

Elmer Perry's history of working, and
programming, computers involves an
Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com
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The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://eeperry.wordpress.com
http://podcast.ubuntu-uk.org/
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I
didn't have to work for very

long in Calc before I needed to

use cell names to reference

values in different cells. This

need was followed by those same

reference names failing to do what

I was expecting from them. While

referencing cells is not

complicated, it sometimes requires

a little thought about what you're

trying to accomplish.

At its heart, there are two

reference types: relative and

absolute. Relative references refer

to a set of offsets from the current

cell. Absolute references refer to

the exact (or fixed) cell, column, or

row. With these two types we can

show references in four different

ways. Cell references can even

cross between sheets.

Sometime, you will need to

reference more than one cell. This

is done with cell ranges. You can

make a cell range relative or

absolute just like the cell

reference. You can even name a

cell range.

RELATIVE REFERENCES

A relative cell reference is a set

of offsets from the current cell. If

you put a reference to C4 in cell D6,

the reference is to the cell one

column to the left and two rows

up. If you copy this reference to

other cells, say D7, it will refer to

the cell C5, which is one column to

the left and two rows up from D7.

Let's create an example to clear

up any confusion. Create a new

Spreadsheet document. In the cells

B3 and B4 put the values 1 5 and 46.

In the cells C3 and C4 put in the

values 1 1 and 1 4. Select cell B5 and

enter the following formula (yes,

the equal sign [=] is necessary):

=B3+B4

When you press enter, it will

show a total of 61 , the sum of the

two values in B3 and B4. Now,

right-click B5 and copy. Select C5,

right-click, and paste. In C5 you get

the total 25, the sum of the two

values in C3 and C4. See how the

reference shifted to the new

column? Since we didn't change

rows, the row references stayed

the same. However, if we did, the

relative cell reference would have

shifted to accommodate the

change.

So, when we make a relative

reference, it will move positions,

keeping the same offsets, when

copied to a new location.

ABSOLUTE REFERENCES

An absolute cell reference is

fixed. If you make an absolute

reference to cell C1 , then no

matter where you copy that

reference, it always refers to C1 .

We create absolute references by

adding the dollar sign ($) before

the column or row we want to

remain absolute. For example $C$1

is an absolute reference to the cell

C1 .

Let's do another example to

illustrate absolute references.

Imagine we need to multiply a

group of numbers by a factor. In

cell D1 we put 0.75. This is our

factor. In D2, D3, and D4 we put 1 0,

20, and 30. In the E column, we will

put our calculations. In cell E2 put

the formula:

=D2*D1

This will give us the answer 7.5,

which is correct. However, if we

copy the formula in E2 to E3 and

E4, we get answers of 200 and 600,

which are wrong. If you look at the

copied formulas, the references

shifted. This is because we used a

relative reference. We do want the

first number to shift when we copy,

but we need D1 to stay fixed. Edit

the formula in E2 and change it to

=D2*$D$1

We still have the right answer in

E2. Now, copy the formula in E2 to

E3 and E4. We get the answers 1 5

and 22.5, which are the correct

answers. If you look at the copied

formulas in E3 and E4, you find the

reference to D1 remained fixed.

FOUR WAYS TO REFERENCE
CELLS

With this in mind, this gives us

four different ways we can

reference a cell. They are relative,

absolute, and two partially
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which will pick up the value of 7.5

from the cell E2 in the MyData

sheet.

NOTE: If the sheet name contains

spaces, surround the name with

single quotes, as in 'My Sheet'.C3.

Just like other references, the

reference to the sheet is absolute

or relative depending on whether

we put the dollar sign ($) in front

of it.

CELL RANGES

Sometimes, you need to

reference a group of cells rather

than just one. For such cases, we

use cell ranges. A cell range is

created by separating two cell

references with a colon (:) . The left

cell references the upper left

corner of the cell range, and the

right cell references the lower

right corner of the cell range. For

example A1 :C2 represents a range

of six cells: A1 , A2, B1 , B2, C1 , and

C2. However, the range can also

represent just one column or row

as in C2:C1 00 or B3:H3.

The same rules for relative and

absolute references apply to cell

ranges. You can create a full or

partial absolute reference. You can

even apply a range across sheets.

Let's say you need a cell range of

all the A1 cells on all the sheets

named Sheet1 through Sheet1 0.

You would use the cell range

Sheet1 .A1 :Sheet1 0.A1 .

For convenience, you can name

a range. To name a range, select a

range of cells in the sheet. Insert >

Names > Define brings up the
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absolute references.

• D1 – Relative, from cell E3, it is

one column left and two rows up

• $D$1 – Absolute, from any

position references cell D1

• $D1 – Partially absolute, column

D is fixed but the row is relative

• D$1 – Partially absolute, column

is relative but the row is fixed to 1

REFERENCE CELL IN
ANOTHER SHEET

To reference a cell in another

sheet, we use dot notation to add

the sheet name to the reference.

For example, Sheet1 .A1 . This is

handy if you need to carry a

calculation or figure from one

sheet to another. To illustrate, we

will rename our current sheet, add

a new one, and create a reference

from one to the other.

Right-click on the tab for the

current sheet and select “Rename

Sheet.” When prompted, name the

sheet MyData and click OK. To

create a new sheet, click on the

plus (+) at the end of the sheet

tabs. Select cell A1 in the new

sheet. Type in

=MyData.E2

“Define Name” dialog. Give the

range a name. Keep in mind that

cell range names can contain only

letters, numbers, and underscore

(_). Note the use of absolute

references in the Range field. You

can adjust your range as needed,

manually or by clicking the range

button and selecting the range

with the mouse or cursor. The

Scope field allows you to define

whether the named range applies

to the entire document or just a

certain sheet. Click OK to save the

range with the new name.

Cell references and ranges are

fundamental when you begin to

work on more complex sheet

layouts, functions, and formulas in

Calc documents. Understanding

how relative and absolute

references work can save time and

prevent mistakes when copying

formulas and references. While

simple, incorrect use of references

can lead to the wrong answer.

http://eeperry.wordpress.com
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S
preadsheets are good for

collecting data like

temperatures, stock prices,

and sports data. However,

the data on its own does us little

good. We need ways to analyze the

data. LibreOffice Calc provides us

with built-in functions to do this. In

this article, we will look at a few of

the simple statistical functions

built into Calc. This is not meant as

a thorough examination of all the

functions, but more an exercise to

get you comfortable using

functions.

IMPORTING THE DATA

For our data, I have collected a

few months worth of stock prices

on the mutual fund FFACX. You can

find the data at

http://pastebin.com/AeLcyM1 t.

The data is laid out as comma-

delimited plain text. Copy the data

from Pastebin. Make sure that you

copy from the ”Raw Paste Data”

text box. Create a new Calc

document. Right-click on cell A1

and select Paste. The Text Import

dialog will show. Under Separator

Options, select “Separated by” and

check Comma. Click OK. You now

have two columns of data, the date

and the price. Save the sheet.

CREATING A NAMED CELL
RANGE

Throughout this article we will

use the prices as our data range.

Since we will use the range several

times, we will name it to make the

references easier. Select all the

prices (cells B2:B82). The easiest

way to select all the cells is to type

the range B2:B82 into the cell

name box on the formula toolbar

and press Enter on the keyboard.

Insert > Names > Define, and the

“Define Name” dialog shows. Name

the range “Prices”. Notice the

absolute reference in the Range

text box ($Sheet1 .$B$2:$B$82).

Names apply to a specific group of

cells, so the reference is absolute.

Under the Scope, we will restrict

the use of this name to just Sheet1 .

Click Add to create the range

name.

Now, in any formula or function

where we use the name “Prices”, it

is the same as typing the cell range

$Sheet1 .$B$2:$B$82.

MAX AND MIN

The first two statistical

functions we will look at are MAX

and MIN. Both functions accept a

http://pastebin.com/AeLcyM1t
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CONDITIONAL FORMATTING

In our data set, the top and

bottom are pretty close together,

so the average will work good for

us as the typical value for this data

set. We can use conditional

formatting to mark each of the

prices as either above or below the

average.

Start by selecting all the prices

in the B column (B2:B82). Since we

named the range B2:B82, a quick

way to select all the prices is by

using the drop down arrow for the

cell name box on the formula

toolbar and selecting the name

“Prices(Sheet1 ) .”

Format > Conditional

Formatting > Condition will bring

up the Conditional Formatting

dialog. Select “Cell value is” from

the left drop-down list. From the

drop-down list in the center, select

“less than.” Enter $E$7 in the text

box to the right. If you want to use
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list of values or range(s) . MAX

returns the maximum (or largest)

value in the list. MIN does just the

opposite, returning the minimum

(or smallest) value in the list.

Move your cursor to D4. Type in

“Highest.” In the cell E4, type in

the formula

=MAX(Prices)

You should get the result 1 4.1 6.

If you look through the list of

prices, you will discover this is the

largest number in the list.

In D5 put “Lowest.” The

formula for E5 is

=MIN(Prices)

The result is 1 3.57, the lowest

number in the list.

It is also possible to use these,

or any Calc function, as an operand

in a formula. For example, if we

wanted to know the difference

between the highest and lowest

price, we could use the formula

=MAX(Prices) – MIN(Prices)

in cell E6. In the formula, the

results of the functions are

calculated first. MAX(Prices)

becomes 1 4.1 6, and MIN(Prices)

becomes 1 3.57. Then the result of

1 4.1 6-1 3.57 is placed in the cell E6.

Place the text “Difference” in the

cell D6 as a label.

AVERAGE, MEDIAN, AND
MODE

In statistics there are many ways

to determine just what is the

typical value for a set of numbers.

Among these are the arithmetic

average, the median, and the

mode. The arithmetic average,

known to most people as simply

the average, is the sum of a series

of numbers divided by the number

of items in the series. In Calc we

use the AVERAGE function to get

the arithmetic average.

The median ranks the numbers

from the lowest to the highest. If

the number of items in the series is

an odd number, it takes the one in

the middle. If it is even, the median

is the arithmetic average of the

two center numbers. Calc uses the

MEDIAN function to calculate the

median for you.

Mode is the number that

repeats most often. If there is a tie,

it uses the smallest number. Calc

uses the MODE function to get

the mode for you.

We can see the results of these

three functions by putting the

following formulas in the cells E7,

E8, and E9.

=AVERAGE(Prices)

=MEDIAN(Prices)

=MODE(Prices)

You will notice that the results

are within a few hundredths of

each others. This is not true in all

cases. Numbers that are much

larger or much smaller than all the

others can affect the average. In

those cases, the mode or median

might better suit your needs for a

typical value.

The Calc statistical functions

help us to analyze the data in a

Calc spreadsheet. We touched on

only a few of the statistical

functions. Calc has over 70

statistical functions. This is just

one of many categories of

functions available to us in Calc.

You can get a list of all the Calc

functions in the help

documentation.
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EXTRA! EXTRA!
READ ALL ABOUT IT!

Our glorious news reporters

are now posting regular news

updates to the main Full Circle

site.

Click the NEWS link, in the site

menu at the top of the page,

and you'll see the news

headlines.

Alternatively, look on the right

side of any page on the site,

and you'll see the five latest

news posts.

Feel free to discuss the news

items. It's maybe something

that can spill back from the site

into the magazine. Enjoy!
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the median or mode for the

comparison, you can use $E$8 or

$E$9. We are using an absolute

reference here because we want to

reference the same cell regardless

of what row we are formatting.

For the Apply Style, select “New

Style” from the drop-down list. The

Cell Style dialog will open. On the

Organizer tab, name the style

“Below Average.” Switch to the

Background tab and select the Red

color swatch. Click OK to close the

dialog and save the new style. You

will see “Below Average” is now

selected as the Apply Style.

Click Add to add a second

condition. This time select “greater

than” instead of “less than.” Use

the same absolute reference, $E$7,

$E$8, or $E$9, as you used in the

less than condition. Once again

select “New Style” for the Apply

Style. Give the new style the name

“Above Average”, and make the

background green instead of red.

OK to save the new style.

OK in the Conditional

Formatting dialog will save the

settings. Prices that are over the

average will highlight in green, and

the prices below the average will

highlight in red.

NOTE: You can create your style

for conditional formatting before

creating the condition. In such a

case, you would just select the

style to use.

I hope this article has helped

you to understand the use of the

statistical functions demonstrated

and functions in general. We saw

how to use named ranges to

identify cell ranges being used

repeatedly. We used functions by

themselves and as operands in a

formula. Using conditional

formatting, we highlighted certain

cells to show visually the status of

the cell's value. This eliminates

the need to scroll back up the

sheet to check the average value.

Until next month, look up some

functions in the help and put them

to work for you. Also, play with

some of the features of the

conditional formatting and see

what other visuals you can create.

Next time, I will show you how

to validate cell values.

http://eeperry.wordpress.com
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W
hen you begin to

create formulas in

Calc, you soon

realize that the

wrong kind of data in a cell

referenced by your formula can

throw the results off. Calc does its

best to interpret the data entered

according to the formatting style

of the cell. If you format the cell as

a date type, Calc does its best to

translate the input in that cell as a

date. At times it is successful and

other times not. Fortunately, Calc

comes with validity options built in

to help you design your

spreadsheet in such a way as to

give the user help with the input or

even force them to enter the data

type needed for the cell. In this

article, we will look at the validity

options and its capabilities.

SHEET SETUP

Before we get to the validity

options of Calc, we need to set up

a spreadsheet where we will use

the options. The spreadsheet is a

time sheet for showing the hours

worked during a week. The time

sheet works well for our example

because on a given day, the next

time input must have a greater

value than the previous entry.

We will start by creating our

title and column headers. In cell A1 ,

enter “Time Sheet”. On row 2, fill in

columns A-F with the following

titles: DAY, IN, OUT, IN, OUT,

TOTALS. Now for the row headers.

In cell A3, type in “Sunday”. Making

sure that cell A3 is highlighted,

click on the small square in the

lower right corner of the

highlighted cell. The cursor will

become a crosshair. Drag down to

A9. When you release mouse

button, the rest of the weekday

names are filled in. This happens

because the days of the week are

one of the default sort lists. You

can see all the lists and add your

own at Tools > Options >

LibreOffice Calc > Sort Lists.

Now let's format the cells.

Select B3:E9, right-click, and select

Format Cells. Click the Numbers

tab. From the Category list box,

select Time. If you normally use a

1 2-hour clock, select the “01 :37

PM” option under format.

However, for a 24-hour clock,

select “1 3:37.” Click OK to save the

options. Column F is the totals. We

will need to select a time format, at

least for the last one, that can go

beyond 24 hours. Select cells

F3:F1 0, right-click, select Format

Cells. Again, on the Numbers tab,

select the Time category, but for

the format, select “87661 3:37.”

This will allow for totals that are

greater than 24 hours. Click OK to

save the settings.

If you haven't yet, you might

want to save your sheet.

SETUP VALIDATION

We will need to check the

validity of the time inputs. We will

want them in a Calc-acceptable

time format. This is the only

requirement for valid data in the B

column. For the other columns (C-

E), we will need to also make sure

the input is greater than the input

before it.
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Select cell B3, then Data >

Validity. The Validity dialog will

appear.

The Criteria tab (above) is

where we control what constitutes

valid data. The Allow drop-down

list defines the type of data that is

acceptable. The default is All

Values. The other types are Whole

Numbers, Decimal, Date, Time, Cell

Range, List, and Text Length. The

choices for the different types are

basically the same except for Cell

Range and List. With the cell

Range, you define a cell range and

the cell must contain a value that is

in one of those cells. The defined

range must consist of only one

column or one row. With the List

option, you define a list of

acceptable values. With both the

List and Cell Range options, you

get a drop-down list box with the

acceptable values. For our

purposes, we need Allow set to

Time.

Check the box for “Allow empty

cells” to allow cells to remain

empty. This will allow us to start

with a blank time sheet.

The Data drop-down list allows

you to select the comparative

operator to use for this validation.

The choices are equal, less than,

greater than, less than or equal to,

greater than or equal to, not equal,

valid range, and invalid range. Each

one asks for a minimum, maximum,

or value to compare, except for the

two range choices. The range

choices require a minimum and

maximum. For our purpose, we

need the greater than operator. In

the minimum text box, enter 1 2:00

AM or 00:00.

Click on the Input Help tab

(below). The settings on this tab

are optional. The idea is to provide

the user with information about

what to enter into the cell as a tip

box that pops up when the cell is

selected. To activate, click the

checkbox for “Show input help

when cell is selected.” Create a

title for the tip box by typing it in

the Title text box. For us, we could

use the title “Start Time”. The

Input Help text box is where you

put the actual help tip like “Enter

the start time: ex. 1 :00 PM or

1 3:00”.

Switch to the Error Alert tab

(above). Here we can set the

validation to display a message

when invalid data is entered. To

activate the setting, check the

checkbox for “Show error message

when invalid values are entered”.

There are four choices for the

Action drop-down list, Stop,



full circle magazine 1 26 Return to ContentsLibreOffice

LIBREOFFICE - PART 44

Information, Warning, and Macro.

Stop, the one we will use, prompts

with a dialog and rejects the input

when invalid data is entered. For

Information and Warning, they

prompt with a dialog containing

OK and Cancel buttons when

invalid data is entered. If the user

clicks OK, the input is left as it is. If

the user clicks Cancel, the input is

rejected. Macro will allow you to

select a macro to run when invalid

data is entered. The Title and Error

Message is the title and message

for the dialog box. We could set

them to “Invalid Time” and “Enter

in time format: 1 3:00 or 1 :00 PM”.

Once you have everything set,

click OK to save the Validity dialog

settings.

We will copy cell B3 to cells

B4:B9. Right-click cell B3 and

select Copy. Select cells B4:B9,

right-click, and select Paste. This

will copy the validity settings to

the cells. The whole column will

have the same requirements for

input.

For columns C, D, and E, we will

do almost the same thing. We will

go through the steps on C, and you

can repeat for D and E. Select cell

C3, Data > Validity. On the Criteria

tab of the Validity dialog, select

Time from the Allow drop-down

list. Check to allow empty cells. Set

Data to greater than, and set the

minimum value to B3. Notice that

we use a relative cell reference

here. This will allow us to copy it to

the other cells and have the

reference translate. These criteria

tell Calc that the cell requires a

value greater than the value in cell

B3. Do what you want with the

help and error tabs. I do

recommend using at least

Information or Warning messages

for invalid data. The messages

could mention needing a greater

value (or a later time). Right-click

cell C3 and copy the cell, then

paste it into cells C4:C9.

You can repeat for columns D

and E. You can also just copy C3 to

D3:D9 and E3:E9, but you will need

to adjust the text in the dialogs for

help and error.

TOTAL FORMULAS

Now that we have our

validation set up, we need to

create the formulas to give us our

totals. We will start with the daily

totals. Select cell F3. Enter the

formula

=(C3­B3)+(E3­D3)

which will give us the total for

Sunday's times. Right-click F3 and

Copy. Select cells F4:F9, right-click,

and Paste.

For the weekly total in F1 0, we

will just sum the daily totals. Here

is the formula:

=SUM(F3:F9)

PROTECT CELLS

Once you have a sheet set up

the way you like, you may want to

protect the parts of the sheet you

don't want changed like the labels

and formulas. First, you need to

tell Calc whether the cell is

protected or not. Then you add

protection to the sheet or

document once everything is

finished. In the case of our time

sheet, we need to protect

everything except for the cells

where the user enters their times,

B3:E9.

By default, the Protect option is

turned on for all cells. To change

the protection setting for the input

cells, select B3:B9, Format > Cells,

and the Format Cells dialog

appears. Click on the Cell

Protection tab and uncheck

Protected.

At this point, you can still edit

any cell because the sheet or

document is not protected. To turn

on protection for the sheet or

document, Tools > Protect

Document > Sheet (or Document).

The Protect Sheet or Protect

Document dialog will appear

depending on which option you

selected. Enter and confirm a

password in the dialog. The options

will allow you to check whether the

user can select protected or

unprotected cells. If you do not

enter a password, then no

password is required to remove

protection from the sheet or

document.

To remove protection from a

sheet or document, Tools > Protect
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EXTRA! EXTRA!
READ ALL ABOUT IT!

Our glorious news reporters

are now posting regular news

updates to the main Full Circle

site.

Click the NEWS link, in the site

menu at the top of the page,

and you'll see the news

headlines.

Alternatively, look on the right

side of any page on the site,

and you'll see the five latest

news posts.

Feel free to discuss the news

items. It's maybe something

that can spill back from the site

into the magazine. Enjoy!
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Document > Sheet (or Document).

If a password was used when

protection was set, enter the

password used to protect the

sheet or document.

MARK INVALID DATA WITH

DETECTIVE

If you selected Warning or

Information from the Action drop-

down list in the Validity dialog, a

user could enter invalid data and

click OK to keep the invalid input.

This may generate strange results

in your totals or an error. Tools >

Detective > Mark Invalid Data will

mark the invalid data. Once the

user corrects the data, Tools >

Detective > Mark Invalid Data

should clear the marks, unless the

data is still invalid. Notice from my

sample that invalid data can cause

other cells data to show as invalid.

The Calc Validity options are a

great way to set up sheets for use

by other people, or to keep you

from entering invalid data on a

complicated sheet. You can set it

up to reject the invalid data

outright, or for the user to make a

choice about keeping the input.

Once you have the sheet set the

way you want it, you can protect

the sheet from unwanted changes.

This is a good way to protect

formulas and labels. Finally, the

Detective tool allows the user to

mark invalid data they entered.

http://eeperry.wordpress.com
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I
n my last article, I showed you

how to use the Mark Invalid

Data tool in Calc's Detective

tools. This time, I am going to

discuss the rest of the tools in the

Detective menu that help us trace

the cells used in formulas. Through

these tools, we can learn what cells

affect the result of a formula, what

formulas a cell affects, and what

cells are involved in a formula that

results in an error. The sheet we

will use is small to help you

understand how they work, but

these tools are most helpful in a

large sheets with complicated

formulas.

SETTING UP THE SHEET

Create a new, blank sheet. In

cell A1 , enter the value 1 3. Select

cells A1 :A6. Edit > Fill > Series to

bring up the Fill Series dialog. For

the Direction, select Down, and for

the Series type, select AutoFill.

Click OK, and the cells are filled

with sequential numbers. Select

cells A1 :D6. Edit > Fill > Series. This

time, select Right for the Direction,

but again select AutoFill for the

Series type. Click OK and the cells

to the right are filled with

sequential numbers.

Create totals for the rows and

columns by selecting the blank cell

at the end of the row or column.

Click the SUM button on the

formula toolbar. The cells to the

left for rows, and above for the

columns, are automatically

selected. Press the Enter / Return

key on the keyboard to accept the

results. Repeat for each of the

rows and columns.

Cell E7 will sum the totals of

both the rows and the columns.

The formula is

=SUM(A7:D7,E1:E6)

TRACE PRECEDENTS

The Trace Precedents function

(bottom right) shows the cells used

by the formula in the current cell.

Traces are displayed on the sheet

with blue arrows and blue frames

around cell ranges. This is true for

all the trace functions.

Select cell E7. Tools > Detective

> Trace Precedents. Blue arrows

and frames show the cells used by

the formula. If you entered the

formula correctly, this includes all

the totals for the rows and

columns. To clear the trace

markings off the sheet, select

Tools > Detective > Remove

Precedents.

TRACE DEPENDENTS

Trace Dependents (next page,

top left) draws arrows to the cells

containing formulas that rely on

the currently active cell. If you

select C4 then Tools > Detective >

Trace Dependents, you get arrows

pointing to C7 and E4. Both of

these cells contains formulas that

reference C4 in their range. Just as

with the Trace Precedents, the

ranges of the two formulas are

surrounded by a blue box. To clear

the trace markers, Tools >

Detective > Remove Dependents.

COMMON CALC ERRORS
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realize that the two cells used in

the formula are the same value.

Then it hits you; you meant to use

C6 – not C3. Change C3 to C6 in the

formula in E8, and the error and

the error trace arrow go away. Also

note that the precedents traces

move with the change of the

formula.

With the detective's trace tools

in Calc, you can trace the cells used

in a formula and determine why

you didn't get the results you

expected. Trace Precedents shows

you the cells used by the formula

in the current cell. Use Trace

Dependents to show the cells

containing formulas that use the

currently selected cell. If you are

trying to determine why a formula

is generating an error in the

current cell, you use the Trace

Error tool. Finally, you can combine

the different trace tools to get a

broader view of what is happening,

or not happening, in your sheet.

This is often caused by referencing

a cell with text in a mathematical

function or formula.

Err:51 0 – A variable is missing from

the formula. This can happen when

you type two operators together,

like =1 +* 3.

TRACE ERROR

Trace Error draws trace arrows

to all the precedent cells which

caused an error in the currently

selected cell's formula. To

demonstrate this, we will need to

generate an error. #DIV0 is
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Before we talk about Trace

Error, let's take a quick look at

some common errors you will see

in Calc.

#DIV0! – The formula is trying to

divide a number by zero. As we

learned in elementary

mathematics a long time ago, you

can't divide a number by nothing.

Some functions, like VARP and

STDEV, will give this error when

you fail to use the minimum

required arguments.

#REF – The cell or range reference

is invalid. This mostly happens

when you mistype your reference

or you reference a cell or range

that no longer exists. For example

you have a reference to a sheet

that has been deleted.

#VALUE – The input was a type

other than what was expected.

probably the easiest to generate.

Enter the formula =C3-D2 in cell

E8. The result is zero. In cell E9

enter the formula =E7/E9. This will

generate a #DIV0 error.

To trace the error, select cell

E9. Tools > Detective > Trace Error.

A trace arrow is drawn through the

cells involved in the formula. In our

case, it is just two cells. You can

change the minus to a plus and the

arrow will clear and the error will

go away, but for now, let's leave it

the way it is. I have one more thing

I want to show you. The only way

to clear an error trace without

correcting the error is Tools >

Detective > Remove All Traces.

COMBINING TRACES

Tracking down a problem or an

error is not always as simple as just

using one of the trace tools. You

might need to combine them to

find the real issue. Let's take our

error for example. We can select

the cell E9, and run the error trace,

and see that the formula uses the

two cells above it. However, once

you realize that both cells contain

formulas as well, you can trace the

precedents on cell E8 to see if you

can find the problem. You then
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I
n past articles, I have

discussed and used functions

to illustrate other

functionality in Calc, but

today, I am going to show you

three different ways to enter

functions. I ' ll show you the

structure of a function; we will

create data for a spreadsheet; then

I will apply each of the input

methods: Function Wizard,

Function List, and manual entry.

STRUCTURE OF A FUNCTION

I t helps to understand the

structure of functions if you plan to

use them. I will use the following

function for my discussion of

function structure:

=PRODUCT(B5, A1:A6, 0.25)

Functions are always a part of a

formula. When you use any formula

or function, it must begin with an

equals sign (=). If you use multiple

functions, the equals sign is

required only at the beginning.

The start of a function is the

function name. By tradition,

function names are entered in all

upper-case letters, but Calc will

recognize them in lower or mixed

case letters. Keeping with the

tradition, I usually enter function

names in all capitals. The name of

our function in the example is

PRODUCT. PRODUCT is to

multiplication what SUM is to

addition, it multiplies all its

arguments into a final total.

After the function name is the

argument list, separated by

commas, and surrounded by

parenthesis. This is the (B5, A1 :A6,

0.25) part of our sample function.

Arguments can come in several

forms, and the function will usually

expect a certain type in each

position of the arguments.

Arguments can take the form of

numbers (9), “Quoted text”, cell

reference (C3), cell range (C3:C1 0),

comparisons (C3 > C1 ), or another

function. Note that quotes around

a number, “9”, defines the

argument as text – and not a

number.

SETTING UP THE SHEET

I work with installers of

controlled access systems. When

setting up a new system, it is

necessary to calculate how many

power supplies are needed in order

to power the equipment for the

site. We use a formula for

calculating the voltage drop at

each device. The calculation

involves the input voltage, the

current draw of the device plus the

current draw of any devices after it,

multiplied by the resistance of the

length of wire to the device. The

basic formula is

Vout = Vin – I(DR)

where Vin is the input voltage, I

is the current draw of the device

and any devices after it, D is the

length of wire (in feet) , and R is the

resistance of the wire per foot.

Let's set up a sheet to help us

calculate the voltage at each

device.

Start with the label “Start Volts”

in cell A1 . In cells A2:E2 put the

following column headings: Device,

Amps, Distance, Ohms/Foot, and

Voltage. In cell B1 put 1 3.2 for your

starting voltage. In A3:A5 put 1 , 2,

3 for the devices. B3:B5 are the

current draw for each device. Use

0.3, 0.25, and 0.5. The three

distances for the wire are 75, 1 1 0,

and 1 20. For the Ohms/Foot, use

0.00639 for all three. This is the

approximate Ohms per foot for 1 6

AWG (US). Leave the Voltage

column blank. This is where we will

enter our formulas.

FUNCTION WIZARD

The function wizard is the most

complete method for entering

formulas with functions. It is also

the slowest because of the many
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options. The wizard is a great way

to work through the set up of a

complicated formula by allowing

you to deal with individual pieces

of information one at a time. We

will use the wizard to create the

voltage formula for the first

device.

There are three ways to access

the Function Wizard. Select cell E3

and do one of the

following:

• Click the Function

Wizard button on the formula

toolbar.

• Insert > Function...

• CTRL + F2

The Function Wizard displays a

function list box to the left. The

Category drop-down list allows you

to narrow the functions in the list

to the selected category. There is

also a Last Used category for

selecting recently used functions.

If you single-click on a function

name, it displays a short

description of the function to the

right. When you double-click on a

function, it inserts the function

into the formula text box on the

bottom right. Notice that the

wizard has already inserted the

equals sign for you. The right

center displays text boxes for
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entering the arguments for the

function. Above the argument

boxes, it displays the short

description and a list of the

arguments and their type. The top

right shows the results of the

current formula and the formula

result is displayed above the

formula edit box.

Our formula starts with the

voltage coming into the device.

For the first device this is 1 3.2

from cell B1 , so click into the

formula text box at the bottom

and type “B1 -”. From the category

drop down list select

Mathematical. Scroll down the list

and double-click PRODUCT. The

PRODUCT function is added to the

formula.

Click into the Number 1 text

box. The first argument is the sum

of all the amps for all the devices.

Click on the Function Wizard

button to the left of the Number 1

text box. This gives you a blank

function wizard screen. Note that

you now have Back and Next

buttons at the bottom. Select

Mathematical from the category

list, but this time double-click the

SUM function. Click into the

Number 1 text box. Use your

mouse to select cells B3:B5. The

range is added to the Number 1

text box for SUM.

Click Back twice to return to the

PRODUCT function we started

with. Notice that the SUM function

is now in the Number 1 text box.

Select the Number 2 text box.

Double-click on PRODUCT again. In

the Number 1 text box for the

second PRODUCT function, enter

or select the range C3:D3.

We are now finished with our

formula. The final formula should

look like

=B1­

PRODUCT(SUM(B3:B5),PRODUCT(C

3:D3))

Click OK to finish the wizard.

NOTE: I could have used the

multiplication operator (*) to

accomplish the same thing in the

PRODUCT function, but I used the

function in order to illustrate the

ability to use functions as

arguments to other functions.

FUNCTION LIST

The Function List is the wizard

without the bells and whistles. In

fact, it is just the function list
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portion of the wizard. The idea

behind it is to help you in adding

functions directly into the cells.

You can bring up the Function List

by using the menus, Insert >

Function List, or by clicking the

Functions icon in the sidebar.

When you select a function name

in the list, a short description

appears at the bottom of the list.

The Function List also has a

category item called Last Used,

containing a list of the functions

you have used recently.

Let's use it to create the

formula for the second device.

Select the cell E4. Select the Input

Line text box on the function

toolbar. This is the best place to

enter functions using the function

list. For this device, we need the

Elmer Perry's history of working, and
programming, computers involves an
Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com
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ending voltage of the previous

one, so start the formula with

“=E3-”. You should see PRODUCT

listed on your Last Used list.

Double-click PRODUCT to add it to

the formula. With the cursor

between the parenthesis, double-

click SUM, which should also show

in the Last Used list. Select cell

range B4:B5. Click into the formula

and use the arrow keys to move

the cursor outside SUM's

parenthesis. Type a comma then

double-click PRODUCT again. Type

in or select the range C4:D4. Press

Enter.

The final result should look like

=E3­

PRODUCT(SUM(B4:B5),PRODUCT(C

4:D4))

MANUAL ENTRY

Manual entry is just that, typing

the formula directly into the cell

from memory. The formula for the

last device is the easiest because

you no longer need the sum of

device currents because it is the

only one left. Select cell E5 and

type in

=E4­PRODUCT(B5,

PRODUCT(C5:D5))

and press Enter. While you are

typing in the functions, Calc will

show you a hint balloon of the

function and its arguments.

Calc gives you three different

methods for entering functions

into a cell. Use the Function Wizard

when you need as much guidance

as possible, or when entering a

complicated formula for the first

time. The Function List gives you a

list and short descriptions to aid

you in using the correct arguments

and functions in your formula. The

manual method is great for

entering short formulas, using

functions you are familiar with, or

repeating a formula you have used

before.

http://eeperry.wordpress.com
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S
preadsheets are a great

place to collect data. The

web is a great resource for

data and much of that data

is dynamic. You may even want to

collect this data into a spreadsheet

and make the spreadsheet mirror

the dynamic nature of the web

data. Calc allows us to link to

external data sources, including

web pages, and it will surprise you

how easy it is.

Many people trade stocks.

Trading requires diligently tracking

the stocks. In the past, I have

shown this done manually, but

today, I am going to show you a

way to use a Calc spreadsheet to

track the top 1 00 stocks as

compiled by the web site

barchart.com.

Like so many things, there is

more than one way to do this. I 'm

going to show the method I feel is

the easiest for discovering and

getting exactly the information you

want. You will import the web page

using the Web Page Query filter.

Once imported, you can examine

the elements of the page to find

the data you want to extract. You

will then create your sheet of 1 00

stocks by pulling from your

imported source file.

SETTING UP THE SOURCE
SHEET

When you import the source

using the Web Page Query filter,

you are not actually working with a

local copy, but a link to the page on

the Internet. You will not save this

import (but you could). Instead, you

are using it as a reference to the

actual page on the barchart.com

web site.

From the menus, File > Open. In

the Open dialog, you will find the

file type filter drop-down list at the

bottom of the dialog. All the

different file types recognized by

LibreOffice are listed here. Scroll

through and find the filter named

“Web Page Query (Calc)”. This will

help you create your link to the

web page. In the “File name” text

box, enter (or copy and paste) the

following URL:

http://www.barchart.com/stocks/si

gnals/top1 00

Click the Open button. Calc will

take a few seconds then come up

with the Import Options dialog.

The Automatic option will import

the web page “as is.” Custom

allows you to select another

language for importing the page. I

recommend using Automatic as it

has the greatest chance for proper

interpretation. The “Detect special

numbers (such as dates)” checkbox

does what you think it does. When

checked, it will detect dates, times,

etc, and format them appropriately

in the sheet. We do not have

special numbers we are concerned

about, so we don't need it. Click OK

to accept the options. Depending

on your Internet connection,

computer speed and memory, Calc

will take a few seconds to import

the web page. Notice that it

imports the entire web page minus

the images.

NOTE: This is a link to the actual

web page. Nothing has been saved

on your local computer at this

point.

HHOOWW--TTOO
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THE NAVIGATOR

We will use the Navigator to

examine the imported page and

link the data to our new document.

The Navigator shows you the

elements and structure of a

document and changes depending

on the type of document you have

open. Not only is it good for our

purposes here, but for navigating

and manipulating a document,

especially a large document.

Currently, there are four ways to

open the Navigator:

• Press F5 on your keyboard

• View > Navigator

• Navigator tab on the sidebar

• Navigator button on the standard

toolbar

LIBREOFFICE - PART 47

EXAMINE THE SOURCE

When a web page is imported,

several range-names are created,

as well as importing named tables

on the web page. The prefix

HTML_ is added to any names

imported from the page. The filter

creates two special ranges,

HTML_all and HTML_tables.

HTML_all allows you to select the

entire document. HTML_tables

allows you to select all the tables.

The problem you run up against is

the creator of the web page

probably wasn't thinking about you

importing his page into Calc.

Imported table names were for the

creator's reference not yours.

If you open the Navigator using

one of the methods listed above, in

our source document, you will

discover a list of names under the

“Range-names” item in the

Navigator. Double-click on a range-

name to highlight it in the

document. As you go through the

list, you soon discover that the

names HTML_4 and HTML_dt1

both contain the table with our

stock data. You will use one of

these to create your stocks

document.

IMPORT TABLE TO NEW
SHEET

Now that you know what

range-name to import for the

stocks data, it's time to create the

sheet you want to save and keep.

You will import from the source

document into a new document.

Remember that your source

document is just a link to the

actual web page, nothing has been

saved to your local computer yet.

From the menus, File > New >

Spreadsheet. Use any of the four

methods discussed above to open

the Navigator. From the

documents list at the bottom of

the Navigator window/panel,

select the source document,

top1 00. Click on the drag-mode

icon in the Navigator toolbar and

change the setting to “Insert as

link.” Expand the entries under the

“Range names.” Select either

HTML_4 or HTML_dt1 , drag it to

cell A1 in the new document, and

release. After a few seconds,

depending on your internet and

computer speeds, the stocks data

will appear in your new sheet. Save

the new document. You can now

close the source document. There

is no need to save it. Your new

document is actually linked to the

page on the web site and not the

source document.
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You can close your new

document, and when you open it,

you are prompted about whether

to update the links in the file. If

you answer Yes, Calc will retrieve a

fresh version of the page and

update the data in your sheet. You

can set the file to update

periodically when it is opened. In

the menus, Edit > Links brings up

the Edit Links dialog. With the link

selected, click on the Modify

button to bring up the External

Data dialog. Check the “Update

every...” check box, and fill in the

number of seconds between every

update. For example, every five

minutes is 300 seconds, ten

minutes is 600 seconds, and an

hour is 3,600 seconds. Click OK to

save your changes and Close to

close the Edit Link dialog.

Importing dynamic data from a

web page in Calc is pretty simple.

Use the Web Page Query filter to

link the page to a sheet. With the

Navigator, you can examine the

page to determine which range-

name contains the data you need.

Once you know the range you

need to use, you use the Navigator

to drag the range-name into a new

sheet and save the new document.

The new document will prompt

you to update every time you open

the document or periodically,

should you assign an update period

to it.

http://eeperry.wordpress.com
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L
inking to data on the web

is often useful, but,

sometimes you need to

just get data from a sheet

in another Calc file. You can just

import or link the whole sheet

from another file. You do this

through the Insert Sheet dialog.

Another choice, with a little more

power, is to create named ranges

of the data you need to link to your

new sheet. You can do this through

the Navigator as we did with the

web data, but there is another

method for inserting through the

External Data dialog.

DIFFERENCE BETWEEN
INSERT AND LINK

Since our main topic concerns

linking data from other sheets, you

need to know the difference

between inserting a sheet and

linking a sheet. When a sheet is

inserted, you can change the cells

in both sheets and changes in one

will not affect the other. However,

when you create a link in sheet 2 to

sheet 1 , changes to cells in sheet 1

will override changes in sheet 2

when sheet 2 is updated. Changes

in sheet 2 have no effect on sheet

1 .

LINK/ INSERT WHOLE SHEET

Sometimes, you just need the

entire sheet from a spreadsheet

file in your new spreadsheet file. If

you want to make changes to the

sheet, and have those changes

stay, you will need to import the

sheet. However, if you need any

changes to the original sheet to

apply to the new sheet also, you

need to create a link. From the

menus, Insert > Sheet will bring up

the Insert Sheet dialog.

You have two choices for the

position of the new sheet within

the spreadsheet file. You can place

it before or after the currently

selected sheet. The Position

options allows you to select where

you want the imported / linked /

new sheet(s) located.

You have the choice of creating

new blank sheet(s) or select an

existing sheet from another file.

The settings under “New Sheet”

allows you to create one or more

new blank sheets. The settings

under “From sheet” let you import,

and optionally link, a sheet from

another file.

For the “New sheet” options,

you can specify a number of sheets

to add and a name for the sheet (if

you’re adding one sheet). If you are

creating more than one sheet, the

option for the name is grayed out.

The sheets are created with the

default sheet prefix and a numeric

iteration. You can set the default

sheet prefix in Tools > Options >

LibreOffice Calc > Defaults.

For the “From file” options, you

use the Browse button to locate

the file containing the sheet(s) you

want to import into your new
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spreadsheet file. Once you open

the file containing the sheets you

want to use, a list of sheets will

appear in the list box. Select the

sheet(s) you want in your new file.

To select sequential sheets, click on

the first one, then hold SHIFT while

clicking on the last one. To select

non-sequential sheets, click on the

first one, then hold CTRL while

clicking on the others. Once you

have your sheets selected, you can

check the Link check box to link to

the sheet(s) rather than just import

a copy of them. Remember, when

linked, the data will update from

the original sheet.

Click the OK button to import /

create the sheets using the options

you have selected.

LINK PART OF A SHEET

When I showed you how to link

to data on the web, I used the

Navigator to link the data. Today, I

am going to show you another

method for linking data, but this

time we will link data from another

file rather than from the web.

When linking to just a section of

a sheet, you need a way to define

the section of the sheet you want

to link. This is done by creating a

named range. We discussed named

ranges back in part 42 (Full Circle

Magazine, issue 90). We will create

a named range in order to link to

that portion of the sheet.

For example, let's say you want

to link to just the top ten stocks

from the top 1 00 stocks we pulled

from the web last time. Open up

the 1 00 stocks file linked to the

data on the web. Select the range

A1 :H1 2. Insert > Name > Define.

The Define Name dialog will show.

Give the range a name like “Top1 0”.

Remember that the name cannot

contain spaces. The range should

fill in with the range you selected.

Leave the scope as “Document

(Global) .” Click the Add button, and

save the file.

Create a new spreadsheet file,

File > New > Spreadsheet. We will

use the External Data dialog

instead of the Navigator this time.

Insert > Link to External Data opens

the dialog. The drop-down list

shows a list of recent documents.

Select the top 1 00 stocks file. If the

document you need does not

appear in the drop-down list, you

can click on the ellipse (…) button

to browse to and select the file.

Once you select your file, the
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named ranges appear in the list

box. Select the named range

Top1 0 from the stocks file to link

to the top 1 0 stocks. You can set

how often the file should update

when open by setting the “Update

every” field. Keep in mind the

number is in seconds.

Click OK and you now have a

link to the top 1 0 stocks. The data

will update from the original sheet

every time you open the file or at

the specified update interval.

You can link to a web page

using the External Data dialog as

well. Just type in or paste the URL

into the drop down box and press

enter. You will get the import data

dialog discussed in the last article.

You will get a list of link names.

Unlike the Navigator method,

there is no way to preview which

element is the one you need. It

becomes a matter of trial and error

(mostly error). This is why I

recommended the Navigator

method as the best for linking to

web data.

You can also use the Navigator

to link to named ranges in other

documents. Just drag the ranged

range into your new document.

Not only can we link to data on

the web, but we can also link to

data in other Calc files. We can

import or link entire sheets using

the Insert Sheet dialog. If we need

just a portion of a sheet, we can

create a named range in the

original sheet. In a new sheet, we

can link to the named range in the

original sheet through the External

Data dialog. Always keep in mind

the difference between linking and

importing. Imported data is not

affected by changes in the original,

but linked data is affected by

changes in the original.

http://eeperry.wordpress.com
http://goo.gl/DPt2q0
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I
n next month's article, I will

discuss the use of macros as

functions, but before I do, I

must discuss macro security.

While macros are a powerful tool

when used properly, macros can

contain code that is harmful to the

data on your computer. Through

the years, documents with macros

have been the transfer method for

many computer viruses. With a

little caution and a few settings,

you can minimize the chances of

your computer getting a virus from

document macros.

SECURITY LEVELS

Open the macro security

settings through the menus: Tools

> Options > Security > Macro

Security (button). LibreOffice has

four different macro security levels

that cover security – from no

restrictions to highly restrictive.

Each level has its merits. Let's look

at each one in detail.

Low: This is the “Off” level. All

macros are executed without

prompting. They can run without

you knowing, and they can damage

your files and settings. It's like

walking through a snake pit in your

bare feet: you will get bitten. The

only way this level would ever

make sense is on a computer that is

completely isolated from the

Internet and never opens a file that

was not created on that computer.

Not very likely.

Medium : This level is the “Are

you sure?” level. With medium level

protection, the document will run

macros if it comes from one of the

trusted sources, discussed below,

without any prompting. If the

document is not from a trusted

source, LibreOffice will prompt you

about whether to run the macros in

the document. You have the

choice: Yes or No. I have

recommendations later about how

to make this decision.

High : This is the “hands off”

level. Only signed macros from a

trusted source, or macros from

trusted file locations, are allowed

to run. All others will have their

macros disabled. You have no

choice; you are never prompted.

This is a level where you don't want

the end users making the decisions,

but you want LibreOffice to make

the decision for them.

Very High : This is the

“paranoid” level. Only files from

trusted file locations can run

macros. Again, you are not

prompted or given a choice. If the

file doesn't come from a trusted

file location, the macros are

disabled. This is the most locked-

down, don't-trust-nobody level

there is. If you think the world is

out to steal your identity and know

all your secrets, you might be right,

and this is the level for you.

TRUSTED SOURCES

The Trusted Sources tab allows

you to identify the trusted sources
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for your documents.

Certificates: Certificates are

used to digitally sign documents.

Certificates come from a

certification authority. They are

usually used on web sites and

servers to authenticate the source.

The installation of certificates is

beyond the scope of this article,

but to digitally sign a macro, Tools

> Macros > Digital Signature.

File Locations: No matter what

level you use – except Low – I

recommend you define at least one

trusted file location. You need at

least one place where you can run

proven files with macros without

having to OK a prompt. Don't use a

location where you usually

download files from email or the

Internet. Use a location where you

collect and save documents you

need to keep. Sometimes, two or

three locations are helpful. Also,

make sure the location isn't too

general, like your home folder.

RECOMMENDATIONS

Never, ever use Low. No, I mean

NEVER. Don't try to argue that you

know what you are doing, and you

have a firewall, anti-virus, and

malware protection. Don't do it!

No. No Low level setting. Go there

now in your copy of LibreOffice

and change it to something else.

There. Now, don't you feel safer

already? Now, we can calmly

discuss the benefits of the other

levels.

Medium is my preferred setting.

While it protects you, you also get

the choice of making that decision

for yourself. I recommend this

setting for computers on your

home network. The setting gives

you protection, but does not take

away your right to make a choice.

If some computers are used by

students, you will want to educate

them on a good method for

making the decision for

documents from email and the

Internet. Later I will offer you a

method that I feel is useful.

High and Very High are best

reserved for office networks and

computers used by younger

students. Use these when you are

locking down a computer where

you want to limit the power of the

end user. I see this in my line of

work all the time. The company has

the user's computer limited in

what they can do to protect the

company's investment in the

computer and data. Sometimes,

this is set according to the

experience and necessity of the

users. If you are the network

administrator, you will need to

make this decision for each user.

As I said before, whatever level

you decide to use, I recommend at

least one trusted file location. In

fact, for the Very High setting, you

have no choice. Also, with file

locations, you can avoid the need

to sign the macros in every file

with a security certificate.

YOU ARE YOUR BEST TOOL

The most important virus

protection of all: the mushy gray

matter between your ears. If you

were not expecting a document to

contain macros, then, maybe, you

shouldn't allow the macros to run.

Follow your instincts that

developed in humans as a

protective measure. Be the



full circle magazine 1 41 Return to ContentsLibreOffice

Elmer Perry's history of working, and
programming, computers involves an
Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com

LIBREOFFICE - PART 49

FCM#1 00
SURVEY

The question is:

What are your most

loved/hated flavors and

releases?

Take the quick survey and we'll

publish the results in

FCM#1 00.

http://goo.gl/DPt2q0

skeptic! If you have a feeling that

something is not right, maybe

something is not right.

Take these steps when

receiving a new file. Open the file

from an untrusted file location, but

do not allow the macros to run.

Examine the macros in the

document. If you have any

questions about the macros, asks

the person who sent the

document. If they cannot give you

a satisfactory answer as to why the

macros are there, eliminate the

document. Chances are, they are

not your friend and do not have

your best interest in mind (or their

computer is infected with a virus).

Yes, this may all sound a little

paranoid, but better safe than

losing time and data. If the

document is clean (no macros) or

the sender gives you a satisfactory

reason for the macros, move the

document to a safe file location.

While macros are useful, people

also use them for malicious

purposes. LibreOffice provides you

with four different levels of

protection against malicious

macros. You should never use the

Low level setting, but the Medium

level is good for most home

computers and networks. High and

Very High are good in office

environments where you need to

control the end users interaction.

Always take precautions when

dealing with documents coming

from other people. Sometimes,

people unknowingly pass on

documents that contain malicious

code.

http://eeperry.wordpress.com
http://goo.gl/DPt2q0
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L
ibreOffice Calc has

hundreds of built-in

functions. They cover

mathematics, including

geometry, trigonometry, and

calculus; logical functions; cell

functions; and text functions. After

years of using Calc, I haven't had a

need I couldn't solve or a formula I

couldn't recreate using the

functions in Calc.

However, I am aware that the

day may come when I will need a

highly specialized function, a

function that does something that

the built-in functions can't, or

calculates an extremely

complicated formula. Luckily, Calc

allows you to use macros as

functions. You can create your own

functions and call them from within

a cell's formula. You can even pass

the values of cells or even cell

ranges to your functions.

CREATE USER-DEFINED
FUNCTIONS

In order to create user defined

functions, you first need a module

for storing the macros. Create a

new Calc file and save it as

MacroFunctions.ods. Open the

LibreOffice Basic Macros dialog:

Tools > Macros > Organize Macros

> LibreOffice Basic. In the Macro

From list box, select the name of

your file, MacroFunctions.ods. Click

New. In the New Module dialog,

give the module the name

UserFunctions and click OK.

LibreOffice will open your new

module in the LibreOffice Basic

IDE. The module automatically

defines a blank main subroutine.

You can leave it or delete it. The

choice is yours. You will not use it

in this case. The IDE is a mini

programming editor. As a built-in

macro editor in an office suite, it's

actually pretty good. There are

tools for testing and tracking

macros, but all that is beyond the

scope of today's discussion. In the

IDE, you will write your first

function. It is very simple. The

function just returns the number

five.

Function NumberFive()

NumberFive = 5

End Function

The first line is the function

definition. It begins with the word

“Function” showing it as a function

rather than a subroutine (Sub). The

main difference between a

function and subroutine is that a

function returns a value. Next is

the function name, NumberFive,

followed by parentheses. The

parentheses are required, even if

they are empty. The second line of

this function is the body of the

function. The body of a function

can contain any number of lines.

This function simply returns the

number 5. We return a value from a

function by setting the function

name (without the parentheses)

equal to the value we want to

return. Finally, we have the line

“End Function” which denotes the

end of the function. Once you have

the new function typed in, click the

save button.

To use the macro in our

spreadsheet, select a cell and type

=NumberFive()

When you press Enter, the

number 5 will appear in the cell

where you typed the formula that

uses the function name. You can

even use the function as part of a

bigger formula like

=2 + NumberFive() ­ 3

which should give you 4.

PASSING ARGUMENTS

Having a macro you created and
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can use in a formula is great. To

make a function really useful, you

need the ability to send data to the

function. You send data by the use

of arguments. You can use text,

numbers, cell references, and cell

ranges as arguments. First, you will

create a function which passes a

single argument whether a cell

reference or a value.

Function SqrIt(x)

If IsNumeric(x) Then

SqrIt = x * x

Else

SqrIt = 0.0

End If

End Function

The signature of your new

function is like the first one except

it has a variable x in the

parentheses. The x represents the

value you are passing to the

function. In the body of the

function, it checks x to make sure it

is a number. If it is a number, the

function multiplies x by itself and

returning the result. If x is not a

number, it returns 0.0.

You can use hard-coded

numbers as x when you use the

function:

=SqrIt(3)

=SqrIt(2.4)

Or you can reference cells as x:

=SqrIt(A1)

=SqrIt(B4)

Or as part of a larger formula:

=NumberFive() + SqrIt(C4)

By default in LibreOffice Basic,

arguments are passed by value.

When you pass a cell reference to a

function, the function does not

receive a reference to the actual

cell. Instead, the function receives

the value of the cell or the result of

its formula. If the cell A1 contains

the number 3, or a formula that

results in 3, the function SqrIt

receives the value 3 and not a

reference to A1 .

PASSING MULTIPLE VALUES

While passing one value to a

function is useful, sometimes you

need to pass multiple values. For

example, you create a function that

calculates the volume of a cuboid.

A simplistic version of this function

is represented by the function Vol

(shown below).

In Vol, you pass the three

needed values to calculate the

volume of the cuboid. The

parentheses contain three

variables separated by commas. In

the If statement, the function

checks whether each of the

variables is a number, and then if

they are, it returns the product of

the values. Otherwise, it returns

0.0.

We can use this function much

as we have the others.

=Vol(2, 3, 4)

=Vol(A1, A2, A3)

=Vol(SqrIt(A1), A2, A3)

=SqrIt(Vol(A1, A2, A3))

PASSING A CELL RANGE

So far you have passed single-

cell references to your functions,

but you might want to pass a cell

range rather than a single-cell

reference. A cell range is passed to

Basic functions as an array. An

array is a collection of values. Cell

ranges come across as

multidimensional arrays, i .e. x(Row,

Column). You can use a function

named IsArray to determine

whether the value being passed is

an array. The function SumIt

demonstrates the use of a cell

range reference. SumIt will accept

a single value or a cell range. If the

argument is a single value, it

returns the value. If the argument

is a cell range, it sums the values of

all the cells in the range. Code for

this is shown on the next page,

right hand side.

The body of the function

defines three variables, TheSum,

iRow, and iCol. iRow and iCol are

defined as Integers, which are

Function Vol(a, b, c)

If IsNumeric(a) AND IsNumeric(b) AND IsNumeric(c) Then

Vol = a * b * c

Else

Vol = 0.0

End If

End Function
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Function SumIt(x)

Dim TheSum as Double

Dim iRow as Integer

Dim iCol as Integer

TheSum = 0.0

If IsArray(x) Then

For iRow = LBound(x, 1) To UBound(x, 1)

For iCol = LBound(x, 2) To UBound(x, 2)

TheSum = TheSum + x(iRow, iCol)

Next

Next

Else

TheSum = x

End If

SumIt = TheSum

End Function

whole numbers, i .e. 1 , 2, 3. These

two variables are the row and

column placeholders. TheSum is

defined as a Double, which is a real,

floating point number, i .e. 2.34, and

will contain our running total.

TheSum is assigned an initial value

of 0.0.

You have only one argument in

your function definition, x. The user

could send a single value, single cell

reference, or a cell range. The

function tests for this using an If

statement. It uses the IsArray

function to check if x is an array. If

it is, SumIt sets up two loops. The

outer loop cycles through the row

lower-to-upper values. The inner

loop cycles through the column

lower-to-upper values. The lower

values are obtained through the

LBound function, and the upper

values are obtained through the

UBound function. Both functions

take a reference to the array, x, and

the dimension of the array, 1 or 2.

Remember, it references the values

through x(row, column). The row is

the first level, and the column is the

second level. In the middle of the

two loops, SumIt takes the current

sum, TheSum, and adds the value of

the current cell in the array to it,

x(iRow, iColumn). Once the first

row is complete and iColumn has

reached its UBound limit, the iRow

increases by one, and the inner

loop starts over again. This

procedure continues until both

iRow and iColumn have reached

their UBound limits. The two Next

statements end the two loops

once they reach the UBound limit

for their range. The Else statement

handles the case when x is not an

array but a single value. It sets

TheSum equal to the value of the

single argument.

Finally, the function returns the

value of TheSum.

This function allows you to

actually use a cell range as your

argument. You can also use a single

value or cell as the argument. You

can even use the function as part of

a bigger function.

=SumIt(A3:C6)

=SumIt(A1)

=SqrIt(SumIt(A1:A5))

While Calc provides you with

hundreds of functions for

manipulating the data in your

spreadsheets, you may occasionally

need a specialized function that is

not easily duplicated using the

functions built into Calc. Once you

create a function in Basic, you can

call it from a cell using a formula.

You can design your functions to

accept a single value, a cell

reference, or a cell range. This

allows you to create very versatile

functions.

http://eeperry.wordpress.com
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DDisk DDrive DDisaster

In Issue #80 of the magazine Ronnie
wrote:

WELCOME TO A PROPER ISSUE OF FULL

CIRCLE!

I
have to start this month

with an apology about the

state of the previous issue

(FCM#79). To cut a long

story short: I ran a dd command

without properly checking drive

letters, and completely

annihi lated my 1TB drive

partitions and lost al l my data.

Including, of course, the Scribus

fi le for FCM#79. Needless to

say, I 've written up an article on

how to backup your data and a

brief article on data recovery.

Take it from me, don't sit there

and think (l ike I did) that it' l l

never happen to you. It can!

In this compilation I have used

images of the pages from the

Issue 79 PDF as published. Here

are the raw text and images of

that article for those who might

wish to use them.

Appendix - 1 Part 32 (Issue #79) Content
LibreOffice Pt 32: Impress

Remote

by Elmer Perry

If you have ever given a

presentation, you know that

moving back to the computer to

advance your slides is a pain,

especially if, like me, you move

around a lot and actively engage

your audience. I recently

presented for a training session

at work and constantly wished I

had a remote. The Document

Foundation has provided a

solution in the Android

application Impress Remote.

Impress Remote allows you to

control your Impress

presentation from your Android

phone or tablet.

Impress Remote requires

LibreOffice version 4.0.1 or

greater, and a phone or tablet

running Android 2.3 or greater. If

you own a recent phone or tablet

and your Linux distribution is up

to date, you shouldn't have any

problem using the program.

Setup

We will need to make changes to

our LibreOffice Impress setup to

run the remote program. Start

by opening a new or existing

presentation. Then Tools >

Options > LibreOffice Impress >

General. Check “Enable Remote

Control”. Click OK. Tools >

Options > LibreOffice >

Advanced. Check “Enable

experimental features”. Click

OK. Restart LibreOffice and

open your presentation.

When we set up the remote

control app, we will need the IP

address of the computer running

LibreOffice. From a Linux

terminal prompt, the following

command should work for most

users:

ifconfig eth0

The information you need is on

the line that starts with “inet

addr:xxx.xxx.xxx.xxx”, where

xxx.xxx.xxx.xxx is the IP address

for your computer. Write this

address down and keep it for

later. You will need it when you

set up the remote app.

Now, we install the Impress

Remote app. From the Google

Play store, search for Impress

Remote, and install the app on

your phone or tablet. The first

time you open the app, you see

a mostly empty screen. Select

“Add WI-FI Computer Manually”.

Enter a name for the computer

and the IP of the computer.

Select Add. Select the computer

from the list and let it connect.

Back in Impress, Slide Show >

Impress Remote. Select your

remote device. Enter the code

given you by the app. Click

Select. In the remote app, click

“Start Presentation” to start the

presentation.
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If your computer has Bluetooth,

you can also connect by pairing

your phone with your computer.

Once you open the app, it will

scan for your device using

Bluetooth, and you can just

select your device from the list.

You still need to enable the

remote and experimental

options in LibreOffice.

[sidebar]NOTE: If you are

running a firewall on your

computer, you will need to open

TCP port 1 599 for

communications through WiFi.

Using Impress Remote App

The remote app is pretty basic,

but let's face it, the less

complicated the better when

you're giving a presentation. The

tool bar across the top has the

current time, which is handy

when your presentation needs

to start or end at certain times.

To the left of the time is the

view switcher, and to the right

of the time is the app menu.

Issue 79 Content

Once you start a presentation,

you get the slide scroll view of

your presentation. This view is

the most useful, because while

you are in scroll mode, you can

also see any notes you made for

the slide. While you can use your

finger to move between slides,

this is not the best method

unless you are just needing to

skip forward or move back in

your presentation several slides

at a time. The best, or designed,

way to move through your

presentation is with the volume

up and down buttons. The up

button moves forward in the

presentation, and the down

button moves backward in the

presentation.

Sometimes, you need to pause a

presentation and move your

audiences' attention from the

screen to something else.

Impress Remote gives you the

ability to blank the screen. In

the app menu, select “Blank

Screen”. Your presentation

screen will go blank. When you

are ready to return to the

presentation, just click “Return

to Slide”. The presentation will

pick up where you left off.

You can display your slides in

two different ways. One we

have seen already, the scroll

mode. The other is the list

mode. You can switch between

the two mode by selecting the

view switcher button. In the

scroll mode, you move quickly

to a slide by swiping with your

finger. To select a slide in list

view, you just select the slide.

This is practical only for fixed

slides. Any slides with

animations will require the use

of the volume up and down

buttons.



full circle magazine 1 47 Return to ContentsLibreOffice

http://fullcirclemagazine.org/scr

ibus-special-edition/
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If you select the clock, you have

the option of leaving it as the

current time or starting a

stopwatch. Select the

stopwatch to use it. You will get

a Start and Reset option. Press

Start to start the timer. The

timer will begin to count, and

the options will change to Pause

and Restart. Select Pause to

pause the timer, and Restart to

start over from 0.00. This is

handy for timing an activity or

working on your timing for your

presentation.

In the app menu, there is an

item for Options. The first

option is for using the volume

up and down buttons to control

the presentation. I can't think of

a good reason to uncheck this,

but I 'm guessing it is there

because someone had a reason.

The second option is for

enabling a wireless connection

between the phone and the

computer. This allows the app

to automatically search for

devices on the wireless network

that are running LibreOffice

Impress with the remote feature

turned on. Finally, the switch

computer option allows you to

switch to a different computer.

Conclusion

When giving a presentation, it is

nice to have mobility. The

Android app Impress Remote

gives you mobility by allowing

you to control your Impress

presentation from your Android

phone or tablet. The app is easy

to set up through Bluetooth or

WiFi. The interface is not

cluttered, making it easy to use

and control. Since the app was

developed by the same people

who develop LibreOffice, future

compatibility is almost assured.

Elmer Perry's history of working,

and programming, computers

involves an Apple I IE, adding

some Amiga, a generous helping

of DOS and Windows, a dash of

Unix, and blend well with Linux

and Ubuntu. He blogs at

http://eeperry.wordpress.com

http://fullcirclemagazine.org/scribus-special-edition/
http://fullcirclemagazine.org/2015/05/11/using-gimp-special-edition/
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