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I didn't have to work for very longin Calc before I needed to use

cell names to reference values in

different cells. This need was

followed by those same reference

names failing to do what I was

expecting from them. While

referencing cells is not

complicated, it sometimes requires

a little thought about what you're

trying to accomplish.

At its heart, there are two

reference types: relative and

absolute. Relative references refer

to a set of offsets from the current

cell. Absolute references refer to

the exact (or fixed) cell, column, or

row. With these two types we can

show references in four different

ways. Cell references can even

cross between sheets.

Sometime, you will need to

reference more than one cell. This

is done with cell ranges. You can

make a cell range relative or

absolute just like the cell

reference. You can even name a

cell range.

RELATIVE REFERENCES

A relative cell reference is a set

of offsets from the current cell. If

you put a reference to C4 in cell D6,

the reference is to the cell one

column to the left and two rows

up. If you copy this reference to

other cells, say D7, it will refer to

the cell C5, which is one column to

the left and two rows up from D7.

Let's create an example to clear

up any confusion. Create a new

Spreadsheet document. In the cells

B3 and B4 put the values 1 5 and 46.

In the cells C3 and C4 put in the

values 1 1 and 1 4. Select cell B5 and

enter the following formula (yes,

the equal sign [=] is necessary):

=B3+B4

When you press enter, it will

show a total of 61 , the sum of the

two values in B3 and B4. Now,

right-click B5 and copy. Select C5,

right-click, and paste. In C5 you get

the total 25, the sum of the two

values in C3 and C4. See how the

reference shifted to the new

column? Since we didn't change

rows, the row references stayed

the same. However, if we did, the

relative cell reference would have

shifted to accommodate the

change.

So, when we make a relative

reference, it will move positions,

keeping the same offsets, when

copied to a new location.

ABSOLUTE REFERENCES

An absolute cell reference is

fixed. If you make an absolute

reference to cell C1 , then no

matter where you copy that

reference, it always refers to C1 .

We create absolute references by

adding the dollar sign ($) before

the column or row we want to

remain absolute. For example $C$1

is an absolute reference to the cell

C1 .

Let's do another example to

illustrate absolute references.

Imagine we need to multiply a

group of numbers by a factor. In

cell D1 we put 0.75. This is our

factor. In D2, D3, and D4 we put 1 0,

20, and 30. In the E column, we will

put our calculations. In cell E2 put

the formula:

=D2*D1

This will give us the answer 7.5,

which is correct. However, if we

copy the formula in E2 to E3 and

E4, we get answers of 200 and 600,

which are wrong. If you look at the

copied formulas, the references

shifted. This is because we used a

relative reference. We do want the

first number to shift when we copy,

but we need D1 to stay fixed. Edit

the formula in E2 and change it to

=D2*$D$1

We still have the right answer in

E2. Now, copy the formula in E2 to

E3 and E4. We get the answers 1 5

and 22.5, which are the correct

answers. If you look at the copied

formulas in E3 and E4, you find the

reference to D1 remained fixed.

FOUR WAYS TO REFERENCE

CELLS

With this in mind, this gives us

four different ways we can

reference a cell. They are relative,

absolute, and two partially

absolute references.
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• D1 – Relative, from cell E3, it is

one column left and two rows up

• $D$1 – Absolute, from any

position references cell D1

• $D1 – Partially absolute, column D

is fixed but the row is relative

• D$1 – Partially absolute, column is

relative but the row is fixed to 1

REFERENCE CELL IN

ANOTHER SHEET

To reference a cell in another

sheet, we use dot notation to add

the sheet name to the reference.

For example, Sheet1 .A1 . This is

handy if you need to carry a

calculation or figure from one

sheet to another. To illustrate, we

will rename our current sheet, add

a new one, and create a reference

from one to the other.

Right-click on the tab for the

current sheet and select “Rename

Sheet.” When prompted, name the

sheet MyData and click OK. To

create a new sheet, click on the

plus (+) at the end of the sheet

tabs. Select cell A1 in the new

sheet. Type in

=MyData.E2

which will pick up the value of 7.5

from the cell E2 in the MyData

sheet.

NOTE: If the sheet name contains

spaces, surround the name with

single quotes, as in 'My Sheet'.C3.

Just like other references, the

reference to the sheet is absolute

or relative depending on whether

we put the dollar sign ($) in front

of it.

CELL RANGES

Sometimes, you need to

reference a group of cells rather

than just one. For such cases, we

use cell ranges. A cell range is

created by separating two cell

references with a colon (:) . The left

cell references the upper left

corner of the cell range, and the

right cell references the lower

right corner of the cell range. For

example A1 :C2 represents a range

of six cells: A1 , A2, B1 , B2, C1 , and

C2. However, the range can also

represent just one column or row

as in C2:C1 00 or B3:H3.

The same rules for relative and

absolute references apply to cell

ranges. You can create a full or

partial absolute reference. You can

even apply a range across sheets.

Let's say you need a cell range of

all the A1 cells on all the sheets

named Sheet1 through Sheet1 0.

You would use the cell range

Sheet1 .A1 :Sheet1 0.A1 .

For convenience, you can name

a range. To name a range, select a

range of cells in the sheet. Insert >

Names > Define brings up the

“Define Name” dialog. Give the

range a name. Keep in mind that

cell range names can contain only

letters, numbers, and underscore

(_). Note the use of absolute

references in the Range field. You

can adjust your range as needed,

manually or by clicking the range

button and selecting the range

with the mouse or cursor. The

Scope field allows you to define

whether the named range applies

to the entire document or just a

certain sheet. Click OK to save the

range with the new name.

Cell references and ranges are

fundamental when you begin to

work on more complex sheet

layouts, functions, and formulas in

Calc documents. Understanding

how relative and absolute

references work can save time and

prevent mistakes when copying

formulas and references. While

simple, incorrect use of references

can lead to the wrong answer.

Elmer Perry's history of working, and
programming, computers involves an
Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com

http://eeperry.wordpress.com
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Spreadsheets are good for

collecting data like

temperatures, stock prices, and

sports data. However, the data on

its own does us little good. We

need ways to analyze the data.

LibreOffice Calc provides us with

built-in functions to do this. In this

article, we will look at a few of the

simple statistical functions built

into Calc. This is not meant as a

thorough examination of all the

functions, but more an exercise to

get you comfortable using

functions.

IMPORTING THE DATA

For our data, I have collected a

few months worth of stock prices

on the mutual fund FFACX. You can

find the data at

http://pastebin.com/AeLcyM1 t.

The data is laid out as comma-

delimited plain text. Copy the data

from Pastebin. Make sure that you

copy from the ”Raw Paste Data”

text box. Create a new Calc

document. Right-click on cell A1

and select Paste. The Text Import

dialog will show. Under Separator

Options, select “Separated by” and

check Comma. Click OK. You now

have two columns of data, the date

and the price. Save the sheet.

CREATING A NAMED CELL

RANGE

Throughout this article we will

use the prices as our data range.

Since we will use the range several

times, we will name it to make the

references easier. Select all the

prices (cells B2:B82). The easiest

way to select all the cells is to type

the range B2:B82 into the cell

name box on the formula toolbar

and press Enter on the keyboard.

Insert > Names > Define, and the

“Define Name” dialog shows. Name

the range “Prices”. Notice the

absolute reference in the Range

text box ($Sheet1 .$B$2:$B$82).

Names apply to a specific group of

cells, so the reference is absolute.

Under the Scope, we will restrict

the use of this name to just Sheet1 .

Click Add to create the range

name.

Now, in any formula or function

where we use the name “Prices”, it

is the same as typing the cell range

$Sheet1 .$B$2:$B$82.

MAX AND MIN

The first two statistical

functions we will look at are MAX

and MIN. Both functions accept a

http://pastebin.com/AeLcyM1t
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list of values or range(s) . MAX

returns the maximum (or largest)

value in the list. MIN does just the

opposite, returning the minimum

(or smallest) value in the list.

Move your cursor to D4. Type in

“Highest.” In the cell E4, type in the

formula

=MAX(Prices)

You should get the result 1 4.1 6.

If you look through the list of

prices, you will discover this is the

largest number in the list.

In D5 put “Lowest.” The formula

for E5 is

=MIN(Prices)

The result is 1 3.57, the lowest

number in the list.

It is also possible to use these,

or any Calc function, as an operand

in a formula. For example, if we

wanted to know the difference

between the highest and lowest

price, we could use the formula

=MAX(Prices) – MIN(Prices)

in cell E6. In the formula, the

results of the functions are

calculated first. MAX(Prices)

becomes 1 4.1 6, and MIN(Prices)

becomes 1 3.57. Then the result of

1 4.1 6-1 3.57 is placed in the cell E6.

Place the text “Difference” in the

cell D6 as a label.

AVERAGE, MEDIAN,
AND MODE

In statistics there are many

ways to determine just what is the

typical value for a set of numbers.

Among these are the arithmetic

average, the median, and the

mode. The arithmetic average,

known to most people as simply

the average, is the sum of a series

of numbers divided by the number

of items in the series. In Calc we

use the AVERAGE function to get

the arithmetic average.

The median ranks the numbers

from the lowest to the highest. If

the number of items in the series is

an odd number, it takes the one in

the middle. If it is even, the median

is the arithmetic average of the

two center numbers. Calc uses the

MEDIAN function to calculate the

median for you.

Mode is the number that

repeats most often. If there is a tie,

it uses the smallest number. Calc

uses the MODE function to get the

mode for you.

We can see the results of these

three functions by putting the

following formulas in the cells E7,

E8, and E9.

=AVERAGE(Prices)

=MEDIAN(Prices)

=MODE(Prices)

You will notice that the results

are within a few hundredths of

each others. This is not true in all

cases. Numbers that are much

larger or much smaller than all the

others can affect the average. In

those cases, the mode or median

might better suit your needs for a

typical value.

The Calc statistical functions

help us to analyze the data in a Calc

spreadsheet. We touched on only a

few of the statistical functions.

Calc has over 70 statistical

functions. This is just one of many

categories of functions available to

us in Calc. You can get a list of all

the Calc functions in the help

documentation.

CONDITIONAL FORMATTING

In our data set, the top and

bottom are pretty close together,

so the average will work good for

us as the typical value for this data

set. We can use conditional

formatting to mark each of the

prices as either above or below the

average.

Start by selecting all the prices

in the B column (B2:B82). Since we

named the range B2:B82, a quick

way to select all the prices is by

using the drop down arrow for the

cell name box on the formula

toolbar and selecting the name

“Prices(Sheet1 ) .”

Format > Conditional

Formatting > Condition will bring

up the Conditional Formatting

dialog. Select “Cell value is” from

the left drop-down list. From the

drop-down list in the center, select

“less than.” Enter $E$7 in the text

box to the right. If you want to use

the median or mode for the
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EXTRA! EXTRA!
READ ALL ABOUT IT!

Our glorious news reporters

are now posting regular news

updates to the main Full Circle

site.

Click the NEWS link, in the site

menu at the top of the page,

and you'll see the news

headlines.

Alternatively, look on the right

side of any page on the site,

and you'll see the five latest

news posts.

Feel free to discuss the news

items. It's maybe something

that can spill back from the site

into the magazine. Enjoy!
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comparison, you can use $E$8 or

$E$9. We are using an absolute

reference here because we want to

reference the same cell regardless

of what row we are formatting.

For the Apply Style, select “New

Style” from the drop-down list. The

Cell Style dialog will open. On the

Organizer tab, name the style

“Below Average.” Switch to the

Background tab and select the Red

color swatch. Click OK to close the

dialog and save the new style. You

will see “Below Average” is now

selected as the Apply Style.

Click Add to add a second

condition. This time select “greater

than” instead of “less than.” Use

the same absolute reference, $E$7,

$E$8, or $E$9, as you used in the

less than condition. Once again

select “New Style” for the Apply

Style. Give the new style the name

“Above Average”, and make the

background green instead of red.

OK to save the new style.

OK in the Conditional

Formatting dialog will save the

settings. Prices that are over the

average will highlight in green, and

the prices below the average will

highlight in red.

NOTE: You can create your style

for conditional formatting before

creating the condition. In such a

case, you would just select the

style to use.

I hope this article has helped

you to understand the use of the

statistical functions demonstrated

and functions in general. We saw

how to use named ranges to

identify cell ranges being used

repeatedly. We used functions by

themselves and as operands in a

formula. Using conditional

formatting, we highlighted certain

cells to show visually the status of

the cell's value. This eliminates the

need to scroll back up the sheet to

check the average value. Until next

month, look up some functions in

the help and put them to work for

you. Also, play with some of the

features of the conditional

formatting and see what other

visuals you can create.

Next time, I will show you how

to validate cell values.

http://eeperry.wordpress.com
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When you begin to create

formulas in Calc, you soon

realize that the wrong kind of data

in a cell referenced by your formula

can throw the results off. Calc does

its best to interpret the data

entered according to the

formatting style of the cell. If you

format the cell as a date type, Calc

does its best to translate the input

in that cell as a date. At times it is

successful and other times not.

Fortunately, Calc comes with

validity options built in to help you

design your spreadsheet in such a

way as to give the user help with

the input or even force them to

enter the data type needed for the

cell. In this article, we will look at

the validity options and its

capabilities.

SHEET SETUP

Before we get to the validity

options of Calc, we need to set up

a spreadsheet where we will use

the options. The spreadsheet is a

time sheet for showing the hours

worked during a week. The time

sheet works well for our example

because on a given day, the next

time input must have a greater

value than the previous entry.

We will start by creating our

title and column headers. In cell A1 ,

enter “Time Sheet”. On row 2, fill in

columns A-F with the following

titles: DAY, IN, OUT, IN, OUT,

TOTALS. Now for the row headers.

In cell A3, type in “Sunday”. Making

sure that cell A3 is highlighted,

click on the small square in the

lower right corner of the

highlighted cell. The cursor will

become a crosshair. Drag down to

A9. When you release mouse

button, the rest of the weekday

names are filled in. This happens

because the days of the week are

one of the default sort lists. You

can see all the lists and add your

own at Tools > Options >

LibreOffice Calc > Sort Lists.

Now let's format the cells.

Select B3:E9, right-click, and select

Format Cells. Click the Numbers

tab. From the Category list box,

select Time. If you normally use a

1 2-hour clock, select the “01 :37

PM” option under format.

However, for a 24-hour clock,

select “1 3:37.” Click OK to save the

options. Column F is the totals. We

will need to select a time format, at

least for the last one, that can go

beyond 24 hours. Select cells

F3:F1 0, right-click, select Format

Cells. Again, on the Numbers tab,

select the Time category, but for

the format, select “87661 3:37.”

This will allow for totals that are

greater than 24 hours. Click OK to

save the settings.

If you haven't yet, you might

want to save your sheet.

SETUP VALIDATION

We will need to check the

validity of the time inputs. We will

want them in a Calc-acceptable

time format. This is the only

requirement for valid data in the B

column. For the other columns (C-

E), we will need to also make sure

the input is greater than the input

before it.



full circle magazine #92 1 5 contents ^

HOWTO - LIBREOFFICE

Select cell B3, then Data >

Validity. The Validity dialog will

appear.

The Criteria tab (above) is

where we control what constitutes

valid data. The Allow drop-down

list defines the type of data that is

acceptable. The default is All

Values. The other types are Whole

Numbers, Decimal, Date, Time, Cell

Range, List, and Text Length. The

choices for the different types are

basically the same except for Cell

Range and List. With the cell

Range, you define a cell range and

the cell must contain a value that is

in one of those cells. The defined

range must consist of only one

column or one row. With the List

option, you define a list of

acceptable values. With both the

List and Cell Range options, you

get a drop-down list box with the

acceptable values. For our

purposes, we need Allow set to

Time.

Check the box for “Allow empty

cells” to allow cells to remain

empty. This will allow us to start

with a blank time sheet.

The Data drop-down list allows

you to select the comparative

operator to use for this validation.

The choices are equal, less than,

greater than, less than or equal to,

greater than or equal to, not equal,

valid range, and invalid range. Each

one asks for a minimum, maximum,

or value to compare, except for the

two range choices. The range

choices require a minimum and

maximum. For our purpose, we

need the greater than operator. In

the minimum text box, enter 1 2:00

AM or 00:00.

Click on the Input Help tab

(below). The settings on this tab

are optional. The idea is to provide

the user with information about

what to enter into the cell as a tip

box that pops up when the cell is

selected. To activate, click the

checkbox for “Show input help

when cell is selected.” Create a

title for the tip box by typing it in

the Title text box. For us, we could

use the title “Start Time”. The Input

Help text box is where you put the

actual help tip like “Enter the start

time: ex. 1 :00 PM or 1 3:00”.

Switch to the Error Alert tab

(above). Here we can set the

validation to display a message

when invalid data is entered. To

activate the setting, check the

checkbox for “Show error message

when invalid values are entered”.

There are four choices for the

Action drop-down list, Stop,

Information, Warning, and Macro.

Stop, the one we will use, prompts

with a dialog and rejects the input
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when invalid data is entered. For

Information and Warning, they

prompt with a dialog containing

OK and Cancel buttons when

invalid data is entered. If the user

clicks OK, the input is left as it is. If

the user clicks Cancel, the input is

rejected. Macro will allow you to

select a macro to run when invalid

data is entered. The Title and Error

Message is the title and message

for the dialog box. We could set

them to “Invalid Time” and “Enter

in time format: 1 3:00 or 1 :00 PM”.

Once you have everything set,

click OK to save the Validity dialog

settings.

We will copy cell B3 to cells

B4:B9. Right-click cell B3 and select

Copy. Select cells B4:B9, right-click,

and select Paste. This will copy the

validity settings to the cells. The

whole column will have the same

requirements for input.

For columns C, D, and E, we will

do almost the same thing. We will

go through the steps on C, and you

can repeat for D and E. Select cell

C3, Data > Validity. On the Criteria

tab of the Validity dialog, select

Time from the Allow drop-down

list. Check to allow empty cells. Set

Data to greater than, and set the

minimum value to B3. Notice that

we use a relative cell reference

here. This will allow us to copy it to

the other cells and have the

reference translate. These criteria

tell Calc that the cell requires a

value greater than the value in cell

B3. Do what you want with the

help and error tabs. I do

recommend using at least

Information or Warning messages

for invalid data. The messages

could mention needing a greater

value (or a later time). Right-click

cell C3 and copy the cell, then

paste it into cells C4:C9.

You can repeat for columns D

and E. You can also just copy C3 to

D3:D9 and E3:E9, but you will need

to adjust the text in the dialogs for

help and error.

TOTAL FORMULAS

Now that we have our

validation set up, we need to

create the formulas to give us our

totals. We will start with the daily

totals. Select cell F3. Enter the

formula

=(C3-B3)+(E3-D3)

which will give us the total for

Sunday's times. Right-click F3 and

Copy. Select cells F4:F9, right-click,

and Paste.

For the weekly total in F1 0, we

will just sum the daily totals. Here

is the formula:

=SUM(F3:F9)

PROTECT CELLS

Once you have a sheet set up

the way you like, you may want to

protect the parts of the sheet you

don't want changed like the labels

and formulas. First, you need to tell

Calc whether the cell is protected

or not. Then you add protection to

the sheet or document once

everything is finished. In the case

of our time sheet, we need to

protect everything except for the

cells where the user enters their

times, B3:E9.

By default, the Protect option is

turned on for all cells. To change

the protection setting for the input

cells, select B3:B9, Format > Cells,

and the Format Cells dialog

appears. Click on the Cell

Protection tab and uncheck

Protected.

At this point, you can still edit

any cell because the sheet or

document is not protected. To turn

on protection for the sheet or

document, Tools > Protect

Document > Sheet (or Document).

The Protect Sheet or Protect

Document dialog will appear

depending on which option you

selected. Enter and confirm a

password in the dialog. The options

will allow you to check whether the

user can select protected or

unprotected cells. If you do not

enter a password, then no

password is required to remove

protection from the sheet or

document.

To remove protection from a

sheet or document, Tools > Protect

Document > Sheet (or Document).

If a password was used when

protection was set, enter the

password used to protect the

sheet or document.
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MARK INVALID DATA WITH

DETECTIVE

If you selected Warning or

Information from the Action drop-

down list in the Validity dialog, a

user could enter invalid data and

click OK to keep the invalid input.

This may generate strange results

in your totals or an error. Tools >

Detective > Mark Invalid Data will

mark the invalid data. Once the

user corrects the data, Tools >

Detective > Mark Invalid Data

should clear the marks, unless the

data is still invalid. Notice from my

sample that invalid data can cause

other cells data to show as invalid.

The Calc Validity options are a

great way to set up sheets for use

by other people, or to keep you

from entering invalid data on a

complicated sheet. You can set it

up to reject the invalid data

outright, or for the user to make a

choice about keeping the input.

Once you have the sheet set the

way you want it, you can protect

the sheet from unwanted changes.

This is a good way to protect

formulas and labels. Finally, the

Detective tool allows the user to

mark invalid data they entered.

http://eeperry.wordpress.com
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I n my last article, I showed youhow to use the Mark Invalid Data

tool in Calc's Detective tools. This

time, I am going to discuss the rest

of the tools in the Detective menu

that help us trace the cells used in

formulas. Through these tools, we

can learn what cells affect the

result of a formula, what formulas

a cell affects, and what cells are

involved in a formula that results in

an error. The sheet we will use is

small to help you understand how

they work, but these tools are

most helpful in a large sheets with

complicated formulas.

SETTING UP THE SHEET

Create a new, blank sheet. In

cell A1 , enter the value 1 3. Select

cells A1 :A6. Edit > Fill > Series to

bring up the Fill Series dialog. For

the Direction, select Down, and for

the Series type, select AutoFill.

Click OK, and the cells are filled

with sequential numbers. Select

cells A1 :D6. Edit > Fill > Series. This

time, select Right for the Direction,

but again select AutoFill for the

Series type. Click OK and the cells

to the right are filled with

sequential numbers.

Create totals for the rows and

columns by selecting the blank cell

at the end of the row or column.

Click the SUM button on the

formula toolbar. The cells to the

left for rows, and above for the

columns, are automatically

selected. Press the Enter / Return

key on the keyboard to accept the

results. Repeat for each of the

rows and columns.

Cell E7 will sum the totals of

both the rows and the columns.

The formula is

=SUM(A7:D7,E1:E6)

TRACE PRECEDENTS

The Trace Precedents function

(bottom right) shows the cells used

by the formula in the current cell.

Traces are displayed on the sheet

with blue arrows and blue frames

around cell ranges. This is true for

all the trace functions.

Select cell E7. Tools > Detective

> Trace Precedents. Blue arrows

and frames show the cells used by

the formula. If you entered the

formula correctly, this includes all

the totals for the rows and

columns. To clear the trace

markings off the sheet, select

Tools > Detective > Remove

Precedents.

TRACE DEPENDENTS

Trace Dependents (next page,

top left) draws arrows to the cells

containing formulas that rely on

the currently active cell. If you

select C4 then Tools > Detective >

Trace Dependents, you get arrows

pointing to C7 and E4. Both of

these cells contains formulas that

reference C4 in their range. Just as

with the Trace Precedents, the

ranges of the two formulas are

surrounded by a blue box. To clear

the trace markers, Tools >

Detective > Remove Dependents.

COMMON CALC ERRORS

Before we talk about Trace

Error, let's take a quick look at
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some common errors you will see

in Calc.

#DIV0! – The formula is trying to

divide a number by zero. As we

learned in elementary mathematics

a long time ago, you can't divide a

number by nothing. Some

functions, like VARP and STDEV,

will give this error when you fail to

use the minimum required

arguments.

#REF – The cell or range reference

is invalid. This mostly happens

when you mistype your reference

or you reference a cell or range

that no longer exists. For example

you have a reference to a sheet

that has been deleted.

#VALUE – The input was a type

other than what was expected. This

is often caused by referencing a

cell with text in a mathematical

function or formula.

Err:51 0 – A variable is missing from

the formula. This can happen when

you type two operators together,

like =1 +* 3.

TRACE ERROR

Trace Error draws trace arrows

to all the precedent cells which

caused an error in the currently

selected cell's formula. To

demonstrate this, we will need to

generate an error. #DIV0 is

probably the easiest to generate.

Enter the formula =C3-D2 in cell

E8. The result is zero. In cell E9

enter the formula =E7/E9. This will

generate a #DIV0 error.

To trace the error, select cell E9.

Tools > Detective > Trace Error. A

trace arrow is drawn through the

cells involved in the formula. In our

case, it is just two cells. You can

change the minus to a plus and the

arrow will clear and the error will

go away, but for now, let's leave it

the way it is. I have one more thing

I want to show you. The only way

to clear an error trace without

correcting the error is Tools >

Detective > Remove All Traces.

COMBINING TRACES

Tracking down a problem or an

error is not always as simple as just

using one of the trace tools. You

might need to combine them to

find the real issue. Let's take our

error for example. We can select

the cell E9, and run the error trace,

and see that the formula uses the

two cells above it. However, once

you realize that both cells contain

formulas as well, you can trace the

precedents on cell E8 to see if you

can find the problem. You then

realize that the two cells used in

the formula are the same value.

Then it hits you; you meant to use

C6 – not C3. Change C3 to C6 in the

formula in E8, and the error and

the error trace arrow go away. Also

note that the precedents traces

move with the change of the

formula.

With the detective's trace tools

in Calc, you can trace the cells used

in a formula and determine why

you didn't get the results you

expected. Trace Precedents shows

you the cells used by the formula in

the current cell. Use Trace

Dependents to show the cells

containing formulas that use the

currently selected cell. If you are

trying to determine why a formula

is generating an error in the

current cell, you use the Trace

Error tool. Finally, you can combine

the different trace tools to get a

broader view of what is happening,

or not happening, in your sheet.
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I n past articles, I have discussedand used functions to illustrate

other functionality in Calc, but

today, I am going to show you

three different ways to enter

functions. I ' ll show you the

structure of a function; we will

create data for a spreadsheet; then

I will apply each of the input

methods: Function Wizard,

Function List, and manual entry.

STRUCTURE OF A FUNCTION

I t helps to understand the

structure of functions if you plan

to use them. I will use the

following function for my

discussion of function structure:

=PRODUCT(B5, A1:A6, 0.25)

Functions are always a part of a

formula. When you use any

formula or function, it must begin

with an equals sign (=). If you use

multiple functions, the equals sign

is required only at the beginning.

The start of a function is the

function name. By tradition,

function names are entered in all

upper-case letters, but Calc will

recognize them in lower or mixed

case letters. Keeping with the

tradition, I usually enter function

names in all capitals. The name of

our function in the example is

PRODUCT. PRODUCT is to

multiplication what SUM is to

addition, it multiplies all its

arguments into a final total.

After the function name is the

argument list, separated by

commas, and surrounded by

parenthesis. This is the (B5, A1 :A6,

0.25) part of our sample function.

Arguments can come in several

forms, and the function will usually

expect a certain type in each

position of the arguments.

Arguments can take the form of

numbers (9) , “Quoted text”, cell

reference (C3), cell range (C3:C1 0),

comparisons (C3 > C1 ), or another

function. Note that quotes around

a number, “9”, defines the

argument as text – and not a

number.

SETTING UP THE SHEET

I work with installers of

controlled access systems. When

setting up a new system, it is

necessary to calculate how many

power supplies are needed in

order to power the equipment for

the site. We use a formula for

calculating the voltage drop at

each device. The calculation

involves the input voltage, the

current draw of the device plus the

current draw of any devices after

it, multiplied by the resistance of

the length of wire to the device.

The basic formula is

Vout = Vin – I(DR)

where Vin is the input voltage, I

is the current draw of the device

and any devices after it, D is the

length of wire (in feet) , and R is the

resistance of the wire per foot.

Let's set up a sheet to help us

calculate the voltage at each

device.

Start with the label “Start Volts”

in cell A1 . In cells A2:E2 put the

following column headings: Device,

Amps, Distance, Ohms/Foot, and

Voltage. In cell B1 put 1 3.2 for your

starting voltage. In A3:A5 put 1 , 2,

3 for the devices. B3:B5 are the

current draw for each device. Use

0.3, 0.25, and 0.5. The three

distances for the wire are 75, 1 1 0,

and 1 20. For the Ohms/Foot, use

0.00639 for all three. This is the

approximate Ohms per foot for 1 6

AWG (US). Leave the Voltage

column blank. This is where we will

enter our formulas.

FUNCTION WIZARD

The function wizard is the most

complete method for entering

formulas with functions. It is also

the slowest because of the many

options. The wizard is a great way
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to work through the set up of a

complicated formula by allowing

you to deal with individual pieces

of information one at a time. We

will use the wizard to create the

voltage formula for the first

device.

There are three ways to access

the Function Wizard. Select cell E3

and do one of the following:

• Click the Function

Wizard button on the

formula toolbar.

• Insert > Function...

• CTRL + F2

The Function Wizard displays a

function list box to the left. The

Category drop-down list allows

you to narrow the functions in the

list to the selected category. There

is also a Last Used category for

selecting recently used functions.

If you single-click on a function

name, it displays a short

description of the function to the

right. When you double-click on a

function, it inserts the function

into the formula text box on the

bottom right. Notice that the

wizard has already inserted the

equals sign for you. The right

center displays text boxes for

entering the arguments for the

function. Above the argument

boxes, it displays the short

description and a list of the

arguments and their type. The top

right shows the results of the

current formula and the formula

result is displayed above the

formula edit box.

Our formula starts with the

voltage coming into the device. For

the first device this is 1 3.2 from

cell B1 , so click into the formula

text box at the bottom and type

“B1 -”. From the category drop

down list select Mathematical.

Scroll down the list and double-

click PRODUCT. The PRODUCT

function is added to the formula.

Click into the Number 1 text

box. The first argument is the sum

of all the amps for all the devices.

Click on the Function Wizard

button to the left of the Number 1

text box. This gives you a blank

function wizard screen. Note that

you now have Back and Next

buttons at the bottom. Select

Mathematical from the category

list, but this time double-click the

SUM function. Click into the

Number 1 text box. Use your

mouse to select cells B3:B5. The

range is added to the Number 1

text box for SUM.

Click Back twice to return to the

PRODUCT function we started

with. Notice that the SUM function

is now in the Number 1 text box.

Select the Number 2 text box.

Double-click on PRODUCT again. In

the Number 1 text box for the

second PRODUCT function, enter

or select the range C3:D3.

We are now finished with our

formula. The final formula should

look like

=B1-
PRODUCT(SUM(B3:B5),PRODUCT(C3
:D3))

Click OK to finish the wizard.

NOTE: I could have used the

multiplication operator (*) to

accomplish the same thing in the

PRODUCT function, but I used the

function in order to illustrate the

ability to use functions as

arguments to other functions.

FUNCTION LIST

The Function List is the wizard

without the bells and whistles. In

fact, it is just the function list

portion of the wizard. The idea

behind it is to help you in adding

functions directly into the cells.
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You can bring up the Function List

by using the menus, Insert >

Function List, or by clicking the

Functions icon in the sidebar. When

you select a function name in the

list, a short description appears at

the bottom of the list. The

Function List also has a category

item called Last Used, containing a

list of the functions you have used

recently.

Let's use it to create the

formula for the second device.

Select the cell E4. Select the Input

Line text box on the function

toolbar. This is the best place to

enter functions using the function

list. For this device, we need the

ending voltage of the previous

one, so start the formula with

“=E3-”. You should see PRODUCT

listed on your Last Used list.

Double-click PRODUCT to add it to

the formula. With the cursor

between the parenthesis, double-

click SUM, which should also show

in the Last Used list. Select cell

range B4:B5. Click into the formula

and use the arrow keys to move

the cursor outside SUM's

parenthesis. Type a comma then

double-click PRODUCT again. Type

in or select the range C4:D4. Press

Enter.

The final result should look like

=E3-
PRODUCT(SUM(B4:B5),PRODUCT(C4
:D4))

MANUAL ENTRY

Manual entry is just that, typing

the formula directly into the cell

from memory. The formula for the

last device is the easiest because

you no longer need the sum of

device currents because it is the

only one left. Select cell E5 and

type in

=E4-PRODUCT(B5,
PRODUCT(C5:D5))

and press Enter. While you are

typing in the functions, Calc will

show you a hint balloon of the

function and its arguments.

Calc gives you three different

methods for entering functions

into a cell. Use the Function Wizard

when you need as much guidance

as possible, or when entering a

complicated formula for the first

time. The Function List gives you a

list and short descriptions to aid

you in using the correct arguments

and functions in your formula. The

manual method is great for

entering short formulas, using

functions you are familiar with, or

repeating a formula you have used

before.

http://eeperry.wordpress.com
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Spreadsheets are a great place

to collect data. The web is a

great resource for data and much

of that data is dynamic. You may

even want to collect this data into

a spreadsheet and make the

spreadsheet mirror the dynamic

nature of the web data. Calc allows

us to link to external data sources,

including web pages, and it will

surprise you how easy it is.

Many people trade stocks.

Trading requires diligently tracking

the stocks. In the past, I have

shown this done manually, but

today, I am going to show you a

way to use a Calc spreadsheet to

track the top 1 00 stocks as

compiled by the web site

barchart.com.

Like so many things, there is

more than one way to do this. I 'm

going to show the method I feel is

the easiest for discovering and

getting exactly the information

you want. You will import the web

page using the Web Page Query

filter. Once imported, you can

examine the elements of the page

to find the data you want to

extract. You will then create your

sheet of 1 00 stocks by pulling from

your imported source file.

SETTING UP THE SOURCE
SHEET

When you import the source

using the Web Page Query filter,

you are not actually working with a

local copy, but a link to the page on

the Internet. You will not save this

import (but you could). Instead,

you are using it as a reference to

the actual page on the

barchart.com web site.

From the menus, File > Open. In

the Open dialog, you will find the

file type filter drop-down list at the

bottom of the dialog. All the

different file types recognized by

LibreOffice are listed here. Scroll

through and find the filter named

“Web Page Query (Calc)”. This will

help you create your link to the

web page. In the “File name” text

box, enter (or copy and paste) the

following URL:

http://www.barchart.com/stocks/si

gnals/top1 00

Click the Open button. Calc will

take a few seconds then come up

with the Import Options dialog.

The Automatic option will import

the web page “as is.” Custom

allows you to select another

language for importing the page. I

recommend using Automatic as it

has the greatest chance for proper

interpretation. The “Detect special

numbers (such as dates)” checkbox

does what you think it does. When

checked, it will detect dates, times,

etc, and format them appropriately

in the sheet. We do not have

special numbers we are concerned

about, so we don't need it. Click

OK to accept the options.

Depending on your Internet

connection, computer speed and

memory, Calc will take a few

seconds to import the web page.

Notice that it imports the entire

web page minus the images.

NOTE: This is a link to the actual

web page. Nothing has been saved

on your local computer at this

point.

http://www.barchart.com/stocks/signals/top100


full circle magazine #95 20 contents ^

HOWTO - LIBREOFFICE

THE NAVIGATOR

We will use the Navigator to

examine the imported page and

link the data to our new document.

The Navigator shows you the

elements and structure of a

document and changes depending

on the type of document you have

open. Not only is it good for our

purposes here, but for navigating

and manipulating a document,

especially a large document.

Currently, there are four ways to

open the Navigator:

• Press F5 on your keyboard

• View > Navigator

• Navigator tab on the sidebar

• Navigator button on the standard

toolbar

EXAMINE THE SOURCE

When a web page is imported,

several range-names are created,

as well as importing named tables

on the web page. The prefix

HTML_ is added to any names

imported from the page. The filter

creates two special ranges,

HTML_all and HTML_tables.

HTML_all allows you to select the

entire document. HTML_tables

allows you to select all the tables.

The problem you run up against is

the creator of the web page

probably wasn't thinking about

you importing his page into Calc.

Imported table names were for the

creator's reference not yours.

If you open the Navigator using

one of the methods listed above,

in our source document, you will

discover a list of names under the

“Range-names” item in the

Navigator. Double-click on a range-

name to highlight it in the

document. As you go through the

list, you soon discover that the

names HTML_4 and HTML_dt1

both contain the table with our

stock data. You will use one of

these to create your stocks

document.

IMPORT TABLE TO NEW
SHEET

Now that you know what range-

name to import for the stocks

data, it's time to create the sheet

you want to save and keep. You

will import from the source

document into a new document.

Remember that your source

document is just a link to the

actual web page, nothing has been

saved to your local computer yet.

From the menus, File > New >

Spreadsheet. Use any of the four

methods discussed above to open

the Navigator. From the

documents list at the bottom of

the Navigator window/panel,

select the source document,

top1 00. Click on the drag-mode

icon in the Navigator toolbar and

change the setting to “Insert as

link.” Expand the entries under the

“Range names.” Select either

HTML_4 or HTML_dt1 , drag it to

cell A1 in the new document, and

release. After a few seconds,

depending on your internet and

computer speeds, the stocks data

will appear in your new sheet. Save

the new document. You can now

close the source document. There

is no need to save it. Your new

document is actually linked to the

page on the web site and not the

source document.
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You can close your new

document, and when you open it,

you are prompted about whether

to update the links in the file. If

you answer Yes, Calc will retrieve a

fresh version of the page and

update the data in your sheet. You

can set the file to update

periodically when it is opened. In

the menus, Edit > Links brings up

the Edit Links dialog. With the link

selected, click on the Modify

button to bring up the External

Data dialog. Check the “Update

every...” check box, and fill in the

number of seconds between every

update. For example, every five

minutes is 300 seconds, ten

minutes is 600 seconds, and an

hour is 3,600 seconds. Click OK to

save your changes and Close to

close the Edit Link dialog.

Importing dynamic data from a

web page in Calc is pretty simple.

Use the Web Page Query filter to

link the page to a sheet. With the

Navigator, you can examine the

page to determine which range-

name contains the data you need.

Once you know the range you

need to use, you use the Navigator

to drag the range-name into a new

sheet and save the new document.

The new document will prompt

you to update every time you open

the document or periodically,

should you assign an update

period to it.

http://eeperry.wordpress.com
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Linking to data on the web is

often useful, but, sometimes

you need to just get data from a

sheet in another Calc file. You can

just import or link the whole sheet

from another file. You do this

through the Insert Sheet dialog.

Another choice, with a little more

power, is to create named ranges

of the data you need to link to

your new sheet. You can do this

through the Navigator as we did

with the web data, but there is

another method for inserting

through the External Data dialog.

DIFFERENCE BETWEEN

INSERT AND LINK

Since our main topic concerns

linking data from other sheets, you

need to know the difference

between inserting a sheet and

linking a sheet. When a sheet is

inserted, you can change the cells

in both sheets and changes in one

will not affect the other. However,

when you create a link in sheet 2 to

sheet 1 , changes to cells in sheet 1

will override changes in sheet 2

when sheet 2 is updated. Changes

in sheet 2 have no effect on sheet

1 .

LINK/ INSERT WHOLE SHEET

Sometimes, you just need the

entire sheet from a spreadsheet

file in your new spreadsheet file. If

you want to make changes to the

sheet, and have those changes

stay, you will need to import the

sheet. However, if you need any

changes to the original sheet to

apply to the new sheet also, you

need to create a link. From the

menus, Insert > Sheet will bring up

the Insert Sheet dialog.

You have two choices for the

position of the new sheet within

the spreadsheet file. You can place

it before or after the currently

selected sheet. The Position

options allows you to select where

you want the imported / linked /

new sheet(s) located.

You have the choice of creating

new blank sheet(s) or select an

existing sheet from another file.

The settings under “New Sheet”

allows you to create one or more

new blank sheets. The settings

under “From sheet” let you import,

and optionally link, a sheet from

another file.

For the “New sheet” options,

you can specify a number of sheets

to add and a name for the sheet (if

you’re adding one sheet). If you are

creating more than one sheet, the

option for the name is grayed out.

The sheets are created with the

default sheet prefix and a numeric

iteration. You can set the default

sheet prefix in Tools > Options >

LibreOffice Calc > Defaults.

For the “From file” options, you

use the Browse button to locate

the file containing the sheet(s) you

want to import into your new

spreadsheet file. Once you open
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the file containing the sheets you

want to use, a list of sheets will

appear in the list box. Select the

sheet(s) you want in your new file.

To select sequential sheets, click

on the first one, then hold SHIFT

while clicking on the last one. To

select non-sequential sheets, click

on the first one, then hold CTRL

while clicking on the others. Once

you have your sheets selected, you

can check the Link check box to

link to the sheet(s) rather than just

import a copy of them. Remember,

when linked, the data will update

from the original sheet.

Click the OK button to import /

create the sheets using the

options you have selected.

LINK PART OF A SHEET

When I showed you how to link

to data on the web, I used the

Navigator to link the data. Today, I

am going to show you another

method for linking data, but this

time we will link data from another

file rather than from the web.

When linking to just a section of

a sheet, you need a way to define

the section of the sheet you want

to link. This is done by creating a

named range. We discussed named

ranges back in part 42 (Full Circle

Magazine, issue 90). We will create

a named range in order to link to

that portion of the sheet.

For example, let's say you want

to link to just the top ten stocks

from the top 1 00 stocks we pulled

from the web last time. Open up

the 1 00 stocks file linked to the

data on the web. Select the range

A1 :H1 2. Insert > Name > Define.

The Define Name dialog will show.

Give the range a name like

“Top1 0”. Remember that the name

cannot contain spaces. The range

should fill in with the range you

selected. Leave the scope as

“Document (Global) .” Click the Add

button, and save the file.

Create a new spreadsheet file,

File > New > Spreadsheet. We will

use the External Data dialog

instead of the Navigator this time.

Insert > Link to External Data

opens the dialog. The drop-down

list shows a list of recent

documents. Select the top 1 00

stocks file. If the document you

need does not appear in the drop-

down list, you can click on the

ellipse (…) button to browse to

and select the file. Once you select

your file, the named ranges appear
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in the list box. Select the named

range Top1 0 from the stocks file to

link to the top 1 0 stocks. You can

set how often the file should

update when open by setting the

“Update every” field. Keep in mind

the number is in seconds.

Click OK and you now have a

link to the top 1 0 stocks. The data

will update from the original sheet

every time you open the file or at

the specified update interval.

You can link to a web page

using the External Data dialog as

well. Just type in or paste the URL

into the drop down box and press

enter. You will get the import data

dialog discussed in the last article.

You will get a list of link names.

Unlike the Navigator method,

there is no way to preview which

element is the one you need. It

becomes a matter of trial and error

(mostly error) . This is why I

recommended the Navigator

method as the best for linking to

web data.

You can also use the Navigator

to link to named ranges in other

documents. Just drag the ranged

range into your new document.

Not only can we link to data on

the web, but we can also link to

data in other Calc files. We can

import or link entire sheets using

the Insert Sheet dialog. If we need

just a portion of a sheet, we can

create a named range in the

original sheet. In a new sheet, we

can link to the named range in the

original sheet through the External

Data dialog. Always keep in mind

the difference between linking and

importing. Imported data is not

affected by changes in the original,

but linked data is affected by

changes in the original.

FCM#1 00
SURVEY

The question is:

What are your most

loved/hated flavors and

releases?

Take the quick survey and we'll

publish the results in

FCM#1 00.

http://goo.gl/DPt2q0

http://eeperry.wordpress.com
http://goo.gl/DPt2q0
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