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Collecting clip art for use in your

newsletter, spreadsheet,

presentation, or other document

can become a timely task.

Especially when it comes to

organizing – and later finding – the

image you want to use. LibreOffice

provides a built-in Gallery for

collecting and organizing images,

sounds, and videos. The Gallery

collects files into categories called

themes. You can add files from the

Gallery directly into your

document. Creating new themes

allows you to add your own files

into the collection.

THE GALLERY

You can access the Gallery in

three different ways, through the

menus (Tools > Gallery); by a

button on the standard toolbar;

and through a panel on the

experimental sidebar. By default,

the Gallery is docked under the

formatting toolbar. You can undock

and dock the Gallery with the

combination of CTRL + double-click

on the border of the Gallery. Use

the hide/show button on the lower

border to display and hide the

Gallery while it is docked. If you

hover over the lower border, your

mouse cursor will turn to a double

arrow, and you can resize the

docked Gallery's height.

On the left side of the Gallery is

the themes list. Selecting a theme

changes the files which display in

the main panel. The main panel

shows the files available in the

currently selected theme. Above

the main area are two buttons for

displaying the files – in tile or detail

view. Beside the buttons, it shows

the theme name, file name, and

path for the selected file.

USING THE GALLERY

The Gallery allows you to insert

a file as a copy, a link, or a

background. When you insert the

file as a copy, the file is embedded

into the current document and is

not reliant on another file. If you

insert the file as a link, a reference

to the file is created in the

document. If you opened a

document with linked files, the

files will show only if they are in

the location referenced in the

document. If the file needs to

travel among multiple computers,

insert a copy. If the document will

reside on only one computer, you

can safely insert a link.

To insert a copy of a file from

your Gallery into the document,

select the theme containing the

file and select the file. You can

then drag and drop the file into

your document, or right-click the

file and Insert > Copy.

To link a file from your Gallery

into a document, select the theme

and file. Hold down SHIFT + CTRL

while dragging and dropping the

file into the document, or right-

click then Insert > Link.

Sometimes, you will want to use

an image as the background for a

page or a paragraph. To set an

image as the background for a

page, select the theme and image.

Right-click the image and Insert >

Background > page. To set the

image as the background for the

current paragraph, right-click the

image and Insert > Background >

Paragraph.

MANAGING THE GALLERY

A nice feature of the Gallery is

the ability to add your own files to

the collection. You cannot,

however, add to, remove from, or

delete the default themes. In order

to add your own files to the

Gallery, you will have to create

your own themes. You add your

own theme by clicking on the “New
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Theme” button, which opens the

“New Theme” dialog. In the

“General” tab, enter the name for

your new theme. You can now add

files to your theme in the “Files”

tab or just click “OK” to save the

theme.

Adding files to the theme you

just created is easy. You can add

files one at a time by dragging and

dropping them into the main panel

with your theme selected. To

selectively add files or to add an

entire folder, right-click on the

theme title and click “Properties.”

A theme “Properties” dialog will

display. This is the same dialog you

get when adding a theme, so you

can use this method to add files

when you create a new theme.

Select the “Files” tab, then click

“Find Files.” Use the file dialog to

navigate to the folder containing

the file(s) you want, and click

“Select.” A list of files in the folder

will display in the list box. Use the

drop-down box above the list to

filter the files if needed. Take time

to scroll through the filter list to

get an idea of the many file

formats the Gallery accepts. For

image files, you can get a preview

by checking the “Preview” check

box. Once you find the file you

want, you can select it and click

“Add” to add it to the theme, or

click “Add All” to add all the files in

the list box.

You won't always add files to

the Gallery with the intention of

keeping them there indefinitely.

You may want to just add them

while working on a certain project.

Once the project is done and you

no longer need them, you will want

to delete the files and themes

created for the project. To delete a

file from a theme, right-click the

file and select “Delete.” You can

also delete a theme with all its files

by right-clicking the theme title

and selecting “Delete.” Keep in

mind that there is no undo for

these actions, and that deleting a

file from the Gallery does not

delete it from the computer, just

from the Gallery’s theme list.

LibreOffice provides a media

library called the Gallery. The

Gallery is divided in collections

called themes. You can add your

own themes and files to the

Gallery. If a file or theme is added

only for a certain project, you can

delete them when the project is

finished. The Gallery is available in

all modules of the suite, and helps

you to maintain consistency for

newsletters, spreadsheets,

presentations, databases, and

reports.

Elmer Perry's history of working, and
programming, computers involves an
Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com

http://eeperry.wordpress.com
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I f you work with Base longenough, you will run into a

situation where you need a table

structured a little differently, or

you’ll need the results of a query as

a table you can use. The answer to

these problems is ‘Views’. A view is

a query which acts like a table you

can use in other queries, forms, or

controls. Today, I will show you an

example of how this is useful when

creating forms.

OUR TABLES

We are going to create a simple

database with two tables. The

database will track projects for a

company and allow us to assign a

team member to each project.

Below is the structure of the tables

we will create.

Project Table
Field|Type|Properties
ID|Integer|Primary Key, Auto
Increment
Title|varchar(50)|Not Null
Description|varchar(250)
Due|Date
MemberID|Integer|foreign key

TeamMember Table
Field|Type|Properties
ID|Integer|Primary Key, Auto

Increment
FirstName|Varchar(25)|Not
Null
LastName|Varchar(25)|Not Null

Shown right is the SQL to create

the tables. Create a new database

document, then go to Tools > SQL,

and type the commands in by hand

or copy and paste.

You can also get the above SQL

commands on pastebin.com at

http://pastebin.com/Wyb3R5Fz.

The key to our task is the

foreign key “MemberID” in the

“Project” table, which connects to

the “TeamMember” table's “ID”

field. When we create our form we

will create a drop-down list for

selecting the team member who is

responsible for the project. Notice

that the “TeamMember” table

provides first and last name fields.

The list control allows us to use

only one field in the list. We could

display just the last name in the

drop-down list, but what if two

team members have the same last

name. We will solve this problem

by creating a view that will

combine the first and last name

into one field called “Name”. We

will use our view to populate the

drop-down list box.

If the tables do not show in your

table list after running the

commands, Review > Refresh Table

will populate the list.

CREATE QUERY / VIEW

To create our view, we will use a

two-step process. First, we create a

query, then convert the query into

a view. In our query, we combine

the first and last name fields to

create one field. We will also get

the “ID” field, as we will need it to

connect back to the “Project” table.

To create the query, we select

the “Queries” option in the

“Database” pane. In the “Actions”

pane, select “Create Query in SQL

View.” The follow SQL command

will create our query:

SELECT "FirstName" | | ' ' | |

"LastName" AS "Name",

"ID" FROM "TeamMember";

drop table "Project" if exists;
drop table "TeamMember" if exists;

create table "TeamMember" (
"ID" integer generated by default as identity

(start with 1) not null primary key,
"FirstName" varchar(25) not null,
"LastName" varchar(25) not null

);

create table "Project" (
"ID" integer generated by default as identity

(start with 1) not null primary key,
"Title" varchar(50) not null,
"Description" varchar(250),
"Due" date,
"Member" integer,
constraint FK_MEM foreign key ("Member")

references "TeamMember" ("ID")
);

http://pastebin.com/Wyb3R5Fz
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If you are familiar with SQL, this

looks like a standard query except

for the double pipe symbols “| | ”.

They are used to concatenate

strings together. In the command,

we select each “FirstName” and

join it to a space, then take the

result and join it to “LastName.”

Finally, we name this string

“Name.” We also get the “ID” as it

identifies each record. You can test

the query to make sure it works,

but at this point your results are

blank, but the query should run

without error. Save the query as

“QueryTeam”.

Turning the query into a view is

as simple as right-clicking the query

name and selecting “Create as

View.” Name the view “TeamView.”

If you select “Tables” under the

“Database” pane, you will see

“TeamView” listed under the

tables.

CREATE THE FORMS

We will create a team member

form and a project form for data

input. The team member form is

the easiest, so let's make it first.

Click on the “Forms” icon in the

“Database” pane and select “Use

Wizard to Create Form.” The form

wizard will display.

On the first screen, select

“Table: TeamMember” from the

drop-down box. Move the

“FirstName” and “LastName” fields

into the list box labeled “Fields in

the form.” Click the “Next >”

button. There is no subform so just

click “Next >” again. On step 5, use

any of the options for arranging

the controls except tabular. On

step 6, just accept the defaults.

With Step 7 pick a style that you

like. When you get to step 8, name

the form “TeamMemberForm” and

leave it on “Work with the form.”

When you click the “Finish” button,

the form will open for input. Add a

few names for testing the project

form when we finish it.

For the project form, we need

about the same thing, except use

“Table: Project” from the drop-

down in step 1 , and select all the

fields except for “ID” for inclusion

in the form. Name the form

“ProjectForm” and select “Modify

the form” on step 8. This time,

instead of the form opening for

input, it opens for editing.

When you create forms using

the form wizard, the wizard groups

a text box for most data types with

a label for each field. In order to

change the control for the data

field, you have to ungroup the text

box from the label. In our case, we

want to change the “Member”

field, so right-click the “Member”

label and text box and select Group

> Ungroup. Click on the form

background to unselect both.

Right-click on the text box and

select “Delete.” From the forms

toolbar, select the list box. If the

form toolbar is not showing then

View > Toolbars > Form Controls to

display it. Once you select the list

box, your cursor will become a

crosshair, +. Click and drag to

create the list drop-down box.

When you release the mouse

button the list box wizard will pop

up.

Select “TeamView” as your table

and click “Next >”. The field we

want to fill the list box is “Name”,

so select “Name” and click “Next

>”. Finally, we need to match the

fields from the two tables. For the

“Value Table” select “Member”.

“ID” is the field to select for “List

Table” as it is the primary key that

matches up with the “Member”

foreign key field in the “Project”

table.

Save your changes and close the

design window.

Now, if you entered names in

“TeamMemberForm”, you can open

the “ProjectForm” and those

names will appear in the drop-

down list box we created. You will

want to test creating several

projects and assigning members to

them to test the workability of

your forms.

In this article, we discussed the

use of a LibreOffice Base view to

create a new table from an existing

table. We used this view in the

construction of a form that

automated the retrieval and

selection of records from that

view.

Elmer Perry's history of working, and
programming, computers involves an
Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com

http://eeperry.wordpress.com
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I n my article in issue 83 of FullCircle Magazine, I walked you

through creating a form that used

a view, but I left things unfinished

in the forms: I didn't do anything to

format the controls to ensure data

integrity. If you haven't already

done so, read the article in Full

Circle 83, and follow along to

create the tables and forms. We

will work with the “ProjectForm,”

and see how we can improve data

integrity. I ' ll wait if you need to

work through the How-To in issue

83.

DATE AND TIME CONTROLS

Now let's get down to work. On

the “Forms” pane in the database

file you created, right-click the

“ProjectForm” and select “Edit”. As

I have said before, the wizard

usually joins a label with an input

box, but in the case of date and

time fields, it actually pairs them

up with date and time controls.

Without any formatting, they just

look like text input boxes, but trust

me, they are date and time

controls. We will need to ungroup

the control from its label in order

to work with the date control.

Right-click the “Due” label or date

control, then select Group >

Ungroup.

Double-click the date control to

bring up the control's properties

dialog. On the “General” tab, you

find all the adjustments you can

make to the control. We are

interested in the ones that create

adjustments for date entry.

Date Min / Date Max – These

two options allow you to control

the minimum and maximum date

values allowed in the fields. These

fields have default values of

01 /01 /1 800 for minimum and

1 2/31 /2200 for maximum. In

general applications, these

defaults should work, but if you

have different needs, feel free to

adjust. An example is an inventory

database, where no shipping

invoices dated before the inception

of the company is necessary. You

could set the minimum date to the

opening day.

Date Format – There are 1 2

different date formats. This option

determines how the control will

display the date. Scroll through the

options and see which one best

suits your application.

Default Date – This is a default

value for the field. If you have a

date that users should use most of

the time, then use that date. It will

speed up data entry. It can also

show the user the format in which

to enter dates. Unfortunately, at

this time, you cannot easily set the

default to the (current) date the

record was added.

Spin Button – Setting this

option to Yes will put an up-and-

down spin button on the control.

The user can use this button to

adjust the month, day, and year.

The user clicks into the part of the

date they want to adjust and

makes changes by clicking on these

buttons. Very handy for data entry.

Repeat – The Repeat option is

related to the spin button option. It

controls whether to repeat when

you hold down the mouse button

on the spin button. Use at your

own discretion. Sometimes, it

makes sense. Other times, not so

much.

Delay – The Delay option

controls the speed of the repeat

option. A longer delay means you

have to hold the button down

longer before it will repeat. The

default is “50 ms” (milliseconds).
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Dropdown – Dropdown adds a

listbox style arrow to the control.

Clicking it displays a calendar

where you can select the date you

need.

NOTE: You can use the Spin Button

and Dropdown options together to

create a flexible control.

After you make your

adjustments to the control, save

the form and close it. Open the

form and test your newly adjusted

date control. Feel free to

experiment with the different

control options to get a better idea

of how they work. The options for

a time control are the same as the

date control except you don't have

the Dropdown option.

MAKING THE TITLE

MANDATORY

Now that we have set up the

date control, let's tackle some

possible issues with the “Title”

field's input box. When we created

the field, we set its maximum

length at 50. However, as the input

box stands now, we can type more

than 50 characters into the box.

Trying to save the record with

more than 50 characters in “Title”

results in an SQL insert error. Also,

when we created the table, we

declared “Title” as “NOT NULL.” We

want to make the “Title” a

mandatory entry for each record.

The “NOT NULL” status prevents

the input box from being left

empty, but it is still possible to

type just a space and the form will

accept the entry as

valid. So, we have a few things to

fix in our form.

Open “ProjectForm” for editing.

Right-clicking the “Title” label or

input box, Group > Ungroup. Now,

double-click the “Title” input box

to bring up its properties dialog.

On the “General” tab, set the value

for “Max Length” to 50. This will

prevent the user from entering

more than 50 characters. On the

“Data” tab, make sure that both

“Empty String Is NULL” and “Input

Required” are set to “Yes.” These

two settings become a redundancy

check for making sure there is a

valid value in the input field.

However, we still have an issue

with the fact that the user can just

create a “Title” with spaces. To fix

this issue, we will need to use a

little SQL. I have looked for a

graphical way to get the same

result, but sometimes, when you

work with databases, SQL is the

best, if not only, choice. We will

add a CHECK constraint to the

“Project” table. Click on Tools >

SQL. To enter the SQL, Tools >

SQL... Use the following SQL

command to add the constraint to

the table:

ALTER TABLE “Project”

ADD CONSTRAINT NOSPACES_CK

CHECK(TRIM(BOTH FROM “Title”)
<> '');

The ALTER TABLE command

means we are making changes to

the table, in this case the table

“Project.” To indicate the change

we are making, we use the ADD

CONSTRAINT command.

NOSPACES_CK is the name of the

constraint we are adding. It's not
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required that you make your

constraint names all caps. I just do

it as a matter of convention. The

last line is the CHECK constraint.

Using the built-in function TRIM, it

removes all the spaces from both

sides of the string and checks to

make sure it is not equal to an

empty string. Now, if someone

tries to use a string of spaces for

the “Title”, an SQL constraint error

is generated.

You can do the same thing for

the “FirstName” and “LastName”

fields in the “TeamMember” table.

The “Max Length” for the name

fields is 25. I suggest the following

SQL for adding the constraints:

ALTER TABLE “TeamMember”

ADD CONSTRAINT
RNAME_NOSPACES_CK

CHECK(TRIM(BOTH FROM
“FirstName”) <> '');

ALTER TABLE “TeamMember”

ADD CONSTRAINT
LNAME_NOSPACES_CK

CHECK(TRIM(BOTH FROM
“LastName”) <> '');

IMPROVING THE VIEW

QUERY

The view we create for putting

the names in the drop down list

box in the “ProjectForm” is good,

legal SQL, but there are a couple of

problems. First, although we have

prevented a name from being just

spaces, the users can still add a

legal name with spaces added to

the beginning or end. Also, the

names are not in any order.

Luckily, we can edit our view

and make some additions to

address these problems. Select

“Tables” from the “Database” pane.

Right-click “TeamView” and select

“Edit in SQL View...” This brings up

the SQL we used to create the

view. Change the current SQL so it

looks like the following:

SELECT TRIM(BOTH FROM
“FirstName”) || ' '
|| TRIM(BOTH FROM “LastName”)
AS “Name”, “ID”
from “TeamMember” ORDER BY
“LastName”, “FirstName”;

We already saw TRIM when we

created our CHECK constraints. It

removes all spaces from the

beginning and end of ”FirstName”

and “LastName”.

At the end, we tag on an ORDER

BY command to sort the names by

“LastName”, then “FirstName.” This

means the names will first sort by

“LastName”, then if there is more

than one of the same “LastName”,

it will sort by “FirstName.”

With adjustments to the

controls and a little SQL, we were

able to make many improvements

to our forms, making data input

not only easier but more reliable. If

you are interested in a better

understanding of the SQL used in

this How-To, I have a couple of

resources for you.

My blog “What the Tech Am I

Doing?” LibreOffice Base posts

http://eeperry.wordpress.com/cate

gory/libreoffice/libreoffice-base/

W3Schools SQL Tutorial

http://www.w3schools.com/sql/def

ault.asp

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://eeperry.wordpress.com
http://eeperry.wordpress.com/category/libreoffice/libreoffice-base/
http://www.w3schools.com/sql/default.asp
http://podcast.ubuntu-uk.org/
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I magine a scientist, let's call himDoc Brown, who has just written

a manuscript for a book describing

his new theory on time travel. The

manuscript is a few hundred pages

long. He has broken it down into

chapters and sections, but he

needed to add a table of contents

and an index that the other

scientists, who will praise and

adore his work, can use to navigate

his book with ease. Luckily, he

knew about LibreOffice and how to

use Writer's indexes and tables

tools to create a table of contents

and an index. Let's see how he did

it.

SETTING UP THE STYLES

In many of my articles, I have

emphasized the importance of

using styles, but just in case you

haven't got the message yet,

“Using styles is the best way to

save time and create uniformity in

your documents.” Luckily, Doc

Brown knew the importance of

using styles, and he used styles to

help simplify the creation of his

table of contents. These are the

heading styles “Heading 1 [...1 0] .”

He could edit the styles in any way

he wanted for appearance, but we

are interested in how he used them

in the overall outline of the

document.

To set up the overall outline of

his document, Doc Brown opened

the “Outline Numbering” dialog,

Tools > Outline Numbering.

Selecting each of the different

levels, he noticed that each one

was already assigned to a heading

styles in order from 1 to 1 0.

Working with these defaults he

selected level 1 with the paragraph

style “Heading 1 ” assigned as its

style. For the “Number” setting, he

selected “1 , 2, 3,...” For the

“Before”, he entered “Chapter ”

(note the space), and for the

“After”, he entered a colon “:”.

Using this method, each “Heading

1 ” inserted into the document

would have the format of “Chapter

N: Title”, where N is the chapter

number.

Doc Brown has also decided

that the second and third levels

needed a numbering scheme of 1 .1

for the second level and 1 .1 .1 for

the third level. On the second level,

he changed “Number” to “1 , 2, 3,

...”, set “Show sublevels” to 2, and

added a period and space to

“After.” For the third level, he set

“Number” to “1 , 2, 3, ...”, set “Show

sublevels” to 3, and added a period

and space to “After.”

With all the styles set, Doc

Brown went to work on his

document. He used “Heading 1 ” for

all the chapter headings, and

“Heading 2” and “Heading 3” for

the subheadings within the

chapters. Because he took the time

to set up his styles, he could easily

create his table of contents once

his document was finished.

CREATE THE TABLE OF

CONTENTS

With the writing all done, Doc

Brown was ready to create his

table of contents. Placing the

cursor below the last line of the
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title page, he decided the table of

contents should start on a new

page. Insert > Manual Break

brought up the “Insert Break”

dialog. He selected “Page Break”

and clicked OK. The cursor moved

to the start of a new page.

Now, to create the table of

contents. Insert > Indexes and

Tables > Indexes and Tables. The

“Insert Index/Table” dialog

appeared. He changed “Title” to

“Regarding the Mathematics of

Time Travel.” For the “Type”, he

made sure that “Table of Contents”

was selected.

The “Create Table/Index for”

gave him two options: “Entire

Document” or “Chapter.” If he

wanted, he could have placed a

table of contents at the beginning

of each chapter by inserting a table

of contents after the chapter

headings and selecting “Chapter”

for the “Create Table/Index for.”

However, he was creating the table

of contents for the whole book, so

he selected “Entire Document.”

Finally, he had the “Evaluate up

to level” option. Here he selected

the depth of his table of contents.

If he changed this to 1 , only the

chapter titles would show. He

could then create a table of

contents for each chapter to show

the subheadings. In the end, he

decided to show 3 heading levels in

the table of contents and set this

option to 3.

Doc Brown clicked OK, and the

table of contents was created.

Without any editing, the page

numbers for the first three levels

were added to the table of

contents. Each new level was

indented just a little to show that it

was a lower level. Each title in the

table of contents was a link to the

heading in the document. This

became handy when he converted

the document to PDF and Ebook.

He could have left his table of

contents like this and it would have

worked great, but he decided it

needs just a few more added

touches.

EDIT THE TABLE OF

CONTENTS STYLES

To change the appearance of

the different levels in the table of

contents itself, Doc Brown would

need to edit the “Contents 1 [...1 0]”

styles. There was also the

“Contents Heading” style which

was used to style the table of

contents title.

Doc Brown wanted the title

centered, enlarged, and bold. He

opened the “Styles and

Formatting” dialog through the

new sidebar (no longer

experimental in version 4.2). He

could also open the “Styles and

Formatting” dialog by clicking on

its button in the “Formatting”

toolbar, or through the menus,

Format > Styles and Formatting. He

right-clicked the “Content

Heading” style and selected

“Modify”. On the “Font” tab, he

selected bold and set the size to

20pt. He switched to the “Align”

tab and selected “Center.” He

clicked OK to save his changes.
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Since Doc Brown was only

including the first three levels, he

only needed to change the

paragraph styles “Contents 1 ”,

“Contents 2”, and “Contents 3.”

The first level he wanted a little

bigger and bold, since these were

the chapter titles. He modified the

“Contents 1 ” style by selecting

bold and changing the size to 1 6pt

on the “Font” tab. To distinguish

the second level from the third, he

set the second to bold but left the

size at the default. For the third, he

changed the font to italic but left

the size at the default.

Doc Brown saved his document

with its newly formatted table of

contents. He was now one step

closer to publishing his book and

becoming world famous. He smiled

as he imagined the raving peer

reviews it would receive, but wait...

what about the alphabetical index?

CREATE THE INDEX ENTRIES

In a book of such scientific

importance, an index at the end

would help researchers find a

reference to certain scientific

knowledge contained in the book.

With the final edit completed, Doc

Brown began reading through his

manuscript to determine which

words he would need to include in

the index.

Before he created the index

itself, he needed to create the

index entries for the words he

decided to include in the index. To

get started, he selected the first

word he wanted indexed; then

from the menus, he selected Insert

> Indexes and Tables > Entry. The

“Insert Index Entry” dialog

appeared.

He left the “Index” at the

default, “Alphabetical Index.” If he

had planned to create a custom

index, he would create one using

the button beside the dropdown

list.

“Entry” is the word or phrase for

the index, and it doesn't

necessarily have to appear the

same as in the manuscript. For

example, he changed the term

“supplementary angle” to “angle,

supplementary”in the index. Even

though the order of the words has

changed, it continues to refer to

the same place in the manuscript.

Writer allows for two levels of

“Keys” or categories for grouping

indexes together. For example,

Doc Brown decided that all indexes

concerning angles should appear

together in the index, as well as

the different operators used. For

the angle entries, he entered

“angle” in “Key 1 ”, and for the

operator entries, he entered

“operators” in “Key 1 .” Though he

only created one key level in each

case, he could have created two by

entering a second value in “Key 2”.

Whenever he was on the page

where the main text for a topic

appeared, he would check “Main

Entry.” This makes the page

number appear in bold numerals

for that entry by default. (You can

change the appearance of the main

entry page number by editing the

character style “Main index entry.”)

Doc Brown checked the entry

“Apply to all similar text” as this

creates an entry for every time the

word or phrase appears in the

manuscript. He left “match case”

unchecked, as sometimes the word

or phrase appears in a different

case. He checked “Whole words

only” as he does not want

variations to the word or phrase

indexed.

Once finished with a word, Doc

Brown clicked “Insert.” Leaving the

dialog open, he selected the next

word or phrase in his document.

When he clicked on the dialog, the

new word or phrase appeared in

the dialog's “Entry” field. He made

the changes needed for this entry

and clicked “Insert.” This ability to

switch between the dialog and the

manuscript makes creating the

index entries quicker than if he had

to open the dialog each time.

CREATING THE INDEX

Once Doc Brown completed

creating his index entries, he was

ready to create the actual index.

He went to the last page of his

manuscript, and deciding the index

should start on a new page,

inserted a page break (Insert >

Manual Break; select “Page Break”;

click OK).
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Insert > Indexes and Tables >

Indexes and Tables, brought up the

“Insert Index/Table” dialog. On the

“Index/Table” tab, he selected

“Alphabetical Index” for the

“Type”, changed the “Title” to

“Index”, and unchecked all entries

except “Combine identical entries.”

This prevents the index from

creating separate entries because

of upper or lower case.

Doc Brown decided that the

index should have two columns to

conserve some space. On the

“Columns” tab, he changed the

number of columns to 2. To create

some space between the two

columns, he changed the spacing

to 0.20'' (0.50cm).

Satisfied the index was set up

the way he wanted it, he clicked on

OK. The index then appeared on

the page the way he formatted it.

Now, Doc Brown's manuscript

was ready for publication. He

began to dream of the raving peer

reviews he would receive. Thanks

to LibreOffice, he was able to add

his table of contents and index

rather quickly.

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://eeperry.wordpress.com
http://podcast.ubuntu-uk.org/
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When I was in school, I was

very focused on writing, and

I didn't see the value in many other

subjects, especially mathematics.

As I grew older, I began to

appreciate and enjoy mathematics.

Through the years, I have studied

mathematics on my own. While I

studied, I created many documents

containing my mathematics notes. I

decided it was time to put them all

into one document with chapters, a

table of contents, and an index.

But how does one combine a bunch

of documents into one?

I guess I could have just copied

the text from one document into

another big document, but this

could get messy, especially since I

wasn't sure about the best order

for the documents. I wanted a

method where I could work on the

documents individually then

combine them into one, and I

wanted the ability to rearrange the

order of the documents. In

LibreOffice, you can do this with

‘master documents’. You can think

of a master document as a

container that joins together

separate Writer documents. Just

the kind of thing I needed. So, I

decided to use a master document.

PREPARING THE DOCUMENTS

Since the documents were

scattered through several years,

they were created with different

versions of OpenOffice and

LibreOffice. They had no style or

template in common. I needed to

create a template for consistency

throughout all the documents and

the master document.

To create my template, I started

with a new blank document. While

creating my template, there were a

few things I took into

consideration. I knew I wanted to

create a table of contents, so I

would need to edit the “Outline

Numbering.” I also wanted each

chapter to start on a new page.

Finally, I would need a unique title

page style.

To edit the “Outline

Numbering”, I went to Tools >

Outline Numbering. I edited the

top level to put “Chapter” and the

chapter number before the top

level headings, just as I discussed in

Part 38 of this series (Full Circle

issue 85). I decided to leave the

other levels bare, although I would

probably include some of them in

the table of contents.

To make each chapter start on a

new page, I edited the outline top

level style, “Heading 1 .” I opened

the “Styles and Formatting” tab in

the sidebar, right-clicked on

“Heading 1 ” in the paragraph

styles, and selected “Modify.” On

the “Text Flow” tab under “Breaks”,

I checked “Insert”. For the type I

selected “Page,” and for the

position, I selected “Before.” OK

saved the changes.

NOTE: You can also open the

“Styles and Formatting” window

from its button on the Formatting

toolbar, the menus (Format >

Styles and Formatting), or by

pressing F1 1 .

I created a page style named

“Title Page” based off the “First

Page” style. The only real change I

made was to set the top to halfway

down the page to center the title

on the page vertically. I modified

the “Title” paragraph style to a

font and size of my liking. I also

created the paragraph style

“Byline” based on the “Subtitle”

style. Not many changes here, just

selected a font to go with the title

font.

To save the template, File >

Save as Template opened the

Template Manager. I clicked on

Save, and the program prompted

me for a name for the template. I

named it “Math Reference.” I

clicked OK, and I had a new

template.

When you are creating a

template, you may have other
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changes you want to make. These

were the ones that I felt were a

good starting point for me. You can

go as far as you want with a

template. In the end it is up to you.

If you decide, while working on

sub-documents, that you need to

make more changes to styles, make

the changes to the template rather

than the individual document.

To make changes to my

mathematics template, File > New

> Templates. I selected the

template and clicked the Edit

button. This opened the template

rather than a new document using

the template. I made my changes

and then saved it as though it was

a normal document (Click the save

button on the main toolbar, File >

Save, or CTRL-S). When I opened

one of the documents that uses

the template, LibreOffice notified

me that the template had changed

and asked me to update the

document with the new version of

the template. I clicked “Update

Styles”, and the styles updated in

the document.

Now, I needed to apply my new

template to my existing

documents. I opened each of the

documents and Edit > Select All. I

then created a new document

using my template, File > New >

Templates. I selected my template

and clicked Open. Edit > Paste and

the text and objects from the

original file were pasted into the

new file. I closed the old document

because I wanted to save it with

the same filename. I saved the new

document and I had the old file

contents using the new template. I

repeated this procedure for all the

existing documents.

CREATING THE MASTER

DOCUMENT

To create my master document,

I opened a new document using my

“Math Reference” template.

Selecting the “Title” style from the

paragraph styles, I typed in my

title. I then created the subtitle

and byline. Once I had something in

the document, I saved it as a

master document, File > Send >

Create Master Document. I gave

the document a name and clicked

Save. I then went to the page styles

in the Styles and Formatting dialog

and changed the page style to

“Title Page.”

INSERTING DOCUMENTS

Once I had a master document, I

could start adding files to it. When

I saved the master document, it

opened the Navigator in a floating

window automatically. I could have

worked in this floating window, but

I closed it and used the Navigator

panel in the sidebar. They are both

the same, so it's your choice which

one you use. The Navigator

window is opened by pressing F5

on the keyboard, or from the

menus, View > Navigator.

The Navigator in master

documents is different from other

documents. By default it is in

document list mode. The first

button in the toolbar is a toggle

button that allowed me to toggle

between the document list and a

standard Navigator panel. While

working in the master document, I

did not see any reason for

switching to normal mode, but it is

there should you have a reason for

navigating to an object or

subheading in one of the sub-

documents.

I noticed that one document

was already in the list of files. This

was the Text of the master

document itself, at this point, my

title page. I would add other Text

blocks as needed in the master

document using the insert button.

To add my documents to the

master document, I clicked and

held on the Insert button <image>.

Dragging down to the File

selection, I released the mouse

button. An insert file dialog

appeared for me to find and select

my file. I clicked open and the file

was added to my master

document. When adding a file to

the master document, Writer

always adds it above the currently

selected file. I used the “Move Up”

and “Move Down” buttons

<image> to get my documents in

the order I wanted them. All

references and chapter numbers

adjusted automatically as I moved

the documents up and down in the

list.

EDITING FROM THE MASTER

DOCUMENT

All documents linked to the
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master document are read only in

the master document. To edit a

document from the master

document, I selected the document

in the Navigator list and clicked the

edit button. A new window

containing the document I wanted

to edit opened. I made my changes

to the document, saved, and closed

it. In the master document, I

clicked and held the Update

button. Dragging I released on

Links. A message window appeared

asking me whether I wanted to

update all the links in the

document. I clicked Yes, and the

document I just edited updated in

the master document. I was also

able to open the document

through normal methods and edit

it that way. The changes still

appeared when I updated the

master document's links.

I inserted a table of contents by

inserting a page break after my

title page and using the same

methods discussed in Part 38 of

this series (Full Circle issue 85). I

did the same for an index, but I had

to insert a Text block at the end of

the master document through the

insert button. This text block was

needed to create an editable block

at the end of the master

document.

Master documents are a great

way to create large documents. In

my case, I wanted the flexibility to

work on the individual documents

and the ability to rearrange the

order of the documents. A master

document works best with a

template shared by all the

documents. Just like normal Writer

documents, you can add a table of

contents and indexes. While a

master document is not always the

best choice, it is a good choice if

you need the ability to move the

different parts around or have

different people authoring the

different parts. This was just one

example of using a master

document. If you plan things well,

you can start from the very

beginning before you even write

the first document.

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://eeperry.wordpress.com
http://podcast.ubuntu-uk.org/
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I t probably won't surprise you tolearn that I use LibreOffice to

write these articles. For the

longest time, I would print out

each draft of an article, mark it up

with a red pen, then transfer my

changes to the computer. This old-

school method came from my years

editing papers as a student and as

a professional. As I began to write

on a regular basis, I accumulated a

growing stack of recycle paper

from writing. I tried to use both

sides of the paper, and even ripped

some in quarters for use as note-

paper. Before long I was burning

through a lot of paper and ink.

At some point I decided I

needed a digital solution. I already

knew that Writer provided editing

markup, but had never tried to use

it for editing my documents. With

some hesitation, I began to use it.

The whole “old dog, new trick”

issue. After using it for a couple of

months, I began to wonder why I

hadn't used it before. From right

inside Writer, I can track my

changes, make notes (comments),

and accept or reject the changes. In

many ways, it is quicker and even

more efficient than the hard-copy

method.

PREPARING TO RECORD

CHANGES

Once I finish the first draft of

my article, I save it as a version and

turn on recording changes. (More

on version control later.) ‘Edit >

Changes > Record’ sets Writer to

begin recording changes. Edit >

Changes > Show sets Writer so it

shows me the changes that have

been made. I have debated with

myself the wisdom of showing

changes while I am actually editing.

On the one hand, I can see the

changes as I make them. On the

other hand, showing the changes

while I edit can make reading the

text difficult. I have tried it both

ways, and see some logic in not

showing changes during the actual

edit process, but waiting until the

accept and reject process to

actually show the changes. In the

end, the choice is yours.

NOTE: If you are passing the

document to someone else to edit,

you might want to take some

precautions. File > Properties;

select the Security tab; check

“Record Changes”, and click on

“Protect”. Enter and confirm a

password. This will prevent the

other person from making changes

and then accepting or rejecting

them. When you get the document

back with their changes, File >

Properties, click on “Unprotect”,

and enter your password. You can

now accept or reject their changes.

RECORDING CHANGES

If I set Writer to show changes,

and I add text, it is underlined and

changed to the color I have set.

When I remove text, it is shown as

struck-through just as I would when

editing a hard copy. The strike-

through text is shown in a different

color from the added text. The

colors used for added and deleted

text are controlled by the settings

at Tools > Options > LibreOffice

Writer > Changes.

If I hover over a change, it will

show the author, date, and time of

the change in a tool-tip box. If I

have “Extended tips” turned on in

Tools > Options > LibreOffice >

General, the tool-tip will show the

author, date, time, and any

comments attached to the change.

The author's name is controlled by

the information in Tools > Options

> LibreOffice > User Data.

To add a comment to a change, I

place the cursor anywhere within

the changed text. Edit > Changes >

Comment brings up the comment
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dialog. I can then enter my

comment for the change. This is

sometimes useful to remind myself

of why I made a certain change.

Once I am finished, I click on OK

and the comments are added to

the change.

ACCEPTING / REJECTING

CHANGES

After editing the draft, I am

ready to review my changes. If

changes are not currently showing,

Edit > Changes > Show. Edit >

Changes > Accept or Reject brings

up the “Accept or Reject Changes”

dialog, which displays a list of all

my changes. Each listing shows the

type of change, author, date, time,

and any comments. Selecting any

of the items in the list highlights

the change in the document. If I

want to keep the change, I click the

Accept button. If I don't want to

keep the change, I click the Reject

button. If I know I want to keep all

my changes, I can just click the

Accept All button. However, if I

decide to throw out all my changes,

I can click the Reject All button.

On the Filter tab, I can narrow

down the kind of changes that are

displayed in the list. There are four

different filters for me to choose

from: Date, Author, Action, and

Comment.

The Date filter allows me to see

only changes that were created

earlier than, since, equal to, and

not equal to a certain date. I can

also select changes that occur

between two dates. The buttons

with the clock face at the end of

the date entry fields allow me to

set the date to the current date

and time by clicking them. The last

setting for the date filter is to

show only the changes made since

the last time the document was

saved.

I never have much use for the

Author filter, as I am usually the

only one who is making changes.

However, if I did have someone

else editing for me, I could pick

between my own changes and the

changes made by another editor of

the document.

The Action filter allows me to

display just a certain type of

change. The four change types are

insertion, deletion, formats, and

table changes.

If I feel the need to add a lot of

comments to my changes, I can use

the Comments filter to filter

changes based on the text

contained in the comments. I just

check the Comment filter and

enter the text I want to look for.

MARGINAL NOTES OR

COMMENTS

Sometimes, I need to make a

note to myself. Using the hard copy

method, I would just write a note in

the margins. These usually don't

represent an actual change, but an

idea or action to act on at a later

time. For example, needing to

expand on an idea, or save an idea

for a later article. Marginal notes

are accomplished through
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Comments. Do not confuse these

with change comments.

To create a comment, I highlight

the information it applies to. Insert

> Comment. A box in the color

assigned to the author by

LibreOffice appears in the right

margin. The name that appears at

the bottom of the comment is

controlled by the data entered in

Tools > Options > LibreOffice >

User Data. Placing my cursor inside

the box, I type my comment. I can

even format the text within the

comment box using the format

tools in the formatting toolbar or

the side-bar. I right-click or click on

the down-arrow to get a menu that

allows me to delete comments

when they are no longer needed.

SAVING VERSIONS

After each cycle of changing

and then accepting / rejecting, I

like to save a version of the

document in its current state. File >

Versions opens the Versions

dialog. I click on Save New Version

and give the version a name like

“Rough Draft”, then maybe any

comments I may need like “image

markers in place.” I click OK to save

the version. If I ever need to go

back to a version, I can open the

Versions dialog, select the version I

need, and click Open. For more

information on version control, see

my blog post at

http://wp.me/pvwht-9k.

NOTE: The version control in

LibreOffice is okay for small to

moderate size documents, but less

than ideal for very large

documents.

The editing tools built into

Writer are useful for single-person

editing or multi-person editing. I

can have the program track my

changes and allow me to later

accept or reject the changes. I can

add comments to the changes to

help me remember why I made the

change. I can also add margin notes

to the document through the

comment tool. After each edit, I

can save a version of the document

in case I decide to revert back to a

previous version.

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://eeperry.wordpress.com
http://wp.me/pvwht-9k
http://podcast.ubuntu-uk.org/
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Back in parts 8-1 2 (FCM issues

53, 55-58), I took you from a

blank spreadsheet to a full working

budget spreadsheet. Something

similar is what I use twice a month

to do my home budget. I keep a

whole year of budget spreadsheets

in one document, which means

twice a month I copy the sheet,

rename it, and make sure I get all

the settings correct to put a copy

of the current sheet at the end of

the sheet tabs. Believe me,

mistakes have been made. Curses

have been breathed. Innocent

computers have been threatened.

In time, I decided, since I was

such a fallible, flawed human

being, I needed to reduce the

number of steps necessary to

complete this task in order to

lessen my chances for mistakes.

The result was a macro where all I

have to do is give the sheet a new

name. The macro handles all the

rest, making sure it is copied and

placed at the end of the tab list.

The task fits perfectly into the idea

behind macros, a repeatable

process that automation can speed

up, or prevent mistakes. Today, I

share it with you.

THE MANUAL METHOD

In order to appreciate a macro,

you really have to understand what

it's doing for you, and the mistakes

you can make. Therefore, I will start

with the description of the manual

process that the macro makes

simpler. There is actually more than

one way to copy a sheet in Calc, but

I will show you the dialog method

with all the options.

Right-click on the tab of the

sheet you want to copy and select

Move/Copy Sheet. The Move/Copy

dialog appears. You then select

Copy. One of the mistakes I have

made is to forget this. I end up just

renaming my sheet. Under “Insert

Before” select the option at the

end “-move to end position-”. If I

forget this one, the sheet is placed

before the current sheet rather

than at the end where I want it.

Finally, I have to rename the sheet.

There have been times while trying

to remember to get the other

settings right, that I have forgotten

to actually change the name. When

I do, the copied sheet gets the

name of the current sheet with a

“_2” appended to the end. Click OK

to execute the settings.

I know, you're thinking that it's

not that bad, but after a few times

getting it wrong, your inner Hulk

comes out and you want to smash

things. Okay, maybe that's just me.

Trying to balance the home budget

is frustrating enough without the

bonus of mistakes while copying

the spreadsheet.

THE COPYSHEET MACRO

The macro is not very long (next

page, top right) and you can easily

type it in. You can also copy it from

http://pastebin.com/s3iTGjN6.

The micro starts by declaring 3

variables used in the body of the

macro. “Sheet1 ” and “Sheet2” are

strings that will contain the names

of the current sheet (Sheet1 ) and

the new sheet (Sheet2). The “Doc”

variable will hold a reference to the

current document. It is declared as

a type Object because the

reference is to a LibreOffice API

object.

Doc = ThisComponent

ThisComponent is the current

active document in LibreOffice. In

this case, the macro is looking for a

Calc spreadsheet.

If NOT
Doc.supportsService("com.sun.
star.sheet.SpreadsheetDocumen
t") then

http://pastebin.com/s3iTGjN6
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MsgBox "This Macro Only

Works with Calc Spreadsheets"
Exit Sub

End If

The “If” statements check to

make sure that the current

document is a Calc spreadsheet. It

checks to see whether the

document supports the

SpreadsheetDocument service,

identifying it as a Calc spreadsheet

and not some other document

type. If it is not a spreadsheet, the

macro pops up a message box

telling the user the macro works

only with spreadsheets. The macro

then executes an “Exit Sub” that

exits the macro without running

any more of the code.

Sheet1 =
Doc.CurrentController.ActiveS
heet.Name

The macro uses the Doc object

to extract the name of the current

sheet. The breadcrumb dot

notation goes through a

progression of getting more

specific. CurrentController is a

reference to the service that

controls the document.

ActiveSheet is a reference to the

currently active sheet in the

document. Finally, Name gets the

name of the current sheet and this

is assigned to the variable Sheet1 .

Sheet2 = InputBox("Enter Name
for Copied Sheet:", "Copy
Sheet", Sheet1)

To get the name of the new

sheet, the macro uses an InputBox

function. The InputBox takes 3

arguments:

• The prompt to show the user

(“Enter Name for Copied Sheet:”) .

• The title of the InputBox window

(“Copy Sheet”) .

• The default text (it just uses the

name of the current sheet [Sheet1 ]

as the default text).

If the user clicks the OK button,

the InputBox will return the string

entered in the text box or the

default text when no changes are

made. If the user clicks the Cancel

button, a blank string is returned.

If Sheet2 = "" Then Exit Sub

Do While
Doc.Sheets.hasByName(Sheet2)

Sheet2 = InputBox(Sheet2
+ _

" already exists, select
a different name:", "Copy
Sheet", Sheet2 + "2")

If Sheet2 = "" Then Exit
Sub
Loop

Now, the macro must use some

logic to determine how to proceed.

The “If” checks to see if the

returned string is blank. If so, that

means that the Cancel button was

pressed, therefore the “Exit Sub” is

executed. “Exit Sub” exits the

macro without running any more of

the remaining code.

The Do While...Loop checks to

see if another sheet in the Calc

document has the same name. The

hasByName method checks the

supplied name against the names

of all the sheets in the collection. If

a match is detected, the macro

uses an InputBox to prompt the

user for a new, unmatched name.

The Do While...Loop will loop until

the name in Sheet2 does not match

Sub CopySheet
dim Sheet1 as String
dim Sheet2 as String
dim Doc as Object
Doc = ThisComponent

If NOT Doc.supportsService("com.sun.star.sheet.SpreadsheetDocument") then
MsgBox "This Macro Only Works with Calc Spreadsheets"
Exit Sub

End If
Sheet1 = Doc.CurrentController.ActiveSheet.Name
Sheet2 = InputBox("Enter Name for Copied Sheet:", "Copy Sheet", Sheet1)
If Sheet2 = "" Then Exit Sub
Do While Doc.Sheets.hasByName(Sheet2)

Sheet2 = InputBox(Sheet2 + _
" already exists, select a different name:", "Copy Sheet", Sheet2 + "2")
If Sheet2 = "" Then Exit Sub

Loop
Doc.Sheets.CopyByName(Sheet1, Sheet2, Doc.Sheets.Count)

End Sub
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the name of any other sheet. The

“If” inside the loop exits the macro

if Cancel is pressed. If the name is

unmatched from the start, the loop

never runs. This prevents two

sheets from having the same name.

NOTE: The underscore (_) in the

InputBox statement is used to

break a long line up into shorter

lines. LibreOffice Basic requires

that the underscore is the last

thing on the line. Nothing, not even

a space, can follow it. When lines

are joined in this way, LibreOffice

Basic sees them as one line.

Doc.Sheets.CopyByName(Sheet1,
Sheet2, Doc.Sheets.Count)

The last line of the macro brings

all this preparatory work together

to finally execute the copy. Sheets

is a reference to the collection of

sheets in the document.

CopyByName is the method that

actually copies the sheet and

moves it to the end of the sheet

tabs. The CopyByName method has

3 parameters:

• The sheet to copy from (Sheet1 ) .

• The sheet to copy to (Sheet2).

• The position of the new sheet

(Doc.Sheets.Count).

Count is the total number of

sheets in the collection (Sheets).

Since the sheet numbers are

referenced starting with 0, the use

of Count here puts the new sheet

at the end.

CREATING THE CALC MACRO

MODULE

When I developed and wrote

the CopySheet macro, I created a

macro module for Calc. Here I

could store this macro as well as

any future macros designed for the

Calc program. It's a good idea to

group like macros together.

To create the module, Tools >

Macros > Organize Macros >

LibreOffice Basic. The LibreOffice

Basic Macros dialog opens. Click

Organizer to get the LibreOffice

Basic Macro Organizer dialog.

Under My Macros > Standard, there

is a default module named Module

1 . Select it and click Delete. With

Standard selected, click New.

Name the new Module “Calc” and

click OK. Click Close.

Now back in the LibreOffice

Basic Macros dialog, select the new

“Calc” module you just created and

click Edit, opening the LibreOffice

Macro Editor. Delete the

automatically created “Sub Main”

and “End Sub”. Type in or copy and

paste the SheetCopy macro into

the editor. Save the module and

close the editor.

TEST THE MACRO

After typing in the macro and

saving it, you will want to test it to

make sure you typed everything

correctly. First, open a Calc

document or create a new one. You

can then test the macro by going
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EXTRA! EXTRA!
READ ALL ABOUT IT!

Our glorious news reporters

are now posting regular news

updates to the main Full Circle

site.

Click the NEWS link, in the site

menu at the top of the page,

and you'll see the news

headlines.

Alternatively, look on the right

side of any page on the site,

and you'll see the five latest

news posts.

Feel free to discuss the news

items. It's maybe something

that can spill back from the site

into the magazine. Enjoy!

Elmer Perry's history of working, and
programming, computers involves an
Apple ][E, adding some Amiga, a
generous helping of DOS and
Windows, a dash of Unix, and blend
well with Linux and Ubuntu.
He blogs at
http://eeperry.wordpress.com
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to Tools > Macros > Run. Under

Library, select My Macros >

Standard > Calc. Under “Macro

Name” select CopySheet and click

Run. Enter a name for the sheet

like “New Sheet.” Click OK. If all

goes well, a new sheet is created

with the name you gave it. You will

want to repeat the test and not

change the name to see if the

macro prompts you to change the

name. Also, test to make sure the

macro stops when you click on

Cancel rather than OK. For the final

test, open a text document and run

the macro. You should get the

message telling you that the macro

works only on spreadsheets.

NOTE: Back in Full Circle issue 64

(LibreOffice Part 1 7: Macros), I

showed you how to create a menu

shortcut to a macro. This is a good

candidate for such a shortcut.

Create the menu and shortcut in

Calc.

Macros like CopySheet can

speed up your processes and

prevent you from making mistakes,

which is the whole idea behind

macros. This is just an example of

something you can do with macros,

but you can write your own macros

that can expand the use or

capabilities of any of the

LibreOffice programs, or just

reduce a task you do often. A

Google search for “LibreOffice

Basic” is a good place to start

learning more.

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some great

guests on the show, telling us

first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://eeperry.wordpress.com
http://podcast.ubuntu-uk.org/

	Volume Five
	Pt35: The Gallery
	Pt36: Base Views
	Pt.37 Base Forrm Improvement
	Pt.38 Contents and Indexes
	Pt.39 Master Documents
	Pt.40 Writer, Tracking Changes
	Pt.41 Copy Sheet Macro




