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XHTML purity, and embraced the
work of WHATWG, such that the
HTML standard is now nominally
What followed was a period of back in their hands. But
stagnation for the web. No
structurally, things have changed:
browser wanted to introduce any
no longer can the W3C write specs
As academically pure as the
radically new syntax into HTML or and expect browsers to implement
aims of XHTML were, they fell
CSS for fear of re-kindling the bad them; now the browser vendors
down in the real world. HTML had old days of proprietary extensions. agree what to implement amongst
First, a very brief (and
But eventually, the browser
themselves, and then the
simplified) history lesson: SVG, the thrived partly because it was so
lax.
Browsers
would
do
their
best
companies
began
to
talk
amongst
specification is written to match
file format used by Inkscape, was
themselves about ways to push the the implementations. Okay, in
created under the auspices of the to interpret even the most
malformed syntax, which greatly
web forward again. The result was practice it's more nuanced than
World Wide Web Consortium
the formation of another
that, but the key point is that,
(W3C) – the organisation that was lowered the barrier to entry for
non-programmers
to
create
their
standards
body,
WHATWG,
whose
these days, specs are largely driven
also charged with creating the
own web pages. Lowering it
remit was to improve the old HTML by what browsers are prepared to
specifications for HTML and CSS.
further still were applications such specs largely by documenting what implement.
HTML was already an established
the browsers already did, making it
language, but loosely defined, and as Dreamweaver and HoTMetaL,
which
would
allow
users
to
create
easier for all the vendors to bring
This has an impact on Inkscape
with a host of differences between
web pages as easily as they would their programs up to the same
because, as an SVG editor, its
the various browser
a Word document. HTML
level of compliance. They also
feature set follows the capabilities
implementations. The W3C tidied
continued to proliferate online,
added a few new features to
written into the SVG specification.
things up, but ultimately decided
and
it
would
have
been
commercial
HTML,
branding
it
as
“HTML5”,
But the SVG spec, in practice, can't
that the best way to get everyone
although we're now several years
gain any new capabilities without
writing good, cross-browser HTML suicide for any browser to render
only XHTML. For all its purity and
on and many of their more useful
support from the browser vendors.
was to effectively abandon the
technical superiority, XHTML
ideas still haven't been universally Yet those vendors are loath to
undisciplined language it had
inevitably
lost
out
to
the
looser
implemented (how are those date implement many of the new
become, and move to a rigorously
and time pickers coming along,
features, given that there are
defined and structured alternative, standard, and the W3C's work
became largely irrelevant. It was
Mozilla?).
barely any files online that use
XHTML. This was also part of a
them. Users, meanwhile, are
larger plan to promote XML, which clear that the approach of having a
standards
body
to
write
the
specs,
Eventually
the
W3C
gave
up
on
equally loath to create content
can be thought of as a language
and only then for the browsers to their philosophical march towards using these new features because
for defining languages. XHTML
'm going to take a slight
departure from the usual format
for the first part of this month's
article – and talk about politics.
Not Trump, Brexit or the rise of
populism, but rather the politics of
open formats and browsers.

was HTML re-cast as an XML
language, bringing with it more
scope for interoperability with
other XML languages, including
SVG.
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implement them, was not one that
would work in practice.
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formats, can do to help ensure that
SVG has a future? Since it's largely
in the hands of the browser
vendors, the best we can to is to
show them that there is a demand
for the format, and for the new
additions that are being made to it.
We need to create more SVG
documents, especially those with
With more features moving to
And so we go round in circles:
CSS, and the vendors showing little features from the SVG 2
specification, and post them
no files using the new features
interest in implementing those
online. And we need to encourage
online means no browser support; that remain part of SVG, there's
no browser support means the
even been talk of not renewing the others to do the same. But this
approach isn't without its
specs don't stabilise; unstable
SVG Working Group's charter
specs make authoring tools less
beyond a short period to stabilise problems.
likely to support the features; no
the work that has been done on
The SVG 2 spec isn't yet
support in authoring tools makes
the SVG 2 specification over the
finalised. Creating documents
users less likely to create and post past couple of years. That would
using the current version could
files that use the new features; no mean no SVG 3, and no new
render them obsolete if there are
files using the new features online features in the future. Given how
further changes to the
means no browser support... and
many great ideas were dropped
so on.
from SVG 2 with the promise that specification before it's finally
ratified. So any files you create
they could be revisited for later
now might require some (hopefully
To be fair, some limited support specs, this would be a tragedy.
minor) fixes if they are still to work
for new SVG features has made it
Sure, Inkscape would likely
in a year's time. A bigger problem
into browsers – but mostly in areas continue, probably adding
for most people is how to create
where the SVG Working Group has proprietary extensions to SVG to
relinquished ownership in order to support new features as time goes them in the first place. Handcoding SVG is certainly possible,
move the feature to CSS. This is
on. But the promise of an open
but it's probably not a practical
both good and bad news: CSS is
vector format that could be used
option for most people, which
one of the cornerstones of the
cross-application, and rendered
means that the only way to get
web, so adding features there,
natively on the web, would have
new features into your files is to
rather than in SVG, makes them
died.
wait for them to become available
more likely to be adopted by
in authoring tools. Thankfully,
browsers; conversely it further
Is there anything that we, as
Inkscape is, to some extent,
weakens the position of SVG as a
users and advocates of open
full circle magazine #1 1 8
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no browser supports them. The
authoring tools (such as Inkscape)
would like to implement them, but,
without browser support, the spec
is unlikely to be finalised and
supported – so any work they do
could be rendered obsolete if the
specification changes.

stand-alone format, and requires
non-browser applications to
comply with standards that often
don't sit easily outside the web
environment, diminishing SVG's
position as an independent file
format.

leading the way for this approach.
The recent 0.92 release adds
support for rendering several SVG
2 features, although,
unfortunately, UI support for
creating them in the first place is
somewhat more limited.
Nevertheless, there are a couple of
SVG 2 features that you can start
using in your Inkscape drawings
today, the first of which I'll cover in
this article, and the second next
time.
The first step towards using
these new features is, of course, to
install version 0.92.x of Inkscape.
Windows users can just download
an installer from
https://inkscape.org/en/download/
windows/ whereas MacOS users
are left behind somewhat, with no
official .dmg files available at the
time of writing (see
https://inkscape.org/en/download/
mac-os/ for more details and
alternative options).
Linux installation instructions
vary between distributions, but
there's now a distributionindependent Snap package
available. Systems that aren't
based on Ubuntu may have to
install the “snapd” daemon
separately (see
contents ^
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https://snapcraft.io/docs/core/inst from an icon might leave you with
all for details), but if you're already no Inkscape window, and no
indication as to what went wrong.
on Ubuntu 1 6.04 or later, you
should simply be able to run the
If you already have Inkscape
following command:
installed via the normal Apt tools,
sudo snap install inkscape
you will find that the old version is
still installed, even after you've
Unfortunately the snap doesn't added the snap – and that it
necessarily have all the
probably gets run in preference to
prerequisites to get Inkscape up
the new release when you just
and running correctly. One change execute “inkscape” from the
in 0.92, for example, is that
command-line, or click the launcher
Inkscape no longer bundles a built- in your menu. You'll need to
in copy of the Potrace library (for
modify your path to give the
tracing bitmaps or using the
/snap/bin directory priority over
bucket fill tool); I had to use:
/user/bin or update your launchers
and links to point to the snap
sudo apt-get install
version instead.
libpotrace0
to get it working on my system.
There have also been theming
issues with early snaps (which I
also fixed by apt-get installing
some additional libraries),
although by the time you read this,
there should have been a point
release which fixes those issues. I
strongly recommend launching
Inkscape from the command-line
at first (just enter
“/snap/bin/inkscape”) as error
messages in the console may make
it clear if there are any unmet
dependencies, whereas launching

sudo apt-get install inkscape

Whichever approach you take,
it's worth visiting Help > About
Inkscape to ensure that you are
running version 0.92.

It certainly stands out more (the
fact that the fill appears darker is
The first SVG 2 feature exposed an optical illusion that helps
enhance the effect further), but,
in the UI is “paint-order”. This is
due to the construction of the
actually a rather uncontroversial
font, we've now got bits of the
feature for the browser vendors,
outline appearing “inside” letters,
as it has already been
where the tail of one flows into the
implemented in at least Firefox,
Chrome, Opera and Safari. It solves body of the next. We can adjust
the kerning to separate the
a very common problem in SVG,
especially when dealing with text: problem characters, but that
pretty much defeats the point of
any stroke applied to an object is
using a cursive font in the first
painted on top of the fill, and
extends half in and half out of the place. Converting the letters to
object. Consider this simple bit of paths, then creating a boolean
There are still traditionally
union, fixes the visual problem, but
text, rendered in a cursive font:
packaged versions available for
now our text isn't actually text any
several distributions as well, which
more, which in many cases makes
is especially useful if you have an
this approach a non-starter. Let's
older system that doesn't support
suppose we resign ourselves to
snaps. See
having to separate the letters. A
https://inkscape.org/en/download/
little manual kerning gives us this:
linux/ for details. For example, on
Ubuntu 1 4.04, you might prefer to
Suppose we want to add an
use the stable PPA that is available,
outline to it, to make it stand out a
by issuing these commands:
little bit more against its
sudo add-apt-repository
background. That's simple enough,
ppa:inkscape.dev/stable
right? Just give it a thin stroke.
Unfortunately that's where the
sudo apt-get update
problems start.
full circle magazine #1 1 8
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What if we want it to stand out
a bit more? Let's double the
thickness of the stroke and see
what effect it has.

Urk! That's not good. All the
thin parts of the script have
become completely filled by the
stroke, ruining the light elegance
that we wanted from the font in
the first place. The problem, of
course, is that increasing the
thickness of the stroke not only
adds more pixels to the outside of
it, but also to the inside, obscuring
more of the fill. One common
solution to this – and to the
previous problem – is to copy the
text, putting an unstroked version
directly on top of a stroked copy.

This works, but now you've got
two text objects to keep in sync.
With a little effort you can do the
trick with clones instead, using an

unset fill and stroke, but, if you
want anything other than a black
fill, you'll be trying to keep three
objects (a text object and two
clones) under control.
The problem would completely
go away if only you could tell
Inkscape to render the fill on top
of the stroke, instead of the other
way round. And that's precisely
what the SVG 2 “paint-order”
property does! Except it goes a
step further, and also includes any
markers that are on the path.
Considering all the possible
orderings for the three things to
be rendered, this gives six possible
combinations:
• Fill, Stroke, Markers
• Fill, Markers, Stroke
• Stroke, Fill, Markers
• Stroke, Markers, Fill
• Markers, Fill, Stroke
• Markers, Stroke, Fill

In each icon, the circle
represents a marker, the dark blue
rectangle is the fill, and the light
blue path represents the stroke,
with a dashed white line to indicate
its centre. You can produce a
similar collection of shapes by
drawing a square with a thick
border, converting it to a path,
then setting a start marker.
Clicking each of the buttons whilst
your bigger version is selected will
immediately reflect the change,
and make it much clearer to see
what the result of each option is. I
recommend creating a shape like
this and switching between the
different modes to help you to
fully understand the effect.

The first of these is the default,
and is the way that SVG 1 .x
operated. But now there's an extra
section in the Stroke Style tab of
Inkscape's Fill and Stroke dialog
that presents six buttons to let you
choose your preference for any
selected paths.

As for our text, because there
are no markers involved, any of the
three modes that draw the stroke
before the fill will give our desired
result, with only a single text
object and no need for clones,
copies, or other workarounds. It
even works well with a really thick
outline.
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Even though paint-order is
already well supported in
browsers, I urge you to create new
designs and works of art that use
it, and put them online. The more
files we share that use SVG 2
features, the more likely it is that
the browser vendors might realise
there's a demand for them, so
going after “low hanging fruit”
such as this is an easy way to
express your interest without
having to worry about posting files
that don't render in the browser.
Next time I'll move onto Mesh
Gradients – perhaps one of the
most useful, and most desperately
needed, new features in SVG 2, but
one which is in very real danger
due to browser vendor antipathy.

Mark uses Inkscape to create three
webcomics, 'The Greys', 'Monsters,
Inked' and 'Elvie', which can all be
found at
http://www.peppertop.com/
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few simple parameters. The first
two icons (labelled “New:”) let you
select between a Mesh Gradient
and a Conical Gradient. In practice
there isn’t a genuine conical
gradient in SVG – the button just
There’s no doubt that the
creates the convenient illusion of
simple linear and radial gradients
one using a mesh gradient. For
available with SVG 1 .x are
now, ensure that the first button is
extremely limiting. Rather than
selected. The next pair of buttons
add separate types for conical,
spiral, square and other gradients, (“on:”) define whether to create
SVG 2 adds Mesh Gradients, which the mesh on the fill or the stroke
of your object – I’ll use Fill for
are flexible enough to cover all
these examples. Finally you need
these cases and more – albeit at
to decide how many rows and
the expense of more manual
columns should be present in your
tweaking to get the exact results
mesh. Higher values will slow down
you want. As with any type of
gradient, you’ll first need an object rendering, but grant you finer
control over the gradient. I’ll start
to apply it to – I’ll begin with a
with a simple 2×2 mesh, as that’s
simple square. With the target
sufficient to explain the basics.
object selected, click on
the Mesh Gradient icon
As you move your cursor back
in the toolbar:
Last time I looked at the
over the canvas, the status bar
uncontroversial addition of Paint
informs you that you can “Drag or
This will display the Mesh
Order to the SVG spec. This time
Gradients tool control bar (shown double click to create a mesh”.
I’ll look at another big addition –
With a single object selected, both
below).
one that has been eagerly
approaches give the same result,
anticipated by Inkscape users since
so I usually just double-click on the
To create a new mesh on your
it first made an appearance in
object. With more than one object
object, you first have to set up a
development releases – Mesh
Gradients (also referred to as
Gradient Meshes, depending on
n the previous instalment, I
talked about the very real
danger facing the SVG 2 standard:
although it contains some
extremely useful new features,
lack of buy-in from the browser
vendors threatens the very future
of SVG as an independent
standard. As individual users,
there’s little we can do to
influence the outcome, but one
thing we can do is to start putting
documents online that use some of
the SVG 2 features, to prove that
there’s a demand for them. Short
of hand-coding documents,
however, this limits us to those
features that have support in the
authoring tools – which, practically,
means those supported in
Inkscape.

who you ask). To follow along,
you’ll need a copy of Inkscape 0.92;
see the previous article for some
hints about installing it.

full circle magazine #1 1 9
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selected, however, a double-click
will apply the mesh to only one of
them, with the others becoming
de-selected. Click-dragging the
mouse, on the other hand, applies
separate meshes to each object.
You don’t even have to drag over
the objects themselves, so, if
you’ve got a particularly busy
drawing, you can simply drag over
a blank bit of canvas around the
periphery to have the same effect
without any risk of accidentally
affecting other elements.
Whichever approach you take,
your object will now be filled with
a grid of nodes and connecting
lines, dividing the area into the
number of rows and columns you
selected in the tool control bar.
Each node is given a color,
alternating
between the
fill color and
white, to
give a result
something
like this:

contents ^

HOWTO - INKSCAPE

In this case there are nine
nodes. With the Mesh Gradient
tool active, you can click on an
individual node to select it, a
connecting line to select the nodes
at each end, or you can drag over a
number of nodes to perform a
rubber-band selection. You can
also use the Shift key to add nodes
to the selection, or remove them
from it. With one or more nodes
selected, you can use the swatches
at the bottom of the window, or
the Fill & Stroke dialog, to assign a
color to them. Setting each node
to a different color immediately
lets you create complex gradients
that would have been extremely
tedious to create with earlier
releases of Inkscape:

As well as giving each node a
different color, it’s also possible to
move them around by dragging
with the mouse, allowing you to
set the color at any point on your
object, not just the regularly

spaced ones that you’re initially
provided with. Dragging the edge
nodes inside the object leaves
empty gaps around the edge;
there’s no notion of repeating
gradients here. Dragging those
nodes outside simply cuts off the
fill at the edges.

that there’s no longer any conflict
between node and gradient
editing. If you do want to be able
to edit gradients with the Node
tool, however, you can work
around the co-located handle
problem by switching to the Mesh
Gradient tool, toggling the
Show/Hide button(s) to turn off
the visibility of the gradient nodes
While we’re in the vicinity of the and handles, and then switching
Show/Hide Handles button, it’s
back to the Node tool to make
worth mentioning the buttons to
your changes.
the right of it. First are a pair of
buttons to show and hide the
Moving on from those buttons
editing nodes for fill and stroke
there’s one with a warning symbol,
gradients respectively. Depending intended to make it absolutely
Halfway along the tool control on your preferences, gradients can clear that the Mesh Gradient tool is
bar you’ll find a toggle button for (to some extent) be modified while still slightly experimental. Click on
the Node tool is active, which
showing and hiding the nodes’
it and you’ll be presented with a
makes it easy to tweak your
handles. With this active, you can
dialog that tells you the SVG
gradients
by
just
double-clicking
use the handles to control the
syntax could still change, and that
on your object. The nodes and
shape of the paths that join the
“Web browser implementation is
nodes, and therefore fine-tune the handles of the gradient, however, not guaranteed”. That’s quite the
can interfere with the handles you understatement!
precise shape of the gradients
might usually use to manipulate
within the mesh. Long-time
your object. In the case of a
readers of these articles may
Finally on the toolbar is a droprectangle, for example, the default down menu to select the algorithm
remember that early instalments
positions of the mesh nodes put
presented a variety of different
used to interpolate the colors
them
directly
on
top
of
the
handles
ways to create a circle in Inkscape.
between each node in the mesh.
Mesh Gradients add another to the for resizing the rectangle or
“Coons” mode uses linear
changing the radius of the corners. interpolation to ramp from one
armoury, although you’re more
One solution is to double-click the color to the next, but this can
likely to end up with something
Node tool to access its
circle-ish than a mathematically
result in visible banding at the
preferences, then uncheck the
correct shape.
boundaries between patches (a
“Enable gradient editing” option so phenomenon known as “Mach
full circle magazine #1 1 9
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Banding”). “Bicubic” mode uses a
non-linear interpolation which
results in smoother transitions. In
the example below, note the
visible banding in the middle of the
green section on the left-hand
image (Coons), compared with the
smooth transition of the righthand image (Bicubic).

Now use the node handles to
curve the outer edges, whilst also
moving the inner nodes towards
each other until they’re all colocated at the center of your
shape. You’ve just turned your
mesh into a conical gradient –
something hitherto impossible to
create with SVG.

Now imagine, if you will,
creating a mesh of one row by
eight columns on a square object,
then moving the bottom nodes
upwards to give you a thin
gradient strip running along the
width of the shape. With a little
manipulation, you can bend the
strip into an arc, then even further
into a donut. The top nodes
become the outside of the mesh,
and the bottom row of nodes
becomes the inside. It would end
up looking something like this:

It’s not a “true” conical
gradient, of course. The XML
markup is way more complex than
would be necessary if SVG had
native support. For a start, the
center of the cone is defined not
by a single node, but by eight of
them stacked upon each other. If
you want to move the point – or
the bottom middle “node” (which
is actually two co-located nodes) –
you need to rubber-band select in
order to ensure that all the nodes
are moved at once. Otherwise your
cone will quickly deconstruct and
reveal the secret sauce behind it.

happens when you use the second
button on the toolbar to create a
conical gradient, rather than a
mesh gradient. The result may look
different – for a start it will
actually be circular, rather than the
rough approximation in my handconstructed version – but in reality
it’s still a mesh gradient, and if you
want to manipulate it or move the
nodes, you’ll need to treat it in the
same way as the manual version by
rubber-band selecting any colocated nodes. Don’t worry if you
move a single node by mistake
though; just CTRL-Z to undo your
edit, then rubber-band and try
again.

There’s a block of four icons on
the tool control bar that I haven’t
covered yet – although don’t let
that grouping fool you into
thinking that they share related
functionality. This is really just the
The reason for showing you this “miscellaneous” bin of the toolbar,
where odd buttons that don’t have
is that it helps to explain what
any friends are bundled together.
full circle magazine #1 1 9
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The first of these icons lets you
switch selected lines between
straight and curved modes.
Straight lines have no Bézier
handles, but behave a little more
predictably when you drag them
around, so sometimes it’s easier to
convert to a straight line, move the
nodes, then convert back to
Béziers for final tweaking. It’s how
I produced the manual version of
the conical gradient above. Note
that you use the same button to
switch back to Béziers – the second
icon might look like it’s the right
one for the task, but it’s not.
Rather, the second button will
change the length (but not the
angle) of the Bézier handles of any
selected nodes, in order to make
the paths form an ellipse, if
possible. This may seem like a
rather arbitrary thing to do, but it
does make it easier to smooth the
transitions between different
parts of your
mesh,
simplifying the
creation of
gradients like
this:
contents ^
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The third button is intended to
save you a little work if you’re
using mesh gradients to reproduce
the tones of an existing image.
Clicking it causes any selected
nodes to take on the color of the
object behind them in the z-order.
Consider trying to create a vector
representation of a bitmap image:
you can drag the nodes around to
position them over key points in
the image, press CTRL-A to select
all the nodes, then click the button
to set them to the respective
colors. In this example I’ve used
this technique to “trace” a bitmap
image of a red pepper:

The mesh in this case was
1 0×1 0, but even then there aren’t
enough nodes in some areas to
capture the details – the green
stalk at the top is perhaps the
most obvious example. This is an
unfortunate limitation of mesh
gradients: there’s no way to
subdivide individual patches in the
mesh, to allow for fine detail

where it’s needed, while retaining
broad swashes of color elsewhere.
The workaround is to stack several
meshes on top of each other, but
this then becomes harder to
manage.
If you do need more detail it is
possible to split a row or column in
two, creating more patches to
work with. With the Mesh Gradient
tool active, double-click on the line
connecting two nodes and an extra
set of nodes and lines will be
inserted. Remember, though, that
the operation affects the entire
row or column, not just a single
patch, so potentially adds many
more nodes than you actually
need. Currently there is no way to
delete a row or column, so it’s
usually better to start with a
slightly coarser mesh than you
need and then split to add more
nodes where you need to, rather
than be stuck with an unnecessarily
fine mesh that you can’t simplify.
The last rogue button in the
toolbar is used to address a small
deficiency in the mesh gradients
implementation: they don’t track
changes to the bounding box of
your object. This is easiest to
demonstrate by creating a mesh
gradient on a square, then
full circle magazine #1 1 9

switching to the Node tool to
convert the square to a rectangle
by dragging the handle in the
bottom right. You’ll see that the
mesh retains its previous
dimensions.

so you might also want to post an
exported bitmap image until such
time as the browsers (hopefully)
catch up. Alternatively you could
try using the JavaScript polyfill
written by Tavmjong Bah (the
author of the mesh gradient code
in Inkscape):
http://tavmjong.free.fr/SVG/POLYF
ILL/MESH/mesh.html

Mesh gradients are just one
With the newly rectangularised feature of SVG2 that is at risk if
(that’s a word, right?) object
browser vendors can’t be
selected, switch to the Mesh
persuaded to support it. The only
Gradient tool and click on the final way that SVG will continue to have
button in the miscellaneous bin. Lo a strong future is if people use it.
and behold, the mesh is stretched Whether your SVG files use mesh
to suit the new bounding box of
gradients or not, post them online
the object.
and encourage others to do the
same.

I MAGE CREDITS

https://commons.wikimedia.org/wi
ki/File:Red-Pepper.jpg

That’s the new Mesh Gradient
tool in a nutshell. Now go ahead
and create SVG files filled with
meshes, and put them online for
Google to index! Of course you’ll
face the catch-22 issue that
browsers won’t know what to do
with the new content in your files,
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Mark uses Inkscape to create three
webcomics, 'The Greys', 'Monsters,
Inked' and 'Elvie', which can all be
found at
http://www.peppertop.com/
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s you may have read
elsewhere (you do read the
rest of the magazine, right?), this
issue marks the 1 0th birthday of
Full Circle Magazine. As you may
also have read, that means that we
(the authors) have been given the
freedom to do something a little
different with our articles. So I’ve
decided to make a cake.

simply eat it with a nice cup of tea
or coffee to keep your spirits up
when Inkscape crashes for the
third time.
• Using the pointing device to
control Inkscape, and the monitor
to see the result, draw a cake.

Ingredients:
• One computer, suitable for
running Inkscape
• One recent version of Inkscape
• One pointing device, suitable for
controlling Inkscape
• A monitor, to provide feedback as
you make the cake
• (Optional) Artistic talent

We’ll construct our cake layer
by layer, starting from the bottom
and working our way up. But
before we can even begin to think
about whether we want a vanilla or
chocolate sponge, we’ll need a
platter for the cake to sit on. Start
by drawing an ellipse, then
duplicate it (CTRL-D) and move the
duplicate up a little using the
Now double-click on one of the
arrow keys.
straight lines to create an extra
node, then drag the two top nodes
to the left and right, so that they
touch the edges of the upper
ellipse to give the appearance of
straight sides. You may need to
To make it look less like one
zoom in to position the nodes
disk stacked on another, and more accurately, or enable snapping to
like a solid platter, we need to
smooth nodes (which will also snap
straighten the sides of the bottom to the quadrant points of an
shape. Select it and convert it to a ellipse). If everything has gone

Luckily, I had all of the ingredients
already – with the exception of the
last one. That means that my cake
will be acceptable, if a little
ordinary: if you have some artistic
flair, I’ve no doubt you can make a
much tastier creation.
Method:
• Go to the shops and buy a real
cake. Use it for reference, or

What? You want something
more detailed. Okay then...
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path (Path > Object to Path, or
press CTRL-SHIFT-C). Double-click
on it to edit the nodes and you
should see that there are four
nodes. Drag a box to select the top
three, then convert them all to
corner nodes using the button in
the toolbar. You should now have
three selected diamond-shaped
nodes, and one square node.
Finally click the “Make selected
segments lines” button on the
toolbar to give you an elliptical pieslice.
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well, you should be faced with
something like this:

Switch back to the selection
tool, click on the background to deselect everything, and you should
find your shapes give the
appearance of a thin disc. You may
want to add a gradient fill to give it
more depth, but I’m going for a
fairly flat effect on my image
(that’s non-artist speak for
“getting highlights and shadows
right is a bit tricky!”). Instead, I
used a repeating linear gradient
running from white to light gray,
to give the impression of a simple
silver finish to the platter:

Building the first layer of the
cake is very similar. Start by
duplicating the top of your platter
then scaling it down (hold CTRLSHIFT as you drag the resize
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handles to get it to scale
proportionally from the center).
Give it a suitable fill and stroke
(I’ve decided on vanilla sponge),
then duplicate it, move it up with
the arrow keys (a bit further this
time), and repeat the steps above
to form a layer of cake. You might
want to bow the sides out a little
to give it a better shape, but
otherwise it’s just a variation on
making the platter.

attracted to the perfectly formed,
beautifully mirror-glazed,
geometrically precise offerings,
rather than those which look like
the chef may have accidentally sat
on them. When drawing an image,
however, a flat disc of jam lacks the
appeal of an overloaded cake,
gloopily dripping great gobs of
strawberry goodness from its
sides. So gloopy gobs it is for our
image. Which means more node
editing.

no sharp corners in our jam! Watch
out when removing nodes, as the
adjacent ones may be converted to
corners automatically. With a bit of
manipulation you should get
something similar to this:

more nodes to handle the
transition from vertical to
horizontal, but otherwise it’s the
same idea. With those additions,
here’s the cake so far – it’s starting
to look good enough to eat!

To really get a gloopy effect,
we’ll want to add some drips
Convert your jam ellipse to a
running down the side. The basic
path, but this time we’ll be working form of a drip is created by adding
with the bottom half of the shape, a couple of nodes to let you pinch
not the top. Select the bottom
in the “neck”, with one in-between
three nodes, leaving the top one
that you can drag down to form
As any competent pâtissier
alone, but don’t convert them to
the base of the droplet itself. Make
knows, a cake is only as good as its corner nodes this time: rather,
that center one into a symmetric
filling. We’ll go with the classic
press the INSERT key a few times
node to save yourself a little
combination of jam (“jelly” to US
to create more smooth nodes
editing work, and position all three
readers) and cream. Obviously,
between the existing ones. Click
to give you the desired
once we spread jam all over the
the background canvas to de-select appearance.
top of the cake, we won’t be able
them all, then start dragging
to see that top ellipse any more, so individual nodes downwards,
we may as well change its fill and
working from the center out, to
stroke to shades of red, and use it give the appearance of the jam
as the basis of the jam layer
flowing down the side of the cake.
instead.
Move some of the nodes to the left
or right, and add or delete some to
This is where a little psychology give it a more random appearance
kicks in: when presented with the
– dragging the paths rather than
dessert trolley at a fancy
the nodes can also help. Try to
A drip running all the way down
restaurant, we tend to be
stick to smooth nodes – there are
to the platter will need a couple
full circle magazine #1 20
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Despite my earlier avoidance of
highlights and shadows, there’s no
denying that the best jam has a
glistening surface that makes ours
look somewhat lifeless. An obvious
candidate for adding specular
lighting would be to use the filter
primitive of the same name – but
that’s probably overkill for the
result we’re looking for, and would
likely take a lot of trial-and-error to
even come close. For the comicstyle image we’re creating, hardedged highlights are frequently a
better choice, and can often be
made using copies of the very
shape you’re trying to highlight.
Start by duplicating your jam
path and moving the duplicate up,
away from the cake, by using
SHIFT-UP ARROW. The advantage
of moving it in this way is that the
final result can be moved back
contents ^
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precisely by pressing SHIFT-DOWN
ARROW, even if you’ve changed
the zoom level whilst working.
Remove the stroke from this copy.
Now duplicate the new copy (so
that you’ve got two duplicates of
the original, stacked on top of each
other), and give the top one a
contrasting fill. Holding the ALT
key, use the cursor keys to shift
the top copy slightly to the left
and down, so that you have a thin
slice of the underlying red path
peeking out at the right of each
descending loop.

quite right.

Fill & Stroke dialog, and select a
pattern fill, specifically the “Sand
(bitmap)” pattern. Depending on
the size you’re drawing at, the
grain of the image may be too
coarse or too fine, so, if necessary,
double-click on the object to gain
Repeat the jam layer, but with a access to the handles for scaling
pale yellow fill color to represent
the pattern. These appear as a
cream. Highlights don’t work so
cross, circle and square, anchored
well on something so pale, so,
to the top-left of the page. Use the
instead, create some lowlights –
cross to reposition them, if you
shifting your duplicate in the
wish. Dragging the square will
opposite direction, and using a
change the scale of the pattern,
slightly darker fill color to add a
whereas the circle will let you
subtle shadow to each glob of
rotate it (which you’ll need later
Drag a selection box around
cream. You can also give it a little
on). By the time you’re finished,
both duplicates (that’s why we
more depth by simply putting a
you should have a dark beige cake
moved them away from the main
dark duplicate below the cream
base completely covered by a
part of the cake), and ensure that
path and shifting it so that it peeks course, sandy duplicate. Select
the status bar shows two paths are out ever so slightly.
both, then use Object > Mask > Set
selected. Now use the Path >
to reduce the pair to a single,
Difference menu entry to remove
blobby, brown shape. Move it back
the top shape, leaving only those
down over the cake, and use the
thin edges. Use SHIFT-DOWN
Page Down key (or the button on
ARROW to move the resultant
the toolbar) to drop it down in the
path back into place, then set its
z-stack until it’s above the cake
fill to white. Holding the ALT key,
base, but below the jam.
you can now use the arrow keys to
That’s the first layer of our cake
precisely position the highlights
pretty much finished, but there is
until most are in the right place.
one final trick that will make the
Now use Path > Break Apart to
sponge look more... well, spongey.
separate each highlight into its
Duplicate the beige sponge object
own object, making it easier to fine and move it up away from the cake.
tune them, by moving, editing or
Tweak the color to make it a darker
even deleting those that don’t look shade, then duplicate it. Open the
Repeat the steps above to
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create more layers of cake, jam and
cream. On your topmost layer, add
a little shadow to the front edge
by using Path > Difference
between two ellipses to create a
thin crescent of color which helps
to define the shape.

As this is a celebratory cake, it
should probably have a little more
decoration. How about some
sprinkles? There are a few ways to
approach this, but I opted to use
tiled clones (see parts 33 to 36 of
this series). My parent object was
just a short straight line which I
cloned into 1 0 rows by 20 columns.
Each row and column position was
randomised, as was the rotation of
each clone. Once I achieved the
sort of distribution I was looking
for, I unset the stroke on the
original object so that I could use
the Color tab of the Tiled Clones
dialog to set a random hue to each
sprinkle, giving me this result:
contents ^
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fill, it was possible to clone the
group and give each clone its own
individual color:

Grouping the clones, then
scaling the group vertically gives
the right sort of perspective
appearance. Clipping with an
ellipse results in a neat top for the
cake.

After placing the candles onto
the cake, there was one final step
to really make the image stand out:
in classic comic-strip style, I wanted
to give it a thick black outline. To
do this, I selected the whole image
and duplicated it, then moved the
duplicate well away from the
original. I deleted the sprinkles,
highlights and lowlights, since they
wouldn’t have an effect on the
silhouette. Then I repeatedly used

Edit > Clone > Unlink Clone and
Object > Ungroup – until the status
bar showed that there were no
more clones or groups in the
selection. Finally, Path > Union
joined all those separate objects
into a single shape, which I could
fill with black as a silhouette. I
moved it back over the original
image, gave it a thick black stroke,
then sent it to the back of the zstack.
So here’s the result of all that
work: Happy 1 0th birthday Full

Circle Magazine!

As this is specifically a birthday
celebration, candles are also in
order. I began by creating a single
candle using the same basic
techniques of drawing primitives,
converting them to paths, and
tweaking the shape using the node
handles. To add stripes to the
candle, I used the same approach
(of a patterned fill masking a flat
color) that I used for the texture
on the cakes. This time the fill was
“Stripes (1 :1 ) White”, and I used
the previously mentioned pattern
adjustment handles to not only
scale, but also rotate the pattern.
The object behind was given an
“unset” fill, then the whole candle
was grouped. Because of the unset

Mark uses Inkscape to create three
webcomics, 'The Greys', 'Monsters,
Inked' and 'Elvie', which can all be
found at
http://www.peppertop.com/
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rior to last month’s
celebratory distraction, I was
advocating that readers should
install Inkscape 0.92 and begin
posting files that use its SVG 2
features online, as a way to help
show the browser vendors that
there is a demand not only for SVG
on the web in general, but for a
format that lives and grows to
encompass more capabilities than
those that were baked into the
specification over 1 5 years ago.
The release of 0.92 also offers an
option to turn off “spacebar
panning”, which was my biggest
complaint with 0.91 . So, I have
finally retired my old 0.48 system
and move entirely to 0.92. Which
gives me a prime opportunity to
spend a few months introducing
some of the new features of 0.91
and 0.92 that I haven’t covered in
any real detail to date.
Many of the changes from 0.48
aren’t things that are directly
reflected in the user interface: the
usual round of performance
improvements, bug fixes and
compatibility tweaks don’t always
make for headline news, but are

vital to the stability and
capabilities of the program,
nevertheless. But I’ll be
concentrating more on the new UI
features that, as a user, will most
affect your day-to-day use of
Inkscape. I’ll begin with a
completely new tool that can be
found on the main toolbar, just
after the Zoom
tool: the
Measure tool
(also referred to
as the
Measurement
tool).

soon as you switch to a different
tool, the measurement disappears.
The new features in 0.92 include
some slightly clunky workarounds
for both of these issues, but it’s
still not the same as the sort of
dimensioning tool you would find
in a fully fledged CAD application,
as will become clear.

the line segment, whereas the
annotation at the end shows the
total length of the line. On a blank
canvas, these will show the same
value, as there’s only a single line
segment to consider.

If you now click the mouse
somewhere else, the starting point
of your line will move to the
With the tool active, start by
location you click on. This can be
clicking and dragging a line on your useful for taking several
canvas. You’ll see that there’s a
measurements from the same
blue line that follows the mouse,
datum point, but it does seem
and red lines marking out its angle counter-intuitive to me that it’s the
from the horizontal. There doesn’t start that moves, not the end. If I
seem to be a way to measure the
wanted to take several
You can, of course, activate this angle from the vertical, let alone
measurements from the same
tool by clicking on the button – or any other arbitrary datum line.
point, I would naturally expect to
you can use the keyboard shortcut, Your line will also be annotated
click first on the common datum,
which is “M” by default. This tool
with its overall length, which could and then click on each point I wish
had limited utility in 0.91 , but
appear on it twice, depending on
to measure. Instead, Inkscape
gained a lot of extra features in
your settings. The midway
requires you to drag from the first
0.92, so I’ll be describing the latter. annotation shows the length of
point back to the datum, and then
In either version, at its simplest,
click on each subsequent point.
the Measure tool does exactly
You can also drag the handle at
what you would expect: it lets you
either end of your line to move it
measure the distances, and angles,
to a different location, so if you’re
between parts of your drawing. In
happy to drag rather than click you
its basic mode, the measurements
can use that approach to work with
are ephemeral – you can make only
the datum as the first point.
one measurement at a time, and as
full circle magazine #1 21
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As you might imagine, holding
CTRL whilst dragging the initial
measurement will constrain it to
particular angles based on the
rotation steps setting in the
Inkscape preferences. This is
particularly useful to limit your
measurements to the horizontal or
vertical direction. It doesn’t work
so well when dragging the
endpoints around, though, as it
tries to constrain the angle of the
measurement, not the direction of
your mouse movement, which isn’t
always what you need.
The labels themselves can be
modified a little using the first few
widgets on the tool control bar:
Font Size and, at the other end,
Units, are pretty self-explanatory.
Precision dictates the number of
decimal places that are shown. The
Scale control adds a multiplication
factor to all your lengths; setting
this to 50% will halve the values
shown, whereas 400% would
quadruple them. It’s intended for
use where your drawing isn’t a 1 :1
representation of the original,
although it would be useful to

have a mode that lets you set this
value by measuring a line and
entering its real length. That would
make it much easier to trace a
bitmap diagram, where the actual
scale is not known but one of the
original lengths is. Instead you’ll
have to place your measurement,
then adjust this control iteratively
to suit. For most uses, however,
just leaving the scale at 1 00% will
be fine.
I mentioned earlier that
drawing a measurement on a blank
canvas only shows a single length.
What happens if we draw on a nonblank canvas instead? Here’s the
result of drawing a horizontal line
with arbitrary start and end points,
over a couple of shapes:
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Notice how Inkscape, rather
cleverly, marks the length of each
segment of the measuring line
between the points at which it
crosses other shapes. It also shows
the overall length of the line. But,
in this case, my endpoints were
arbitrarily chosen, so I’m probably
not terribly interested in the fact
that the line extends 1 3.90mm to
the left and 28.64mm to the right.
Back to the tool control bar once
more...

These four buttons determine
which points are considered when
working out the measurements.
The first has a tooltip of “Ignore
first and last”, and toggling that on
does exactly what it suggests: the
first and last points on the
measurement line are dropped
from the main part of the display,
making it clearer to see the overall
length of the section I’m
concerned with (though the overall
length of the measurement line
does still appear at the far right):

The second button on the
toolbar turns off the intermediate
measurements, making for a much
clearer display when you just need
the overall length between a
couple of points. The third button
has a similar effect for any
intersections that are hidden
behind other objects. By making
my topmost shape opaque you can
see the difference when this
option is toggled off:
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In this particular case, the result
is the same as if the second button
was toggled off, but that won’t
always be true. If you use the
measurement tool on a complex
drawing, with many overlapping
objects, the output can become
very hard to read if you don’t use
this button, or the next one, to
reduce the number of items that
are included in the measurement
process. As for that next button, it
simply determines whether the
measurement will be limited to
objects in the currently selected
layer, or in all layers. NOTE: If you
turn this button off, Inkscape will,
indeed, only show you
measurements based on objects in
the current layer, but the
measurements don’t update live as
you switch between layers: you
need to either make a change to
one of the tool controls (such as
toggling a button on and off
again), or adjust the position of
one of the endpoints of the
measurement.

The last few widgets on the tool
control bar offer some options for
extra things you can do with the
measurements:

The first button swaps the
endpoints of the measurement
line; in doing so it also switches the
angle being measured from the
inside to the outside angle (or vice
versa). No, I don’t know why it has
an icon that better represents
reflection than reversal.
The second button’s icon makes
a bit more sense: the camera takes
a “snapshot” of the current
measurement, allowing it to hang
around while you make a second
measurement somewhere else.
Despite the icon, however,
Inkscape doesn’t use the word
“snapshot”, preferring to refer to it
as a “phantom measurement”.
Whatever the terminology, it
renders your first measurement in
gray – both lines and labels – whilst
your second measurement still
uses the normal colors. This
feature does make it easier to
compare measurements, but you
can still only have one phantom
snapshot, and one live
measurement: if you click the
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button again, the existing phantom
vanishes, and the current live
version is converted into a
snapshot instead. In this example,
you can see that my previous
measurements have been
converted, and I also have a live
measurement going on at the
bottom:

The next button on the bar will
create guides that correspond to
the key points of your measuring
line. Be warned, this can easily
create lots of guides – you’ll get
one that follows the direction of
the measurement path, and a
guide for each labelled path
intersection that is drawn
perpendicular to the measurement
line. In addition, there will be a
horizontal and vertical path for the
endpoints of your line, though not
for the intersection points. It’s
important to use the earlier tool
control bar buttons to reduce the
number of intersections being
measured, especially if you’re
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working with a complex drawing,
otherwise you can easily end up
with way more guides than you
wanted. You can, at least,
immediately use Edit > Undo if you
do make a mistake with the
settings. If you want to remove just
a few of the guides, remember
that you only have to hover the
mouse over a guide until it changes
color, then press the Delete key to
remove it – a quicker option than
deleting via the guide’s dialog.

Should you need to see more
than two measurements at once,
the next button provides
something of a solution. Clicking it
will convert the current
measurement layout to a group of
real objects. You can then enter
the group and manipulate them as
you would any other shapes –
including deleting unnecessary
measurements or changing the
text of the labels. Because they’re
real objects, they’ll still be visible
when you draw another
measurement. But equally, as real
contents ^
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objects, they can be included as
crossing points in any
measurements themselves, should
your new line cross them, which
can lead to a confusing collection
of lines and labels on the screen.
One possible solution to this is to
put your converted measurements
onto a separate layer and turn off
the “Measure all layers” toggle.
You might think that this
button makes for a viable way to
mark up the dimensions on a
technical drawing, but there is a
(slightly) better method. The
penultimate control on the
toolbar, “Mark Dimension”, will
render a line with arrowheads at
either end which runs the whole
length of your measurement path,
but with a slight offset, the
amount of which is set by the last
control. The length of the
dimension will also be created as a
text object alongside the new line;
it’s larger than the normal
measurement labels, but can still
be adjusted by a relative amount
using the first control on the
toolbar.
At first this might seem like a
more limited choice than the
previous “Convert to item” button,
but, because it doesn’t create a

whole load of superfluous
elements, it can be used more
rapidly without requiring a lot of
cleaning up afterwards. The secret
is to use snapping when placing
the start and end points of your
measurement line, so that it
stretches exactly over the
dimension you wish to measure.
The orientation of the text will
depend on the direction of the
measurement path, so, if it’s
upside down, simply undo the
operation, click the tool control
button to swap the ends of the
path, then “Mark Dimension” once
again. You can quickly mark out a
drawing in this way, but do note
that, in the following example, I
had to enlarge the arrowheads and
draw the vertical projection lines
myself (the latter was made easier
with the Measurement Tool’s
“Convert to guides” option):

Perhaps the biggest limitation
of using this method to dimension
a technical drawing is that the
dimensions are just lines and text
objects, with no relationship to the
objects they measure. If you
change the size of an object, the
dimensions won’t update on their
own: you’ll need to either modify
or re-create them. This, combined
with the additional steps needed
to produce the dimensions in the
first place, is the main reason why,
for anything more than the most
basic of diagrams, you’re much
better off using a real CAD
program for technical drawings.
Handy, then, that FCM is running a
tutorial series on FreeCAD – the
program that I turn to myself when
I need to draw something more
technical than artistic.

Mark uses Inkscape to create three
webcomics, 'The Greys', 'Monsters,
Inked' and 'Elvie', which can all be
found at
http://www.peppertop.com/
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ne area of functionality that
has received a huge boost in
0.91 and 0.92 is finding and
selecting objects. There are many
situations in which you may need
to find similar, or identical objects
in a busy drawing, perhaps to
delete or change them all at once.
In previous versions, this was a
chore, especially if you had to
make the same selection multiple
times. So let’s look at the various
ways in which recent releases
make this easier. I’m going to use
this contrived grid of objects to
give you a feel for how the new
tools operate:

The first few items all live under
the Edit > Select Same submenu,
and offer several different ways to
select all items which share a
particular visual style. To use any
of them, you must first select one
or more objects whose close
relatives you wish to also select. As
a first example, if I select the teal
square at the top left of my grid,
then use Edit > Select Same >
Object Type, all the other squares
are selected. In my image I’ve given
the selected items a gold colored
background to make them stand
out a little better, but you won’t
see that in normal use.

One important thing to note is
that selecting the same “object
type” purely refers to the type of
underlying Inkscape object – so
squares and rectangles, or circles
and ellipses, are considered
equivalent. You can see this effect
if I select the green star on the top
line, then use Select Same > Object
Type. Not only are the stars
selected, but so are the triangles,
as they were all created using the
‘star’ tool.

Frustratingly, the select by type
option doesn’t work terribly well
with multiple items selected. If
every object in the selection is
full circle magazine #1 22
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already the same type, it will work
to select the other objects of that
type; but if any one of them is of a
different type then, rather than
selecting all the objects of either
type, everything is de-selected
instead.
Select Same > Fill Color has no
such problem: if I have both the
teal square and the green star
selected, then all the objects with
a teal or green fill will be selected
by the command.

Note, however, that selecting
by color is extremely specific: it
will only select items whose fill
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color is absolutely identical to your
starting object. There’s no way to
set a threshold, in order to select
all the items with approximately
the same shade of green, for
example.
There’s also a Select Same >
Stroke Color option, which does
the same thing, with the same
exacting requirements for a match,
but based on the stroke color
rather than the fill color. For
example, selecting the teal square
once again (before executing the
command) will select all the shapes
on the top and bottom rows; they
all have a black stroke, even
though the stroke thickness and
dashes are different between
them. Once again, starting with a
multiple selection will result in a
cumulative set of items whose
stroke colors match any of the
objects in your initial line-up.
The counterpoint to selecting
by stroke color is to select by
Stroke Style. This matches objects
only if they have the same stroke
thickness and dashes – including
the same dash offset, which seems
a little strict, in my opinion. Stroke
color, line caps, join type and
markers don’t seem to have an
effect, whereas the mitre limit

does. The choice of what
properties do and don’t contribute
to a “matching” line style seem
rather arbitrary and counterintuitive, which may limit the
usefulness of this option in many
situations.

<text id="text1178">
<tspan
id="tspan1180"
style="font-style:normal;
font-weight:bold;
font-family:Arial;

referred to as ‘attributes’. In the
<text> node, for example, the
id="text1 1 78" is an ‘id’ attribute,
with a value of “text1 1 78”. The
‘style’ attribute is a little special –
it holds CSS style data, which itself
takes the form of a list of
‘property:value;’ pairs.

Even more limiting, however, is
-inkscape-fontthe Select Same > Fill and Stroke
With that information in mind,
specification:'Arial Bold';
menu entry. This will match items
let’s take a look at the
fill:#000000;"
only with an identical stroke, but
Find/Replace dialog, with its
where both the fill and stroke
Options section expanded:
x="320.68646"
colors also match. It’s the digital
y="86.745667">
equivalent of a club doorman not
This is some text
only refusing entry for wearing
</tspan>
sneakers, but actually only
allowing entry to people with
</text>
exactly the same shoes as him, in
the same color and style – and only
XML represents a tree structure
then if they’re also the same size.
in text. Here you can see that we
have an opening <text …>
The next tool we’ll look at this
element, which gets closed by the
month is the recently souped-up
</text> line at the end. Inside of
Find/Replace dialog, which can be that is a single <tspan …> element,
opened from the Edit menu or by
again being closed near the end.
pressing Ctrl-F. The key to working Inside that is the text itself, “This is
with this dialog effectively is to
some text”. This is between the
understand that all it’s really doing opening and closing <tspan> tags,
is a search (and possibly a replace) but is not a tag itself. This piece of
of text within the XML code that
literal text is what XML refers to as
makes up an Inkscape document.
a ‘text node’, whereas <tspan> and
So, first, a quick recap on XML
<text> are ‘element nodes’. The
using a heavily abridged snippet of element nodes also have
code representing a text object in name=value pairs of extra data,
Inkscape:
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As you might expect from a
Find/Replace dialog, the first two
fields allow you to type in text to
be searched for and, optionally,
text to replace it with. The search
will match against substrings,
unless the ‘Exact Match’ checkbox
is ticked, so searching for “Fred”
will match against Fred, Freda,
Winifred and Alfred – although the
latter two will match only if the
‘Case Sensitive’ checkbox is
cleared. Interestingly, you can
search with this field left blank. As
you might guess, an empty string
matches against everything, but
the match is further restricted by
the choices in the ‘Object types’
section at the bottom. Usually you
would probably leave this set to
‘All types’, but, by setting specific
checkboxes and leaving the search
field blank, it provides a fast way
to select all the objects of specific
types – a workaround for the
Select Same > Object Type’s
restriction on finding only one
type at a time.

as ‘Properties’ in the Inkscape UI).
Use the former to search and
replace text content – handy if
you’re using Inkscape as a poorman’s desktop publishing program
(though I do recommend that you
learn how to use Scribus if you
need to do any significant text
layout work). Use the ‘Scope’
buttons, and the checkboxes in the
‘General’ section to limit your
search a little, if necessary.

unable to get it to work at all on
my test file. Use a ‘Style’ search
instead.
• Attribute Value – Search within
the values of attributes. This
includes searching the values of id
and style attributes, even if the
earlier checkboxes are blank.
• Attribute Name – Search for
elements with a particular
attribute name. Not as useful as
searching for values.

visible any longer. If you search for
“#ff0000” hoping to select all the
elements with a red fill, you’ll also
select the object with no stroke.
Although it might not be visible,
there will still be a color stored for
the stroke in the style attribute,
which is enough for it to become
part of your selection.

The second warning is with
regard to the ‘replace’ field:
performing a find and replace in
text mode is generally safe; doing
Switching the ‘Search in’ control
Usually, searching for an
so in properties mode could have
to ‘Properties’ provides a great
attribute value is sufficient. It will unforeseen results. Thankfully,
deal more power, if you’re
find matching IDs, styles and font Inkscape is sensible enough to stop
comfortable enough with the
you performing a replace
insides of an SVG file to know what names, without you having to
operation if the ‘Attribute name’
to look for. By ‘Properties’ it means understand how they’re stored in
the XML. Only if it finds too much, checkbox is selected, but
attributes and attribute values,
including CSS properties. Making a is it worth switching to search only arbitrarily replacing strings within
IDs or styles. Searching for
attribute values can be almost as
distinction between these terms
attribute names is never really
destructive. It might seem safe
might seem a little petty, but
necessary for normal users, but
enough to replace your black fills
understanding them is key to
might have its place if you’re using with white, by searching for
making effective use of this
Inkscape to work on graphics for a “000000” and replacing it with
section of the dialog. There you’ll
web application that carry
“ffffff”, but a series of six zeroes
find checkboxes to tell Inkscape
additional custom metadata.
could easily appear in the
which parts of the XML it should
coordinates of your objects, where
search:
Assuming the more common
There are a couple of things to hexadecimal values are an error
• ID – Only search the value of the
case, where a search string is
beware of when using this dialog in that could break your entire
‘id’ attributes.
entered, the ‘Search in’ radio
• Style – Search for CSS properties ‘Properties’ mode, however. Firstly, drawing. If in doubt, save a backup
buttons determine whether the
it can end up selecting objects you of your file first.
and CSS values within the value
XML text nodes will be searched,
didn’t expect. Consider an element
part of ‘style’ attributes.
or the attributes on the element
with a red stroke; later you change
Having used the previous tools
• Font – Presumably this searches
nodes (though the latter is labelled for only CSS font names, but I was the stroke width to zero, so it isn’t to make a selection, Inkscape now
full circle magazine #1 22
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also provides a way to save that
selection for later use. The Object
> Selection Sets… menu item
opens a rather empty dialog for
managing stored collections of
selections:

The most important thing to
note about this dialog is that the
“+” button at the bottom does not
create a set containing your
current selection. Instead it
creates a new, empty selection set
which has another “+” button next
to it. Only when you click this other
button will your selection be
stored in the set. The same button
can be used later to add another
selection to any existing items in
the set.
If you click on the triangle next

to a set, hoping to view the
elements within it, you’ll quickly
find that there’s a rather useless
intermediate level, labelled
“Items”, that you also have to
expand. If you click the triangle
next to the “Items” entry to
expand it, you’ll finally get to a list
of the objects in your selection.

Clicking on the cross next to an
item in the list will remove it from
the set. Clicking on a name in the
list will select it, whereas clicking
on the Set itself will select all the
items in that set. Unfortunately,
clicking on a Set doesn’t highlight
all the items within it, so, if you
want to re-select all the items
except one, for example, you have
full circle magazine #1 22

to highlight each entry separately
whilst holding the CTRL-key. You
can even use the CTRL-key to
select multiple Sets, or
combinations of Sets and
individual items. What you can’t do,
however, is select something from
this dialog, then add to (or remove
from) the selection by CTRLclicking on objects on the canvas,
which is a pity as it effectively
turns Selection Sets into a separate
selection mechanism rather than
something which integrates
seamlessly into your normal
Inkscape workflow.
Selection sets are preserved
when you save a document,
however they do get cleared when
the Edit > Clean Up Document
menu is used. Nevertheless, they
have their uses – for example, as
another means to work around the
restriction on Select By Type only
working with a single type at a
time. If you want to select, say, all
the circles and rectangles, you
could use the Select By Type
option twice, adding each resultant
selection to the same Set.
The new and extended
selection tools in 0.92 are a
welcome addition, especially when
working with complex documents.
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They do have their limitations and
idiosyncrasies, but hopefully they’ll
continue to mature in future
releases to provide even more
capabilities.

Mark uses Inkscape to create three
webcomics, 'The Greys', 'Monsters,
Inked' and 'Elvie', which can all be
found at
http://www.peppertop.com/

contents ^

A

H OW-TO

Written by Mark Crutch

frequently requested
feature, particularly from
users coming to Inkscape from
other vector tools, is a dialog that
shows a hierarchical tree of the
objects in a drawing. This is now
present, as of version 0.92, via the
Object > Objects… menu entry.
This feature was actually backported from Ponyscape, a fork of
Inkscape that is no longer being
developed, so bravo to the
Inkscape developers for merging it
back into the program, and thanks
to the original Ponyscape
developer for creating it in the
first place. Here’s what the dialog

looks like, with a few objects in a
drawing:

I n k s ca p e - P a r t 6 3

take a look at the canvas that
As for that “Collapse All”
produced that list:
button, what it actually does is
collapse every top level layer or
It shares some similarities with group except the one that the
the Layers dialog (see part 9 of this currently selected object is in. This
series), and can largely be used as is a common theme for this dialog
a replacement for it if you wish –
– right-click on an object in the tree
although I prefer the simplicity of and you’ll be presented with a
the old dialog. At the top is the
wide range of options in a context
hierarchy of objects in your
menu, in which several choices
drawing, with groups and layers
(those from the “Solo” and “Lock
displayed as collapsible entries
All” sections) actually work on topthat can be opened to reveal the
level layers and groups, regardless
objects within them, or closed to
of how deeply nested the object is
hide the clutter. The lower section that you clicked on.
provides buttons for adding layers,
deleting selected objects,
Each object is listed by its
“Collapse All” (more on that in a
“Label”, which was previously only
moment), and buttons for moving settable in the Object Properties
individual objects up or down in
dialog or the XML Editor. Now you
the list (which, in turn, moves them can simply double-click on the
up and down in the z-order).
entry in this new dialog to change
There’s a pop-up for selecting a
the label – a significant usability
blend mode – which can now be
Notice that the stars are
improvement. But unless you’re
easily applied to any object.
labelled as “paths”, as is the
fastidious about changing the
Previously, only layers could easily default labels assigned by Inkscape (clipped) spiral. The 3D box has a
have blend modes applied; other
label of “g3700”, because in SVG
(as I have done in the case of
objects required a trip to the filter “Orange Circle”) you could well be terms it’s actually a group, so
editor, so this is a welcome
in for some surprises. Take another Inkscape labels it as such. Which
addition. It’s also possible to set
path corresponds to which star?
look at the screenshot of the
the blur and opacity of the
The only way to tell is to select
Objects dialog, considering the
selected object, group or layer.
each one and see which object
labels of the objects there. Now
full circle magazine #1 23
29
contents ^

HOWTO - INKSCAPE

becomes selected on the canvas. I
hope that a future release of
Inkscape will add an extra column
to show the “Inkscape type” of the
object (e.g. star, spiral or 3D box),
and preferably a small preview
image of the object as well.
To the left of the object tree,
you’ll have noticed that there are
five other columns, with terse
titles that only make sense once
you’ve hovered over each of them
to read the tooltip. The first and
second should be familiar from the
Layers dialog – they toggle the
visibility and locked state of each
object. At last there’s an easy way
to unlock individual objects: many
new users have found themselves
tempted by the Lock option in the
Object Properties dialog, only to
then find that they could no longer
select the object to unlock it! The
third column, nominally “Type”,
holds an icon to indicate whether
the item is an object, layer or
group. As you may recall, SVG
doesn’t actually have a concept of
layers, so Inkscape implements
them as groups with some extra
metadata. An interesting extra in
this dialog is the ability to click on
the Type icon of a layer to turn it
into a group, or vice versa.
The next column is supposed to

show an icon to indicate whether
an object is clipped and/or masked.
In my screenshot, you can see the
effect on the clipped spiral,
however my copy of Inkscape does
not show an icon there for masked
objects, despite the claim of the
tooltip. In this case the icon is
purely informative; the dialog
doesn’t provide any additional
capabilities for working with
clipping paths or masks, so there’s
still no way to edit masks or some
types of clip paths without
releasing them first.
The last column is rather
specialised, and will probably be
rarely used. Within the Inkscape
Preferences (Edit > Preferences), in
the Tools > Node section, you can
set the default color used to draw
the path outline when the Node
tool is active. Typically this is set to
1 00% red on a standard
installation. The swatches in this
column can be used to set the path
color on a per-object basis. Clicking
on a swatch, then setting a color
with a non-zero opacity, will
change the color; set the opacity to
zero, regardless of the color, to
revert to the default set in the
preferences. This may occasionally
be useful if you’re editing an object
whose color is similar to the
full circle magazine #1 23

default, and you want to set it to
something contrasting, but that’s
really the only sensible use for this
option. You can see the effect on
the top two stars which I have
converted to paths, and changed
the outline color on the second to
blue:
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clicking on the label) and duplicate
it (the same as pressing CTRL-D).
The third item should probably be
called “New Layer” for clarity, as it
opens the new layer dialog
regardless of what type of object
was clicked on in the tree. This
seems like a pointless addition to
the context menu given that
there’s a dedicated button for this
on the dialog.

The “Solo” option takes its
name from music software, in
Let’s
which it is used to mute all the
take a look other tracks so that you can easily
at the
work on just one. In Inkscape, it
context
hides all the top level layers and
menu that groups, except for the one that the
appears
selected item is in. It doesn’t hide
when you other elements that are in the
right-click same group, so it acts as a literal
on any
“solo” option only if each of your
entry in
objects is in its own group or layer.
the object It should probably also be renamed
tree. The
to “Hide Others” for consistency
first two
with the “Lock” options that follow
entries let in the next group. “Up”, “Down”,
you
“Group” and “Ungroup” are fairly
rename
self-evident, but it is worth noting
the
that “Ungroup” is available even if
selected
the selected object is not a group
item (more or layer. The same lack of context
easily
awareness exists for the “Set Clip”
done by
and “Set Mask” options, which are
double
available even if you have only a
contents ^
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single object selected – they
require at least two objects in
order to work. Thankfully in all
these cases, the result of selecting
an option that is not valid is for no
change to take place, but it would
still be better if invalid options
were hidden or disabled in this
menu.
The new “Create Clip Group”
option is also present on the
context menu for an object but,
despite experimenting with it
myself and searching online, it
appears that nobody really seems
to know what it’s for, artistically
speaking. Choosing this option will
group any selected objects, then
clip them with a clone of the
group. Quite why you would want
to do this – and especially why
anyone wants to do it so
frequently that it needs an entry
on the context menu – is beyond
me. I can think of a couple of
esoteric situations in which this
kind of structure is useful, but
nothing that isn’t made clearer by
creating it step-by-step. If anyone
has any good ideas about this one,
please let me know!
Moving on from the Objects
dialog, 0.91 also introduced some
small UI improvements that can

have a big effect on how you use
Inkscape. The first is the ability to
enter simple calculations into
spinboxes (the numeric fields with
up/down arrows next to them). You
can use the usual symbols for the
main arithmetic operations of
addition (+), subtraction (-),
multiplication (*) and division (/), as
well as brackets to group parts of
the calculation. Any simple
numbers will be used in the current
units that are set for the field, but
you can also append a unit name
(e.g. “pt”, “mm” or “px”) to
individual numbers to have them
converted for you. For example the
following, when applied to a field
set as “mm”, will result in a value of
45.4mm: 1 0 + 1 in + 1 cm

for some time (see part 1 6 of this
series), but now there’s really no
need to ever use it, as you can just
append a relative offset to the end
of the existing value inside the X, Y
or Angle spinbox. I’d really like to
have a way to duplicate guides in a
future release, as this would make
it much easier to create a series of
them by just setting the first in
place then repeatedly duplicating
and adding an offset.
Although there’s no Duplicate
button, the Guideline dialog has
gained a few other features. It’s
now possible to name your guides
(the label appears in small text by
the anchor point), give them

Because the spinbox typically
shows the current value of the
parameter, you can often just tack
bits of a calculation onto the end,
then hit the RETURN key. Do you
need a field to be 50% wider? Just
add “*1 .5” to the end of its value.
Want to reduce it by 1 cm,
regardless of the current value?
Just append “-1 cm”.
One place where I find this
feature invaluable is when setting
guides. The Guideline dialog has
had a “Relative change” checkbox
full circle magazine #1 23
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individual colors, and lock them
against accidental movement. This
can make guides much more useful
when setting up a common
template page that might be used
as the basis of multiple similar
documents in future.
Another UI addition that is
particularly welcome is a new
section in the Inkscape
preferences for setting keyboard
shortcuts. You can get to it by
opening the preferences from Edit
> Preferences (or SHIFT-CTRL-P by
default), then drilling down to
Interface > Keyboard Shortcuts.
There’s a drop-down list at the top
to let you select from a range of
preset options, which could be
especially useful if you’re coming
to Inkscape from another product.
As has become the norm with
these kinds of dialogs in GTK
programs, setting a new shortcut is
done by highlighting the row you
wish to modify, then clicking in the
“Shortcut” column – either on the
existing shortcut, or the blank
space if there isn’t a shortcut
defined for the operation you’ve
selected. The field will populate
with some text that says “New
accelerator…” or something
similar, which is your cue to press
the keyboard shortcut you wish to
contents ^
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assign. Note that there’s no
warning if you use a shortcut that’s
currently assigned to another
operation – it will just be removed
from the old command and
assigned to the new one – so you
may wish to choose your shortcuts
carefully. If you want to remove a
shortcut entirely, press the
BACKSPACE key when prompted
for the new accelerator.

button at the bottom of the dialog
– where you’ll also find options for
importing and exporting shortcut
configurations, so that you can
back-up your highly customised
settings somewhere safe.

If things go completely awry,
you can change the shortcuts back
to the defaults using the Reset

Mark uses Inkscape to create three
webcomics, 'The Greys', 'Monsters,
Inked' and 'Elvie', which can all be
found at
http://www.peppertop.com/
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his month, we’ll be continuing
our look at some of the new
features of Inkscape 0.9x by
looking at the Symbols dialog. This
is a frequently requested addition
that allows you to create and
maintain collections of related
images that can then be inserted
into the current document as
necessary. Think about the boxes
and shapes in a flowchart, the
bubbles and word balloons in a
cartoon, or the component
symbols in an electronic circuit

diagram, and you’ll be on the right
lines.
The SVG format has always
allowed for symbols. They are
stored in the <defs> section of the
XML, where various definitions are
held that could be re-used
throughout the document. This is
where you’ll also find gradients
and filters, for example. Just
having a <symbol> element in this
section won’t actually render it on
the page, however. For that, you

have to include one or more <use>
elements which refer back to the
symbol. This screenshot of the
XML editor shows the basic idea:
the <defs> section near the top of
the tree holds a single <symbol>
element, which itself acts like a
group, holding all the various parts
of the symbol; meanwhile, at the
bottom of the tree you can see
three <use> elements, all of which
refer to the same symbol via the
“xlink:href” attribute you can see
in the right-hand panel.
There are two advantages to
this approach. The first is file size.
You can see that repeating all the
content of the <symbol> element
three times would take up more
space than simply referring to it
with <use> tags, and the more
complex the symbol the greater
the savings. The second is that
changes to the original symbol will
automatically propagate to any
instances of it in the document. If
that sounds a lot like clones then
you’d be right – clones are also
implemented as <use> elements,
except that the original target is
an object within the document
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body, not in the defs section. So, in
some regards, symbols can be
thought of as being clones whose
source object isn’t visible. If you’ve
ever found yourself hiding the
source of a clone behind another
object, or outside the bounds of
the drawing, you can probably see
the advantages. If, however, you’re
scratching your head as to why you
would ever need to hide the
source of a clone, read on.
Consider drawing a flowchart,
in which you want to use the
“decision” block multiple times.
The standard shape for a decision
block is simply a diamond, so you
might draw something like this:

You could use that one for the
first block in your chart, then clone
it for subsequent blocks, and
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everything is fine… right up to the
point where you decide to colorcode areas of the chart. Now some
of your decision blocks need a
different colored background, or a
different stroke. A simple clone
will no longer do the job. The
solution was described in detail in
part 30 of this series: you have to
unset the fill and stroke on the
original, then you can set them
individually on the clones.

dialog, though they’ll be fine when
some way – sneaking it behind
another element in the drawing, or inserted into a document.
placing it outside the bounds of
the drawing so that it doesn’t
appear in a web browser, or if you
export the page as a PNG image.
Arguably the most sensible
approach is to put it onto its own
layer, which you can then hide, but
it makes it more awkward to use if
you have to clone from it again.
In theory, Symbols should avoid
all these problems. But, in practice,
the Inkscape implementation
brings along enough quirks and
issues that it’s nowhere near as
straightforward to use as it should
be. Let’s begin by opening the
Symbols dialog via the Object >
Symbols menu (CTRL-SHIFT-Y by
default).

the stroke style.

In other words, it behaves
pretty much like a clone with unset
fill and stroke, but without the
Find the Decision symbol – in
original object being present on
my screenshot it’s the penultimate the page. But all is not perfect: try
shape on the top row. Note that
changing the stroke width and
each symbol also has a tooltip to
you’ll find it stubbornly stuck at
help identify it. Select the Decision one size, regardless of how thick or
symbol and then either copy it to
thin the UI claims it to be.
the clipboard (CTRL-C) and paste it
In fairness, this is an affliction
into your document (CTRL-V), or
that can also affect clones.
simply drag it from the dialog onto Although most of the stroke
Great! Now you can style each
You’ll probably see a rather
block exactly the way you want to. empty dialog with a pop-up menu your page.
properties are unset on the
But you also have the unset
at the top and some buttons at the
original object, it does have a
With the symbol selected in the stroke width defined, and no
original to contend with. The unset bottom. Using the pop-up, switch
document you should see that the amount of fiddling with the cloned
fill appears black, and the unset
to the pre-defined Flow Chart
status bar specifically identifies
stroke isn’t visible at all, so it’s
symbols. You can use the buttons
version will override it. The only
the object as a “Symbol called
unlikely that you can use it as a
at the bottom-right of the dialog
solution is to remove the stroke
Decision”. Duplicating, or copydecision block in your diagram as it to change the size of the
width from the original object,
stands. If you try to make it
thumbnails, and whether they are pasting it gets you another symbol, which in this case means modifying
as does dragging in an extra one
invisible, say by reducing its
individually scaled to fit, or all
the source symbol that’s in the
from the dialog. With one of your
opacity to 0, you’ll find all the
shown at the same relative size.
<defs> section of your document.
symbols selected you can change
clones disappear as well. So you
Note that the latter can result in
There are two ways to do this: the
the fill and stroke color, and even
have little choice but to hide it in
symbols that are cut off in the
easy way involving the XML editor,
full circle magazine #1 24
30
contents ^

HOWTO - INKSCAPE

or the tricky way via the GUI. Yes,
those sentences are the right way
round – somehow the Inkscape
developers have made GUI editing
of symbols so unintuitive that it’s
often easier to wade into the XML!
After opening the XML editor
(Edit > XML Editor, or CTRL-SHIFTX) and selecting one of the
symbols in my document you can
see that the relevant line is
highlighted in the left-hand panel
of the dialog.
The attributes on the right

include “xlink:href”, which tells you
the ID of the original symbol in the
<defs> section, prefixed by a
“hash” or “pound” character (#).
Looking at the left-hand panel you
should be able to see the symbol in
question (in this document it’s
actually the only symbol, which
makes finding it even easier).
Expanding the symbol using the
triangle on the left reveals the
elements inside it. Because this is a
really simple symbol, it’s easy to
guess that the element that needs
to be edited is the path. The
screenshot below shows how the
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XML editor looks with the symbol
expanded and the path selected:

the “Set” button to apply your
change. In this specific case the
end result is exactly the same, as
You can see that I’ve also
removing the entire text has the
selected the “style” attribute in the effect of also removing the
right-hand panel. Because this only attribute, rather than leaving it in
contains the stroke-width
place with an empty value. With
property, I could remove the entire
attribute by clicking on the “Delete
Attribute” button in the toolbar at
the top. In other cases, however,
there may be additional style
properties that you wish to keep.
In that case you need to select the
attribute, then edit the value in the
bottom-right panel before clicking
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that change made, you can now
close the dialog, return to your
symbols, and change their stroke
widths to whatever value you
choose.

<defs>. To edit a symbol, you have
to remove it from the <defs>
section and insert it into the main
document by selecting it in the
dialog, then clicking the second
button at the bottom left.
Of course you’ll sometimes
Confusingly this has a tooltip that
want to make changes to a symbol says it’s going to remove the
that go beyond just removing or
symbol from the current document
altering an attribute or two, and in – whereas the actual behaviour is
that case you have little choice but to insert the symbol, as a group,
to use the GUI method for editing into the document, removing it
it. In order to do that, however,
from the <defs> section and
you’ll first have to convert it from a therefore from this view in the
hidden object in the <defs> section dialog.
to a real object in the page. During
this feature’s early development,
The editable version that is put
this was done through a “Convert
into your page has far more in
to Group” menu option, which
common with a clone parent than
seemed to me to be a simple and
you might expect. Because it has
sensible approach. So, of course, it an unset fill and stroke, it will
was removed from the release
appear black, and if you select any
version.
of the symbols on the page that
were created from it, you’ll find
Instead you have to start with a that the status bar now declares
trip back to the Symbols dialog.
them to be clones, rather than
Switch the pop-up menu to
symbols. If you were to check the
“Current Document” – the same
XML editor, you’d find that they
view that was empty when you
haven’t changed – they are still
first opened the dialog earlier.
<use> elements with an xlink:href
Assuming you’ve added some
attribute that links them via an ID –
symbols to your document, this
it’s just that the object with that ID
view will now contain an image of is now in the page itself, not in the
each of them. You can think of this <defs> section. See, a symbol is
as being a sneaky view into the
quite literally just a clone parent
normally hidden world of the
that’s stored in the <defs> rather
full circle magazine #1 24

than on the page. This duality also
means that, if you do need to
convert an individual symbol into a
real object, Edit > Clone > Unlink
Clone will work.

early builds had a simple menu
option (“Convert to symbol”), but
with the release version we’re
stuck with confusingly tooltipped
buttons in the dialog.

You can now enter the group
and edit as you would normally.
You can add extra elements into
the group, change the shape of the
path, or explicitly set (or unset) the
fill and stroke to determine what
parts of your symbol can be
overridden when it’s used in a
document. If you examine the
Object Properties for the enclosing
group, you’ll find that it’s got a
title and ID (as well as some other
properties). Leave the ID alone,
unless you want to break the link
to any existing instances of the
symbol in your document, but feel
free to change the title to
distinguish your newly edited
symbol from the original. Finally,
with it still selected in your
document, use the bottom-left
button in the Symbols dialog (“Add
symbol from the current
document”) to insert it back into
the <defs> section of the
document. It also converts the
copy you’ve been editing into a
symbol – so you’ll need to manually
delete it if you don’t need another
one on your page. Once again, the

In practice you can turn any
group into a symbol. Inkscape
automatically creates an ID for
your group, but it’s probably best
to open the object properties and
set something more humanreadable, as well as giving it a title.
Then just select it and use the
bottom-left button in the Symbols
dialog to convert it. Don’t forget to
unset fills and strokes if you want
to be able to alter them for each
instance of the symbol in your
document.
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Once you have got to grips with
creating one or two symbols, you
might feel that you need an entire
set, whether it be symbols for
electronic components, crochet
stitches or, in my case, a handy
place to keep some cartoon
characters. All you need to do is
create all the related symbols in a
single document, then give it a
title in the File > Document
Properties dialog (Metadata tab).
Save the document to
/usr/share/inkscape/symbols (for
those you wish to share with other
contents ^
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users on the machine), or
~/.config/inkscape/symbols (for
use by a single user – though you’ll
probably have to create the
“symbols” directory). The next
time you start Inkscape, you’ll find
a new entry in the Symbols dialog’s
pop-up, showing the title you gave
to your document. Select it to gain
access to your own symbols.

shipped with Inkscape are okay as
a starting point, but somewhat
limited in scope. So if you do create
any symbol libraries that are
generally useful, then please
consider sharing them with the
wider community – it’s a great way
that you can give back to the
project without having to write any
code.

As this image shows, symbols
aren’t restricted to simple shapes
or single colors. Here I’ve got
complex groups of paths with a
variety of colors in each. It does
also show, however, that there are
still limitations: the sarcophagus
on the right is supposed to be a
shimmering gold color, but the
repeating gradient of the original
failed to make it into the symbol
version. In general you may find
similar issues with anything that
links to a definition in another part
of the document – such as
gradients, patterns, filters or other
symbols.
But the Symbols dialog is really
intended for simpler shapes – for
domain-specific tags, markers and
building blocks that might be
needed to annotate or create an
informative image, rather than an
artistic one. The standard symbols

Mark uses Inkscape to create three
webcomics, 'The Greys', 'Monsters,
Inked' and 'Elvie', which can all be
found at
http://www.peppertop.com/

full circle magazine #1 24

33

contents ^

