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  <h1 class="headline" id="sigil_toc_id_8">Drawing with Inkscape &ndash; Part 9</h1>



  <h2 class="author sigil_not_in_toc">By Mark Crutch</h2>



  <p class="text"><span class="capital">H</span>aving covered the use of groups in Inkscape, we're now going to move onto 'layers' &ndash; which are just like groups, but with a different interface for manipulating them. There's a good reason for the similarities between groups and layers: the SVG format has no concept of layers, so Inkscape actually implements each layer as a group with some extra bits of custom data.</p>



  <p class="text">There are three parts of the Inkscape interface that are used for managing layers: the Layer menu, a dedicated Layers dialog, and some quick access tools in the status bar at the bottom of the screen. Let's start with the Layers dialog which can be opened via the Layer &gt; Layers... menu entry, by pressing CTRL-SHIFT-L, or by using the View Layers button on the toolbox:<img alt="" src="Inkscape902.png" style="width: 23px; height: 20px;" /></p>



  <div class="photos"><img alt="" src="Inkscape903.png" style="" /></div>



  <p class="text">The layers dialog is fairly sparse, consisting of a list of layers at the top, and a few buttons and other widgets at the bottom. For a new file, only a single layer will be present, usually named &ldquo;Layer 1.&rdquo; Create a few objects in your drawing, and they will become part of that layer. Now try clicking on the little eye icon to the left of &ldquo;Layer 1,&rdquo; and you'll notice that your objects vanish. Click it again and they reappear. Click on the lock icon and you'll be prevented from making any changes to the objects in your layer. A second click will unlock the layer.</p>



  <p class="text">There are several ways to create a new layer, but the most obvious is simply to click the green + button at the bottom of the Layers dialog. You'll be prompted to give the layer a name, and pick a position for it. For now, let's call our new layer &ldquo;Layer 2&rdquo; and position it above the current layer.</p>



  <div class="photos"><img alt="" src="Inkscape907.png" /></div>



  <p class="text">The Layers dialog should appear much as you would expect, with two entries: &ldquo;Layer 2&rdquo; is at the top of the list and &ldquo;Layer 1&rdquo; is below it. The order of layers in the dialog represents their z-index within the drawing such that layers lower in the list will appear behind layers that are higher in the list. Check that &ldquo;Layer 2&rdquo; is selected and draw some more objects, ensuring that they overlap the previous objects from &ldquo;Layer 1&rdquo; and are in a suitably contrasting color. You should be able to see that your new objects are always drawn on top of the old objects. Using the arrow icons at the bottom of the Layers dialog, you can re-order your layers, which in turn alters the z-index of the objects in your drawing. You may recall that the contents of groups can't be interleaved, with each group occupying a single &ldquo;slot&rdquo; in the z-index. The same applies to layers: you can move them relative to one another, but their contents can't mix.</p>



  <p class="text">When creating a new layer you can use the Position pop-up to choose whether the new layer should be above or below the current layer. There is also a third option, which is to make it a sublayer of the current layer. Sublayers appear below their parent layer in the dialog, slightly indented. The parent gains a small triangle icon that can be used to show or hide the list of sublayers. In the same way that groups can be nested down to deep levels, so it's possible to add sublayers to sublayers &ndash; although going more than two or three levels deep is likely to confuse more than it helps. This image shows our &ldquo;Layer 1&rdquo; with the addition of three sublayers, two of which also have sublayers of their own, one of which is collapsed using the triangle button:</p>



  <div class="photos"><img alt="" src="Inkscape904.png" /></div>



  <p class="text">The order of sublayers within the dialog follows the same rules as for normal layers: the lower down the dialog a sublayer is, the lower down the z-index its contents will be in the drawing. From this, it follows that a sublayer's content will always appear&nbsp;below&nbsp;any content in its parent layer. Although this makes logical sense, it's often not what you want artistically, so I find that the best approach to using sublayers is simply to keep the parent layer empty of objects and construct an additional sublayer below the others to hold any background content.</p>



  <p class="text">The biggest advantage of sublayers is as a means to quickly hide several parts of an image at once. Considering our snowman from previous instalments, you could easily construct a parent layer to contain the snowman as a whole, with several sub-layers for each part of his body. Now you have the ability to hide or lock individual parts of him by using the icons next to each sublayer, or to quickly hide or lock the whole character using the icons by the parent layer.</p>



  <div class="photos"><img alt="" src="Inkscape908.png" /></div>



  <p class="text">You may recall that the previous instalment suggested grouping the various parts of the snowman together to create a single object that you can easily move around. So which is better, grouping or layers? As is so often the case, the answer is &ldquo;it depends&rdquo;. For something like the snowman I would tend to use groups: the ability to move the whole character as one is usually more useful than the ability to easily hide it. For the background of the image &ndash; the snow, sky and stars &ndash; I would probably use a layer: you're unlikely to move the background much, but you may want to hide it when working on the snowman, or lock it to prevent it accidentally being modified once you're happy with it.</p>



  <p class="text">Let's look at a real-world example. This is a comic strip I drew in 2010, together with the corresponding Layers dialog. You can download the Inkscape source file from the URL at the end of the article:</p>



  <div class="photos"><img alt="" src="Inkscape905.png" style="" /><img alt="" src="Inkscape909.png" /></div>



  <p class="text">Working from the top layer downwards, we first have a Frame layer which is locked. This is a thick black border that sits as the topmost layer in most of my comics and hides the ends of lines that extend outside the main image, meaning that I don't have to be quite so careful when drawing objects near the edge of the scene. Next is the text layer, which holds both the caption for this comic, and the box it sits in. That layer is also locked to prevent me accidentally moving it when editing other parts of the comic.</p>



  <p class="text">Below that is the Content layer. In many of my comics this is used as a normal layer in its own right, with all the main characters and props being placed directly into it. In this case, I wanted to be able to hide various parts of the drawing as I was working on it, so the Content layer is just a holder for various sub-layers. Inside each of those sub-layers the objects are grouped, such that the Towers layer contains three groups, one for each layer. That allowed me to move each tower individually, whilst still giving me the option to hide them all at once.</p>



  <p class="text">The Background layer holds everything else that's visible within the comic image, including the arena walls and hilly horizon. The Border layer, locked once again, holds a common border that I use with my comics which contains license information, the URL of my website and a drop shadow.</p>



  <p class="text">Those last two layers are particularly interesting because they both contain heavily blurred objects. Blurs are implemented as SVG filters, which will be covered in a future article, but at this stage it's useful to know that filters can be mathematically intensive, and can significantly slow Inkscape's redraw speed. One of the best ways to avoid this slowdown is to hide the layer that contains the filtered objects. Inkscape doesn't have to draw them, so it doesn't do the mathematical operations required, and it can render your image much more quickly.</p>



  <p class="text">When drawing a complex image, you may find that you need to move objects between layers. This can't be done from the layers dialog, but is instead handled from the Layer menu or a keyboard shortcut. Select the objects you want to move, and use Layer &gt; Move Selection to Layer Above (SHIFT+PageUp) or Layer &gt; Move Selection to Layer Below (SHIFT+PageDown).</p>



  <p class="text">Another option you'll see in the Layer menu is Duplicate Current Layer. This not only duplicates the layer itself, but also all the objects within that layer, including any sub-layers and their contents. Because the duplicated objects appear directly on top of the originals, it's not always obvious that copies have been created, so be a little careful when using this option. You can also duplicate layers directly inside the Layers dialog by using the context menu on the layer name. Although the context menu offers up a &ldquo;Rename Layer...&rdquo; option, it's usually easier to just click on a selected layer name which turns it into an editable field.</p>



  <p class="text">One odd omission from the context menu is the option for deleting a layer. This is available via the Layer &gt; Delete Current Layer menu entry, or by the red minus button in the dialog. Be aware that this will delete the layer and everything within it, including sub-layers, without any further prompting. If you do inadvertently delete a layer then all is not lost, as Edit &gt; Undo (CTRL-Z) will restore it.</p>



  <p class="text">Let's finish our tour of the Layers dialog with the controls at the bottom. The Opacity slider works in the same manner as the one in the Fill and Stroke dialog, but applies to all the objects in the selected layer. It's yet another of Inkscape's many ways of making objects invisible.</p>



  <p class="text">The Blend Mode pop-up defines how the selected layer is drawn with respect to the layers below it. Much like the Blur slider in the Fill and Stroke dialog, it's actually a shortcut for adding a filter. The blend modes on offer are Normal, Multiply, Screen, Darken, and Lighten &ndash; although there's rarely much reason to use anything other than Normal. I know of one artist who puts all the shadows in his images into a single layer which is set to Multiply, and I've also used the Multiple mode to produce an anaglyph 3D image of the space shuttle. In this image I've used that anaglyph space shuttle to demonstrate the differences between the blend modes, but the actual effect produced is highly dependent on the colours you start out with.</p>



  <div class="photos"><img alt="" src="Inkscape906.png" /></div>



  <p class="text">There's one aspect of layer management left to mention: the pop-up menu on the status bar. This allows you to quickly switch between layers and to hide, show, lock, or unlock the current layer using the buttons to the left of the pop-up.</p>



  <div class="photos"><img alt="" src="Inkscape900.png" /></div>



  <p class="text">The previous instalment introduced this pop-up in the context of managing groups. This is a side-effect of the fact that layers are just groups with a bit of extra metadata. In this case, the name in the button will actually be the internal ID of the group, and you can use the menu to exit a group by switching to a parent group, or straight to a different layer entirely. This can be particularly useful if you're in a deeply nested collection of groups as it provides a mechanism to jump back through several steps at once.</p>



  <div class="photos"><img alt="" src="Inkscape901.png" /></div>



  <p class="text">Beware, however, that using the Hide or Lock buttons when you've got a group selected can be dangerous, resulting in hidden groups that you can't easily reveal or locked groups that you can't readily unlock. For this reason I tend to only use the Hide and Lock buttons in the Layers dialog, or at least double-check that I'm not inside a group before using them from the status bar.</p>



  <h3 class="chapter sigil_not_in_toc">Links:</h3>



  <p class="text">The comics used in this tutorial, plus their Inkscape source files, can be downloaded from: <a href="http://www.peppertop.com/fc/"><span style="color: inherit; text-decoration: inherit;">http://www.peppertop.com/fc/</span></a></p>

  <hr />



  <div class="notice">

    Mark&nbsp;has been using Linux since 1994, and uses Inkscape to create two webcomics, 'The Greys' and 'Monsters, Inked' which can both be found at:<br />

    <a href="http://www.peppertop.com/"><span style="color: inherit; text-decoration: inherit;">http://www.peppertop.com/</span></a>

  </div>
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