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  Welcome to another issue of Full Circle Magazine.


  This month, we have an in depth article looking at the various pieces that make up GNOME themes. Once you've got your desktop looking pretty, we give you details on how you can create your own perfect Ubuntu install CD from that installation. We also have the next installment of Using GIMP, and the final installment of Create Your Own Server. Do you, the readers, have anything you want Daniel to discuss next? If so, email him at:: daniel.lamb@openyourwindows.com

  

  After last year's 'Christmas' edition furor, as an artist and art lover, I just want to say that this issue's cover - a painting depicting creation - is appropriate for an issue with an article on creating your own Ubuntu. It's an illustration. So, please, no emails on religion! They will be ignored.

  

  No articles means no magazine. Feel free to send us some articles. See the news pages for more info. You don't have to be a skilled writer. An article's content is what is most important.

  

  Although we have many translators bringing Full Circle to their native tongue, we could use more. So, if you would like to translate, please contact us. If there's an active group in your language, we'll put you in touch with them. If not, you can start a group. Don't worry, we're here to provide help, raw text and Scribus files.

  

  All the best,

  

  Ronnie

  Editor, Full Circle Magazine

  ronnie@fullcirclemagazine.org


  

  



  Command & Conquer


  Written by Robert Clipsham


  Now that you know how to navigate a command line, find out where you are, and how to list the files in your current directory, we'll show you how to manage your files using a shell. To begin with, open up a terminal and do the following:

  

  $ touch foo

  $ mkdir bar

  

  The first of these commands will create an empty file called 'foo'. This is often useful if you run a web server along with web applications, and are asked to create a file with the given name to prove you have permission to install the application. The second command is used to make directories, and here makes a directory called 'bar'. If you want to make sure these commands worked, you can use the command you learned last issue to see a list of files/directories within your working directory (No, I'm not going to tell you what it is!). Now that we have a file and directory to practice with, it's time to do something with them. The first thing I'll show you is how to make a copy of a file or directory.

  

  $ cp foo foo2

  

  This will copy the file 'foo' (which we created earlier) to 'foo2'. Now let's move our new file 'foo2' to the 'bar' directory, and at the same time rename it to 'foo'. To do this, we use the mv tool.

  

  $ mv foo2 bar/foo

  

  Notice how you can use the mv tool to rename files, as well as move them. If you just wanted to move 'foo2' to the 'bar' directory without renaming it, you could do either of the following:

  

  $ mv foo2 bar/

  $ mv foo2 bar/foo2

  

  As you are not renaming it, you don't need to append the filename to the directory, but you can do so, if you like to be sure what's going on. You need to be careful when using mv and cp, as they will overwrite any existing files you may have. This is not an issue with our practice files, but when you do it with real files, it could cause problems. You should back up before interacting with any files using the command line if you are worried about losing things. If you would like to be notified when your command calls for an overwrite, use the -i switch. For example:

  

  $ cp -i foo bar/

  

  If you did 'mv foo2 bar/foo' before, you will be prompted to make sure you want to overwrite the file. There are several other options that you might find useful which can be found in the man pages. One you may want is -v, which will show all files as they are copied or moved. You can use wildcards to copy or move multiple files.

  

  $ mkdir new-directory/

  $ mv bar/* new-directory/

  

  This will move everything from bar/ to new-directory/. If you would rather move the full directory, and not just the files and directories within it, use the same command, but without the '*'.

  

  Finally, let's remove all the example files using the rm command.

  

  $ rm -rf bar/

  $ rm -rf new-directory/

  $ rm foo

  

  Using rm with -rf causes rm to remove files and directories recursively, and to force removal without prompting. This is normally used for removing folders and all their contents. Be very careful that you enter the right file or directory when using rm; if you hit tab and don't look at what it has completed to, you could end up removing something you didn't want to! Make sure that if anyone is giving you support and tells you to use rm, you know what you're removing, especially if it has sudo in front of it. Don't forget to backup any important files, even if you think you aren't going near them!

  

  Robert Clipsham is a self confessed geek, whose hobbies include: programming/scripting, chatting on IRC and not writing his articles on time.


  

  



  How To

  Create Your Own Ubuntu


  Written by Laszlo Noficzer


  There are many articles on the Web about how to customize a Windows OS or a Linux distribution. On the Windows platform, you can use nLite for Windows XP or vLite for Windows Vista. There are similar programs for Linux that are able to create distributable live CDs based on your present system. The disadvantage of installing an original Ubuntu, or one of its derivatives, is that it includes a lot of applications and files which I never use. Therefore, I decided to build my own version of Ubuntu.

  

  Some weeks ago, I found an article about building a customized Kubuntu at www.howtoforge.com. The author's method is simple; use an Ubuntu server version instead of a desktop system because the former doesn't have a graphical interface. My problem is that you then have to change the kernel. This could result in a lot of possible errors. Furthermore, it is a Kubuntu system, which I don't like, so I changed KDE and KDM packages to GDM and to GNOME. The result was not exactly up to my expectations because I couldn't use X. User Daneey Forummate from www.prohardver.hu suggested the solution: I have to install the xfonts-base package separately (strange: I could bypass this step using KDE). Another recommendation, from n0_gAboR, also on www.prohardver.hu, changed my thinking.

  

  While reading n0_gAboR's recommendation, I learned that there is an Ubuntu minimal release. I found it at https://help.ubuntu.com/community/Installation/MinimalCD, and downloaded the x86 platform 32 bit version.

  

  Then, I made a virtual machine (see Luca De Marini's guide in Full Circle Issue 5 for using virtual machines) and booted the ISO. The Ubuntu bootscreen was a little bit strange for me:
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  As you can see in the picture, if I wanted a normal installation all I had to do was press ENTER. However, my target was to install a base system without GUI, so after the boot: prompt, I typed:

  

  cli

  

  This way, only the base system will be installed with command line interface. That way, I can choose what packages to install later. Also, I don't have to change the kernel. Best of all, the installed packages will all be the most up-to-date versions. Of course, for this type of installation, you should have a broadband Internet connection.

  

  The installation is very similar to the normal "alternate" installation, so I won't explain it here. If you're interested in this topic, you can read it in Issue #3. After the base installation had been finished, I rebooted and began to build up my own customized system.

  

  sudo apt-get install xserver-xorg gdm gnome-core xfonts-base xterm pmount gnome-mount synaptic -y

  

  xserver-xorg, gdm, gnome-core, xfonts-base, xterm, gnome-mount and synaptic are the parts of the GUI and the package manager while pmount is for mounting removable devices as a simple user. I used the -y option when installing, which means that all the confirmation dialogs will be answered with 'yes'.

  

  Before rebooting, it is often a good idea to have the build-essential package. If it is missing, you can be in trouble if you're trying to compile from source.

  

  sudo apt-get install build-essential

  

  It is not absolutely necessary, but I usually reboot at this point.

  

  sudo shutdown -r now

  

  After the first login, I saw this:
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  You can answer 'Delete' as we will solve this manually with the following command:

  

  sudo apt-get install fast-user-switch-applet

  

  Okay, let's see the next error:


  [image: ]


  This means that the Human GDM theme is missing:

  

  ls /usr/share/gdm/themes

  

  total 12

  drwxr-xr-x 2 root root 4096 2008-07-20 15:05 circles

  drwxr-xr-x 2 root root 4096 2008-07-20 15:05 happygnome

  drwxr-xr-x 2 root root 4096 2008-07-20 15:05 happygnome-list

  

  There are a lot of possible solutions. You can install the Human theme, a different one, or use the default theme – the choice is yours. I recommend installing a new theme because (I think) the basic GUI is ugly.

  

  As you can see above, there are three icons next to the System menu. The two application launchers are empty and Help is available from the menu, so I deleted these.

  

  Okay, now you have a base system with a GUI but no applications. The choice of what to install is yours, though I recommend using only free software as non-free can have legal complications. Only make a "clean" system, then let the user install all the additional programs, codecs and so on. I installed the ones I usually use with the following command:

  

  sudo apt-get install firefox-3.0 thunderbird openoffice.org flashplugin-nonfree sun-java6-jre sun-java6-plugin xpdf

  

  This installs Firefox, Flash, Java for web browsing, Thunderbird for email, OpenOffice.org for documents, and Xpdf for viewing PDF files.

  

  Now, for the core of the article: remastering your own distro. A user named Tony Brijeski (also known as Fragadelic) created the Remastersys program, which is able to backup an Ubuntu-based system or to make a distributable live CD. Unfortunately, Remastersys cannot be found in the official repositories, so you have to add its repository to /etc/apt/sources.list with vi, Nano, Gedit or Kate:

  

  ## Remastersys

  deb http://www.remastersys.klikit-linux.com/repository/ remastersys/

  

  Now refresh the package manager's known repositories and install Remastersys:

  

  sudo apt-get update && sudo apt-get install remastersys

  

  After installation, Remastersys is found in the System menu, not the Application menu. If you try to start it from the menu, nothing happens. The reason is obvious if you start it from the terminal – now you have the error:

  

  sudo remastersys-gui

  Cannot find either zenity or kdialog

  

  The zenity package enables communication for shell scripts over the GUI. If you do not want the GUI, you can start Remastersys from the command line without '-gui'. You will then get a little help about the usage of Remastersys. To use the GUI, I installed Zenity:

  

  sudo apt-get install zenity

  

  and started Remastersys from the GUI.
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  First, I always select the Modify option. This lets you specify some parameters, like the name of the ISO file or the description. After doing this, do not start to make your distribution yet, as some preliminary steps are needed. You do not want to put the installation packages of the programs you already installed on your ISO; this can cause oversizing (remember, you only have 700MB to work with). Therefore, run the following command:

  

  sudo apt-get clean

  

  Okay, now that you have cleared your system, start Remastersys again and select the Dist option. Remastersys will then begin to copy the files and folders and create the ISO. During this work, you can take a cup of coffee or have a lunch, as it will take a long time if you have installed lots of applications. Do not open any windows or run any programs while Remastersys is working.

  

  Once the ISO file had been created, it is recommended to test it in another virtual machine before burning it and redistributing it.

  

  If everything is OK, you should see something like the following during boot-up:
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  If you can see something like the screen shown left, you have your own Ubuntu distribution. Congratulations!

  

  Laszlo was introduced to the world of computers in the Commodore 64 era. He learned programming in secondary school and, following that, began working at a large IT company. He likes soccer (favourite club: AC Milan), reading Sci-Fi, playing video games and enjoys helping people who have IT problems.


  
    REMASTERSYS NOTES

    

    • Sometimes Remastersys will tell you the cdfs filesystem is missing. The first time, installing the build-essential package fixed the problem. The second time, only the reinstallation of Remastersys worked. It's possible there could be an easier solution, but I didn't find anything about this at the support forum.

    

    • If you start Remastersys from the command line, you will sometimes see this message:

    

    Recovery file "squashfs_recovery_filesystem.squashfs_12544" written

    If Mksquashfs aborts abnormally (i.e. power failure), run mksquashfs dummy /home/remastersys/remastersys/ISOTMP/casper/filesystem.squashfs -recover squashfs_recover_filesystem.squashfs_12544 to restore filesystem

    

    To prevent future problems, record the command. It cannot be found in the Remastersys log, so I strongly recommended that you record it or, if you started the program from the command line, redirect the standard output to a file. If you experience problems, you will have to use the command to restore it and you won't have to start the build again from nothing.

    

    • Sometimes, even though I set up a background image to my desktop, it didn't become part of the remastered system. I can only imagine that the problem was the picture was not in the system's place for background images.
  


  

  



  How To

  Create Your Own Server - Part 8


  Written by Daniel Lamb


  We are now going to add users to eGroupware and give them permissions to various items.

  

  To add a user, log into your eGroupware install with the admin user you created before. Browse to Admin, click on Admin, and fill in the boxes as you wish, I suggest putting a tick in the box "Never Expires". You can also give the users different permissions. You may want some to be able to view only emails, whereas you may wish to give full control to others. After adding a user, remember to click "Add".

  

  You now want to add a group. You can use the default group for everyone, or use the Admin group if you wish.

  

  You will see under Admin a large number of options depending on what you want to do. Go through the different options there, although the defaults should be fine for anyone to use. There are also preferences for which any users can set themselves. Again, the defaults are fine, but you might choose to change them depending on the use you have planned for them.

  

  A request I received from Philipp Hohn was how to connect Thunderbird and Lightning to eGroupwares ical server. To get a list of calendars (below), go to the URL: http://servername/egroupware/icalsrv.php/username/list.html
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  Ensure the user has permissions to use the ical server. You can do this via the User Accounts tab from the Admin menu, then click on the user you wish to have permissions for this, or do it via the groups menu. My user is called manager, so if I type in: http://server/egroupware/icalsrv.php/manager/list.html

  

  I get a number of calendars showing up. I want to use the main-events calendar, so in Thunderbird, under the calendar option (as long as you have lightening installed, there are loads of guides how to do this on the Web), I would simply right click and select New Calendar, choose 'On The Network' then enter the URL: http://10.0.165.15/egroupware/icalsrv.php/manager/events.ics

  

  Click 'Next' then choose your preferred name for the calendar. When prompted, enter the username and password for the account.

  

  We are now going to install Quotero Document Management System. Some of you may not use it, but in a business environment it is invaluable.
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  To do this we are going to drop to the command line again and enter the following command to download it.

  

  wget http://www.quotero.com/downloads/doc_download.html

  

  As it is automatically downloaded as an HTML file we need to rename it to a zip file and extract it. To do this, we type in the following commands:

  

  mv doc_download.html doc_download.zip apt-get install unzip unzip doc_download.zip

  

  You will now have a new folder called Quotero_Bundle_0.6. We want to move that file to /usr/share/Quotero. To do this, use this command:

  

  mv Quotero_Bundle_0.6/ /usr/share/Quotero -r

  

  As Quotero uses sh files you need to make them executable. Again, to do this for all the files type in the following commands:

  

  chmod +x /usr/share/Quotero/quotero_tomcat/bin/startup.sh

  chmod +x /usr/share/Quotero/Quotero.sh

  chmod +x /usr/share/Quotero/quotero_tomcat/bin/catalina.sh

  chmod +x /usr/share/Quotero/quotero_tomcat/bin/setclasspath.sh

  

  Quotero uses Tomcat Apache to run which depends on java so we need to install java and set it so tomcat knows it’s the default java environment. Do this by typing:

  

  apt-get install sun-java6-bin update-java-alternatives -s java-6-sun

  

  Now you can start Quotero with this command:

  

  sudo ./usr/share/Quotero/Quotero.sh

  

  Now browse to the URL for Quotero to continue the install:

  

  http://servername:8080/QuoteroDeploy

  

  All the default settings are fine except for changing the Database type to HSQL, leave the default Database Username, Password and Name as it is. Fill in the SMTP username and password. Then click Validate. It will now carry out the install for you. Once it has come up with the message 'Enjoy, click on Let’s go Quotero...'

  

  You can now log in using the URL:

  

  http://servername:8080/QuoteroClient/login.jsp

  

  and the username "admin" and password "admin". To add users, click on Administration, expand domains, then HQUOTERO, click on users. You can add new users here using the button Add. Under Special Roles you can add various users with different permissions for different tasks.

  

  Under Quotero Server v0.6, click on this button and choose New workspace, name it whatever you wish and add permissions for the various users you have created. By clicking on the button you can add a new folder by clicking on New folder, and call it what you wish, and add relevant permissions. You can now upload documents by clicking on the button next to the folder name and select Import Document. The Document will now be in the folder. You can now check out this document, open it just to view it or start a workflow involving the document (as well as a number of other options) or any others you add. You can check out a document then check it back in again, which will mean only one person can use it at a time. This is very powerful software and can save businesses a lot of time.

  

  This is your server finished. If there is anything else you wish me to cover or you have questions regarding anything to do with the server topic or open source software in business please get in touch.

  

  Daniel Lamb owns and runs Flonix IT Solutions and is based in Perth, Scotland. He is also involved in a number of open source projects such as Moon Secure AV, Kantaris Media player, and open live support. He is also a committed Leeds United fan.


  

  



  How To

  Using GIMP - Part 5


  Written by Ronnie Tucker


  This month, we will focus on sizes. GIMP can use several types of measurements for images. Create a new image by clicking File > New and let's examine some of the measurement types. If you can't see the X and Y resolution section, click the Advanced Options text below the Image Size and orientation.
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  Beside Image Size, you see width and height values. To the right of the height value you see a drop-down menu. In my case it is showing 'pixels'. Put simply, pixels are the small dots that make up your display. So in this case the image would be 640 pixels (or 'display dots') wide. Click the drop-down menu to see the other available options. Now, try clicking on inches.
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  See the values change? It is now only 8.889 wide. Why? Because we are now in inches. 8.889 inches wide is the same as 640 pixels wide.

  

  Why have these different measurements? If you were working on a banner which was to be used on a web site, for example, then you would need to create your image in pixels, say 400 wide by 50 high. But for print work, your image may need to be 8 inches wide by 12 inches high. Switch between measurement types as needed.

  

  Just below the Advanced Options text is the X and Y resolution. This is, by default, set at 72 pixels per inch, also known as dots per inch (DPI), and is sufficient for most computer display and web work. Think of DPI as being detail. The more dots per inch, the more detail you can put in the image. Be aware, however, that a high DPI can slow some PCs down and will result in much larger file sizes. For print work it should be set to about 300, but check with whoever is printing the image beforehand. If in doubt, use 300 DPI.

  

  So, with our new image (below), let's move on to rulers.
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  You'll notice that, at the top and the left side of the new image, there are rulers displaying the current measurement type, inches in my case. This allows for precise measuring and placement of items within the image. If I need a circle to start one inch down the page and one inch from the left, imagine how much trial and error it would take to get it absolutely right. It'd be almost impossible! But with rulers, we can be much more precise. Click on the top (horizontal) ruler and drag down onto the image.
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  You'll see a horizontal line (or ruler) appear on your image (above). This ruler does not damage your image in any way, it is merely a guideline and can be moved by clicking and dragging on it with the movement tool. Drag it back to where it came from to remove it completely. You'll notice in the information line below the image tells you exactly where the ruler is on the page (vertically in this case). Drag from the left (vertical) ruler on to the page to get another ruler one inch from the left (below).
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  Where those two rulers converge is where you would start dragging your circle out from.
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  I trust GIMP, I really do. But let's play Devil's Advocate and double check, using a different tool, to make sure there really is one inch between the ruler on the page and the edge of the image. For this, we need the Measurement Tool (below left).

  

  [image: ] This tool is like a tape measure. You click to create a start point, and click to create an end point (below). Between the two points, a red line is drawn. In the information bar (again, below the image) you'll see some numbers. These represent the length of the line, the angle of the line, the width of the line (from start point to end point) and the width of the line (again from start to end).
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  And from my measurement line I can see that the ruler is indeed one inch out. Good job GIMP! Clicking any other tool will remove the measuring tape from the screen.

  

  One last tool to cover in this section is the crop tool [image: ], which comes in handy for keeping a single, rectangular, piece of an image.

  

  Select the crop tool, then click and drag a box around the area you wish to keep (below).
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  This area can be moved by clicking and dragging inside the box, or resized by clicking and dragging on one of the inside edges of the box. Notice how the area outside the box darkens to focus your attention inside the box. Use the crop tool to remove uninteresting areas around photographs. Click inside the box area to crop the image.
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  See how cropping the image has forced you, the viewer, to focus on the patio step. Previously, you may have been focusing on the paving stones. If something is unnecessary in a photo, crop it out.

  

  Next month we'll focus on some of the more advanced tools used in touching up photographs.

  

  Ronnie Tucker is Editor of Full Circle magazine, a proud Kubuntu user, and part-time artist whose gallery of work can be seen at www.RonnieTucker.co.uk.


  

  



  How To

  Gnome-Look Guide


  Written by David D Lowe


  When I first joined the Ubuntu community, I was extremely impressed with the amount of customization Ubuntu had to offer. People posted impressive screenshots, and mentioned the themes they were using. They soon led me to gnome-look.org, the number one place for GNOME visual customization. The screenshots there looked just as impressive, but I was very confused as to what the headings on the sidebar meant, and I had no idea how to use the files I downloaded. Hopefully, this guide will help you learn what I found out the slow way.

  

  Wallpapers

  

  This should be self explanatory. Wallpapers are what you decorate the background of your desktop with. Click on a wallpaper, and then click on the download link, and save the image to the harddisk, say, ~/Pictures/Wallpapers.

  

  You may have noticed that gnome-look.org separates wallpapers into different categories, according to the size of the wallpaper in pixels. For the best quality, you want this to match your screen resolution. If you don't know what your screen resolution is, click System > Preferences > Screen Resolution. However, Ubuntu stretches wallpapers quite nicely if you picked the wrong size, so you needn't fret about it.

  

  SVG is a special image format that doesn't use pixels; it uses shapes called vectors, which means you can make it as big as you want without losing quality. Don't hesitate to use these.

  

  After you've finished downloading the wallpaper, simply open it in the image viewer, and click Image > Set as wallpaper.

  

  You can also set your wallpaper by right-clicking on your desktop and selecting the appropriate button (you know which one!).

  

  GTK: Controls

  

  Don't let acronyms intimidate you; you don't have to know what the letters stand for to know what it is. Basically, GTK is the system GNOME uses to display things like buttons and controls. GNOME is Ubuntu's default desktop environment. I will only be dealing with GNOME customization here--sorry Kubuntu and Xubuntu folks!

  

  Gnome-look.org distinguishes between two versions of GTK: 1.x and 2.x (x stands for any number). Ubuntu Hardy Heron can use both kinds, but I recommend GTK 2.x, as Ubuntu prefers this upgraded version.

  

  Before we continue, let me make an important distinction between GTK themes and GTK engines. Unfortunately, gnome-look.org categorizes both of them as theme/style, but you'll see why in a minute. GTK engines extend default GTK-theme functionality. They are like programs and are installed like programs: do a search for gtk-engines in synaptic and see for yourself. GTK themes style your controls; they usually depend on an engine. One engine can have lots of themes, and one theme can be re-done for several engines and made into several themes.

  

  The reason why gnome-look.org lists both as theme/style is because an engine usually comes with a default theme named after the engine. Clearlooks, for example, is the name of both an engine and a theme.

  

  All of the most popular engines are already installed by default in Ubuntu, so unless a theme's description specifically says it needs a specific engine, you don't need to worry about it. So pick a GTK theme and download to your hard disk. Then install by clicking System > Preferences > Appearance > Install. Click Customize and your new theme should be listed under the Controls tab.

  

  GTK themes are usually compressed with the .tar.gz filename extension.



  Metacity: Window Borders
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  Metacity is the program that displays window borders, basically the title-bar including the minimize, maximize and close buttons (above). Window borders are also called window decorations. Metacity is used by default in Ubuntu for all the window borders. Alternatives include Emerald, which I'll cover later.

  

  Metacity themes are pretty simple, for once :) . Just choose one, download it, and install it by clicking System > Preferences > Appearance > Install, and find it by clicking Customize > Window Border. That's it!

  

  Metacity themes have the .tar.gz filename extension.

  

  Compiz: Visual Effects

  

  Compiz Fusion is what's used when you enable visual effects. It has an insane number of options, which you can access by installing the compizconfig-settings-manager package from the repositories. All sorts of customizations for Compiz are shared on gnome-look.org in just one category, but I'll separate the main ones here:
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  Emerald themes: like metacity, Emerald is a window decorator (above). However, it has more effects then Metacity, such as transparent title-bars. It requires Compiz and is not installed by default. To use it, simply install the 'emerald' package from the repositories, press alt-F2, and type 'compiz - -replace' (that's two dashes). If you want to use this window decorator by default, launch Advanced Desktop Effects Settings (System, Preferences), click on the window decorations plugin, and change command to 'compiz - -replace'.

  

  Installing An Emerald Theme Is Easy: download it, click System > Preferences > Emerald Theme Manager, click 'Import' and open your downloaded file. Click on a theme to apply it. Emerald themes have a .emerald extension.

  

  Skydomes: Skydomes are background images for Compiz's cube plugin. Setting up the cube is beyond the scope of this guide but skydomes aren't. Simply download the skydome, click System > Preferences > Advanced Desktop Effects Settings > Desktop Cube > Appearance > Skydome and tick the 'Skydome' checkbox. Click on the open button to load your skydome.

  

  If your skydome doesn't load, don't worry, try another one. Compiz may refuse your skydome because it doesn't fit your screen, or because it is too big for your memory (I think!). Skydomes are image files so they have .jpg or .png file extension.

  

  Beryl

  

  Beryl used to be a competing project to Compiz, but now they've merged into Compiz Fusion, which Ubuntu uses by default, so I'll skip this section. Icons
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  Gnome-look.org divides the icon category into two sub-categories: Icons: these are just simple, single icons. You can find the GNOME logo here, for example. Icon themes: these interest us more. Each icon theme tries to customize a maximum number of icons on your system, so don't be surprised if your application logos your file type icons and your commonly used action icons change. Installing them is simple: just download an icon theme (or icon set), click System > Preferences > Appearance then Install and open your downloaded file. You can find your icon theme by clicking Customize > Icons.

  

  Icon themes are the biggest files on gnome-look.org, and they have the .tar.gz extension.

  

  GDM Themes: Login Welcome Screens

  

  GDM is the login screen system that comes installed by default in Ubuntu. If you're tired of the brown default one, or you want one with a face browser (shows a list of users), you can install other ones. Simply download one to your liking, click System > Administration > Login Window > Local > Add, and open your file. There are other options, such as randomly selecting a different login screen every session, which I'll let you explore.

  

  By the way, did you notice that the login preferences window didn't have the same theme as the one you have on your desktop? That's because you ran it as root, and root has its own preferences for its themes.

  

  GDM themes usually have the .tar.gz extension.

  

  Splash screens
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  Unfortunately, gnome-look.org doesn't distinguish between different types of splash screens (above), and incorrectly categorizes them all as GNOME splash screens, but I won't.

  

  Grub splash screens: if you have more than two systems installed, say Ubuntu and Windows, and are dual-booting, then on every boot you are shown a list to choose from. By default, Ubuntu uses grub, with a menu that is black and white and ugly. However, you can add a background image to the grub bootmenu so you can feel good from the first few seconds after you turn the computer on.

  

  Usplash splash screens: after you select Ubuntu from the grub menu, Ubuntu will proceed to load, while displaying the Ubuntu logo and a simple progress bar. You can replace this with another splash screen of your choosing. GNOME splash screens: some of you may remember the days when this was enabled by default. A small window would appear after logging in, showing the icons of programs being loaded. If you want, you can bring it back.

  

  First, make sure you have gnome-splashscreen-manager installed from the repositories. Select a GNOME splash screen and download it. Click System > Preferences > Splash Screen, click 'Install' and open your downloaded file. Make sure 'Show splash screen on startup' is ticked, and you're done!

  

  GNOME splash screens are images, and have .jpg or .png extensions.

  

  Desklets
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  If you have installed gdesklets from the repositories, then you might be looking for more desklets than the ones that came by default. You can find them here. Installation is as simple as downloading the file, and then clicking File > Install Package from the gdesklets manager. Gdesklets are simple desktop widgets that provide lots of different functionality.

  

  Gdesklets generally have the .tar.gz extension.

  

  Screenlets

  

  Screenlets is a more up-to-date widget system for Linux and competes with Vista gadgets, as well as gdesklets. Screenlets is available in the Hardy Heron repositories. Download a screenlet from gnome-look.org, and install it using the 'Install Screenlet' button in the screenlets manager. You should be getting used to this by now!

  

  Screenlets have the .tar.gz extension.

  

  XMMS themes
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  XMMS is a media player for Linux, and it has its own theme system. You can download some custom themes for it from gnome-look.org.

  

  Screenshots

  

  A place where people have uploaded screenshots of their desktops to show them off. We are, of course, impressed.

  

  Fonts

  

  Fonts are also called typesets. They determine what text looks like. Popular fonts you might have heard of are Times New Roman and Comic Sans MS. Both of these are Microsoft fonts and can be installed on your system with the msttcorefonts package from the Multiverse repository. Gnome-look.org has lots of truetype fonts to choose from. There are several ways to install them, the simplest being to just download a compressed archive of fonts and extract it to ~/.fonts (remember, that's a hidden folder).

  

  That should be enough for most systems. If you find that the fonts don't show up in any applications, run this command in a terminal, and restart the applications.

  

  fc-cache -f -v ~/.fonts

  

  Truetype fonts have a .ttf extension, and usually come in a compressed archive like .tar.gz.

  

  Clipart

  

  This contains clipart for GNU/Linux and other open source projects. See if you find anything that interests you here.

  

  System sounds

  

  These are collections of system sounds. Unfortunately, they're usually just a bunch of sound files, and you have to manually select each type of system sound for each corresponding file. To do so, click System > Preferences > Sound then the Sounds tab.

  

  The sound files are usually ogg files. Ogg Vorbis is a free-as-in-freedom alternative to restricted MP3.

  

  X11 mouse themes

  

  [image: ] Mouse themes change your mouse cursors, also called pointers. Download a pack, and install it using System > Preferences > Appearance > Install. You can find your mouse themes under Customize > Pointers.

  

  If you're running Compiz Fusion, you'll always want to tell it to use the same mouse theme. Click System > Preferences > Advanced Desktop Effects Settings > General Options, and change the value of the cursor theme field to the exact name of your theme. Make sure you respect case.

  

  Qt apps (KDE apps) use KDE's mouse theme. You can customize it by installing and running kcontrol. Mouse themes have the .tar.gz extension.

  

  Topaz brainstorm

  

  This is almost like brainstorm.ubuntu.com, except it's for GNOME. Plus it includes conceptual art. You can post your ideas and design documents here. 



  Cairo-clock themes
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  Cairo clock is a small clock widget that can be installed from the repositories. Its package name is cairo-clock. It basically transforms the look of your analog clock. Download one from gnome-look.org, open it and extract it to ~/.cairo-clock/themes . You will need to make that directory yourself. To do so, make sure you have enabled viewing of hidden files.

  

  Cairo clock themes are generally downloaded inside a compressed archive with the .tar.gz extension.

  

  Screensavers

  

  You should know what these are. Ubuntu comes with a lot of them by default. Just load System > Preferences > Screensaver to select one.

  

  Screensavers are actually programs, which means there are lots of different ways to install them. Just follow the instructions in the description and you should be fine.

  

  Lock dialogs are also under this category. A lock dialog is the window you see after you lock the screen, and you want to return to your session. You can customize this as well. Follow the instructions in each lock dialog's description. If it asks you to edit a gconf key, just run and use gconf-editor.

  

  Nautilus scripts

  

  Nautilus is the default file explorer that comes with GNOME and Ubuntu. When you click on Places > Home Folder, you're using Nautilus.

  

  You can extend Nautilus' functionality using scripts; think of them as extensions, if you like. Simply download one from gnome-look.org and extract the archive into ~/.gnome2/nautilus-scripts (remember to enable viewing hidden folders). That's it!

  

  Scripts don't have extensions, but they're usually contained inside a compressed archive: either .tar.gz or .tar.bz2.

  

  Conclusion

  

  Enjoy your new powers of customization! If you're still hungry for more, I'd like to mention art.gnome.org, ubuntu-art.org, docks like AWN, cairo-dock and Kiba dock, and my still-in-development project complete-look hosted on launchpad.net.


  

  



  Write For Full Circle


  Guidelines


  The single rule for an article is that it must somehow be linked to Ubuntu or one of its many derivatives - Kubuntu, Xubuntu,Lubuntu, etc.

  Write your article in whichever software you choose - I would recommend LibreOffice. But, please spell and grammar-check it!


  The Official Full Circle Style Guidecan be read at:


  http://url.fullcirclemagazine.org/75d471


  Please read this document before submitting an article. Follow the guidelines and you will have a much better chance of seeing your article in Full Circle.


  Writing


  There is no word limit for articles, but be advised that long articles may be split across several issues. In your article, please indicate where you would like a particular image to be. Please do not use any formatting in your document.


  Images


  Images should be no wider than 800 pixels, in JPG format, and use low compression.


  When you are ready to submit your article, please email it to: articles@fullcirclemagazine.org


  Non-English Writers


  If your native language is not English, don't worry. Write your article, and one of the proofreaders will read it for you and correct any grammatical or spelling errors. Not only are you helping the magazine and the community, but we'll help you with your English!


  FOR REVIEWS:


  Games/Applications


  When reviewing games/applications, please state clearly:


  
    	title of the game


    	who makes the game


    	is it free, or a paid download?


    	where to get it from (give download/homepage URL)


    	is it Linux native, or did you use Wine?


    	your marks out of five


    	a summary - with positive and negative points

  


  Hardware


  When reviewing hardware, please state clearly:


  
    	make and model of the hardware


    	what category would you put this hardware into?


    	any glitches that you had while using the hardware?


    	easy to get the hardware working in Linux?


    	did you have to use Windows drivers?


    	marks out of five


    	a summary - with positive and negative points

  


  You don't need to be an expert to write an article - write about the games, applications and hardware that you use every day.


  

  



  My Story

  Out With The New, In With The Old


  Written by Irv Risch


  We live in a world where just about everything costs money. Fuel prices are skyrocketing; food prices are going through the roof. I think you know what I mean. And wait until this winter when fuel prices hit our pocketbooks! Anyone who owns a computer knows the expense of owning one: the cost of hardware, software, Internet access and so on. The Linux world is a breath of fresh air. Well, I have my feet in two different computer worlds and I am finding out I like one much better than the other. Let me explain.
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  I had a laptop that died on me, so I went out an bought a new one (above). My old laptop was not running Windows but Ubuntu Linux. However, my new laptop came with Windows Vista. Luckily, after some repairs, my old laptop is now running fine. Therefore, when I say I have my feet in two different worlds, I mean I am using two different computer operating systems. Now, any Windows system costs money to run. Almost every time you buy or upgrade software or have to subscribe to anti-virus software for protection, it costs money. It's not that way with my Linux system. Everything is free, and I mean everything. The operating system is free, all the software is free, and I find I have no need to have virus protection because it is so secure. I have found only one problem: Linux sometimes does not like new hardware. My old laptop runs just fine with Linux, but my new one doesn't. But there is an interesting thing I found out: my new computer with Vista runs much slower then my old Ubuntu laptop, despite the hardware having lower specs (less memory and a slower processor).

  

  I know that many computer users are afraid of trying Linux because they don't want to learn how to do things all over again. Let me tell you I find enjoyment in learning and using new things, and that Linux was very easy for me to learn. Now that I have been using Linux for many years I dislike Windows, but I am afraid I am stuck with using Microsoft's OS because of my new hardware. I am torn between two systems. Do I keep using the one I don't like or do I go back to the old system that I do like (right)? I would love to be able to use my new laptop with Ubuntu but I have so many issues. The laptop I have is a Dell Inspiron 1521. I don't know if there is any one place I can go to find all the Linux drivers for this hardware or if upcoming releases of Ubuntu will address these issues with this hardware. I have trouble with the sound, Wifi card, video, built-in webcam, etc. My old laptop, which is a no-name, runs perfect with no need for third-party drivers. I wish hardware manufacturers would realize that there is more that just Windows in the world.
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  I did some Googling and found some stuff on the Southend Linux Wiki Site, but the news was not good for this laptop. Just a short quote from this site said, “Regrettably the Dell Inspiron 1521cannot (sic) run Ubuntu or LinuxMint Eyecandy although restricted drivers are installed and the hardware should support the extended features both Ubuntu and LinuxMint are capable of, for some reason none of the extended features on offer are available. This means despite the hi (sic) end graphics this laptop supports no cool cubes or wobbly windows quite a shame really.”

  

  My biggest issue was the wireless card. I did get it to work, but when I was on the road, I really had problems with roaming and finding an Internet connection. It was hit and miss.

  

  Well, in the end, I removed Ubuntu and went back to Vista on the new laptop. However, I am still using Ubuntu on the old one; for the time being, it will stay that way.


  

  



  My Opinion

  Ubuntu And Kubuntu Themes


  Written by Lance Arnold


  I have been using Ubuntu and Kubuntu for over a year now. I love it! I've been toying around with Linux since Mandrake 5, and it has taken me a long time to finally convert. I kept waiting for Enlightenment to really take off, but it never really hit a stage of completeness that I was looking for, so I have temporarily given up on it. Now to my point: I have some issues with themes on both GNOME and KDE 3. It is a challenge to get KDE themed if you don't know what to get, and it took me several days of hunting to find what needs to be installed in order to fully theme Linux/KDE.

  

  Here is what I have found that needs some work.

  

  KDE

  

  1. In order to theme the login manager you have to install KControl. Why is this not already available in the Look and Feel?

  

  2. The GRUB boot loader can be themed, but again, it's not an option by default in KControl. Why does it require an application to be installed?

  

  3. After downloading a theme, there is nowhere to apply it unless you know that it can be dragged and dropped on top of the settings window, or that you can go to the command line and use KControl.

  

  4. I also had to install Ksplash to change and theme the splash screen just after login, but before you hit the desktop.

  

  GNOME

  

  1. This one is a real challenge for me. First, I don't care for the dual bars, so it takes some time to get it configured to one.

  

  2. GNOME themes are a real chore to get installed and applied. I did get one to work, but it took me forever and is not a part of GNOME itself from what I can tell.

  

  3. Once I got my bars all setup I made it too small and now can't seem to find a way to click in an open space in the bar to make changes.

  

  4. I wanted to set the wallpaper as none and just use a color. However, this was not an option by default in Ubuntu 8.04. Was this intentionally removed?

  

  5. I could find no way to theme the splash screen after login but before you hit the desktop.

  

  There are other issues with themes but I would like to see more attention given to customizing the desktop, boot screen, login managers, splash screens, icons, window borders and menu. In my opinion it seems clunky, all the options are not in one location, some apps are hidden, or you need to install other apps to get things done. I did find that everything I needed is in the repositories. It just took some time to find out what I needed to install, and do.


  

  



  MOTU Interview - Jamie Strandboge


  Taken from behindmotu.wordpress.com
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  Age: 36

  Location: Rochester, NY USA

  IRC Nick: jdstrand

  

  How long have you used Linux and what was your first distro?

  

  I was introduced to Linux in 1997, and installed Redhat 5.0 on my home system in 1998. I started using Debian not too long after that.

  

  How long have you been using Ubuntu?

  

  Since Breezy.

  

  When did you get involved with the MOTU team and how?

  

  I became a MOTU in December 2007 and I got involved by reviewing universe security updates for sponsorship.

  

  What helped you learn packaging and how Ubuntu teams work?

  

  I learned most of what I know about packaging through my work on the Gnome 2.2 backport for Debian Woody from several years ago. I am a big fan of Debian Policy and package nearly everything I want to put on more than one computer. As far as learning how teams work, if I don’t know something, I read the wiki and ask someone if something isn’t clear.

  

  Favorite part of working with the MOTU?

  

  Easy – the people. It is very satisfying working with people who share the same passions and want to make Ubuntu even better!

  

  Any advice for people wanting to help out MOTU?

  

  Start doing the work, ask questions and most importantly, don’t be afraid to admit when you don’t know something or made a mistake. This gets back to learning how Ubuntu teams work–there is a lot to learn but one of the strengths of our community is that we have a tremendous collective knowledge base.

  

  You have been working on a lot of different packages in the last cycles, what are you going to focus on in Hardy?

  

  My priority is always security updates, but I am also working on the soon-to-be-uploaded ufw, ubuntu-cve-tracker, apparmor profiles, and network authentication (among other things).

  

  How do you think Hardy will be special for our users?

  

  As an LTS release, Hardy will provide polish and many improvements for all users. I am particularly excited about Ubuntu Server, as there is a great community surrounding it and lots of new features since Gutsy and especially Dapper.

  

  Favorite quote?

  

  I’ll give the first two that popped into my head:

  

  “Thou shalt love thy neighbor as thyself.” Leviticus 19:18

  

  “Do or do not… there is no try.” Yoda from ‘The Empire Strikes Back’ Words to live (and work on Ubuntu) by.

  

  What do you do in your other spare time?

  

  Hmm, ’spare time’. Well, Wikipedia says: “Leisure or free time, is a period of time spent out of work and essential domestic activity.” I find the idea of ’spare time’ intriguing and would like to explore it more.

  

  Seriously though, when not at the computer I spend time with my family, greyhounds, and playing music.


  

  



  Ubuntu Women


  Written by Elizabeth Bevilacqua


  [image: ]


  One of the most commonly asked questions from people interested in the Ubuntu Women project is: "How do I get my girlfriend/sister/wife/ mother to use Ubuntu?"

  

  Many answers to this question have been proposed over the years, ranging from creating a distribution of Linux for women, to creating more pink themes and wallpapers, to writing more applications targeted at women. In general, these suggestions were not successful in drawing vast numbers of women to the Linux world.

  

  The real answer is simply, "Just like you'd get anyone else interested!" Ask the woman in your life that you want to switch what applications she uses.

  

  Take out your laptop and show her the options available in Ubuntu.

  

  • Does she want to be able to customize the colors in GNOME to satisfy her love for the color green? From the System menu, select Preferences > Appearance, then click on a theme and click the Customize button and go to the Colors tab and make changes. Voila, custom green theme!

  

  • Does she want to play a great first person shooter? Show her how to use Add/Remove to browse games and install Open Arena. While you're at it, explain how she can do this for thousands of software packages, all for free.

  

  • Does she want a recipe manager? A quick Google search brings up the Gourmet Recipe Manager, which I highly recommend. The download page even has a .deb package that easily installs on Ubuntu.

  

  • Does she really get into music organization via iTunes? Have her give Amarok or Rhythmbox a spin.

  

  • Does she just want word processing, email, instant messaging and web browsing? Give her a quick tour of the default applications in a vanilla Ubuntu Desktop install and send her on her way.

  

  Keep in mind that throughout this process you want to keep her as engaged as possible. Show her how to install software, don't take the keyboard away when she gets stuck, and make her feel comfortable so she will be successful once you walk away. Women are humans too and Ubuntu was made for all of us.

  

  Elizabeth Bevilacqua is a Systems Administrator in Pennsylvania. She has been using Ubuntu since 2005 and became a member of the Ubuntu project in 2007. She currently leads the Philadelphia Linux Users Group (PLUG) and the Philadelphia Chapter of LinuxChix (PhillyChix).


  

  



  Letters


  A few years ago, while at University, a friend introduced me to Linux and explained what it was all about and most importantly at the time the fact that it was all free! I looked into it but my computer skills were lacking at the time and didn't fancy messing with something I didn't understand. Later after finishing Uni a good friend of mine introduced me to Linux again, but this time it was Ubuntu. By this time my computer skills had developed a lot and the whole Windows, virus, firewall, updates, insecurity, costly thing just annoyed the life out of me. So I repartitioned and installed Edgy and instantly I was amazed and couldn't believe how great it was.

  

  Then more recently (I became a teacher) the school I work for informed us (although seemingly inappropriate to the majority of staff) that the school would be losing some funding so wouldn't have as much money in the future. Upon hearing this, I spoke to a good friend of mine who is the school Web architect and admin Network Administrator about doing a trial of Ubuntu machines on the network. Since April of this year we have been trialing with just one machine getting it on to the network and working as a viable client. We are not there yet, and seeing as it is the summer holidays at the moment, it's on hold for now, we are still soldiering on. We hope to roll this out to the whole school in three or four years time, which ultimately means the school will save thousands on licenses for software, particularly the office stuff. So I decided to send in this letter, to show my appreciation of what the Open Source community and Ubuntu have done for me, and are doing for the school and for everyone who uses Ubuntu directly or indirectly. Keep soldiering on and fighting the good fight.

  

  Adam Watkin


  


  

  Just stumbled upon your link in UbuntuForums.org. I have been looking for something like this for a while now. The forums have news and other good content, but you have to look through pages and pages of threads to really get something good. It would be nice to have it all consolidated into one, convenient, PDF.

  

  I like the "My Desktop" section and want to try out new themes but still haven't figured it all out. Like what Metacity, Emerald, GTK and all that stuff means, and how to change it. I need to look through some of the old issues, but if you haven't had a how-to on themes, it would be a big help, as I haven't found a thread on the forums for complete beginners, and it is something that I could see many beginners struggling with. Keep up the good work!

  

  James Kolberg

  

  Ed: Hopefully this month's article from David D Lowe on GNOME-Look.org (page 18) will tell you everything you need to know.


  


  

  I have lost count of the number of times that I have helped new users install HP printers on UbuntuForums.org.

  

  For some unknown reason, the Ubuntu developers do not include the Python QT3 bindings when Ubuntu is installed, even though a HP printer is detected and HPLIP is automatically installed.

  

  In many instances, the standard Printer installer will detect and install the correct driver, but you cannot use HPLIP's toolbox utility to check for ink levels and for print head cleaning, because HPLIP requires the Python QT3 bindings to function.

  

  Here is a simple way to install HP printers the RIGHT way.

  

  1. Install the Python QT3 bindings. This can either be done using the Synaptic Package manager, but it is much quicker to just open a terminal and type in this command:

  

  sudo apt-get install python-qt3

  

  2. Before going any further, use the Synaptic package manager to ensure that HPLIP is installed. Just search for hplip and make sure that there are green ticks next to hplip, hplip-data and hpijs.

  

  NOTE: If you installed Ubuntu with your HP printer plugged-in they should already be installed.

  

  3. Next, after ensuring that your HP Printer is plugged into your PC and powered-up type this command into a terminal:

  

  sudo hp-setup

  

  After entering your password, a window will open and guide you through the installation. It will then print a test page.

  

  4. Now, type this command into a terminal:

  

  hp-toolbox

  

  A window will open, giving you access to all sorts of goodies, such as ink levels, head cleaning, queueing, etc.

  

  If HPLIP Toolbox is not in your System>Administration menu list, you can add it by navigating to System>Preferences>Main Menu and add it there.

  

  Roger Sanders


  

  



  Q & A


  Written by Tommy Alsemgeest


  
    	Q I want to install niwbillmanager-1.2. The documentation says that I need to install QT4, QT4 SQLite module and SQLite. I installed all three, but I've still no idea how to install niwbillmanager-1.2.


    	A As long as you have installed Qt 4, Qt 4 SQLite module, and SQLite, you have to compile, then install. To find out how to do this, have a look at the How-To in FCM #10.


    	



    	Q Being a mobile user, the main issue that drives me back to Windows XP is my 3G/HSDPA Novatel Merlin U740 card. Is there an application that can handle anything plugged into a PCMCIA slot?


    	A Unfortunately not. But for your Novatel Merlin U740, this page should be of help: http://ubuntuforums.org/showthread.php?t=253466


    	



    	Q I have just reinstalled Windows XP on my other partition, but now the Ubuntu bootloader doesn't come up, and I can only boot into XP. Is there any way to get Ubuntu back without reinstalling?


    	A Yes there is. First, start up the Ubuntu Live CD, open a terminal and type

    

    sudo grub

    find /boot/grub/stage1

    root (hd*,*)

    

    replacing the *'s with what you got from the find command.

    

    setup (hd0)

    

    And you're done


    	.


    	Q I have several MP4 files displaying the movie icon. If I open them in Totem Movie Player, it plays the music. But no video. A view of the files properties tells me:

    

    Type: MPEG-4 video

    Size: 39.3 MB

    Duration: 21 minutes

    Codec: MPEG-4 AAC

    Channels: Stereo

    Sample Rate: 44100 hz

    

    Audacity cannot import AAC files. What program will convert MPEG-4 AAC to MP3?


    	A You might want to give Avidemux a go. It is primarily a video editor/converter, but it can also save/convert just the audio, and should be able to save the audio to MP3.


    	

    


  


  My Desktop
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  My computer is a 4-year-old Compaq Presario SR1265 mini-tower featuring an AMD Athlon XP 3200 processor, 1 GB of RAM and an ASUS motherboard with Via KM400A chipset. I'm using the on-board S3G UniChrome video and AC97 audio. It has a 160 GB hard drive, both CD-R/W and DVD-RW drives and a raft of front mounted I/O ports. It came with a nice Compaq 17" LCD with a resolution up to 1280 X 1024. I'm dual booting the original Windows XP with Ubuntu 8.04. Windows is booted once a month or so to keep things up to date - some day I'll flush it or get another drive.

  

  David Rowell
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  I use Enlightenment DR17 with the BlackTheme, using the wallpapers: enrotacion, nixie, Zerg (by maidenjeanne) and Black_wall. If that seems like a lot, it isn't. It's one theme and four wallpapers, one for each desktop.

  

  David Smith
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  My laptop is my best friend, and I've chosen Ubuntu as the best operating system for her. She is a Dell Inspiron 6400 Vista/Ubuntu dual boot with Lintel video card and 1.5GB of RAM.

  

  I've been using Ubuntu since Ubuntu 6.06 and now I have the fantastic Ubuntu 8.04 Hardy Heron. I've chosen all of the icons myself from the Web, and I use the Ubuntu Studio theme with the OS X border and black pointer. I use AWN and Screenlets to make it more beautiful. I made the right panel to make it easy to access the Internet.

  

  Armin Ahmadi
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  Window borders & menu colors are OverGlossed_Red from gnome-look.org. Wallpaper is Fire vs frost. Icons are the standard Ubuntu human icons. Specs on my digital friend: Intel core 2 duo e 6300 @ 1.86 GHz, 1GB ram, 512 MB GeForce 7 7500 LE 512 MB video card, 320GB hard disk, Ubuntu 8.04 (single-boot), 5.1 surround sound speakers and a 20 inch widescreen monitor

  

  It is good enough. It even runs Enemy Territory, Quake Wars and Savage 2 nicely, and - of course - Nexuiz, Urban Terror and Battle for Wesnoth, you name it...

  

  Durza the Shade


  

  



  Top 5 Twitter Clients


  Written by Andrew Min


  Twhirl
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  Homepage: http://www.twhirl.org/

  

  Twhirl is one of the most popular Adobe AIR applications around. There's a reason: it's got everything except the kitchen sink packed into a little Twitter client. Simply download the latest Twhirl release and get started. Twhirl works with multiple accounts and even supports other sites like Jaiku, Pownce, and FriendFeed. It'll also automatically shorten your URLs with is.gd, snurl, or twurl; posts images; and search. I wasn't thrilled with the cluttered interface or the lack of speed (though this is mainly the fault of AIR), but it's a great replacement for the web version.

  

  To install Twhirl, you'll need the Adobe AIR runtime, which you can get at http://labs.adobe.com/downloads/air_linux.html. Then, download and then double click the installer.

  


  


  gTwitter
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  Homepage: http://code.google.com/p/gtwitter/

  

  If you've used Twitter for a while, you've probably heard of Twitterific, the Mac-only client that's so popular it costs $15. Haven't you ever wished that there was a Linux version (that was free)? Well, there is. It's called gTwitter. Right now, gTwitter's in heavy development, so it's not completely featured. Even basic features like Direct Messages are missing. However, it shows a lot of promise. Currently, my favorite feature is the incredibly handy list view, which condenses screen space very effectively. So if you don't need fancy bling but just want to check your Twitter with a GTK client, gTwitter is your app.

  

  To install gTwitter, just grab the gtwitter package in the universe repositories.

  


  


  Twitux
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  Homepage: http://live.gnome.org/DanielMorales/Twitux

  

  A more simple Twitter client, Twitux is a really clean GTK application that just works beautifully. With an interface very reminiscent of Pidgin, Twitux focuses on cleanliness rather than power. However, it still has all the features that most Twitter clients have, such as sending messages, posting statuses, and viewing everyone else's statuses. It even comes with a few extra surprises, like spell check. As a final bonus, it, like gTwitter, has an option to reside in the tray and, unlike gTwitter, display notifications if you're tweeted. But with all of this, Twitux still manages to keep a wonderfully clean interface.

  

  To install Twitux, use the twitux package in the universe repositories.

  


  


  TwitKit
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  Homepage: http://engel.uk.to/twitkit/

  

  If you're one of those Firefox-inclined people who like Twitter in a browser, give TwitKit a whirl. Just hit Ctrl-Shift-F (or the TwitKit button that you can add to your navigation bar), and the TwitKit sidebar opens up with a list of your timeline. There are also handy buttons to reply to someone, view his or her profile, and update your status. It doesn't, unfortunately, have a few vital features like direct messaging or reading archives, but if all you need is a simple Twitter client, TwitKit is for you. It's the Twitter client for me, anyway.

  

  To install TwitKit, you'll need Firefox (I'm not sure about the version, but it worked for me on 3.0).

  


  


  KDE Twitter
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  Homepage: http://techbase.kde.org/Projects/Plasma/Plasmoids#Twitter_Microblog

  

  KDE Twitter is a KDE 4 widget that lets you update, and receive updates, from other users. It's not as fully featured as some of the others on this list, but if all you need is a simple replacement for the web version, give it a try. It shows a list of the last few messages and an option to update your status. The downside is that it doesn't warn you when you go over 140 characters. Also, the applet was unstable. Sometimes, text 'falls off' the widget, making it look unprofessional.

  

  To install KDE Twitter, you'll need the extragear-plasma package in the universe repositories, then add it to your desktop.

  

  Andrew Min has been a Linux addict since he first installed openSuSE in VMWare. Learn more about him at http://www.andrewmin.com/


  

  



  ﻿FULL CIRCLE NEEDS YOU!


  A magazine isn't a magazine without articles and Full Circle is no exception. We need your Opinions, Desktops and Stories. We also need Reviews (games, apps & hardware), How-To articles (on any K/X/Ubuntu subject) and any questions, or suggestions, you may have.


  We are always looking for new articles to include in Full Circle. For article guidelines, ideas, and for issue translation, please see our wiki:



  http://wiki.ubuntu.com/UbuntuMagazine


  Please email your articles to:

  articles@fullcirclemagazine.org


  If you would like to submit news, email it to:

  news@fullcirclemagazine.org


  Send your comments or Linux experiences to:

  letters@fullcirclemagazine.org


  Hardware/software reviews should be sent to:

  reviews@fullcirclemagazine.org


  Questions for Q&A should go to:

  questions@fullcirclemagazine.org


  Desktop screens should be emailed to:

  misc@fullcirclemagazine.org


  ... or you can visit our forum via:

  misc@fullcirclemagazine.org


  Full Circle Team:


  Editor - Ronnie Tucker -

  ronnie@fullcirclemagazine.org


  Webmaster - Rob Kerfia -

  admin@fullcirclemagazine.org


  Comms Mgr - Robert Clipsham -

  mrmonday@fullcirclemagazine.org


  Podcast - Robin Catling -

  podcast@fullcirclemagazine.org


  Editing & Proofreading:


  Mike Kennedy

  Lucas Westermann

  Gord Campbell


  Our thanks go out to Canonical, the many translation teams around the world and to Thorsten Wilms for the current Full Circle logo.
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